Subject: Problem compiling Apache with modssl on HPUX system...

From: "Almada, Jon F" <[email-masked]>
Date: Fri, 30 Aug 2002 14:54:51 -0700

Hello,

I am attempting to compile Apache with the Mod-SSL modules per the
instructions on 
the site. I am running on a HP-UX 11 machine and everything went fine until
I began 
compiling the Apache server - Any advice about how to get out of this pickle
would 
most certainly be appreciated ;>)

Sincerely,

Jon F. Almada
Web Developer
GenCorp-Aerojet

        rm -f libmain.a
        ar cr libmain.a alloc.o buff.o  http_config.o http_core.o http_log.o
ht
tp_main.o http_protocol.o http_request.o http_vhost.o  util.o util_date.o
util_s
cript.o util_uri.o util_md5.o  rfc1413.o
        /bin/true libmain.a
<=== src/main
===> src/lib
===> src/lib/expat-lite
<=== src/lib/expat-lite
<=== src/lib
===> src/modules
===> src/modules/standard
<=== src/modules/standard
===> src/modules/ssl
        flex -Pssl_expr_yy -s -B ssl_expr_scan.l
Make: Cannot load flex.  Stop.
*** Error exit code 1
______________________________________________________________________
Apache Interface to OpenSSL (mod_ssl)                   www.modssl.org
User Support Mailing List                      [email-masked]
Automated List Manager                            [email-masked]

---

From: "Gilles Gros" <[email-masked]>
Date: Sat, 31 Aug 2002 07:22:08 -0700

You need to have felx and bison installed and accessible in your path.

Gilles

---

From: hunter <[email-masked]>
Date: Sat, 31 Aug 2002 11:27:04 -0400

Gilles Gros wrote:
>>the site. I am running on a HP-UX 11 machine and everything went fine
> 
> until
> 
>>I began
>>compiling the Apache server - Any advice about how to get out of this
> 
> pickle
> 
>>would
>>        ar cr libmain.a alloc.o buff.o  http_config.o http_core.o
> 
> http_log.o
> 
>>ht

In the interest of preventing another misunderstanding...

Giles meant 'flex' not felx...
 > You need to have felx and bison installed and accessible in your path.

Chris.
(please excuse me if it was already obvious)