Subject: error while signing the csr

From: Philippe Marsalle <[email-masked]>
Date: Fri, 09 Aug 2002 12:34:48 +0200

Hi ,

I want to create a ssl server certificate for an intranet server (apache
1.3.14).
I carefully follow the instruction of the documentation which comes with
mod-ssl :
I created a private key for the server:
# openssl genrsa -des3 -out server key 1024
I created a csr with the previous generated key
# openssl req -new -key server.key -out server.csr

As it is for an intranet server, I decided to use my own certificate
authority ,
I first created a private key for the ca :
# openssl genrsa -des3 -out ca.key 1024
I created a self signed certificate with this key :
# openssl req -new -x509 -days 365 -key ca.key -out ca.crt
Then I used the sign.sh script :
# ./sign.sh server.csr

Everything 's all right untill he asks me to commit :

1 out of 1 certificate requests certified, commit? [y/n]y
Write out database with 1 new entries
Data Base Updated
CA verifying: server.crt <-> CA cert
server.crt:
[....]
error 18 at 0 depth lookup:self signed certificate
[...]
error 7 at 0 depth lookup:certificate signature failure

Did I do sth wrong ? what's the meaning of these two errors message?
Thanks for your help :)

--
Philippe,
      [email-masked]

______________________________________________________________________
Apache Interface to OpenSSL (mod_ssl)                   www.modssl.org
User Support Mailing List                      [email-masked]
Automated List Manager                            [email-masked]

---

From: [email-masked]
Date: Fri, 09 Aug 2002 19:01:20 +0800

Hello,

Many users they recommend to use apache 1.3.26 and OpenSSL 0.9.6d ( I
suggest to use 0.9.6e, because I was fail to compile and install 0.9.6d, but
I want to know is it a bug about apache 1.3.26 and OpenSSL 0.9.6d really
from other user ) !

Edward.

---

From: Maurizio Marini <[email-masked]>
Date: Fri, 9 Aug 2002 13:13:28 +0200

www.google.com
search: "error 7 at 0 depth lookup:certificate signature failure"

the first is:
http://lists.openna.com/archives-openna-users/2002-February/msg00028.html
not more not less

(RTFM &&  google) or die("i'm too lame, adios");

- -- maumar