Subject: undefined symbol: _OtsRemainder32Unsigned

From: Kurt <[email-masked]>
Date: Tue, 1 Jan 2002 01:09:02 -0800 (PST)

Hi there,

I've been trying to run apache (1.3.12) and mod_ssl
(2.6.6-1.3.12).  Everything compiles fine, however
when I attempt to run 'apachectl startssl' is says the
following:

[root@tokyo bin]# ./apachectl startssl
Syntax error on line 208 of
/usr/local/apache/conf/httpd.conf:
Cannot load /usr/local/apache/libexec/libssl.so into
server: /usr/local/apache/libexec/libssl.so: undefined
symbol: _OtsRemainder32Unsigned
./apachectl startssl: httpd could not be started

However, 'apachectl start' works just fine. 
'apachectl configtest' says "Syntax OK".
Line 207, 208, and 209 are as follows:
   <IfDefine SSL>
   LoadModule ssl_module         libexec/libssl.so
   </IfDefine>

I've compiled mod_ssl and apache more ways than you
can shake a stick at.  One of the many ways i've
compiled each was the following:

mod_ssl:
  ./configure \
     --with-apache=../apache_1.3.12 \
     --with-ssl \
     --enable-shared=ssl

apache:
  SSL_BASE=../openssl-0.9.5a \
     ./configure \
     --enable-module=ssl \
     --prefix=/usr/local/apache \
     --enable-shared=ssl \
     --enable-module=so

If it makes any difference, the machine I am running
and compiling on is an alpha 600.  If you need any
more information regarding this, please don't hesitate
to ask.

Thanks a bunch.

__________________________________________________
Do You Yahoo!?
Send your FREE holiday greetings online!
http://greetings.yahoo.com
______________________________________________________________________
Apache Interface to OpenSSL (mod_ssl)                   www.modssl.org
User Support Mailing List                      [email-masked]
Automated List Manager                            [email-masked]

---

From: "J. Johnson" <[email-masked]>
Date: Tue, 1 Jan 2002 15:06:32 -0800 (PST)

In your libexec directory:  do you even have 'libssl.so'?

Either way, you probably need to look at your OpenSSL build.

=== JJ =============================================================

---

From: Kurt <[email-masked]>
Date: Tue, 1 Jan 2002 16:32:59 -0800 (PST)

Yes, I have libssl.so in there.  Additionally, i
typed:
  strings libssl.so | grep OtsRemainder

it was in there.

--- "J. Johnson" <[email-masked]> wrote:
> === JJ
=============================================================

---

From: "Simon Ritchie" <[email-masked]>
Date: Wed, 2 Jan 2002 20:43:59 -0000

>   strings libssl.so | grep OtsRemainder

Is strings the right tool for this job on your system?

I don't know enough about the format of object code to be certain, but
according to me, that could just as easily be a call to the function as the
function itself.  In other words, libssl.so contains a call to the function,
but it's actually defined in another library.  It would be better to use an
object code analysis tool.  On my red hat linux system, it's called nm.

If you compile your code with the -g option, you may get a bit more
information in the error message about where the symbol is being called
from.

Simon