Subject: VirtualServers config for SSL

From: "Andrew V. Sirotkin" <[email-masked]>
Date: Thu, 14 Feb 2002 16:04:11 +1100

Hello, All!

I want to use some VirtualServers on port 80 and _default_
VirtualServer on 443 on demand. I used

<ifDefine SSL>
Listen 80     
Listen 443    
</ifDefine>
...
NameVirtualHost host.net:80
...
<VirtualHost _default_:443>
    SSLEngine on
    .....
</VirtualHost>
...
<VirtualHost VServer:80>
     .....
</VirtualHost>

When I brows host.net by 443 I get a good result (certificate & etc.)
When I attempt to connect by 80 port to _default_ I get VServer.
How can I solve this task?

Thanks for a help...

Andrew V. Sirotkin
mailto:[email-masked]
7(41322)97498

______________________________________________________________________
Apache Interface to OpenSSL (mod_ssl)                   www.modssl.org
User Support Mailing List                      [email-masked]
Automated List Manager                            [email-masked]

---

From: Owen Boyle <[email-masked]>
Date: Thu, 14 Feb 2002 10:00:02 +0100

> How can I solve this task?

This is correct behaviour - what do you want to happen?

Do you want to get the SSL site via plain HTTP (port 80) as well?

Rgds,

Owen boyle.