Subject: RE: Installation Woes

From: [email-masked]
Date: Fri, 14 Mar 2003 15:52:04 -0000

Rick,

been fighting with it myself today, I'm using Solaris but if you run httpd
-l it will tell you what modules were compiled into your build, if mod_ssl
isn't there you'll either have to rebuild with mod_ssl or load the module
dynamically. 

-----Original Message-----
From: Rick Root [mailto:[email-masked]]
Sent: Friday, March 14, 2003 3:46 PM
To: [email-masked]
Subject: Installation Woes

Hi folks.. I'm a newbie here, installing Apache and OpenSSL and mod_ssl 
from source on my RedHat 7.3 (I uninstalled the RPMS)

Call me stupid, but I must be missing something...

The installation instructions are pretty straightforward but I have one 
major problem - the httpd.conf doesn't include ANY ssl configuration 
options after it's installed.

So of course, SSL doesn't work.

The instructions seem to assume that the SSL configuration options will 
be there.  This left me really confused.

I ripped out some code from another httpd.conf but now I've got it 
responding to SSL on port 80 as well as 443.

What I'm looking for is BASIC instructions on how to configure apache to 
use SSL (and maybe someone can tell me why it's not IN the instructions 
in the first place).  I've looked in the FAQ and the reference guide but 
I haven't had any luck yet.

Downloaded everything today - apache 1.3.27, open_ssl 0.9.7a, and 
mod_ssl 2.8.12

______________________________________________________________________
Apache Interface to OpenSSL (mod_ssl)                   www.modssl.org
User Support Mailing List                      [email-masked]
Automated List Manager                            [email-masked]

------------------------------------------------------------------------------
The information in this Internet email is confidential and may be legally privileged. It is intended solely for the addressee. Access to this Internet email by anyone else is unauthorised.
If you are not the intended recipient, any disclosure, copying, distribution or any action taken or omitted to be taken in reliance on it, is prohibited and may be unlawful. When addressed to our clients any opinions or advice contained in this Internet email are subject to the terms and conditions expressed in any applicable governing ING terms of business or client engagement letter.
Visit us at www.ing.com
------------------------------------------------------------------------------
01

______________________________________________________________________
Apache Interface to OpenSSL (mod_ssl)                   www.modssl.org
User Support Mailing List                      [email-masked]
Automated List Manager                            [email-masked]

---

From: Stuart Cook <[email-masked]>
Date: Fri, 14 Mar 2003 16:30:45 +0000

Hi,

I have attached a build script I use to make Apache 1.3.27 with SSL. 
Maybe this will be useful.

Regards,

Stuart

---

-- 
--------------------------------------------
  Stuart V Cook BSc. (Hons)
  Senior Software Consultant - Micromuse Ltd.
  90 Putney Bridge Rd, London. SW18 1DA. UK
  Office: +44-(0)20-8875 9500 x734
  Mobile: +44-(0)7771 816 472
--------------------------------------------
#!/bin/sh

if [ $# -lt 1 ]; then
	echo "Usage:"
	echo "\t$0 <arch>"
	exit 1
fi

if [ -n "$2" ]; then
	ROOTPATH=$2
fi

if [ -n "$ROOTPATH}" ]; then
	MASTER_PATH="${ROOTPATH}/master/apache_1.3.27"
	BUILD_PATH="${ROOTPATH}/${1}/apache"
	OPENSSL_PATH="${ROOTPATH}/openssl-engine-0.9.6g"
	# MM_PATH="${ROOTPATH}/mm-1.2.1"
	MOD_SSL_PATH="${ROOTPATH}/mod_ssl-2.8.12-1.3.27"
else
	echo "ERROR: Please specify root path to files."
	exit 1
fi

################################
# Build Open Secure Socket Layer
################################
cd $OPENSSL_PATH
echo "Changed to directory `pwd`"
echo "Configuring OpenSSL..."

echo "Executing \"sh config no-idea no-threads\""

RES=`sh config no-idea no-threads 2>&1`
if [ $? -gt 0 ]; then
	echo "Failed to configure OpenSSL becauase:\n$RES" | more
	exit 1
fi

echo "Cleaning up any previous builds..."
echo "Executing \"make clean\""

RES=`make clean 2>&1`

echo "Making OpenSSL..."
echo "Executing \"make\""

RES=`make 2>&1`
if [ $? -gt 0 ]; then
	echo "Failed to make OpenSSL because:\n$RES" | more
	exit 3
fi

#############################
# Build Shared Memory Library
#############################
# cd $MM_PATH
# echo "Changed to directory `pwd`"
# echo "Configuring Shared Memory Library..."

# echo "Executing \"./configure --disable-shared\""

# RES=`./configure --disable-shared 2>&1`
# if [ $? -gt 0 ]; then
	# echo "Failed to configure Shared Memory Library becauase:\n$RES" | more
	# exit 1
# fi

# echo "Cleaning up any previous builds..."
# echo "Executing \"make clean\""

# RES=`make clean 2>&1`

# echo "Making Shared Memory Library..."
# echo "Executing \"make\""

# RES=`make 2>&1`
# if [ $? -gt 0 ]; then
	# echo "Failed to make Shared Memory Library because:\n$RES" | more
	# exit 3
# fi

########################################
# Configure Secure Socket Library Module
########################################
cd $MOD_SSL_PATH
echo "Changed to directory `pwd`"
echo "Configuring Secure Socket Library Module..."

CMD="./configure --with-apache=${MASTER_PATH} --with-ssl=${OPENSSL_PATH} --prefix=${BUILD_PATH} --enable-module=so"

echo "Executing \"${CMD}\""

RES=`${CMD} 2>&1`
if [ $? -gt 0 ]; then
	echo "Failed to configure Secure Socket Library Module becauase:\n$RES" | more
	exit 1
fi

#########################
# Build Apache Web Server
#########################
cd $MASTER_PATH
echo "Changed to directory `pwd`"
echo "Building Apache..."

echo "Cleaning up any previous builds..."
echo "Executing \"make clean\""

RES=`make clean 2>&1`

echo "Making Apache Web Server..."
echo "Executing \"make\""

RES=`make 2>&1`
if [ $? -gt 0 ]; then
	echo "Failed to make because:\n$RES" | more
	exit 3
fi

echo "Making SSL dummy certificate..."
echo "Executing \"make certificate\""

RES=`make certificate TYPE=dummy 2>&1`

echo "Installing Apache..."
echo "Executing \"make install\""

RES=`make install 2>&1`
if [ $? -gt 0 ]; then
	echo "Failed to make installation because:\n$RES" | more
	exit 4
fi

cd $MASTER_PATH

echo "Finished for apache build for platform $1"
echo