Subject: fatal: libexpat.so.0: open failed: No such file or directory

From: "Boualem, Moncef" <[email-masked]>
Date: Wed, 14 Aug 2002 16:41:05 -0400

Hi,
when I try to compile apache using modssl, I go through step 1, 2, 3, 4 with no problem.
then at step 5 everything goes fine until "make" is run, then it fails with the below message.
does anyone have an idea why it's looking for a file that doesn't exists in the openSSL library,
and what's the fix?

# cd apache_1.3.26
# make
===> src
make[1]: Entering directory `/home/i70815/apache_1.3.26'
make[2]: Entering directory `/home/i70815/apache_1.3.26/src'
===> src/os/unix
gcc -c  -I../../os/unix -I../../include   -DSOLARIS2=270 -DMOD_SSL=208110 -DEAPI -DNO_DL_NEEDED `../../apaci` os.c
gcc -c  -I../../os/unix -I../../include   -DSOLARIS2=270 -DMOD_SSL=208110 -DEAPI -DNO_DL_NEEDED `../../apaci` os-inline.c
rm -f libos.a
ar cr libos.a os.o os-inline.o
ranlib libos.a
<=== src/os/unix
===> src/ap
gcc -c  -I../os/unix -I../include   -DSOLARIS2=270 -DMOD_SSL=208110 -DEAPI -DNO_DL_NEEDED `../apaci` ap_cpystrn.c
gcc -c  -I../os/unix -I../include   -DSOLARIS2=270 -DMOD_SSL=208110 -DEAPI -DNO_DL_NEEDED `../apaci` ap_execve.c
gcc -c  -I../os/unix -I../include   -DSOLARIS2=270 -DMOD_SSL=208110 -DEAPI -DNO_DL_NEEDED `../apaci` ap_fnmatch.c
gcc -c  -I../os/unix -I../include   -DSOLARIS2=270 -DMOD_SSL=208110 -DEAPI -DNO_DL_NEEDED `../apaci` ap_getpass.c
gcc -c  -I../os/unix -I../include   -DSOLARIS2=270 -DMOD_SSL=208110 -DEAPI -DNO_DL_NEEDED `../apaci` ap_md5c.c
gcc -c  -I../os/unix -I../include   -DSOLARIS2=270 -DMOD_SSL=208110 -DEAPI -DNO_DL_NEEDED `../apaci` ap_signal.c
gcc -c  -I../os/unix -I../include   -DSOLARIS2=270 -DMOD_SSL=208110 -DEAPI -DNO_DL_NEEDED `../apaci` ap_slack.c
gcc -c  -I../os/unix -I../include   -DSOLARIS2=270 -DMOD_SSL=208110 -DEAPI -DNO_DL_NEEDED `../apaci` ap_snprintf.c
gcc -c  -I../os/unix -I../include   -DSOLARIS2=270 -DMOD_SSL=208110 -DEAPI -DNO_DL_NEEDED `../apaci` ap_sha1.c
gcc -c  -I../os/unix -I../include   -DSOLARIS2=270 -DMOD_SSL=208110 -DEAPI -DNO_DL_NEEDED `../apaci` ap_checkpass.c
gcc -c  -I../os/unix -I../include   -DSOLARIS2=270 -DMOD_SSL=208110 -DEAPI -DNO_DL_NEEDED `../apaci` ap_base64.c
gcc -c  -I../os/unix -I../include   -DSOLARIS2=270 -DMOD_SSL=208110 -DEAPI -DNO_DL_NEEDED `../apaci` ap_ebcdic.c
gcc -c  -I../os/unix -I../include   -DSOLARIS2=270 -DMOD_SSL=208110 -DEAPI -DNO_DL_NEEDED `../apaci` ap_strtol.c
gcc -c  -I../os/unix -I../include   -DSOLARIS2=270 -DMOD_SSL=208110 -DEAPI -DNO_DL_NEEDED `../apaci` ap_hook.c
gcc -c  -I../os/unix -I../include   -DSOLARIS2=270 -DMOD_SSL=208110 -DEAPI -DNO_DL_NEEDED `../apaci` ap_ctx.c
gcc -c  -I../os/unix -I../include   -DSOLARIS2=270 -DMOD_SSL=208110 -DEAPI -DNO_DL_NEEDED `../apaci` ap_mm.c
rm -f libap.a
ar cr libap.a ap_cpystrn.o ap_execve.o ap_fnmatch.o ap_getpass.o ap_md5c.o ap_signal.o ap_slack.o ap_snprintf.o ap_sha1.o 
ap_checkpass.o ap_base64.o ap_ebcdic.o ap_strtol.o ap_hook.o ap_ctx.o ap_mm.o
ranlib libap.a
<=== src/ap
===> src/main
gcc -c  -I../os/unix -I../include   -DSOLARIS2=270 -DMOD_SSL=208110 -DEAPI -DNO_DL_NEEDED `../apaci` gen_test_char.c
gcc  -DSOLARIS2=270 -DMOD_SSL=208110 -DEAPI -DNO_DL_NEEDED `../apaci` -L/home/i70815/openssl-0.9.6g  -o gen_test_char 
gen_test_char.o  -lsocket -lnsl -lpthread  -lssl -lcrypto -lexpat
./gen_test_char >test_char.h
ld.so.1: ./gen_test_char: fatal: libexpat.so.0: open failed: No such file or directory
Killed
make[3]: *** [test_char.h] Error 137
make[2]: *** [subdirs] Error 1
make[2]: Leaving directory `/home/i70815/apache_1.3.26/src'
make[1]: *** [build-std] Error 2
make[1]: Leaving directory `/home/i70815/apache_1.3.26'
make: *** [build] Error 2

---

From: "Madhon" <[email-masked]>
Date: Wed, 14 Aug 2002 22:31:35 +0100

fatal: libexpat.so.0: open failed: No such file or directoryyou might be
missing the expat library
the source is available http://sourceforge.net/projects/expat/

----- Original Message -----
From: Boualem, Moncef
To: [email-masked]'
Sent: Wednesday, August 14, 2002 9:41 PM
Subject: fatal: libexpat.so.0: open failed: No such file or directory

Hi,
when I try to compile apache using modssl, I go through step 1, 2, 3, 4 with
no problem.
then at step 5 everything goes fine until "make" is run, then it fails with
the below message.
does anyone have an idea why it's looking for a file that doesn't exists in
the openSSL library,
and what's the fix?

# cd apache_1.3.26
# make
===> src
make[1]: Entering directory `/home/i70815/apache_1.3.26'
make[2]: Entering directory `/home/i70815/apache_1.3.26/src'
===> src/os/unix
gcc -c  -I../../os/unix -I../../include   -DSOLARIS2=270 -DMOD_SSL=208110 -D
EAPI -DNO_DL_NEEDED `../../apaci` os.c
gcc -c  -I../../os/unix -I../../include   -DSOLARIS2=270 -DMOD_SSL=208110 -D
EAPI -DNO_DL_NEEDED `../../apaci` os-inline.c
rm -f libos.a
ar cr libos.a os.o os-inline.o
ranlib libos.a
<=== src/os/unix
===> src/ap
gcc -c  -I../os/unix -I../include   -DSOLARIS2=270 -DMOD_SSL=208110 -DEAPI -
DNO_DL_NEEDED `../apaci` ap_cpystrn.c
gcc -c  -I../os/unix -I../include   -DSOLARIS2=270 -DMOD_SSL=208110 -DEAPI -
DNO_DL_NEEDED `../apaci` ap_execve.c
gcc -c  -I../os/unix -I../include   -DSOLARIS2=270 -DMOD_SSL=208110 -DEAPI -
DNO_DL_NEEDED `../apaci` ap_fnmatch.c
gcc -c  -I../os/unix -I../include   -DSOLARIS2=270 -DMOD_SSL=208110 -DEAPI -
DNO_DL_NEEDED `../apaci` ap_getpass.c
gcc -c  -I../os/unix -I../include   -DSOLARIS2=270 -DMOD_SSL=208110 -DEAPI -
DNO_DL_NEEDED `../apaci` ap_md5c.c
gcc -c  -I../os/unix -I../include   -DSOLARIS2=270 -DMOD_SSL=208110 -DEAPI -
DNO_DL_NEEDED `../apaci` ap_signal.c
gcc -c  -I../os/unix -I../include   -DSOLARIS2=270 -DMOD_SSL=208110 -DEAPI -
DNO_DL_NEEDED `../apaci` ap_slack.c
gcc -c  -I../os/unix -I../include   -DSOLARIS2=270 -DMOD_SSL=208110 -DEAPI -
DNO_DL_NEEDED `../apaci` ap_snprintf.c
gcc -c  -I../os/unix -I../include   -DSOLARIS2=270 -DMOD_SSL=208110 -DEAPI -
DNO_DL_NEEDED `../apaci` ap_sha1.c
gcc -c  -I../os/unix -I../include   -DSOLARIS2=270 -DMOD_SSL=208110 -DEAPI -
DNO_DL_NEEDED `../apaci` ap_checkpass.c
gcc -c  -I../os/unix -I../include   -DSOLARIS2=270 -DMOD_SSL=208110 -DEAPI -
DNO_DL_NEEDED `../apaci` ap_base64.c
gcc -c  -I../os/unix -I../include   -DSOLARIS2=270 -DMOD_SSL=208110 -DEAPI -
DNO_DL_NEEDED `../apaci` ap_ebcdic.c
gcc -c  -I../os/unix -I../include   -DSOLARIS2=270 -DMOD_SSL=208110 -DEAPI -
DNO_DL_NEEDED `../apaci` ap_strtol.c
gcc -c  -I../os/unix -I../include   -DSOLARIS2=270 -DMOD_SSL=208110 -DEAPI -
DNO_DL_NEEDED `../apaci` ap_hook.c
gcc -c  -I../os/unix -I../include   -DSOLARIS2=270 -DMOD_SSL=208110 -DEAPI -
DNO_DL_NEEDED `../apaci` ap_ctx.c
gcc -c  -I../os/unix -I../include   -DSOLARIS2=270 -DMOD_SSL=208110 -DEAPI -
DNO_DL_NEEDED `../apaci` ap_mm.c
rm -f libap.a
ar cr libap.a ap_cpystrn.o ap_execve.o ap_fnmatch.o ap_getpass.o ap_md5c.o
ap_signal.o ap_slack.o ap_snprintf.o ap_sha1.o
ap_checkpass.o ap_base64.o ap_ebcdic.o ap_strtol.o ap_hook.o ap_ctx.o
ap_mm.o
ranlib libap.a
<=== src/ap
===> src/main
gcc -c  -I../os/unix -I../include   -DSOLARIS2=270 -DMOD_SSL=208110 -DEAPI -
DNO_DL_NEEDED `../apaci` gen_test_char.c
gcc  -DSOLARIS2=270 -DMOD_SSL=208110 -DEAPI -DNO_DL_NEEDED
`../apaci` -L/home/i70815/openssl-0.9.6g  -o gen_test_char
gen_test_char.o  -lsocket -lnsl -lpthread  -lssl -lcrypto -lexpat
./gen_test_char >test_char.h
ld.so.1: ./gen_test_char: fatal: libexpat.so.0: open failed: No such file or
directory
Killed
make[3]: *** [test_char.h] Error 137
make[2]: *** [subdirs] Error 1
make[2]: Leaving directory `/home/i70815/apache_1.3.26/src'
make[1]: *** [build-std] Error 2
make[1]: Leaving directory `/home/i70815/apache_1.3.26'
make: *** [build] Error 2

______________________________________________________________________
Apache Interface to OpenSSL (mod_ssl)                   www.modssl.org
User Support Mailing List                      [email-masked]
Automated List Manager                            [email-masked]