Subject: .htaccess not processed with client authentication

From: Angus Lee <[email-masked]>
Date: Thu, 7 Mar 2002 21:28:50 +0800 (HKT)

Hi, list,

I used .htaccess to add client authentication to access a particular directory. However it seems that .htaccess is not processed occassionally when http request is made to an object in that directory. Anything wrong with my configuration?

SSLRequireSSL
SSLVerifyClient require
SSLVerifyDepth 1
SSLRequire %{SSL_CLIENT_M_SERIAL} eq "A6"

And when requet to a file requires client authentication, the server would return 'Internal Server Probelm' after a long run. Is my server having too few resources? Please help. Thank you.

Angus Lee
______________________________________________________________________
Apache Interface to OpenSSL (mod_ssl)                   www.modssl.org
User Support Mailing List                      [email-masked]
Automated List Manager                            [email-masked]

---

From: Shiva Murugesan <[email-masked]>
Date: Thu, 7 Mar 2002 05:47:06 -0800 (PST)

Try to put all these directives in httpd.conf file and
 also try to put the SSLRequire directive as follows

<LOCATION>
</LOCATION>
-- Shiva

--- Angus Lee <[email-masked]> wrote:
> Hi, list,
> 
> I used .htaccess to add client authentication to
> access a particular directory. However it seems that
> .htaccess is not processed occassionally when http
> request is made to an object in that directory.
> Anything wrong with my configuration?
> 
> SSLRequireSSL
> SSLVerifyClient require
> SSLVerifyDepth 1
> And when requet to a file requires client
> authentication, the server would return 'Internal
> Server Probelm' after a long run. Is my server
> having too few resources? Please help. Thank you.
> 
> Angus Lee
>
> User Support Mailing List                     

__________________________________________________
Do You Yahoo!?
Try FREE Yahoo! Mail - the world's greatest free email!
http://mail.yahoo.com/
______________________________________________________________________
Apache Interface to OpenSSL (mod_ssl)                   www.modssl.org
User Support Mailing List                      [email-masked]
Automated List Manager                            [email-masked]