Subject: Re: mod_ssl-X.X.X-2.0.YY-tar.gz?

From: "Ralf S. Engelschall" <[email-masked]>
Date: Thu, 17 Jan 2002 20:36:02 +0100

In article <[email-masked]> you wrote:

>    When?

Apache 2.0.X already ships with mod_ssl, because we already ported mod_ssl to
Apache 2 a few months ago and gifted the source code to the ASF. This way
you no longer need an SSL/TLS add-on module for Apache 2.

                                       Ralf S. Engelschall
                                       [email-masked]
                                       www.engelschall.com
______________________________________________________________________
Apache Interface to OpenSSL (mod_ssl)                   www.modssl.org
User Support Mailing List                      [email-masked]
Automated List Manager                            [email-masked]

---

From: [email-masked]
Date: Thu, 17 Jan 2002 14:59:53 -0800

Have problem building that under Windows.  Using cygwin.  Using the Visual C++ dsw/dsp projects.  Rest of Apache 2.0.28 builds fine.  Have put in openssl etc.  (Previously on same machine have successfully built 1.3.20 with mod_ssl, still do.)

The problem is specific to lex, specifically flex, processing
   lex.ssl_expr_yy.c(1753) : error C2143: syntax error : missing ')' before 'constant'

Essentially that means there is a file ssl_expr_scan.l which is being used to generate ssl_expr_scan.c and that generation doesn't work right.  The .c file fails to compile.

A temporary workaround seems to be to skip lex/flex use the ssl_expr_scan.c file that comes with 2.0.28, but I have no idea whether that might actually be an (older) incorrect version then.

Any insights?

(I'm working with 1.3.20 meanwhile, just to get things done for a demo to keep this project alive, and because not sure how well mod_ssl works yet in 2.0.28.  I'd be willing to spend some time on this.  Just seems like another good size piece of source to learn...)