Subject: modssl and htaccess

From: "Michael O'Brien" <[email-masked]>
Date: Mon, 29 Jul 2002 07:01:18 -0500

Hi,

I am running apache 1.3.23 with modssl. I have setup a htaccess file in a directory, but it isn't being picked up. I have set the 
                             
<Directory />                       
    Options FollowSymLinks          
    AllowOverride AuthConfig        
</Directory>   

I seem to remember that I might have to set somthing in the SSL options in the virtual host section of my httpd.conf 

Can anyone suggest some possible cause to why my htaccess file is being ignored. The contents of my htaccess file is

AuthUserFile /apps/apache/bin/.htpasswd     
AuthGroupFile /dev/null                     
AuthName "Restricted Site"                  
AuthType Basic                              
                                            
<Limit GET POST>                            
require valid-user
</Limit>                                    
          
Thanks in advance for any suggestions that you can provide

cheers
Mike           
                                    
-- 
__________________________________________________________
Sign-up for your own FREE Personalized E-mail at Mail.com
http://www.mail.com/?sr=signup

Get 4 DVDs for $.49 cents! plus shipping & processing. Click to join.
http://adfarm.mediaplex.com/ad/ck/990-1736-3566-59

______________________________________________________________________
Apache Interface to OpenSSL (mod_ssl)                   www.modssl.org
User Support Mailing List                      [email-masked]
Automated List Manager                            [email-masked]

---

From: "Boyle Owen" <[email-masked]>
Date: Mon, 29 Jul 2002 14:37:34 +0200

>From: Michael O'Brien [mailto:[email-masked]]
>
>Can anyone suggest some possible cause to why my htaccess file 
>is being ignored. The contents of my htaccess file is
>
>

AuthUserFile is supposed to point at the file containing your usernames and passwords. Did you really do:

cd /apps/apache/bin
./htpasswd -c .htpasswd username

when you were making your password file? (i.e. why call a password file nearly the same as the binary that made it and put it in a bin directory?) I usually have things like:

AuthUserFile /home/site/admin/passwords/member_section.pwd

Which is a whole lot less confusing...

Anyway: Is your "htaccess" file really called "htaccess"? Is so, do you have:

AccessFileName htaccess

because the default is ".htaccess" and "htaccess" will not work on its own (all these leading dots are part of the filename, remember).

Otherwise, check the error log and post the results.

Rgds,

Owen Boyle