Subject: SSLFakeBasicAuth ?

From: "Ron McKeever"<[email-masked]>
Date: Fri, 25 Oct 2002 13:48:56 -0700

Hello 

I have an Apache/1.3.27/mod_ssl/2.8.12/OpenSSL/0.9.6e/Solaris 8 system.

I wanted to use .htaccess without the file .htaccess. SO I found the option to
use SSLFakeBasicAuth in the httpd.conf file. It works and asks for my login. 
My question is what is the timeout after asking for the SSLFakeBasicAuth Dir.
It seems once you get authenticated you can keep clicking on the link without
being asked for your username/password? 

>From httpd.conf:

SSLFakeBasicAuth
<Directory /opt/apache/htdocs/systems>
    SSLRequireSSL
    Options FollowSymLinks
    AllowOverride none
    AuthUserFile /opt/apache/.htpasswd
    AuthType Basic
    AuthName Watchdog
    Require valid-user
</Directory>

Thanks
Rob

______________________________________________________________________
Apache Interface to OpenSSL (mod_ssl)                   www.modssl.org
User Support Mailing List                      [email-masked]
Automated List Manager                            [email-masked]

---

From: Jamie Furtner <[email-masked]>
Date: Fri, 25 Oct 2002 15:13:19 -0600

Browsers cache the username/password and should continue to allow access
until they are restarted -- at least all that I've used do. It is not
controlled by a setting on the server as they are cached and controlled
client-side.

Jamie Furtner

-----Original Message-----
From: Ron McKeever [mailto:[email-masked]]
Sent: Friday, October 25, 2002 2:49 PM
To: [email-masked]
Subject: SSLFakeBasicAuth ?

Hello 

I wanted to use .htaccess without the file .htaccess. SO I found the option
to
use SSLFakeBasicAuth in the httpd.conf file. It works and asks for my login.

My question is what is the timeout after asking for the SSLFakeBasicAuth
Dir.
It seems once you get authenticated you can keep clicking on the link
without
being asked for your username/password? 

SSLFakeBasicAuth

Thanks
Rob