Subject: (OpenSSL library error follows) - in Apache 2.0.35 with mod_ssl

From: MegaZone <[email-masked]>
Date: Mon, 6 May 2002 21:31:54 -0400

When I try to connect via https:// I get this in my log:

(servername obscured by me, sorry, policy, et al)

[06/May/2002 21:07:05 21504] [info]  Connection to child 2 established (server [server]:443, client 192.32.224.59)
[06/May/2002 21:07:05 21504] [info]  Seeding PRNG with 136 bytes of entropy
[06/May/2002 21:07:05 21504] [error] Unable to set session id context to `[server]:443' (OpenSSL library error follows)
[06/May/2002 21:07:05 21504] [error] OpenSSL: error:140DA111:lib(20):func(218):reason(273)

I can't seem to find a place to lookup that error - any help?

This is with OpenSSL 0.9.6c compiled with 'config shared' with 
Apache 2.0.35 compiled with  
./configure --prefix=/local/webhome/apache-2.0.35 --enable-mods-shared="ssl" \
--with-ssl="/usr/local/ssl"

Solaris 8.

I'm thinking the certs used on this test box might be a problem, but I
don't want to go off on a wild goose chase.

Thanks.

-MZ, CISSP #3762, RHCE #806199299900541
-- 
<URL:mailto:[email-masked], Discordian, Author, Engineer, me..
"A little nonsense now and then, is relished by the wisest men" 781-788-0130
<URL:http://www.megazone.org/ <URL:http://www.eyrie-productions.com/Eris
______________________________________________________________________
Apache Interface to OpenSSL (mod_ssl)                   www.modssl.org
User Support Mailing List                      [email-masked]
Automated List Manager                            [email-masked]

---

From: Cliff Woolley <[email-masked]>
Date: Mon, 6 May 2002 21:38:46 -0400 (EDT)

> [06/May/2002 21:07:05 21504] [error] OpenSSL: error:140DA111:lib(20):func(218):reason(273)

Let me guess, SHMCB, right?  Download 2.0.36 (released today) and use
that.  SHMCB is now fixed.

--Cliff

--------------------------------------------------------------
   Cliff Woolley
   [email-masked]
   Charlottesville, VA

---

From: MegaZone <[email-masked]>
Date: Mon, 6 May 2002 22:36:06 -0400

Once upon a time Cliff Woolley shaped the electrons to say...
> that.  SHMCB is now fixed.

Right on!

Ok, I've been here 13.5 hours today, it works now.  I'm bailing. ;-)

Thanks.

(Wisdom I relearned today - use explicit paths.  You never know when
someone else has left an old install laying around earlier in your
build path.  Like, say, a non-shared openssl which makes a shared
apache+mod_ssl sad...  Not that I wasted a lot of time on that...)

-MZ, CISSP #3762, RHCE #806199299900541
-- 
<URL:mailto:[email-masked]> Gweep, Discordian, Author, Engineer, me..
"A little nonsense now and then, is relished by the wisest men" 781-788-0130
<URL:http://www.megazone.org/>  <URL:http://www.eyrie-productions.com/> Eris

---

From: Cliff Woolley <[email-masked]>
Date: Mon, 6 May 2002 22:45:26 -0400 (EDT)

> apache+mod_ssl sad...  Not that I wasted a lot of time on that...)

Bummer, yeah, that's a kind of nasty one.  We're trying to figure out a
clean way to get around that problem, but haven't gotten anything in yet.

Glad you got it.

--Cliff