Subject: Sign.sh

From: Pete Serafin <[email-masked]>
Date: Thu, 07 Feb 2002 14:11:04 -0600

I need help in configuring the sign.sh so that I can sign my own
certificates.  Problem is that Im not familiar with perl.  Upon first
executing the script, I get this error:

F:\oas\Apache\Apache\conf>perl sign.sh ssl.csr\sandbox5.csr
Can't modify constant item in scalar assignment at sign.sh line 9, near
"$1
if"
syntax error at sign.sh line 9, near "-ne"
Semicolon seems to be missing at sign.sh line 10.
syntax error at sign.sh line 12, near "fi
"
Semicolon seems to be missing at sign.sh line 13.
syntax error at sign.sh line 15, near "fi
case "
Bareword found where operator expected at sign.sh line 15, near "$CSR
in"
        (Missing operator before in?)
Bareword found where operator expected at sign.sh line 16, near ") CERT"

        (Missing operator before CERT?)
Bareword found where operator expected at sign.sh line 17, near "* )
CERT"
        (Missing operator before CERT?)
syntax error at sign.sh line 17, near "* ) CERT"
syntax error at sign.sh line 22, near "then
    mkdir"
Not enough arguments for index at sign.sh line 27, near "index ]"
Bareword found where operator expected at sign.sh line 28, near
"/dev/null"
        (Missing operator before null?)
syntax error at sign.sh line 28, near "/dev/null ca"
Semicolon seems to be missing at sign.sh line 33.
Semicolon seems to be missing at sign.sh line 35.
Semicolon seems to be missing at sign.sh line 37.
Semicolon seems to be missing at sign.sh line 44.
Semicolon seems to be missing at sign.sh line 45.
"no" not allowed in expression at sign.sh line 47, near "= "
Semicolon seems to be missing at sign.sh line 49.
String found where operator expected at sign.sh line 60, near "echo "CA
signing:
 $CSR -> $CERT:""
        (Do you need to predeclare echo?)
Semicolon seems to be missing at sign.sh line 60.
Semicolon seems to be missing at sign.sh line 61.
String found where operator expected at sign.sh line 62, near "echo "CA
verifyin
g: $CERT <-> CA cert""
        (Do you need to predeclare echo?)
Semicolon seems to be missing at sign.sh line 62.
Semicolon seems to be missing at sign.sh line 65.
Execution of sign.sh aborted due to compilation errors.

Any help would be greatly appreciated.

Pete Serafin

______________________________________________________________________
Apache Interface to OpenSSL (mod_ssl)                   www.modssl.org
User Support Mailing List                      [email-masked]
Automated List Manager                            [email-masked]

---

From: Andy Osborne <[email-masked]>
Date: Fri, 08 Feb 2002 13:53:05 +0000

> executing the script, I get this error:

Hmmm.....I may be missing something here, but sign.sh is a bourne
shell script, not perl.

Andy

-- 
Andy Osborne      ****************      "Vertical B2B Communities"
Senior Internet Engineer
Sift Group Ltd.               100 Victoria Street, Bristol BS1 6HZ
tel:+44 117 915 9600  fax:+44 117 915 9630   http://www.sift.co.uk