Subject: C compiler cannot create executables

From: "Webmaster" <[email-masked]>
Date: Mon, 24 Jun 2002 11:00:38 +0200

Hi everybody.

    Hans

    I have a problem with mod_ssl 2.8.9 for Apache 1.3.26. When I try to configure
this module for compilation (# configure --with-apache=/var/tmp/apache_1.3.26 ) it gives the following error:

Configuring mod_ssl/2.8.9 for Apache/1.3.26
 + Apache location: /var/tmp/apache_1.3.26 (Version 1.3.26)
 + Auxiliary patch tool: ./etc/patch/patch (local)
./configure:Error: Building of 'patch' tool failed:
-------------------------------------------------
x patch/rename.c, 1323 bytes, 3 tape blocks
x patch/util.c, 9365 bytes, 19 tape blocks
x patch/util.h, 2325 bytes, 5 tape blocks
x patch/version.c, 280 bytes, 1 tape blocks
x patch/version.h, 25 bytes, 1 tape blocks
loading cache ./config.cache
checking for gcc... gcc
checking whether the C compiler (gcc  ) works... no
configure: error: installation or configuration problem: C compiler cannot
create executables.
make: *** No targets.  Stop.
-------------------------------------------------
Hint: Either try to build 'patch' under etc/patch/
Hint: manually and re-run this 'configure' script
Hint: or provide us the path to your vendor 'patch'
Hint: program via the --with-patch=FILE option (but
Hint: expect perhaps failures when applying patches!)

My OS is Solaris 8 and I have tested it with two versions of gcc : 9.95.2 and 3.1
I had no problems with the installation of apache 1.3.20 and mod_ssl 2.8.4

Did anybody experienced this problem and have found a solution?

Thanks in advance.

Oscar.

---

From: "Webmaster" <[email-masked]>
Date: Tue, 25 Jun 2002 17:01:16 +0200

OK, I have found the error, I had two different versions of GCC and I was using the wrong one due to PATH variable setting...
Forget this question
  ----- Original Message ----- 
  From: Webmaster 
  To: [email-masked] 
  Sent: Monday, June 24, 2002 11:00 AM
  Subject: C compiler cannot create executables

  Hi everybody.

      Hans

  Thanks in advance.

  Oscar.