Subject: Apache warning: Connection refused: connect to listener

From: "Alex Hart" <[email-masked]>
Date: Mon, 29 Sep 2003 23:06:31 -0400

I just installed Apache/2.0.47 (Unix) mod_ssl/2.0.47 OpenSSL/0.9.7b in
my server (freebsd 4.8) and everything seems to be working fine. I have apache
configured to serve both secure and insecure pages.

However, I keep getting the following line in my error log file (thousands of times):

[Wed Sep 24 12:51:15 2003] [warn] (61)Connection refused: connect to listener

I have thousands of these warnings now in just a couple of days. I can't figure out any pattern to them.
I get this warning even when I don't have any activity going on with the web server. 
It also happens if I don't have any SSL virtual hosts set up.
I notice no problems with any web pages, secure or not.

When I recompile apache without mod_ssl, the warning goes away.

I've scoured the Internet but I can't find a thing about this warning. Does anyone have any idea about why this is happening?

Alex Hart
http://atpmail.com
______________________________________________________________________
Apache Interface to OpenSSL (mod_ssl)                   www.modssl.org
User Support Mailing List                      [email-masked]
Automated List Manager                            [email-masked]

---

From: Cliff Woolley <[email-masked]>
Date: Tue, 30 Sep 2003 00:23:06 -0400 (EDT)

On Mon, 29 Sep 2003, Alex Hart wrote:

> my server (freebsd 4.8) and everything seems to be working fine. I have
> apache configured to serve both secure and insecure pages.
>
> I have thousands of these warnings now in just a couple of days. I can't
> figure out any pattern to them. I get this warning even when I don't
> have any activity going on with the web server.  It also happens if I
> don't have any SSL virtual hosts set up. I notice no problems with any
> web pages, secure or not.
>
> I've scoured the Internet but I can't find a thing about this warning.
> Does anyone have any idea about why this is happening?

Okay, here's a couple of things for you to check on to help me track down
what's going on (I'm cc'ing dev@httpd in case anybody else has guesses).

 1) Is your server compiled with -D SINGLE_LISTEN_UNSERIALIZED_ACCEPT?
 2) Which MPM are you using?

    You can find out the answers to both of these by running ./httpd -V
    from /usr/local/apache2/bin or wherever your httpd binary is
    installed.  For example:

    ----------------------------------------------------
    root@deepthought:/root/apache/test/bin# ./httpd -V
    Server version: Apache/2.1.0-dev
    Server built:   Aug 12 2003 16:43:24
    Server's Module Magic Number: 20030213:1
    Architecture:   32-bit
    Server compiled with....
     -D APACHE_MPM_DIR="server/mpm/worker"
     -D APR_HAS_SENDFILE
     -D APR_HAS_MMAP
     -D APR_HAVE_IPV6 (IPv4-mapped addresses enabled)
     -D APR_USE_SYSVSEM_SERIALIZE
     -D APR_USE_PTHREAD_SERIALIZE
     -D SINGLE_LISTEN_UNSERIALIZED_ACCEPT
     -D APR_HAS_OTHER_CHILD
     -D AP_HAVE_RELIABLE_PIPED_LOGS
     -D HTTPD_ROOT="/root/apache/test"
     -D SUEXEC_BIN="/root/apache/test/bin/suexec"
     -D DEFAULT_SCOREBOARD="logs/apache_runtime_status"
     -D DEFAULT_ERRORLOG="logs/error_log"
     -D AP_TYPES_CONFIG_FILE="conf/mime.types"
     -D SERVER_CONFIG_FILE="conf/httpd.conf"
    ----------------------------------------------------

Thanks,
Cliff

---

From: Mads Toftum <[email-masked]>
Date: Tue, 30 Sep 2003 10:32:42 +0200

> I notice no problems with any web pages, secure or not.
We need a few more details to guess what might be happening - something like
the output of httpd -V, the configure options used when building apache and
wether you have any other non standard modules installed (ie. php and such).
Also your SSL specific part of the configuration.

vh

Mads Toftum
-- 
Speaking at http://ApacheCon.com/
T03, "Apache 2 mod_ssl tutorial" (3h)
WE03, "Troubleshooting Apache configurations" 
WE11, "Apache mod_rewrite, the Swiss Army Knife of URL manipulation" 
______________________________________________________________________
Apache Interface to OpenSSL (mod_ssl)                   www.modssl.org
User Support Mailing List                      [email-masked]
Automated List Manager                            [email-masked]