Subject: EAPI!

From: Klosa Uwe <[email-masked]>
Date: Fri, 10 May 2002 15:58:08 +0200

I've got a problem with the installation of mod_ssl.
I'm using Apache 1.3.24, mod_ssl-2.8.8-1.3.24 and mm-1.1.3.
I'm configuring apache with

EAPI_MM="../mm-1.1.3" \
./configure \
"--with-layout=RedHat7" \
"--enable-module=most" \
"--enable-module=auth_digest" \
"--enable-module=ssl" \
"--disable-module=auth_dbm" \
"--disable-module=auth_anon" \
"--enable-shared=max" \
"--manualdir=/var/www/apache" \
"$@"

After a make and make install, a apachectl configtest creates
several errors, which wants me do recompile several modules 
with the -DEAPI. But this modules was compiled with -DEAPI.

Has anyone a hint for me?

Uwe
______________________________________________________________________
Apache Interface to OpenSSL (mod_ssl)                   www.modssl.org
User Support Mailing List                      [email-masked]
Automated List Manager                            [email-masked]

---

From: "Frederik Uyttersprot" <[email-masked]>
Date: Fri, 10 May 2002 16:05:18 +0200

Take a look at the document Apacompile if you haven't already,
http://www.delouw.ch/linux/apache.phtml

Greets.

---

From: Owen Boyle <[email-masked]>
Date: Fri, 10 May 2002 16:09:51 +0200

> with the -DEAPI. But this modules was compiled with -DEAPI.

You understand that apache needs the extended API (EAPI) to allow
mod_ssl to hook into the openssl library functions? So that's why you
always need to recompile apache if you want to use mod_ssl.

Are you 100% certain you are not trying to load a module which has not
been recompiled with EAPI? (i.e. to prove it - post the "ls -l" of httpd
and all modules in the modules directory).

Rgds,

Owen Boyle.