Subject: Problem with File-Upload>20k

From: "Michael Metz" <[email-masked]>
Date: Fri, 1 Mar 2002 14:20:56 +0100

Hi there,

i'm running a SSL enabled WebServer since nearly 1 month. Today I 
wanted to make an http-file-upload (~20k) an received the following 
error in my error_log:
[Fri Mar  1 11:26:41 2002] [error] mod_ssl: SSL error on reading data 
(OpenSSL library error follows)
[Fri Mar  1 11:26:41 2002] [error] OpenSSL: error:1408F10B:SSL 
routines:SSL3_GET_RECORD:wrong version number

After that I updated my openssl-Version (which was from Dec 2000) to 
the current release "OpenSSL 0.9.6c [engine] 21 dec 2001" and 
recompiled my apache 1.3.23 mit mod_ssl 2.8.7-1.3.23. With no other 
result.
Normal connections seem to work fine (Opera says "High Encryption TLS 
v1.0 128 bit C4 (1024 bit RSA/SHA) but File-Uploads fail when they 
are larger than about 20k. Smaller files work fine .... I'm running 
on RedHat 7.1

Can anyone give me a solution for this problem?

MfG
 Michael

______________________________________________________________________
Apache Interface to OpenSSL (mod_ssl)                   www.modssl.org
User Support Mailing List                      [email-masked]
Automated List Manager                            [email-masked]

---

From: Ben Groeneveld <[email-masked]>
Date: Tue, 09 Apr 2002 16:44:45 -0700

To: [email-masked], [email-masked],
	[email-masked]
CC: Michael Metz <[email-masked]>, [email-masked]

Did any of you ever resolve this issue?

I corresponded several months ago with Mark, who recommended an upgrade 
to rh7, since he didn't see the problem there anymore. I happened to 
have 7.1 so that worked until now I added mod_ssl.

I'm trying to disable ssl but even without loading mod_ssl I still get 
the error when uploading large files only.  I can upload files of size 
8M, but a 200M sample fails.  The httpd error log says:

Ouch!  malloc failed in malloc_block()

My client is IE6 with latest 'service packs'. Tried several different 
client machines.  With NS6 I also get:

Ouch!  malloc failed in malloc_block()

Help or debugging suggestions would be appreciated.  Thanks, BenG.

Michael Metz wrote:

>Hi Ben,
>
>sorry - I haven't fond a solution yet - I hope that with an update to Apache 2.x this problem could be solved ...
>Away from apache I'm using the same versions - so there must be the problem
>
>Sorry
>
>Bye
>  Michael
>
>Ben Groeneveld <[email-masked]> schrieb :
>
>>Michael, I seem to have run into the same problem.  Ever since I 
>>installed SSL (mod_ssl and openssl) for apache our file upload fails for 
>>large files. I'm using the java oreilly classes for the upload code.  
>>Have you found a resolution?  This is my config.  Thanks, BenG.
>>
>>
>>Red Hat Linux release 7.1sbe (Seawolf)
>>Kernel 2.4.3-6smp on an i686
>>
>>bruce:~> rpm -q apache
>>apache-1.3.19-5
>>bruce:~> rpm -q mod_ssl
>>mod_ssl-2.8.5-3
>>bruce:~> rpm -q openssl
>>openssl-0.9.6-9
>>bruce:~>
>>
>>
>>
>>
>>
>>
>>
>>
>>
>>
>>
>>
>>
>>
>>
>>
>>
>>
>>
>>
>>
>>
>>
>>
>>
>>
>>                                                                              
>>
>>
>>
>>-- 
>>Ben Groeneveld 
>>Information Concepts, Inc., 115 N.W. Oregon, Suite 30, Bend, OR 97701
>>Mailto:[email-masked],
>>phone:541.388.3611, cell:208.52
>>0.6488
>>
>
>MfG
>  Michael Metz
>  SpeedPartner
>
>___________________________________
>NOCC, http://nocc.sourceforge.net
>
>
>
>
>
>.
>

-- 
Ben Groeneveld 
Information Concepts, Inc., 115 N.W. Oregon, Suite 30, Bend, OR 97701
Mailto:[email-masked], phone:541.388.3611, cell:208.520.6488