Subject: Apache_1.3.26 with mod_ssl: build failed

From: Adrian Hardt <[email-masked]>
Date: Mon, 05 Aug 2002 13:15:05 +0200

Hello. I have a problem compiling apache_1.3.26 with mod_ssl. After

cd mod_ssl-2.8.10-1.3.26
./configure --with-layout=Apache --enable-module=rewrite
--enable-module=proxy --server-uid=httpd --server-gid=httpd
--enable-suexec --suexec-caller=httpd --suexec-docroot=/home
--suexec-userdir=public_html --enable-module=expires
--with-apache=../apache_1.3.26 --with-ssl=../openssl-0.9.6e
--enable-module=ssl
cd ../apache_1.3.26

make (of apache) failed with the following lines. Can anybody help,
please?

Thank you. Adrian

Hello.

I have a problem compiling apache_1.3.26 with mod_ssl. After

cd mod_ssl-2.8.10-1.3.26
./configure --with-layout=Apache --enable-module=rewrite --enable-module=proxy --server-uid=httpd --server-gid=httpd --enable-suexec --suexec-caller=httpd --suexec-docroot=/home --suexec-userdir=public_html --enable-module=expires --with-apache=../apache_1.3.26 --with-ssl=../openssl-0.9.6e --enable-module=ssl
cd ../apache_1.3.26

make (of apache) failed with the following lines. Can anybody help, please?

Thank you. Adrian

<=== src/modules/ssl
<=== src/modules
gcc -c  -I./os/unix -I./include   -DLINUX=22 -I/usr/include/db1 -DMOD_SSL=208110 -DUSE_HSREGEX -DEAPI -DUSE_EXPAT -I./lib/expat-lite -DNO_DL_NEEDED `./apaci` modules.c
gcc -c  -I./os/unix -I./include   -DLINUX=22 -I/usr/include/db1 -DMOD_SSL=208110 -DUSE_HSREGEX -DEAPI -DUSE_EXPAT -I./lib/expat-lite -DNO_DL_NEEDED `./apaci` buildmark.c
gcc  -DLINUX=22 -I/usr/include/db1 -DMOD_SSL=208110 -DUSE_HSREGEX -DEAPI -DUSE_EXPAT -I./lib/expat-lite -DNO_DL_NEEDED `./apaci` -L/home1/st/h/s-haa5/src/openssl-0.9.6e   \
      -o httpd buildmark.o modules.o modules/standard/libstandard.a modules/proxy/libproxy.a modules/ssl/libssl.a main/libmain.a ./os/unix/libos.a ap/libap.a regex/libregex.a lib/expat-lite/libexpat.a  -lm -lcrypt -ldb1  -lssl -lcrypto
modules/proxy/libproxy.a(proxy_cache.o): In function `ap_proxy_cache_update':
proxy_cache.o(.text+0x2d30): the use of `mktemp' is dangerous, better use `mkstemp'
/home1/st/h/s-haa5/src/openssl-0.9.6e/libcrypto.a(dso_dlfcn.o): In function `dlfcn_load':
dso_dlfcn.o(.text+0xa2): undefined reference to `dlopen'
dso_dlfcn.o(.text+0xb7): undefined reference to `dlopen'
dso_dlfcn.o(.text+0x11b): undefined reference to `dlclose'
/home1/st/h/s-haa5/src/openssl-0.9.6e/libcrypto.a(dso_dlfcn.o): In function `dlfcn_bind_var':
dso_dlfcn.o(.text+0x1da): undefined reference to `dlsym'
/home1/st/h/s-haa5/src/openssl-0.9.6e/libcrypto.a(dso_dlfcn.o): In function `dlfcn_bind_func':
dso_dlfcn.o(.text+0x2aa): undefined reference to `dlsym'
/home1/st/h/s-haa5/src/openssl-0.9.6e/libcrypto.a(dso_dlfcn.o): In function `dlfcn_unload':
dso_dlfcn.o(.text+0x3a7): undefined reference to `dlclose'
collect2: ld returned 1 exit status
make[2]: *** [target_static] Error 1
make[2]: Leaving directory `/home1/st/h/s-haa5/src/apache_1.3.26/src'
make[1]: *** [build-std] Error 2
make[1]: Leaving directory `/home1/st/h/s-haa5/src/apache_1.3.26'
make: *** [build] Error 2
______________________________________________________________________
Apache Interface to OpenSSL (mod_ssl)                   www.modssl.org
User Support Mailing List                      [email-masked]
Automated List Manager                            [email-masked]

---

From: Cliff Woolley <[email-masked]>
Date: Mon, 5 Aug 2002 15:18:56 -0400 (EDT)

> make: *** [build] Error 2

Hmm... that's interesting.  Try building in mod_so so that libdl will be
linked in.  Odd that your statically linked openssl library would want
libdl though... hmph.

--Cliff

---

From: Geoff Thorpe <[email-masked]>
Date: Mon, 5 Aug 2002 23:47:24 -0400 (EDT)

> linked in.  Odd that your statically linked openssl library would want

Nope, the DSO mechanism in openssl (for loading external engines or
whatever) requires it. If you call ENGINE_load_builtin_engines(), you'll
get a dependancy on DSO code whether it'll be used or not. It normally
doesn't show up because some systems don't need it (BSDs IIRC) and Apache
is usually built with a requirement on SO loading anyway so the linker
extras are already there.

I would have thought the mod_ssl configuration script would deal with this
though - either by grilling the openssl installation in some way, or by
doing its own autoconf-ish test, or at least by forcing the Apache
configuration to do it even if it doesn't want mod_so.

Cheers,
Geoff

-- 
Geoff Thorpe
[email-masked]