Subject: apache, https, ie downloading pdf's word docs etc...

From: Ian Moon <[email-masked]>
Date: Fri, 22 Nov 2002 14:09:22 -0700 (MST)

I can download pdf's and doc files no problem using mozilla using
both http and https, but I can only access them with http when using
ie 6.

I have tried all of the suggestions at ..
	http://www.modssl.org/docs/2.8/ssl_faq.html#ToC49

and scoured the groups and web for other things to try but none
have been successfull.

Running: Apache 1.3.27, mod_ssl 2.8.11,

Any suggestions or other readings would be greatly appreciated.

____________________
Ian Moon

______________________________________________________________________
Apache Interface to OpenSSL (mod_ssl)                   www.modssl.org
User Support Mailing List                      [email-masked]
Automated List Manager                            [email-masked]

---

From: Christopher McCrory <[email-masked]>
Date: 22 Nov 2002 13:51:56 -0800

Hello...

Do you have a <VirtualHost _default_:443> section that contains:

SetEnvIf User-Agent ".*MSIE.*" \
         nokeepalive ssl-unclean-shutdown \
         downgrade-1.0 force-response-1.0

then have a:
<VirtualHost ip.add.re.ss:443>
 ServerName www.example.com
 DocumentRoot /SOME/PATH
</VirtualHost>

? ? ?

If so try adding the 'SetEnvIf' the the www.example.com virtualhost
entry. Does it work?  I posted that this was a bug several days ago, but
it could just be me.

-- 
Christopher McCrory
 "The guy that keeps the servers running"

[email-masked]
 http://www.pricegrabber.com

Let's face it, there's no Hollow Earth, no robots, and 
no 'mute rays.' And even if there were, waxed paper is 
no defense.  I tried it.  Only tinfoil works.

---

From: Ian Moon <[email-masked]>
Date: Fri, 22 Nov 2002 17:09:00 -0700 (MST)

I don't have the _default_:443 section...
instead I put the directives straight into my

<VirtualHost *:443>
ServerName foo

SetEnvIf ...

</VirtualHost>

____________________
Ian Moon