Subject: Mod_SSL + Apache Config Problem.

From: "Theodore A. Jencks" <[email-masked]>
Date: Mon, 31 Dec 2001 10:59:16 -0800

I'm trying to get apache 1.3.22, mod_perl 1.26, mod_ssl latest and PHP to
compile staticly.  Mod_ssl seems to be giving an error when I try to do my
final ./configure for apache.  I get the following which has been posted on
the list before but was not answered.

I configure the apache source like this:

[root@pilsner apache_1.3.22]# SSL_BASE=SYSTEM \
> EAPI_MM=SYSTEM \
> OPTIM="-O2" \
> CFLAGS="-DDYNAMIC_MODULE_LIMIT=0" \
> ./configure \
> --prefix=/home/httpd \
> --bindir=/usr/bin \
> --sbindir=/usr/sbin \
> --libexecdir=/usr/lib/apache \
> --includedir=/usr/include/apache \
> --sysconfdir=/etc/httpd/conf \
> --localstatedir=/var \
> --runtimedir=/var/run \
> --logfiledir=/var/log/httpd \
> --datadir=/home/httpd \
> --proxycachedir=/var/cache/httpd \
> --mandir=/usr/share/man \
> --enable-module=mmap_static \
> --enable-module=auth_db \
> --enable-module=rewrite \
> --enable-module=ssl \
> --enable-rule=SSL_SDBM \
> --disable-rule=SSL_COMPAT \
> --activate-module=src/modules/php4/libphp4.a \
> --enable-module=php4 \
> --activate-module=src/modules/perl/libperl.a \
> --enable-module=perl \
> --disable-module=status \
> --disable-module=userdir \
> --disable-module=negotiation \
> --disable-module=imap \
> --server-uid=www \
> --server-gid=www

I get this:

Configuring for Apache, Version 1.3.22
 + using installation path layout: Apache (config.layout)
 + activated php4 module (modules/php4/libphp4.a)
 + activated perl module (modules/perl/libperl.a)
Creating Makefile
Creating Configuration.apaci in src
Error: Cannot find SSL header files in any of the following dirs:
Error: . /usr/include /usr/include/ssl/ /usr/local/include
/usr/local/include/ssl
Creating Makefile in src
 + configured for Linux platform
 + setting C compiler to gcc
 + setting C pre-processor to gcc -E
 + checking for system header files
 + adding selected modules
    o rewrite_module uses ConfigStart/End
      disabling DBM support for mod_rewrite
      (perhaps you need to add -ldbm, -lndbm or -lgdbm to EXTRA_LIBS)
    o db_auth_module uses ConfigStart/End
      using Berkeley-DB/3.x for mod_auth_db (-ldb)
    o ssl_module uses ConfigStart/End
      + SSL interface: mod_ssl/2.8.5
      + SSL interface build type: OBJ
      + SSL interface compatibility: disabled
      + SSL interface experimental code: disabled
      + SSL interface conservative code: disabled
      + SSL interface vendor extensions: disabled
      + SSL interface plugin: Built-in SDBM
      + SSL library path: [SYSTEM]
      + SSL library version: OpenSSL 0.9.6b [engine] 9 Jul 2001

I'm using Redhat Linux 7.2 and I have the standard Openssl rpm installed.  I
don't know where the header files are...?  Is there some sort of
openssl-devel rpm I need to install before hand?

Thanks to all those who reply!

Regards,
Theo

********************************************
Theodore A. Jencks --- Media Net Link,Inc --
                   671 San Ramon Valley Blvd
                   Danville, CA
                   94708

Main Phone:        925-855-9809
Direct Phone:      925-217-3632
Email:             [email-masked]
********************************************
______________________________________________________________________
Apache Interface to OpenSSL (mod_ssl)                   www.modssl.org
User Support Mailing List                      [email-masked]
Automated List Manager                            [email-masked]

---

From: Mads Toftum <[email-masked]>
Date: Tue, 1 Jan 2002 18:31:01 +0100

> openssl-devel rpm I need to install before hand?
Yes, you have to install openssl-dev.

vh

Mads Toftum
-- 
With a rubber duck, one's never alone.
              -- "The Hitchhiker's Guide to the Galaxy"
______________________________________________________________________
Apache Interface to OpenSSL (mod_ssl)                   www.modssl.org
User Support Mailing List                      [email-masked]
Automated List Manager                            [email-masked]