Subject: Any tools to test https+mod_ssl ???

From: "Arthur Chan" <[email-masked]>
Date: Tue, 5 Aug 2003 05:26:08 -0400

Hi All.
Further to my earlier comments that httpd + mod_ssl seems to be ignored by
Netscape 7.1
After logging-in and accepting the certificate, 7.1's liitle lock remains
open and says I am transmitting in clear text.
Yet Netscape 6.2, MSIE5 and Mozilla all accepted the certificate and they
say the transmission is encrypted.
Are there any tools available to test the transmission ???
Cheers.
:-)

______________________________________________________________________
Apache Interface to OpenSSL (mod_ssl)                   www.modssl.org
User Support Mailing List                      [email-masked]
Automated List Manager                            [email-masked]

---

From: Kiyoshi Watanabe <[email-masked]>
Date: Tue, 05 Aug 2003 18:38:59 +0900 (JST)

Hi I think that the following may help you.

openssl s_client -connect localhost:443 -state -debug

Please Refer to the FAQ in detail (www.modssl.org)

-Kiyoshi
Kiyoshi Watanabe

---

From: "Arthur Chan" <[email-masked]>
Date: Thu, 7 Aug 2003 05:10:09 -0400

Hi All.
When I run the  following line command :
[ssl] # openssl s_client -connect localhost:443 -state -debug
I get this error message :
...
SSL_connect:error in SSLv2/v3 read server hello A
1565:error:140770FC:SSL routines:SSL23_GET_SERVER_HELLO:unknown
protocol:s23_clnt.c:460:
...
Looking at line 460 of the source, it is exactly that error, no further
clues available.
Does anyone know more about it and want to help out ???
CHeers.