Subject: Problems with POSTing

From: Torvald Baade Bringsvor <[email-masked]>
Date: Fri, 13 Jun 2003 10:24:15 +0200

Hello.

Have run into a strange problem with Apache/mod_ssl 2.0.43:

I have set up a url that requires client certificates. And GET operations on
this URL works very well indeed. But POST doesnt work:

[Thu Jun 12 11:06:27 2003] [error] SSL Re-negotiation in conjunction with
POST method not supported!
hint: try SSLOptions +OptRenegotiate

I have tried +OptRenegotiate all over, but it doesnt make a difference.

Googling a bit reveals that this used to be a problem, but it seemes to be
uncertain if it still is (in newer versions).

Have any of you run into this one?

Regards
Torvald
______________________________________________________________________
Apache Interface to OpenSSL (mod_ssl)                   www.modssl.org
User Support Mailing List                      [email-masked]
Automated List Manager                            [email-masked]

---

From: "Pascal Rodrigue" <[email-masked]>
Date: Fri, 13 Jun 2003 08:36:15 -0400

Hi, 

I'm currently trying to resolve the same problem, so if any of you have
a solution, don't hesitate to POST it here ;o)

-------------------------------------------
Pascal Rodrigue
Analyste de l'informatique
Division de l'exploitation
Service de l'informatique et des télécommunications
Pavillon Louis-Jacques-Casault, local 2410
Université Laval, Québec, Canada,  G1K 7P4
[email-masked]
 
"La vie n'est pas que la somme des obstacle que l'on rencontre à chaque
jour. La vie, la vraie, c'est la manière dont on les franchit!"
 
Das Leben ist nicht nur die Summe des Hindernisses, daß man an jedem Tag
begegnet. Das Leben, das wahre, ist es die Art, von der man sie
überquert! 

-----Original Message-----
From: [email-masked]
[mailto:[email-masked]] On Behalf Of Torvald Baade
Bringsvor
Sent: 13 juin, 2003 04:24
To: [email-masked]'
Subject: Problems with POSTing

Hello.

I have set up a url that requires client certificates. And GET
operations on
this URL works very well indeed. But POST doesnt work:

[Thu Jun 12 11:06:27 2003] [error] SSL Re-negotiation in conjunction
with
POST method not supported!
hint: try SSLOptions +OptRenegotiate

Googling a bit reveals that this used to be a problem, but it seemes to
be
uncertain if it still is (in newer versions).

Regards
Torvald