Subject: RE: 1 certificate for several sites using redirection ?

From: [email-masked]
Date: Wed, 12 Jun 2002 10:27:53 +0100

There's always the possibility of a wildcard certificate, but you'd need to
have the same domain name throughout. Some browsers don't work with them.

See www.thawte.com for details.

- 
John Airey
Internet systems support officer, ITCSD, Royal National Institute of the
Blind,
Bakewell Road, Peterborough PE2 6XU,
Tel.: +44 (0) 1733 375299 Fax: +44 (0) 1733 370848 [email-masked] 

Is the statement 'There is no such thing as truth'  true?

> -----Original Message-----
> From: Peter Viertel [mailto:[email-masked]]
> Sent: 12 June 2002 10:24
> To: [email-masked]
> Subject: Re: 1 certificate for several sites using redirection ?
> 
> 
> You could do that using reverse proxy, ie mod_proxy.
> Redirects are not going to help.
> 
> Wim Godden wrote:
> 
> >Hi,
> >
> >I'd like to use a certificate to secure several of our subdomains...
> >buying hundreds of certificates is simply too expensive.
> >Is there some way to do this :
> >
> >- Install certificate on secure.ourdomain.com
> >- Let people surf to
> >https://secure.ourdomain.com/other-subdomain.ourdomain.com/wh
> at-ever-page.html
> >
> >Thanks in advance.
> >
> >
> >Greetings,
> >
> >Wim Godden
> >
> >_____________________________________________________________
> _________
> >Apache Interface to OpenSSL (mod_ssl)                   
www.modssl.org
>User Support Mailing List                      [email-masked]
>Automated List Manager                            [email-masked]
>  
>

______________________________________________________________________
Apache Interface to OpenSSL (mod_ssl)                   www.modssl.org
User Support Mailing List                      [email-masked]
Automated List Manager                            [email-masked]

- 

NOTICE: The information contained in this email and any attachments is 
confidential and may be legally privileged. If you are not the 
intended recipient you are hereby notified that you must not use, 
disclose, distribute, copy, print or rely on this email's content. If 
you are not the intended recipient, please notify the sender 
immediately and then delete the email and any attachments from your 
system.

RNIB has made strenuous efforts to ensure that emails and any 
attachments generated by its staff are free from viruses. However, it 
cannot accept any responsibility for any viruses which are 
transmitted. We therefore recommend you scan all attachments.

Please note that the statements and views expressed in this email 
and any attachments are those of the author and do not necessarily 
represent those of RNIB.

RNIB Registered Charity Number: 226227

Website: http://www.rnib.org.uk 

14th June 2002 is RNIB Look Loud Day - visit http://www.lookloud.org.uk to
find out all about it.

______________________________________________________________________
Apache Interface to OpenSSL (mod_ssl)                   www.modssl.org
User Support Mailing List                      [email-masked]
Automated List Manager                            [email-masked]

---

From: David Marshall <[email-masked]>
Date: Wed, 12 Jun 2002 07:57:25 -0700

Yes

-----Original Message-----
From: Wim Godden [mailto:[email-masked]]
Sent: Wednesday, June 12, 2002 7:46 AM
To: [email-masked]
Subject: Re: 1 certificate for several sites using redirection ?

Hi David,

Thanks, but does this require Mod_perl as I haven't got that install (it
eats
too much resources).

Greetings,

Wim

David Marshall wrote:

> To rewrite content you might look at the Perl module Apache::ProxyRewrite.
I
> was given an assignment to Front-end MS EXCHANGE OWA with Apache HTTPS.
> After review of options, I took a copy of the Perl module
> Apache::ProxyRewrite and added the ability to ReplaceText in the content
as
> well, I renamed it ProxyRewriteReplace. This was my 1st excursion into
Perl
> and I've never gotten the time to fully complete/test the module (example,
> the documentation is from ProxyReplace). I also only tested it as far as
to
> meet our objective of Proxying MS Exchange. I don;t know if this will
help,
> but I've included my ProxyRewriteReplace source.

---

From: [email-masked]
Date: Wed, 12 Jun 2002 11:21:19 +0100

Sounds like you have some absolute links rather than relative links. You can
also use 
proxypass /test https://other-subdomain.ourdomain.com

If the data needs to be secured between the proxy and the destination
server.

- 
John Airey

> Sent: 12 June 2002 11:06
> proxypass /test http://other-subdomain.ourdomain.com
> doesn't work properly... I get errors about the images being 
> insecure and all links
> point to the wrong position.
> 
> 
> Peter Viertel wrote:
> 
at-ever-page.html

--
------
Adverteren.be - 100% Nederlandstalig adverteren op kwalitatief hoogstaande
sites !

-

---

From: [email-masked]
Date: Mon, 17 Jun 2002 14:20:09 +0100

Generally speaking there isn't, however you can use mod_rewrite to rewrite
URLs for another site, but you would have to be reasonably consistent
otherwise writing the rules would be very difficult.

John

> Sent: 12 June 2002 13:09
> So there's no system which allows me to really proxy pages 
> and 'modify' them so
> that all future connections go through this 'proxy' as well ?
> 
> Greetings,
> 
> Wim
> 
> Peter Viertel wrote:
> 
> > yes, i think thats whats happening - you need to review the website
> > content you are pointing at. For this to work you can't have any
> > absolute hrefs, and also the backend site may issue 
> redirects, for these
> > to work you need a ProxyPassReverse which will rewrite the Location:
> > header on any redirects the backend site may send.
> >
> >  For example:
> >
> > ProxyPass /test    http://other.subdomain.ourdomain.com/
> > ProxyPassReverse /test  http://other.subdomain.ourdomain.com/
> >
> > proxypassreverse unfortunately is not case insensitive, and 
> the backend
> > webserver may refer to itself canonically, so the location 
> headers may
> > have another hostname. Either fix up the backend webserver 
> to match the
> > proxypassreverse, or add extra proxypassreverse lines.
> >
> > The most common cause of redirects is the / bug handlers of 
> tomcat, and
> > IIS which kick in if your url ends with / and that resolves to a
> > directory, then the webserver looks up what the 
> directoryindex script is
> > (eg. index.html) and sends a redirect. This is something to do with
> > early revision browser releases, I have no idea which ones or if it
> > matters anymore.
> >
> > Also note that mod_proxy got a big upgrade at apache 
> release 1.3.23 that
> > may help things along too in certain cases.
> >
> > [email-masked] wrote:
> >
> > >>>>I'd like to use a certificate to secure several of our
> > >>>>
> > >>>>
> > >>subdomains...
> > >>
> > >>
> Adverteren.be - 100% Nederlandstalig adverteren op 
> kwalitatief hoogstaande sites
> !
> 
> 

-