Subject: Apache SSL

From: "Kevin Smith" <[email-masked]>
Date: Fri, 3 May 2002 16:16:15 +0100

Hi All,

Does anyone know how to get round this problem when starting-up Apache SSL :

I have, /usr/local/bin/prngd /var/spool/prngd/pool, running so not sure what's wrong ? 

[Fri May  3 15:55:06 2002] [error] mod_ssl: Init: Failed to generate temporary 512 bit RSA private key (OpenSSL library error follows)
[Fri May  3 15:55:06 2002] [error] OpenSSL: error:24064064:random number generator:SSLEAY_RAND_BYTES:PRNG not seeded
[Fri May  3 15:55:06 2002] [error] OpenSSL: error:04069003:rsa routines:RSA_generate_key:BN lib

Many thanks,

Kevin Smith

---

From: "Subscribed" <[email-masked]>
Date: Fri, 3 May 2002 11:03:24 -0500

Did you make your openssl certificate? 
Is it referenced in your httpd.conf?
Perhaps openssl's library needs to be recompiled?
or your ssl module? Whave version of Apache are you running?
Just my shotgun approach. :()

====================================
"The things that come to those that wait may be
the things left by those who got there first."
====================================
  ----- Original Message ----- 
  From: Kevin Smith 
  To: [email-masked] 
  Sent: Friday, May 03, 2002 10:16 AM
  Subject: Apache SSL

  Hi All,

  Many thanks,

  Kevin Smith

---

From: "Kevin Smith" <[email-masked]>
Date: Fri, 3 May 2002 20:28:12 +0100

Yep, works on one server but not the other... Solaris platform.

Could it be to do with /dev/random not being installed?

    ----- Original Message ----- 
    From: Kevin Smith 
    To: [email-masked] 
    Sent: Friday, May 03, 2002 10:16 AM
    Subject: Apache SSL

    Hi All,

    Many thanks,

    Kevin Smith

---

From: Austin Gonyou <[email-masked]>
Date: 03 May 2002 15:12:30 -0500

Yeouch! You should either have Prngd, or some kind of /dev/random
/dev/urandom on there. Apache does have it's *built-in* by default,
though it's not truly recommended for production use. 

Solaris doesn't do SSL well. :(

There is an official backport from Solaris 9, to solaris 7 and 8 for an
official /dev/random and /dev/urandom devices. Search over at bigadmin,
and you should find it.

On Fri, 2002-05-03 at 14:28, Kevin Smith wrote:
> From: Subscribed <mailto:[email-masked]>  
> To: [email-masked] <mailto:[email-masked]>  
> From: Kevin  <mailto:[email-masked]> Smith 
> To: [email-masked] <mailto:[email-masked]>  
> [Fri May  3 15:55:06 2002] [error] mod_ssl: Init: Failed to generate
> temporary 512 bit RSA private key (OpenSSL library error follows)
> [Fri May  3 15:55:06 2002] [error] OpenSSL: error:24064064:random number
> generator:SSLEAY_RAND_BYTES:PRNG not seeded
-- 
Austin Gonyou
Systems Architect, CCNA
Coremetrics, Inc.
Phone: 512-698-7250
email: [email-masked]

"It is the part of a good shepherd to shear his flock, not to skin it."
Latin Proverb