Subject: Re: Apache warning: Connection refused: connect to listener

From: [email-masked]
Date: Tue, 30 Sep 2003 17:08:58 +0000

I am away until the 1st of October 2003.  
I will get back to you as soon as i can when I return.  
If the matter is urgent and concerns OASIS, MUBSWEB or MUBS Online 
then please contact one of the other members of the OLSU team.

______________________________________________________________________
Apache Interface to OpenSSL (mod_ssl)                   www.modssl.org
User Support Mailing List                      [email-masked]
Automated List Manager                            [email-masked]

---

From: "Alex Hart" <[email-masked]>
Date: Fri, 31 Oct 2003 06:11:23 -0500

I know everyone forgot about this already, but I still have this problem. I was hoping the new release of apache (2.0.48) would somehow fix this, but it didn't.

To rehash, apache works fine, but when I run with openssl, I consistently (thousands of times in day) get the warning: 

[warn] (61)Connection refused: connect to listener.

Everything seems to work fine.

I'm now running 2 copies of apache, one on port 80 and one on 443. When I run it like this, I get no warnings. It's only when I run both secure and insecure on the same server that I get warnings.  Does that make any sense? It seems like openssl with my insecure pages are causing the warning, but I seem to get these even when no activity is going on.

Here's my version info:
[root@www /usr/local/apache2/bin]# ./httpd -V
Server version: Apache/2.0.48
Server built:   Oct 30 2003 23:42:59
Server's Module Magic Number: 20020903:4
Architecture:   32-bit
Server compiled with....
 -D APACHE_MPM_DIR="server/mpm/prefork"
 -D APR_HAS_SENDFILE
 -D APR_HAS_MMAP
 -D APR_HAVE_IPV6 (IPv4-mapped addresses enabled)
 -D APR_USE_FLOCK_SERIALIZE
 -D SINGLE_LISTEN_UNSERIALIZED_ACCEPT
 -D APR_HAS_OTHER_CHILD
 -D AP_HAVE_RELIABLE_PIPED_LOGS
 -D HTTPD_ROOT="/usr/local/apache2"
 -D SUEXEC_BIN="/usr/local/apache2/bin/suexec"
 -D DEFAULT_PIDLOG="logs/httpd.pid"
 -D DEFAULT_SCOREBOARD="logs/apache_runtime_status"
 -D DEFAULT_LOCKFILE="logs/accept.lock"
 -D DEFAULT_ERRORLOG="logs/error_log"
 -D AP_TYPES_CONFIG_FILE="conf/mime.types"
 -D SERVER_CONFIG_FILE="conf/httpd.conf"

SSLSessionCache dbm:logs/ssl_scache
SSLMutex file:logs/ssl_mutex

Oh well, I'm probably switching off of FreeBSD soon anyway. So I guess the problems will dissappear then.

Alex Hart
President and Head Honcho
ATP Solutions, Inc.
http://www.althepal.com
ATPmail - Your Webmail Solution

The following message was sent by Mads Toftum <[email-masked]> on Fri, 3 Oct 2003 10:49:13 +0200.

> On Thu, Oct 02, 2003 at 11:58:35PM -0400, Alex Hart wrote:
> > More Info:
> > 
> > SSLSessionCache         dbm:logs/ssl_scache
> 
> Ususally I'd suggest using an shm based cache for performance reasons,
> but that probably isn't the cause.
> 
> > SSLMutex  file:logs/ssl_mutex
> > 
> I seem to recall some sort of trouble with mutexes on bsd that has been
> fixed recently - although your error message doesn't seem directly 
> related, it might be worth looking into. Or possibly even going for the
> latest cvs version in APACHE_2_0_BRANCH (a new release should be right
> around the corner anyway).
> 
> > I will try out different values for these, but I reinstalled without 
> modssl, so I have to install modssl first. Seems like these are pretty 
> standard settings. I'm surprised no one else has run across this warning.
> > 
> I have heard one reporting similar problems on irc, but that's it.
> 
> vh
> 
> Mads Toftum
> -- 
> Speaking at ApacheCon 2003 - http://ApacheCon.com/
> T03, "Apache 2 mod_ssl tutorial" (3h)
> WE03, "Troubleshooting Apache configurations" 
> WE11, "Apache mod_rewrite, the Swiss Army Knife of URL manipulation"