Subject: apachectl startssl - error

From: Oliver Koeller <[email-masked]>
Date: Wed, 30 Oct 2002 19:43:28 +0100

Hi,

i am a newbie to apache with ssl.
Under Solaris 8 I installed openssl 0.9.6g in /usr/local/openssl
In Apache 2.0.43 i did:
configure --enable-ssl --with-ssl=/usr/local/openssl
--> No errors.

make
--> No errors.

make install
--> No errors.

I generated a .cert and .key file and copied them to /usr/local/openssl/certs and /usr/local/openssl/private.

Then I tried to start it with:
apachectl startssl

and I get the following message:

[Wed Oct 30 19:31:59 2002] [crit] [Wed Oct 30 19:31:59 2002] \
file vhost.c, line 232, assertion "rv == APR_SUCCESS" failed
Abort - core dumped

No error logs were created.

Any ideas??
Please help.
Thank you.
Bye,
Olli.
______________________________________________________________________________
Angst vor Viren? Nicht bei WEB.DE FreeMail. Hier konnen Sie jeden
Dateianhang auf Viren prufen. http://freemail.web.de/?mc=021157
______________________________________________________________________
Apache Interface to OpenSSL (mod_ssl)                   www.modssl.org
User Support Mailing List                      [email-masked]
Automated List Manager                            [email-masked]

---

From: Oliver Koeller <[email-masked]>
Date: Thu, 7 Nov 2002 10:19:09 +0100

Hi Jeff,

i added my former mail at the bottom.
Yes, I solved the problem but forgot to write it here, sorry.
The solution was to replace '_default_' with the full qualified domainname of my server in the VirtualHost definition:
<VirtualHost FQDN:443>

Bye,
Olli.

"Snyder, Jeff M" <[email-masked]> schrieb am 06.11.02 23:14:39:
> Oliver,
> 
> I am having the same problem, although I don't think it has anything to do
> with SSL.  I can get apache to run fine, but when I add a VirtualHost to the
> httpd.conf, that is when encounter the core dump.  Have you made any
> progress on this error?
> 
> -Jeff
> 

Hi,

make
--> No errors.

make install
--> No errors.

Any ideas??
Please help.
Thank you.
Bye,
Olli.

________________________________________________________________
Keine verlorenen Lotto-Quittungen, keine vergessenen Gewinne mehr! 
Beim WEB.DE Lottoservice: http://tippen2.web.de/?x=13