Subject: SSL only Authentication Cient

From: Daniela Prestipino <[email-masked]>
Date: Thu, 04 Jul 2002 10:31:46 +0100

Hi,
Is it possible to config SSL protocol with only client authentication,
without encrypting the transmitted data, using Apache 1.3.19 with
mod_ssl 2.8.1 and openssl 0.9.5a?
Thanks
Daniela

--
    Daniela Prestipino
    [email-masked]

    I.D.S.,
    Informatica Distribuita e Software srl
    Via Consolare Pompea 19
    98168 Messina ITALIA
    Tel.: +39 90 353638
    Fax : +39 90 3500063

______________________________________________________________________
Apache Interface to OpenSSL (mod_ssl)                   www.modssl.org
User Support Mailing List                      [email-masked]
Automated List Manager                            [email-masked]

---

From: Colm McCartan <[email-masked]>
Date: Fri, 05 Jul 2002 17:20:22 +0100

Hello all,

I know this isn't purely a mod_ssl issue but its pretty closely involved 
and since I imagine many people are doing the same thing just now 
(upgrading apache)...

I have been trying to upgrade to 1.3.26 in the light of the 
chunked-encoding bug but have been unable to build it with the EAPI option. 
AFAICT this is not mentioned anywhere in the install docs or configuration. 
Without it, the most recent version of modssl won't compile complaining 
"Installed Apache doesn't contain Extended API (EAPI)"

If I understand correctly, in earlier versions there was an apache 
configuration rule but with 1.3.26

--enable-rule=EAPI

fails..

Am I missing something glaringly obvious?

Many thanks for any lights,
colm

---

From: "Enrico Demarin" <[email-masked]>
Date: Mon, 8 Jul 2002 21:24:27 -0700

I think hotmail works like that, the authentication is done through
https and then it reverts to regular http.

So yes I think it's possible.

Enrico

> -----Original Message-----
> From: [email-masked] 
> [mailto:[email-masked]] On Behalf Of Daniela Prestipino
> Sent: July 4, 2002 2:32 AM
> To: [email-masked]
> Subject: SSL only Authentication Cient
> 
> 
> Hi,
> Is it possible to config SSL protocol with only client 
> authentication, without encrypting the transmitted data, 
> using Apache 1.3.19 with mod_ssl 2.8.1 and openssl 0.9.5a? 
> Thanks Daniela
> 
> --
>     Daniela Prestipino
>     [email-masked]
> 
>     I.D.S.,