Subject: Chicken and Egg

From: "Roman Ivanov" <[email-masked]>
Date: Thu, 24 Oct 2002 17:06:04 +0400

Hello All!

I've just installed modssl. I want to clarify chicken and egg problem
for me.
I use modssl only for internal purposes so I use 1 self maded
certificate on two cites.
It is not problem that certificate does not match the site name.
I have in httpd.conf:

<VirtualHost IP:443>
ServerName A
...other directives...
<VirtualHost>

<VirtualHost IP:443>
ServerName B
...other directives...
</VirtualHost>

In logs:
[...] [warn]  Init: SSL server IP/port conflict: A:443 (httpd.conf:...)
vs. B:443 (httpd.conf:...)
[...] [warn]  Init: You should not use name-based virtual hosts in
conjunction with SSL!!

But https://B works and https://A works too.

Q
My question is: I didn't meet chicken and egg problem here because I
share one certificate between two servers?
Am I right?

Regards.
Roman Ivanov
CIS HQ SAMSUNG ELECTRONICS CO., LTD
web-master
TEL: +7-(095)-7972309
ICQ UIN #8160057

______________________________________________________________________
Apache Interface to OpenSSL (mod_ssl)                   www.modssl.org
User Support Mailing List                      [email-masked]
Automated List Manager                            [email-masked]

---

From: Barry Smoke <[email-masked]>
Date: 24 Oct 2002 08:21:49 -0500

I have been wondering the same thing...
I have thought about self signing a couple and trying it out.