Subject: RE: Apache.exe generates errors and is closed by Windows.

From: David Marshall <[email-masked]>
Date: Mon, 30 Sep 2002 17:23:21 -0700

Rama,
 
If you are not getting much information, you might try in your apache
https.conf file turning on debugging with "LogLevel debug". This may not
help, but sometimes you can find a clue as to where apache was in it's
processing when a failure occurs.
 
David Marshall

-----Original Message-----
From: Ramakrishna Kuppa [mailto:[email-masked]]
Sent: Monday, September 30, 2002 5:08 PM
To: [email-masked]'
Subject: RE: Apache.exe generates errors and is closed by Windows.

Chris, 

I upgraded our system to use OpenSSL 0.9.6g from your latest build. However,
the error I was referring to occurred in the previous build that had version
0.9.6d of OpenSSL.

The error is a Dr.Watson error. The usual popup box comes with the above
message and until the user acknowledges, the system doesn't service any
requests. There aren't any useful messages that get logged either.

The complete message is as follows: 
"Apache.exe generates errors and will be closed by Windows. You will need to
restart the program. An error log is being created."

> -----Original Message----- 
> From: hunter [ mailto:[email-masked]
<mailto:[email-masked]> ] 
> Sent: Monday, September 30, 2002 4:59 PM 
> To: [email-masked] 
> Subject: Re: Apache.exe generates errors and is closed by Windows. 
> 
> 
> Ramakrishna Kuppa wrote: 
> > I am getting the above error on my Windows platform. The 
> environment 
> > details are as follows: 
> > 
> > OS: Windows 2000 
> > Server: Apache 1.3.26 with OpenSSL 0.9.6d and mod_ssl 2.8.10 
> > 
> > The OS pops up a box with the above message and until the user 
> > acknowledges, the system doesn't respond to any user 
> requests. In a way, 
> > the system "hangs". 
> > 
> > Any ideas on how this can be resolved? Alternatively, can 
> the server 
> > be 
> > made to service user requests? 
> > 
> > Thanks 
> > Ramakrishna 
> > 
> 
> Ramakrishna, 
> 
> Could you please explain what is 'the above error'. 
> 
> Guess: Are you referring to an abnormal end.. a dialog that says a 
> program is exiting unexpectedly? 
> 
> Warning: You should not be using OpenSSL 0.9.6d - I thought you were 
> using one of the new builds I made? 
> 
> Advice: This error might happen if you did not have all of 
> the parts or 
> it is misconfigured.  You may find a clue in the error.log.  Have you 
> ever had this working or are you failing on an initial install. 
> 
> Chris. 
> 
> ______________________________________________________________________ 
> Apache Interface to OpenSSL (mod_ssl)                   www.modssl.org 
> User Support Mailing List                      [email-masked] 
> Automated List Manager                            [email-masked] 
>

---

From: "Andre Schild" <[email-masked]>
Date: Tue, 01 Oct 2002 08:40:34 +0200

We too had those problems with Apache 1.3.x, for this reason we did
never put a Win32 Apache with SSL into production.
Since 3 months we now use the 2.0.x releases, and we are very pleased
with them.
Work realy good under Win32 with/without ssl.

André

>>> [email-masked] 01.10.2002 01:26:51 >>>
I am getting the above error on my Windows platform. The 
environment details are as follows:

OS: Windows 2000

The OS pops up a box with the above message and until the user
acknowledges,
the system doesn't respond to any user requests. In a way, the system
"hangs".

Any ideas on how this can be resolved? Alternatively, can the server be
made
to service user requests?

Thanks
Ramakrishna