Subject: N/A

From: "David Flanigan" <[email-masked]>
Date: Tue, 7 May 2002 07:29:11 +0900

Hello, 

 My apologies if this has been discussed before, I did not turn up much in my 
archive search. I am new to modssl and to this list. Any help you can provide 
would be greatly appreciated. 

 I have a server wide SSL certificate for my domain, but only need SSL 
support in certain areas. Is there a way to redirect non SSL requests (port 
80) for particular directories to SSL without requiring the user to to do 
anything? So automatically:

 http://www.foo.com/private/

 becomes

 https://www.foo.com/private

 I am currently using the SSLRequireSSL directive to lock out non-SSL 
connections to those directories, resulting in a error to the user. 

 I have tried a location specific redirect like the following, but ended up 
with a loop (and a couple thousand extra entries in my log file). 
 
    <Location /private>
    Redirect seeother /private https://www.foo.com/private
    </Location>

 Am I on the right track or making this to difficult? I have no mod-rewrite 
skills, so have not tried that route as of yet. 

 Thanks in advance. 
--
Kind Regards, 
David A. Flanigan ([email-masked])

---

From: "Peter Viertel" <[email-masked]>
Date: Tue, 07 May 2002 12:55:04 +0100

Use VirtualHost stanzas:

ie:

<VirtualHost _default_:80>
        ServerName www.foo.com
        Redirect    /private      https://www.foo.com/private
        DocumentRoot "htdocs"
</VirtualHost>

<ifdefine SSL>
<VirtualHost _default_:443>
        ServerName www.foo.com
        SSLCertificateFile conf/ssl.crt/server.crt
        SSLCertificateKeyFile conf/ssl.key/server.key
        SSLEngine on
        DocumentRoot "secure"
</VirtualHost>
</ifdefine>

>skills, so have not tried that route as of yet.

______________________________________________________________________
Apache Interface to OpenSSL (mod_ssl)                   www.modssl.org
User Support Mailing List                      [email-masked]
Automated List Manager                            [email-masked]

---

From: "David Flanigan" <[email-masked]>
Date: Tue, 7 May 2002 10:53:19 +0900

Peter:

 This server is not running with virtual hosts (only a single domain), the 
doc root for SSL and non-SSL is the same. Anyway I can do the automatic 
redirect without moving the doc roots around?

 Thanks for your help. 

--
Kind Regards, 
David A. Flanigan

---------- Original Message -----------
From: "Peter Viertel" <[email-masked]>
To: [email-masked]
Sent: Tue, 07 May 2002 12:55:04 +0100
Subject: Re: N/A

> >skills, so have not tried that route as of yet.
Apache Interface to OpenSSL (mod_ssl)                   www.modssl.org User 
Support Mailing List                      [email-masked] Automated 
List Manager                            [email-masked]

---

From: "Peter Viertel" <[email-masked]>
Date: Tue, 07 May 2002 17:04:24 +0100

You shouldnt be afraid of virtual hosts.....

If you split them up as vhosts, then you can do what you want. If you
don't, you can't.
In my example i used seperate DocRoot's, but this is not necessary.

P.S. can you fix your PC's clock?  your timezone is 13 hours out.

David Flanigan wrote:

>>>My apologies if this has been discussed before, I did not turn up much in
>>>
>>>
>my
>
>
>>>archive search. I am new to modssl and to this list. Any help you can
>>>
>>>
>provide
>
>