Subject: mod_ssl issue, https is not working

From: Payal Suratwala <[email-masked]>
Date: Thu, 11 Jul 2002 16:54:56 -0400

I have installed Apache-V2.39-compiled with mod_ssl module.  
I have installed OpenSSL-V-0.9.6c and php4.2.2 on my server.  
I have created the RSA certificate and Private key and moved 
them in to the path described in the ssl.conf file.  When I 
do ./apachectl startssl, the ssl starts but when I open 
netscape to go to the https://servername, it prompts me that 
I am about to go to the secure website,and I click okay and 
then it tells me that the website is not found.  my 
http://servername site works, but https://servername does 
not, so what do I need to do? Why does the https now working? 
I have looked every where to find information about this and 
nothing has worked for me so far so, I would really 
appriciate some help on this issue?  Thank You,

PayalSuratwala
______________________________________________________________________
Apache Interface to OpenSSL (mod_ssl)                   www.modssl.org
User Support Mailing List                      [email-masked]
Automated List Manager                            [email-masked]

---

From: "Ashmore, Samuel R" <[email-masked]>
Date: Fri, 12 Jul 2002 07:12:35 -0600

There are many reason such as a port is not setup right, theres a conflict
with other programs.  When you reply to this attach your error log.  If you
want to you can aso attach the httpd.conf or ssl.conf. This might help us
understand what is happening on your system.

-----Original Message-----
From: Payal Suratwala [mailto:[email-masked]]
Sent: Thursday, July 11, 2002 2:55 PM
To: [email-masked]
Subject: mod_ssl issue, https is not working

PayalSuratwala

---

From: "Boyle Owen" <[email-masked]>
Date: Fri, 12 Jul 2002 16:30:06 +0200

Have you created an SSL virtualhost?

As well as installing mod_ssl, you laso have to define a virtual host to make use of it. Also, you have to tell the server to listen to port 443, e.g.

Listen 192.168.0.1:443
<VirtualHost 192.168.0.1:443>
  ...etc

Rgds,

owen Boyle

>Sent: Donnerstag, 11. Juli 2002 22:55

---

From: "Ashmore, Samuel R" <[email-masked]>
Date: Fri, 12 Jul 2002 08:35:51 -0600

ALthough if you just use the default installs the virtual host is already
setup

-----Original Message-----
From: Boyle Owen [mailto:[email-masked]]
Sent: Friday, July 12, 2002 8:30 AM
To: [email-masked]
Subject: RE: mod_ssl issue, https is not working

As well as installing mod_ssl, you laso have to define a virtual host to
make use of it. Also, you have to tell the server to listen to port 443,
e.g.

Listen 192.168.0.1:443

Rgds,

owen Boyle