Subject: Re: Failure to load mod_ssl under NT/apache 2.0

From: "arcean" <[email-masked]>
Date: Wed, 17 Jul 2002 08:12:39 -0700

---------- Original Message ----------------------------------
From: hunter <[email-masked]>
Reply-To: [email-masked]
Date:  Wed, 17 Jul 2002 09:22:37 -0400

>arcean wrote:
>> ---------- Original Message ----------------------------------
>> From: Alex Moon <[email-masked]>
>> Reply-To: [email-masked]
>> Date:  Wed, 17 Jul 2002 11:37:20 +0100
>> 
>> 
>>>I've been trying to get apache 2.0.39 +modssl to work under winNT. 
>>>But i am failing at what seems like the first hurdle i.e. i cannot seem to get the 
>>>apache mod_ssl.so module to load.  It comes up with the following:
>> 
>> 
>> with apache 1.3.2* under windows (not cygwin) you had to load .DDL 
>> and  not .SO
>> 
>> maybe it a way to search
>> 
[over load sniped ... ]

I said :
"with apache 1.3.2* under windows (not cygwin) you had 
to load .DDL"
             ^^^^^^                ^^^^^^^^^^^
not cygwin, native win32 if you prefer (with DLL)
1.3.2* like 1.3.20 or 1.3.26 ... not 1.0.39 
(not sure it existes)

i know my english is bad but ....

with cygwin i never try 

>I have not done this for several weeks and maybe the distribution has 
>changed, but...
>
>mod_ssl.so was not built with Apache 1.0.39
>
>...you have to build it.
>
>1. place openssl into ?:\httpd-2.0.39\srclib ... there are instructions 
>somewhere to follow...
>2. follow the instructions in openssl and build it ... you need masm7, 
>perl, vc6, etc.
>3. build apache ... it finds openssl and builds mod_ssl.so ... you need 
>awk, bison, sed and flex (new cygwin)
>
>... I had to get newer version of cygwin before it worked, but then the 
>newer perl was a problem.
>... older perl must be in path before cygwin
>
>After it all comes to gether you can use nmake -f makefile.win installr
>
>Then I had trouble making certs...
>
>Try these hints ... I will make more detailed instructions later if 
>needed but I think the newer packages (must) probably work better than 
>what I used ... but I have not checked.
>
>I will have to download new source and try again to know what the 
>situation is and I am sorry but I have to run off to work.  Later, ok?
>
>Chris.
>
>
>
>
>
>______________________________________________________________________
>Apache Interface to OpenSSL (mod_ssl)                   www.modssl.org
>User Support Mailing List                      [email-masked]
>Automated List Manager                            [email-masked]
>

__________________________________________________
D O T E A S Y - "Join the web hosting revolution!"
             http://www.doteasy.com
______________________________________________________________________
Apache Interface to OpenSSL (mod_ssl)                   www.modssl.org
User Support Mailing List                      [email-masked]
Automated List Manager                            [email-masked]

---

From: hunter <[email-masked]>
Date: Wed, 17 Jul 2002 21:12:56 -0400

> "with apache 1.3.2* under windows (not cygwin) you had 

I'm sorry I failed to make it clear when I replied - I was in a hurry to 
get to work.

The compile is with vc6 or vc 7 but some of the cygwin (unix) tools are 
used and must be avaialble.  I don't use cygwin to build Apache or openssl.

If you are still having trouble ... I am going to get the latest source 
now and see if the build conditions are the same as when I built mine. 
If they are then I think I can help you ... I worked through similar 
difficulties already.

Chris.