Subject: Re[2]: How a module can tell if a server is enabled to use SSL?

From: Christopher Taranto <[email-masked]>
Date: Thu, 31 Jan 2002 22:02:31 -0800

Hi,

Use the -l directive on the command-line to show the compliled in modules.

Look for mod_ssl.c.

./httpd -l

Compiled-in modules:
   http_core.c
   mod_env.c
   mod_log_config.c
   mod_mime.c
   mod_negotiation.c
   mod_status.c
   mod_include.c
   mod_autoindex.c
   mod_dir.c
   mod_cgi.c
   mod_asis.c
   mod_imap.c
   mod_actions.c
   mod_userdir.c
   mod_alias.c
   mod_rewrite.c
   mod_access.c
   mod_auth.c
   mod_proxy.c
   mod_setenvif.c
   mod_ssl.c

At 02:20 PM 1/31/02 -0800, you wrote:

>Does anyone know how my module (written in C), can tell if a server is 
>enabled to use SSL?
>There doesn't seem to be a direct way of doing it.
>Thanks for the help.

______________________________________________________________________
Apache Interface to OpenSSL (mod_ssl)                   www.modssl.org
User Support Mailing List                      [email-masked]
Automated List Manager                            [email-masked]

---

From: "Melnick, Jeff" <[email-masked]>
Date: Fri, 1 Feb 2002 08:47:15 -0800

I guess I should have been a bit more specific.
I actually need to check if a particular virtual host is enabled to use SSL,
i.e. given a server_rec, how to tell if the server that server_rec refers to
is enabled to use SSL.
Thanks once again.