Subject: RE: Using Aliases and SSL

From: [email-masked]
Date: Thu, 19 Sep 2002 09:19:52 +0100

Do I take it that you mean "ServerAlias"? If you do, then provided the alias
name matches the same IP address that your secure host is listening to, it
should work. I use it here myself.
 
If on the other hand you mean the Alias command that aliases directories, I
know of no reason why this shouldn't work. Can you post an example please?
 
- 
John Airey, BSc (Jt Hons), CNA, RHCE 
Internet systems support officer, ITCSD, Royal National Institute of the
Blind, 
Bakewell Road, Peterborough PE2 6XU, 
Tel.: +44 (0) 1733 375299 Fax: +44 (0) 1733 370848 [email-masked] 

Reality TV - the ultimate oxymoron 

-----Original Message-----
From: Matias Silva [mailto:[email-masked]]
Sent: 18 September 2002 20:39
To: User Group mod_ssl
Subject: Using Aliases and SSL

Can anybody assist me, in using Aliases with ssl?.  
 
I placed several Alias directives within the ssl.conf file specifically
where the virtual host is defined.  
This was to help assist in organizing the Apache server.  Of course its not
working.
 
Where should I place Alias Directives that need to be included in the ssl
area of the server ?
or Does SSL even work with Aliases?
 
Cheers
-Matt

- 

NOTICE: The information contained in this email and any attachments is 
confidential and may be legally privileged. If you are not the 
intended recipient you are hereby notified that you must not use, 
disclose, distribute, copy, print or rely on this email's content. If 
you are not the intended recipient, please notify the sender 
immediately and then delete the email and any attachments from your 
system.

RNIB has made strenuous efforts to ensure that emails and any 
attachments generated by its staff are free from viruses. However, it 
cannot accept any responsibility for any viruses which are 
transmitted. We therefore recommend you scan all attachments.

Please note that the statements and views expressed in this email 
and any attachments are those of the author and do not necessarily 
represent those of RNIB.

RNIB Registered Charity Number: 226227

Website: http://www.rnib.org.uk

---

From: "Matias Silva" <[email-masked]>
Date: Fri, 20 Sep 2002 14:42:38 -0700

Thanks John for your reply..... Yes I want to alias directories.  Basically I have a directory structure n deep and I have to reference common directories, but I don't want to do this relatively (e.g ../.../../TargetDirectory).  I want to use absolute
directories using the Alias command/directive (e.g /TargetDirectory) under the SSL environment.

Below is a partial copy from my ssl.conf file minusing the comments and all the ssl stuff.  I picked up
an Apache 2.0 book today so .... I'm going to keep trying.  Any suggestions would be appreciated.

Cheers
Matt 

<VirtualHost _default_:443>

#  General setup for the virtual host
DocumentRoot "/NetCommander/MainStreetStorageCorp/nc"
ServerName new.host.name:443
ServerAdmin [email-masked]
ErrorLog logs/error_log
TransferLog logs/access_log

Alias /images/ "/NetCommander/MainStreetStorageCorp/nc/images/"

<Directory "/NetCommander/MainStreetStorageCorp/nc/images/">
   Options Indexes MultiViews
   AllowOverride None
   Order allow,deny
   Allow from all
</Directory>

Alias /include/ "NetCommander/MainStreetStorageCorp/nc/include/"

<Directory "/NetCommander/MainStreetStorageCorp/nc/include/">
   Options Indexes Multiviews
   AllowOverride None
   Order allow,deny
   Allow from all
</Directory>

Alias /styles/ "NetCommander/MainStreetStorageCorp/nc/styles/"

<Directory "/NetCommander/MainStreetStorageCorp/nc/styles/">
   Options Indexes Multiviews
   AllowOverride None
   Order allow,deny
   Allow from all
</Directory>

Alias /javascript/ "/NetCommander/MainStreetStorageCorp/nc/javascript/"

<Directory "/NetCommander/MainStreetStorageCorp/nc/javascript/">
   Options Indexes Multiviews
   AllowOverride None
   Order allow,deny
   Allow from all
</Directory>

         :
         :
         :
SSL Directives
         :
         :
         :

<Files ~ "\.(cgi|shtml|phtml|php3?)$">
    SSLOptions +StdEnvVars
</Files>
<Directory "/usr/local/apache2/cgi-bin">
    SSLOptions +StdEnvVars
</Directory>

        :
        :
        :
More SSL Directives
        :
        :
        :

</VirtualHost>                                  

</IfDefine>

  ----- Original Message ----- 
  From: [email-masked] 
  To: [email-masked] 
  Sent: Thursday, September 19, 2002 1:19 AM
  Subject: RE: Using Aliases and SSL

  Do I take it that you mean "ServerAlias"? If you do, then provided the alias name matches the same IP address that your secure host is listening to, it should work. I use it here myself.

  If on the other hand you mean the Alias command that aliases directories, I know of no reason why this shouldn't work. Can you post an example please?

  - 
  John Airey, BSc (Jt Hons), CNA, RHCE 
  Internet systems support officer, ITCSD, Royal National Institute of the Blind, 
  Bakewell Road, Peterborough PE2 6XU, 
  Tel.: +44 (0) 1733 375299 Fax: +44 (0) 1733 370848 [email-masked] 

    -----Original Message-----
    From: Matias Silva [mailto:[email-masked]]
    Sent: 18 September 2002 20:39
    To: User Group mod_ssl
    Subject: Using Aliases and SSL

    I placed several Alias directives within the ssl.conf file specifically where the virtual host is defined.  
    This was to help assist in organizing the Apache server.  Of course its not working.

    Where should I place Alias Directives that need to be included in the ssl area of the server ?
    or Does SSL even work with Aliases?

    Cheers
    -Matt

  - 

  system.

  represent those of RNIB.