Subject: RE: Apache 2 + SSL Problems

From: "MATHIHALLI,MADHUSUDAN (HP-Cupertino,ex1)" <[email-masked]>
Date: Tue, 22 Jan 2002 11:53:54 -0800

Hi Laurie,
	To eliminate any confusion regarding configuration, can you pl. use
the standard httpd.conf and the ssl.conf that's installed when 2.0.28 is
installed.. The only extra thing you'll have to do is to create the
certificate.. Incase you don't have any previousely created certs., you can
use the attached script to generate dummy certs. Pl. note that this script
is derived off Ralf's original script - let me know if you run into
problems.. (to get help, just type "./mkcert.sh")..
	BTW, I believe you have to explicitly tell the server to listen on
443.

-Madhu

-----Original Message-----
From: Laurie Young [mailto:[email-masked]]
Sent: Tuesday, January 22, 2002 4:47 AM
To: [email-masked]'
Subject: Re: Apache 2 + SSL Problems

On Tue, 22 Jan 2002, Teodor Cimpoesu wrote:

> Hi Laurie!
> On Tue, 22 Jan 2002, Laurie Young wrote:
>
> > I have tried starting it with
> > ./apachectrl start
> > and with
> > ./apachectrl startssl
> >
> > both give the same errors
> >
> > It would be good if someone could have a look at my httpd.config file,
> > which I have included as an attachment
> >
> I don't remember if you said how did you compiled the SSL support (deleted
> the mesgs) was it as a loadable module? If so, add a LoadModule directive,
> cause:

I had some problems with DSO (apxs insisted on producing .la files instead
of .dso files) so I gave up on that and compilied modssl into the main
apache binary

>
> > PidFile logs/httpd.pid
> > Timeout 300
> > Listen 8080
> > Listen 443
> ....^ you listen on 443 either mod_ssl is loaded or not.

I wasn't sure if I had to explicitly tel the server to listen to 443. Do
I?

>
> > <VirtualHost 146.169.4.13:443>
> .................^ virtual host where sslengine is on sais a different IP
> than what you've tried from command line (namely 127.0.0.1 aka localhost).

146.169.4.13 is the real world IP for the machine I am running on, I have
tried connecting to localhost, 127.0.0.1, 146.169.3.14 and
stone.doc.ic.ac.uk (the FQDN of the host) but all have the same error ;-(

Laurie

-- 
==================================================
              Laurie Robert Young
[email-masked]  |       [email-masked]
www.wildfalcon.com     |  www.doc.ic.ac.uk/~laurie
              ICQ UIN #20194782
==================================================

______________________________________________________________________
Apache Interface to OpenSSL (mod_ssl)                   www.modssl.org
User Support Mailing List                      [email-masked]
Automated List Manager                            [email-masked]

---

From: Laurie Young <[email-masked]>
Date: Wed, 23 Jan 2002 17:50:28 +0000 (GMT)

I tried using the default files, and still had the same problem even
thoguh the ssl_engine.log was cliaming everythign is ok

I ahve now gone back to  apache 1.3.22 and got it working

Laurie

---

From: Austin Gonyou <[email-masked]>
Date: 23 Jan 2002 11:29:48 -0600

What version of Apache 2 were you using?

-- 
Austin Gonyou
Systems Architect, CCNA
Coremetrics, Inc.
Phone: 512-698-7250
email: [email-masked]

"It is the part of a good shepherd to shear his flock, not to skin it."
Latin Proverb

---

From: Laurie Young <[email-masked]>
Date: Thu, 24 Jan 2002 10:15:09 +0000 (GMT)

I was using the most recent release 2.0.28 (?)