Subject: Problems with Apache SSL under load

From: Dale Weaver <[email-masked]>
Date: Thu, 11 Dec 2003 11:16:48 -0500 (EST)

I have Apache 1.3.27 compiled with mod SSL using openssl 0.9.6.g
OS=AIX 5.1.

The SSL site stops executing CGI scripts when load gets a little 
high.  I checked the process list and found 106 httpd servers running.
System loads at the UNIX level were nominal (< 0.8).

I get tons of the following error in my error logs:

[Thu Dec 11 06:00:00 2003] [error] [client ] (11)Resource temporarily unavailable: couldn't spawn child process: /usr/local/apache/sslcgi/navbar1
[Thu Dec 11 06:00:00 2003] [error] [client ] (11)Resource temporarily unavailable: couldn't spawn child process: /usr/local/apache/sslcgi/navbar2
[Thu Dec 11 06:00:00 2003] [error] [client ] (11)Resource temporarily unavailable: couldn't spawn child process: /usr/local/apache/sslcgi/register.cgi

HTML page responses are still very fast even with the errors.

Problem does not occur when number of Apache servers < 70.

This is not a great deal of load.  The hardware is capable of handling
a lot more than that.

Can someone point me in the right direction?  Help is greatly appreciated.
Server configs availble on request.  Don't want to send large stuff over
the list.

Thanks.

---------------------------------------------------------------------

Dale Weaver                               [email-masked]
UNIX Systems Administrator                (919) 662-3508	
Wake Technical Community College          fax (919) 662-3504

______________________________________________________________________
Apache Interface to OpenSSL (mod_ssl)                   www.modssl.org
User Support Mailing List                      [email-masked]
Automated List Manager                            [email-masked]

---

From: Andreas Gietl <[email-masked]>
Date: Thu, 11 Dec 2003 17:26:02 +0100

On Thursday 11 December 2003 17:16, Dale Weaver wrote:
> [Thu Dec 11 06:00:00 2003] [error] [client ] (11)Resource temporarily
> unavailable: couldn't spawn child process: /usr/local/apache/sslcgi/navbar1
> [Thu Dec 11 06:00:00 2003] [error] [client ] (11)Resource temporarily
> unavailable: couldn't spawn child process: /usr/local/apache/sslcgi/navbar2
> [Thu Dec 11 06:00:00 2003] [error] [client ] (11)Resource temporarily
> unavailable: couldn't spawn child process:
> /usr/local/apache/sslcgi/register.cgi
>

for executing a cgi apache has to fork a new child process. But forking seems 
to fail. Maybe because of an RLIMIT_NPROC you have on your apache or because 
the server has reached a totel process limit.

-- 
e-admin internet gmbh
Andreas Gietl                                            tel +49 941 3810884
Ludwig-Thoma-Strasse 35                      
93051 Regensburg                                  mobil +49 171 6070008

PGP/GPG-Key unter http://www.e-admin.de/gpg.html

---

From: Cliff Woolley <[email-masked]>
Date: Thu, 11 Dec 2003 14:43:42 -0500 (EST)

> the server has reached a totel process limit.

Yes, I concur, this sounds like the most likely cause.

--Cliff