Subject: Antw: RE: Apache 2.0.40 - Loaded mod_ssl successfully on w2k?

From: "Andre Schild" <[email-masked]>
Date: Tue, 03 Sep 2002 17:25:05 +0200

>Has anyone successfully implemented mod_sll under 2.40 apache for w2k?
>I am getting a 501 1051 internal server error back. The ssl engine is
>loading
>but no response when I connect to the port.

2.0.40 works fine for me under W2K with OpenSSL 0.9.6e
Did compile it from the scratch...

Binaries are here:
http://www.switzerland.net/Pneatec/

André
______________________________________________________________________
Apache Interface to OpenSSL (mod_ssl)                   www.modssl.org
User Support Mailing List                      [email-masked]
Automated List Manager                            [email-masked]

---

From: "Paul Bleimeyer" <[email-masked]>
Date: Tue, 3 Sep 2002 13:08:48 -0500

Andre,

I think I am hitting a wall somewhere. Somewhat the same errors running your
code. Could it be my browser? Connections over 80 and 443 are fine, but when
I
invoke ssl via https://localhost or the server name I get the internal 501
error code. I shutdown my copy, renamed the folder to apache2.old inserted
yours, copied my ssl folder over with my key and cert in it and edited
http.conf and ssl.conf to reflect my directory structure. Any Ideas here? I
think I am tired, since I can't seem to figure out what's amiss here.

here is my http.conf and ssl.conf files for reference.

Access log still shows:
127.0.0.1 - - [03/Sep/2002:13:00:37 -0500] "€L" 501 288

> -----Original Message-----
> From: [email-masked]
> [mailto:[email-masked]]On Behalf Of Andre Schild
> Sent: Tuesday, September 03, 2002 10:25 AM
> To: [email-masked]
> Subject: Antw: RE: Apache 2.0.40 - Loaded mod_ssl successfully on w2k?
>
>

---

From: "Thierry Cabuzel" <[email-masked]>
Date: Wed, 4 Sep 2002 18:01:28 +0200

Hi,

I am new to this list. I am trying to explain my problem and how I can solve
it with mod_ssl. For that I have a load of questions :-)

My setup:
 - Win 98
 - Apache 1.3.24
 - WebDAV 1.0.3
 - PHP 4.2.0
 - gzip 1.3.19.1a

What I try to do:
I try to host some websites for my family.
For that I use a bunch of virtualhost, each site has his virtual host name.
For each site there is a WebFolder Access to edit pages.

They are stored like this:

  Path
     ->  URL
     ->  WebDAV Web Folder

  d:/webroot/www/Site1/
     ->  http://site1.server.net/
     ->  http://server.net/dav_site1/  (/dav_site1/ alias of www/site1/)
  d:/webroot/www/Site2/
     ->  http://site2.server.net/
     ->  http://server.net/dav_site2/  (/dav_site2/ alias of www/site2/)
  d:/webroot/www/Site3/
     ->  http://site3.server.net/
     ->  http://server.net/dav_site3/  (/dav_site3/ alias of www/site3/)

As you seen I have a bunch of virtual host for all the sites. And just 1
host with a bunch of alias for webDAV.
To this point I have no problem and this is work very well.

BUT, some old firewall doesn't support the http WebDAV extension. For this,
mod_ssl is the solution: Encrypt WebDAV in a ssl tunnel. At this point old
firewall just let the SSL canal pass thru and with ssl, WebDAV :-) If I have
read correctly SSL doesn't work on virtual host and I don't need it. I just
need it on the aliased hosts going thru SSl.

NOW the questions :-)

Is it possible to keep all my ordinary sites on the http protocol and put
the WebDAV web folder on https ?
I have downloaded "Apache_1.3.24-Mod_SSL_2.8.8-OpenSSL_0.9.6c-WIN32.zip". Is
it enough ?
How I can configure my httpd.conf ?

Thank for the help.

Thierry Cabuzel

---

From: Mads Toftum <[email-masked]>
Date: Wed, 4 Sep 2002 23:40:00 +0200

> the WebDAV web folder on https ?

yes

> I have downloaded "Apache_1.3.24-Mod_SSL_2.8.8-OpenSSL_0.9.6c-WIN32.zip". Is

you need newer versions - apache should be 1.3.26 and openssl also needs
to be the latest version.

> How I can configure my httpd.conf ?

Use the default mod_ssl httpd.conf along with the docs to do that.

vh

Mads Toftum
-- 
`Darn it, who spiked my coffee with water?!' - lwall

---

From: "Thierry Cabuzel" <[email-masked]>
Date: Thu, 5 Sep 2002 08:45:22 +0200

> -----Message d'origine-----
> De la part de Mads Toftum
> Envoyé : mercredi 4 septembre 2002 23:40
>
> > I have downloaded
> "Apache_1.3.24-Mod_SSL_2.8.8-OpenSSL_0.9.6c-WIN32.zip". Is
> > it enough ?
>

I have no probem to update apache. but for mod_ssl, I have bigger problem as
the contrib page of modssl.org seems out of order and the ftp folder is a
bit messy and OpenSSL_0.9.6c seems to be the older I can find in it. Source
is not a good solution as I have no C compiler and I don't want to mess with
one (at a point that I prefer to take the risk of a backdoored mod_ssl found
via google on an unknow server than to have to compile it from source).

---

From: "Martin Dickau" <[email-masked]>
Date: Thu, 5 Sep 2002 08:15:41 -0400

You should try OpenSA (http://www.opensa.org).  V1.0.3 is available, and it
has Apache 1.3.26 + mod_ssl 2.8.10 + OpenSSL 0.9.6g, built for Windows, with
a Windows installer.  The release notes/download page is here:
http://www.opensa.org/download/100.html

----- Original Message -----
From: "Thierry Cabuzel" <[email-masked]>
To: <[email-masked]>
Sent: Thursday, September 05, 2002 2:45 AM
Subject: RE: Apache + VirtualHost + WebDAV + mod_ssl

> via google on an unknow server than to have to compile it from source).

The OpenSA 1.0.3 kit also includes mod_ColdFusion (4.5.x), mod_DAV 1.0.3,
PHP 4.2.2, mod_ASP, mod_GZIP, and mod_AuthMysql 2.22.

Regards,

Martin Dickau, ByAllAccounts
[email-masked]

---

From: "Thierry Cabuzel" <[email-masked]>
Date: Tue, 17 Sep 2002 23:33:39 +0200

Hi,

I have tried it well enough to encounter a big problem with it :-(
SSL work well, but there is not all the PHP extensions I could except.
Especially PHP_IMAP, PHP_GD with GIF support, and PHP_XSLT for the more
important for me :-(( And PHP does some check on the interface version, then
I can't take them from another more complete PHP build :-((

I think I will take this probem to the level 2: Format my 2nd computer,
install Linux and do it all 'a la mano' with a C compiler...

> De : [email-masked]
> [mailto:[email-masked]]De la part de Martin Dickau
> Envoyé : jeudi 5 septembre 2002 14:16
> À : [email-masked]
> Objet : Re: Apache + VirtualHost + WebDAV + mod_ssl
>
>
> > I have no probem to update apache. but for mod_ssl, I have
> bigger problem
> as