Subject: newbie: help to create ssl connection.

From: kulkarni veena <[email-masked]>
Date: Wed, 5 Feb 2003 10:32:18 -0800 (PST)

Hi,

I'm new to all this ssl thing and I wanted to create a ssl connection for online store using modssl. Could you please advice how do i get started?

Thanks in advance.

Veena Kulkarni

---------------------------------
Do you Yahoo!?
Yahoo! Mail Plus - Powerful. Affordable. Sign up now

---

From: "Justin Williams" <[email-masked]>
Date: Wed, 5 Feb 2003 13:46:04 -0500

Thawte.com, actually, has a great step-by-step on this one  That's where the following comes from:
1- make sure you know the full domain name (https://www.domain.com)
2- pick 5 random files that are of moderate size (I use about a 5K file).  Thawte refers to these files as file1:file2:file3...
3- generate the key as follows:
openssl genrsa -des3 -rand file1:file2:file3:file4:file5 -out www.domain.com.key (you can leave out the -des3, if you are confident and secure about your server)
4- generate the CSR from the key:
openssl -req -new -key www.domain.com.key -out www.domain.com.csr (common name, when you are prompted, is not YOUR name, but the complete and entire domain name)
5- generate a temporary, self-signed CRT from the CSR:
openssl x509 -req -days 30 -in www.domain.com.csr -signkey www.domain.com.key -out www.domain.com.crt

You will then send the CSR to the CA of your choice.  Whenthey send you the CRT back, replace your temporary CRT with the real one.
  ----- Original Message ----- 
  From: kulkarni veena 
  To: [email-masked] 
  Sent: Wednesday, February 05, 2003 1:32 PM
  Subject: newbie: help to create ssl connection.

  Hi,

  Thanks in advance.

  Veena Kulkarni

------------------------------------------------------------------------------
  Do you Yahoo!?
  Yahoo! Mail Plus - Powerful. Affordable. Sign up now

---

From: kulkarni veena <[email-masked]>
Date: Wed, 5 Feb 2003 12:32:14 -0800 (PST)

Thanks. But I'm not clear about how to obtain encrytpion on the server and client side . Also, are there any tools to create Digital certificates becasue i need a self signed certificate. 
My configurations:
Server: Apache web server with Modssl enabled on Linux platform
client: internet explorer 5.0, netscape 6.0
programming language to be used for encryption: Java

 Justin Williams <[email-masked]> wrote: Thawte.com, actually, has a great step-by-step on this one  That's where the following comes from:1- make sure you know the full domain name (https://www.domain.com)2- pick 5 random files that are of moderate size (I use about a 5K file).  Thawte refers to these files as file1:file2:file3...3- generate the key as follows:openssl genrsa -des3 -rand file1:file2:file3:file4:file5 -out www.domain.com.key (you can leave out the -des3, if you are confident and secure about your server)4- generate the CSR from the key:openssl -req -new -key www.domain.com.key -out www.domain.com.csr (common name, when you are prompted, is not YOUR name, but the complete and entire domain name)5- generate a temporary, self-signed CRT from the CSR:openssl x509 -req -days 30 -in www.domain.com.csr -signkey www.domain.com.key -out www.domain.com.crt You will then send the CSR to the CA of your choice.  Whenthey send you the CRT back, replace your temporary CRT with the real one.----- Original Message ----- From: kulkarni veena To: [email-masked] Sent: Wednesday, February 05, 2003 1:32 PMSubject: newbie: help to create ssl connection.

Hi,

Thanks in advance.

Veena Kulkarni

---

From: "Justin Williams" <[email-masked]>
Date: Wed, 5 Feb 2003 15:43:07 -0500

That is a set of directions on creating your self-signed certificate.

As far as encryption, what, exactly, are you trying to accomplish?
  ----- Original Message ----- 
  From: kulkarni veena 
  To: [email-masked] 
  Sent: Wednesday, February 05, 2003 3:32 PM
  Subject: Re: newbie: help to create ssl connection.

  My configurations: 

   

   Justin Williams <[email-masked]> wrote: 

      ----- Original Message ----- 
      From: kulkarni veena 
      To: [email-masked] 
      Sent: Wednesday, February 05, 2003 1:32 PM
      Subject: newbie: help to create ssl connection.

      Hi,

      Thanks in advance.

      Veena Kulkarni

--------------------------------------------------------------------------
      Do you Yahoo!?
      Yahoo! Mail Plus - Powerful. Affordable. Sign up now

---

From: kulkarni veena <[email-masked]>
Date: Wed, 5 Feb 2003 16:17:09 -0800 (PST)

I'm trying to create an online store which will have a secured login and also secured transaction for payment processing.
 
 Justin Williams <[email-masked]> wrote:That is a set of directions on creating your self-signed certificate. As far as encryption, what, exactly, are you trying to accomplish?----- Original Message ----- From: kulkarni veena To: [email-masked] Sent: Wednesday, February 05, 2003 3:32 PMSubject: Re: newbie: help to create ssl connection.

Hi,

Thanks in advance.

Veena Kulkarni