Subject: Problem installing mod_ssl on Solaris 8

From: LDC - Alan Mizrahi <[email-masked]>
Date: Tue, 29 Jan 2002 13:21:55 -0400 (GMT)

Hello, I have a problem installing apache-1.3.22 with mod_ssl 2.8.5
(DSO) on Solaris 8 (sparc).
I get the following error starting apache:
Syntax error on line 206 of /usr/local/apache-1.3.22/conf/httpd.conf:
Cannot load /usr/local/apache-1.3.22/arch/libexec/libssl.so into server:
ld.so.1: /usr/local/apache-1.3.22/arch/bin/httpd: fatal: relocation
error: file /usr/local/apache-1.3.22/arch/libexec/libssl.so: symbol
ap_user_id: referenced symbol not found
/etc/init.d/httpd startssl: httpd could not be started

I am have gcc-2.95.3 using GNU's ld and as (binutils-2.11).
To install apache I did the following:

- I installed mm-1.1.3 like this:
./configure --prefix=/usr/local/libmm-1.1.3 \
  --exec-prefix=/usr/local/libmm-1.1.3/arch
make
make install

- I installed openssl-0.9.6c like this:
I modified the config script to force gcc instead of cc
./config --prefix=/usr/local/openssl-0.9.6c/arch \
  --openssldir=/usr/local/openssl-0.9.6c/ssl no-idea \
  no-threads shared -fPIC
make
make install

- I installed apache-1.3.22 and mod_ssl-2.8.5 like this:
tar -xzf apache_1.3.22.tar.gz
tar -xzf mod_ssl-2.8.5-1.3.22.tar.gz
cd mod_ssl-2.8.5-1.3.22
./configure --with-apache=../apache_1.3.22
cd ../apache_1.3.22
EAPI_MM=SYSTEM SSL_BASE=SYSTEM ./configure \
   --prefix=/usr/local/apache-1.3.22 \
   --exec-prefix=/usr/local/apache-1.3.22/arch \
   --enable-module=rewrite --enable-module=so \
   --enable-shared=ssl --enable-module=ssl
make
make install

Previous search of this error led me to use -fPIC when configuring
openssl and using only static libraries of openssl, it didn't work either.
When I run ldd -r libssl.so I find that many "ap_*" symbols that aren't
found.
Am I missing something here?

Thanks for your help.

Regards,

			Alan Mizrahi
			Universidad Simon Bolivar
			Laboratorio de Computacion
			[email-masked]

______________________________________________________________________
Apache Interface to OpenSSL (mod_ssl)                   www.modssl.org
User Support Mailing List                      [email-masked]
Automated List Manager                            [email-masked]

---

From: Mads Toftum <[email-masked]>
Date: Tue, 29 Jan 2002 22:19:18 +0100

>   --exec-prefix=/usr/local/libmm-1.1.3/arch

You need to add --disable-shared to the configure command for mm - see
the INSTALL file.

vh

Mads Toftum
-- 
With a rubber duck, one's never alone.
              -- "The Hitchhiker's Guide to the Galaxy"
______________________________________________________________________
Apache Interface to OpenSSL (mod_ssl)                   www.modssl.org
User Support Mailing List                      [email-masked]
Automated List Manager                            [email-masked]

---

From: LDC - Alan Mizrahi <[email-masked]>
Date: Tue, 29 Jan 2002 17:14:25 -0400 (GMT)

Thanks, I read in the archives that Matt Goyer had a similar problem, but
I think its not the same cause.
His problem was that the runtime linker didn't find the
dynamic openssl library, my problem is that the symbol "ap_user_id"
referenced in libssl.so isn't found in any library.
I think the ap_* symbols are defined in Apache core, so I don't know
what's wrong.
Can somebody help me solve this problem?

Regards,

			Alan Mizrahi

On Tue, 29 Jan 2002, R. DuFresne wrote:

>
> try updateing ld.so to locate the lib, this was covered just this week in
> the list.  man ld.so.1 should point you in the proper direction.  Also,
> there was a sugestion one can create a sym link to the share lib paths
> known to sunOS, from tthe special place folks like to place apache's
> libssl.so file.  Either one should work.
>
> Thanks,
>
> Ron DuFresne
>
> On Tue, 29 Jan 2002, LDC - Alan Mizrahi wrote:
>
> >
> ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
>         admin & senior security consultant:  sysinfo.com
>                         http://sysinfo.com
>
> "Cutting the space budget really restores my faith in humanity.  It
> eliminates dreams, goals, and ideals and lets us get straight to the
> business of hate, debauchery, and self-annihilation."
>                 -- Johnny Hart
>
> testing, only testing, and damn good at it too!
>
>

---

From: "R. DuFresne" <[email-masked]>
Date: Tue, 29 Jan 2002 15:17:13 -0500 (EST)

Thanks,

Ron DuFresne

---

From: LDC - Alan Mizrahi <[email-masked]>
Date: Tue, 29 Jan 2002 21:10:25 -0400 (GMT)

I did everything again, without shared mm and without shared ssl, and id
didn't work either.
I also tried Ron's suggestion (I made a link in /usr/lib to libssl.so,
also I tried with LD_LIBRARY_PATH).
Any ideas?

Thanks

			Alan Mizrahi

---

From: Adam Ronthal <[email-masked]>
Date: Wed, 30 Jan 2002 11:45:09 -0500

I had to add the following to my apachectl script to get it going:

LD_LIBRARY_PATH=$LD_LIBRARY_PATH:/usr/lib:/usr/local/ssl/lib
export LD_LIBRARY_PATH

Hope that helps....

-Adam