Subject: Re: Please, I need aid

From: [email-masked]
Date: Wed, 13 Nov 2002 17:29:40 +0100

in ssl.conf, try to change
<VirtualHost _default_:443>
to
<VirtualHost Your-IP:443>

                    [email-masked]                                                                                           
                    Sent by:                  To:      [email-masked]                                           
                    owner-modssl-users@       cc:                                                                        
                    modssl.org                 Subject:     Please, I need aid                                           
                                               Header:      Internal Use Only                                            
                                                                                                                         
                    13.11.2002 11:31                                                                                     
                    Please respond to                                                                                    
                    modssl-users                                                                                         

Hello,

I'm an Spanish technicien, and my name is Marc Bartres.
Please excuse for my english first.

I've a problem installing Apache 2.0.43 ans SSL.
I've downloading this version and the OpenSSL 0.9g version.

The Apache without SSL runs ok.
But when I runs Apache with startssl appears an error of a library: vhost.c of
APR.

I compiled Apache with:
./configure --prefix=/usr/local/apache2 --enable-ssl
make
make install
and I configured httpd.conf with ServerName "the_IP:80" and ssl.conf with
ServerName "the_IP:443".

I put server.key and server.crt in ssl.conf too.

I want a basic secure server and I don't know what's the problem.

I'm testing enabling all modules, but then appears and error on DAV's library.

Please, it's for my work and I'm only in this project. Nobody knows Apache.

Thany you very much.
______________________________________________________________________
Apache Interface to OpenSSL (mod_ssl)                   www.modssl.org
User Support Mailing List                      [email-masked]
Automated List Manager                            [email-masked]

-------------------------------------------------------------- --
        Visit our Internet site at http://www.reuters.com

Get closer to the financial markets with Reuters Messaging - for more
information and to register, visit http://www.reuters.com/messaging

Any views expressed in this message are those of  the  individual
sender,  except  where  the sender specifically states them to be
the views of Reuters Ltd.
______________________________________________________________________
Apache Interface to OpenSSL (mod_ssl)                   www.modssl.org
User Support Mailing List                      [email-masked]
Automated List Manager                            [email-masked]

---

From: "Boyle Owen" <[email-masked]>
Date: Wed, 13 Nov 2002 17:38:51 +0100

The problem is with your apr libraries. Check out
http://apr.apache.org/.

Rgds,

Owen Boyle

>-----Original Message-----
>From: [email-masked] [mailto:[email-masked]]
>Sent: Mittwoch, 13. November 2002 11:31
>To: [email-masked]
>Subject: Please, I need aid
>
>
>Hello,
>

This message is for the named person's use only. It may contain
confidential, proprietary or legally privileged information. No
confidentiality or privilege is waived or lost by any mistransmission.
If you receive this message in error, please notify the sender urgently
and then immediately delete the message and any copies of it from your
system. Please also immediately destroy any hardcopies of the message.
You must not, directly or indirectly, use, disclose, distribute, print,
or copy any part of this message if you are not the intended recipient.
The sender's company reserves the right to monitor all e-mail
communications through their networks. Any views expressed in this
message are those of the individual sender, except where the message
states otherwise and the sender is authorised to state them to be the
views of the sender's company. 
______________________________________________________________________
Apache Interface to OpenSSL (mod_ssl)                   www.modssl.org
User Support Mailing List                      [email-masked]
Automated List Manager                            [email-masked]

---

From: David Loesche <[email-masked]>
Date: Wed, 13 Nov 2002 07:47:53 -0800

This is the config I used on a test environment that works for Solaris 8
(this includes the new multi-threaded capabilities).

#!/bin/ksh
PATH=/usr/local/bin:/usr/local/sbin:/usr/bin:/usr/sbin
LD_LIBRARY_PATH=/usr/local/lib:/opt/ssl/lib:/usr/lib
export PATH LD_LIBRARY_PATH

SSL_BASE=/opt/ssl \
LIBS=/usr/lib/libC.so.5 \
CFLAGS=-fPIC \

./configure     --prefix=/opt/apache \
                --enable-ssl \
                --with-ssl=/opt/ssl/ \
                --enable-so \
                --with-mpm=worker \
                --enable-deflate

David S. Loesche
[email-masked]			Yipes Enterprise Services, Inc.
Main: 	(415) 901-2000 			114 Sansome Street, Suite 1045
Direct: 	(415) 901-2210			San Francisco, CA 94104
Fax: 	(415) 901-2201			http://www.yipes.com

Yipes is the defining provider of fully scalable bandwidth for businesses.
We offer fully managed high-speed Internet and Nationwide LAN-to-LAN
services at speeds ranging from 1 Mbps to 1 Gbps, in 1 Mbps increments. 

Yipes delivers this uniquely flexible service over the first nationwide
system of optical IP networks.

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]
Sent: Wednesday, November 13, 2002 2:31 AM
To: [email-masked]
Subject: Please, I need aid

Hello,

The Apache without SSL runs ok.
But when I runs Apache with startssl appears an error of a library: vhost.c
of
APR.

I compiled Apache with:

I'm testing enabling all modules, but then appears and error on DAV's
library.

Thany you very much.