Subject: Newbies : Apache - mod-ssl error

From: Andy Soedibjo <[email-masked]>
Date: Wed, 26 Jun 2002 16:15:09 +0200

>Hi,
>
>I tried to install Apache1.3.26 - mod-ssl2.8.9-1.3.26 - OpenSSL0.9.6d in 
>windows2000.
>I think i've succeeded to install everything.
>
>Now for Apache, i can run it without SSL.
>But, if i try to add LoadModule ssl_module modules/mod_ssl.so
>and run it ... it returns error :
>Syntax error on line 192 of d:/apache/conf/httpd.conf:
>Cannot load /apache/modules/mod_ssl.so into server: (126) The specified 
>module could not be found:
>
>i'm sure i've put the mod_ssl.so in the modules directory with others 
>Apache modules.
>I've tried to used the full directory LoadModule ssl_module 
>D:/Apache/modules/mod_ssl.so
>but, still get the same error.
>Syntax error on line 192 of d:/apache/conf/httpd.conf:
>Cannot load d:/apache/modules/mod_ssl.so into server: (126) The specified 
>module could not be found:
>
>Does anyone knows what's wrong? Any suggestion will be accepted.
>
>Thanks in advance,
>Andy.

---

From: Kristijan Cafuta RIP <[email-masked]>
Date: Wed, 26 Jun 2002 17:16:45 +0200

The most common mistake on windows is that people forget to copy
ssleay32.dll and libeay32.dll to WINNT\System32...

it returns exactly that error...

did you copy them?

>>Does anyone knows what's wrong? Any suggestion will be accepted.

______________________________________________________________________
Apache Interface to OpenSSL (mod_ssl)                   www.modssl.org
User Support Mailing List                      [email-masked]
Automated List Manager                            [email-masked]

---

From: Andy Soedibjo <[email-masked]>
Date: Wed, 26 Jun 2002 17:38:30 +0200

Thanks for all the response ...
It's all my fault ... after i use the Dependency Walker to see the 
mod_ssl.so (dll also) ...
I found there are 3 files not found : ApacheCore.dll, libeay32.dll, and 
ssleay32.dll.
It's all because i don't specify the Apache and OpenSLL bin folder into my 
path.

Now, it works. Thanks for the clue, specially for Kristijan ...

Regards,
Andy.