Subject: Problem with Compiling Mod_ssl

From: "Mohamed Alwakeel" <[email-masked]>
Date: Fri, 12 Apr 2002 10:22:51 +0100

I keep on getting an error when I do a
./configure --with-apxs=/usr/local/apachenew/bin/apxs
--with-apache=/root/moh/apache_1.3.22

Error:-
Configuring mod_ssl/2.7.1 for Apache/1.3.14
/configure:Error: Installed Apache doesn't contain Extended API (EAPI)

I am getting very similar error when compiling mod_ssl for apache 1.3.22,
with either version mod ssl-2.7.1
or version mod ssl-2.8.8.

I have a redhat 7.2 box patched up to latest packages. It does have apache
1.3.22 installed as an rpm and apache 1.3.22 installed from source under
/usr/local/apachenew. Im not using the rpm one Im using the source installed
one.
I have the whole source directory for apache under /root/moh/apache_1.3.22

When I do httpd -l I get the following:-
/httpd -l
Compiled-in modules:
  http_core.c
  mod_mmap_static.c
  mod_vhost_alias.c
  mod_env.c
  mod_log_config.c
  mod_log_agent.c
  mod_log_referer.c
  mod_mime_magic.c
  mod_mime.c
  mod_negotiation.c
  mod_status.c
  mod_info.c
  mod_include.c
  mod_autoindex.c
  mod_dir.c
  mod_cgi.c
  mod_asis.c
  mod_imap.c
  mod_actions.c
  mod_speling.c
  mod_userdir.c
  mod_alias.c
  mod_rewrite.c
  mod_access.c
  mod_auth.c
  mod_auth_anon.c
  mod_auth_dbm.c
  mod_auth_db.c
  mod_digest.c
  mod_auth_digest.c
  mod_proxy.c
  mod_cern_meta.c
  mod_expires.c
  mod_headers.c
  mod_usertrack.c
  mod_example.c
  mod_unique_id.c
  mod_so.c
  mod_setenvif.c
suexec: disabled; invalid wrapper /usr/local/apachenew/bin/suexec

Is there any way to fix this without having to recompile apache again ?

Thanks

______________________________________________________________________
Apache Interface to OpenSSL (mod_ssl)                   www.modssl.org
User Support Mailing List                      [email-masked]
Automated List Manager                            [email-masked]

---

From: Owen Boyle <[email-masked]>
Date: Fri, 12 Apr 2002 11:41:04 +0200

> Is there any way to fix this without having to recompile apache again ?

No. apache *needs* the extended API (EAPI) to connect to the openssl
library functions. In order to use mod_ssl, you need to recompile apache
with EAPI.. This is true whether you compile in mod_ssl statically or
load it as a DSO.

However, it shouldn't be too much trouble - the INSTALL document in the
mod_ssl distro is quite good.

Rgds,

Owen Boyle.

---

From: Server Admin <[email-masked]>
Date: Fri, 12 Apr 2002 07:18:28 -0500

>mod_ssl distro is quite good.

Owen: I run FBSD 4.5-stable and have tried 5-6 times to install
apache+mod_ssl-1.3.24+2.8.8 directly from ports that does all the work,
where I simply use "make install clean" but I'm getting the same (or
similar) error message, but don't have a clue as to how to do the
"re-compile". Could you please point me to the
"...the INSTALL document in the mod_ssl distro is quite good..."
that you refer to. I'm desparate to set up a secure server as time is of
the essence. Does "mod_ssl" install that document in the /usr/local/share/
directory during the install.

To be more specific, here is the error I get:
==============================================
[Wed Apr 10 18:26:46 2002] [warn] Loaded DSO libexec/apache/libphp4.so uses
plain Apache 1.3 API, this module might crash under EAPI! (please recompile
it with -DEAPI)
[Wed Apr 10 18:26:46 2002] [warn] Loaded DSO
libexec/apache/mod_frontpage.so uses plain Apache 1.3 API, this module
might crash under EAPI! (please recompile it with -DEAPI)
==============================================

I've received an earlier reply to do what I've been doing, so I'm getting
nowhere fast....

.... our website: http://www.sage-one.net/

Best regards,

Jack L. Stone
Server Admin

---

From: Owen Boyle <[email-masked]>
Date: Fri, 12 Apr 2002 14:45:51 +0200

> To be more specific, here is the error I get:

When you untar the mod_ssl distro it's right there in the top directory.

Here are my notes from the last time I installed plain statically
compiled apache+mod_ssl (this is version 1.3.14 - just change the
numbers and the installation paths to suit your distro):

Installing Apache 1.3.14 with mod_ssl and mm
-----------------------------------------------
(see http://www.modssl.org/example/)

- Get the sources:
- www.apache.org 		<-- apache_1.3.14.tar.gz
- ftp://ftp.openssl.org 	<-- openssl-0.9.6.tar.gz
- www.modssl.org 		<-- mod_ssl-2.7.1-1.3.14.tar.gz
- www.engelschall.com/sw/mm/ 	<-- mm-1.1.3.tar.gz	

- Save all these in /home/obo/downloads/tar_files

# cd /home/apache
# gzip -d -c /home/obo/downloads/tar_files/apache_1.3.14.tar.gz | tar
xvf -
# gzip -d -c /home/obo/downloads/tar_files/openssl-0.9.6.tar.gz | tar
xvf -
# gzip -d -c /home/obo/downloads/tar_files/mod_ssl-2.7.1-1.3.14.tar.gz |
tar xvf -
# gzip -d -c /home/obo/downloads/tar_files/mm-1.1.3.tar.gz | tar xvf -

- Need to add perl and ar to the path;

# PERL=/usr/local/bin/perl
# export PERL
# PATH=$PATH:/usr/local/bin:/usr/ccs/bin
# export PATH

- first, compile MM

# cd mm-1.1.3
# ./configure --prefix=/home/apache/mm
# make
# make test
# make install

- All the files are untarred, so we go to openssl-0.9.6

# cd ../openssl-0.9.6
# ./Configure solaris-sparcv9-gcc --prefix=/home/apache
# make clean
# make

- Switch to the modd_ssl directory and configure it.

# cd ../mod_ssl-2.7.1-1.3.14
# ./configure --with-apache=../apache_1.3.14 --with-ssl=../openssl-0.9.6
--prefix=/home/apache

- Switch to the apache directory 

# cd ../apache_1.3.14
# SSL_BASE=../openssl-0.9.6
# export SSL_BASE
# ./configure --enable-module=ssl --prefix=/home/apache 
# make  
# make install
______________________________________________________________________
Apache Interface to OpenSSL (mod_ssl)                   www.modssl.org
User Support Mailing List                      [email-masked]
Automated List Manager                            [email-masked]

---

From: Server Admin <[email-masked]>
Date: Sat, 13 Apr 2002 15:43:43 -0500

>Installing Apache 1.3.14 with mod_ssl and mm

Many thanks, Owen for the details of your last install. But, on FBSD, if I
already have Apache-1.23+OpemSSL+other mods all set on a server, what would
be the same syntax details to just add the mod_ssl-2.8.7-1.3.23.tar.gz so
not to mess up the existing setup that has a number of vhosts already.

Thanks for your patience with my questions....

Best regards,

Jack L. Stone
Server Admin

---

From: "R. DuFresne" <[email-masked]>
Date: Sat, 13 Apr 2002 17:21:10 -0400 (EDT)

You're going to have to recomplie the whole thing anyways.  And  that
should well leave the http.conf file alone, you can use yer old, just add
in any new directives you will need.  To be safe, tar up what you have
incase you wanna revert back, or setup the new to go to a nice sweet new
spot in the tree.

Thanks,

Ron DuFresne

-- 
~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
        admin & senior security consultant:  sysinfo.com
                        http://sysinfo.com

"Cutting the space budget really restores my faith in humanity.  It
eliminates dreams, goals, and ideals and lets us get straight to the
business of hate, debauchery, and self-annihilation."
                -- Johnny Hart

testing, only testing, and damn good at it too!