Subject: errors starting apache2.0.45 with mod_ssl as DSO.

From: kulkarni veena <[email-masked]>
Date: Thu, 8 May 2003 12:22:51 -0700 (PDT)

Hello,
my question is :

I have set to start Mod-ssl as DSO. When I try to
start apache 2.0.45 i get errors as follows:

# ./httpd -DSSL
Syntax error on line 233 of /etc/apache/httpd.conf:
Cannot load /usr/apache/libexec/mod_ssl.so into
server: ld.so.1: ./httpd: fatal: relocation error:
file /usr/apache/libexec/mod_ssl.so: symbol
X509_INFO_free: referenced symbol not found

any suggestions to rectify it?

thanks in advance.

-veena

__________________________________
Do you Yahoo!?
The New Yahoo! Search - Faster. Easier. Bingo.
http://search.yahoo.com
______________________________________________________________________
Apache Interface to OpenSSL (mod_ssl)                   www.modssl.org
User Support Mailing List                      [email-masked]
Automated List Manager                            [email-masked]

---

From: kulkarni veena <[email-masked]>
Date: Thu, 8 May 2003 23:54:31 -0700 (PDT)

BTW, this is on Solaris 2.9 OS.

---

From: Bruno Georges <[email-masked]>
Date: Fri, 9 May 2003 08:52:23 +0100

Did you compile openssl as shared or static?
If static then you need to build openssl with shared option.

Hope this helps.

Bruno Georges
Xbridge Ltd
Tel: +44 (0) 207 378 9830
Mob: +44 (0) 787 988 4895