Subject: RE: mod_ssl-2.8.10-1.3.26 on Solaris 9 getting errors

From: Zandi Patrick S TSgt AFRL/IFOSS <[email-masked]>
Date: Wed, 2 Oct 2002 17:51:18 -0000

Well it compiles anyhoo.. 
After make, 
make certificate, 
and make install   now if I type apachectl start   or apachectl startssl  
Core Segmentation errors.

-----Original Message-----
From: Zandi Patrick S TSgt AFRL/IFOSS [mailto:[email-masked]] 
Sent: Wednesday, October 02, 2002 1:41 PM
To: [email-masked]'
Subject: RE: mod_ssl-2.8.10-1.3.26 on Solaris 9 getting errors 

It worked -- It figures.. Where did you find that is the Doc's ?
I did not have to do that with solaris 8 !
= 8 ^)

-----Original Message-----
From: Julian R Panchen [mailto:[email-masked]] 
Sent: Wednesday, October 02, 2002 1:17 PM
To: [email-masked]
Subject: RE: mod_ssl-2.8.10-1.3.26 on Solaris 9 getting errors 

You need a copy of flex you can obtain the source code from GNU see
http://www.gnu.org/software/flex/ <http://www.gnu.org/software/flex/> 

I am running Apache  1.3.26 and mod_ssl 2.8.10 on Solaris 9 with no
problems.

Regards

Julian R Panchen

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]
On Behalf Of Zandi Patrick S TSgt AFRL/IFOSS
Sent: 02 October 2002 17:57
To: [email-masked]'
Subject: mod_ssl-2.8.10-1.3.26 on Solaris 9 getting errors 

Hello folks, 

    I getting strange errors on compile.   Anyone See this.. or have any
ideas

Mod_ssl seems to work fine with

./configure \

--with-apache=../apache_1.3.26 \

--with-ssl=/usr/lcoal/ssl/ \

--prefix=/apache

However When I compile the apache I am getting the following.. 

     EEDED `../../apaci` -DSSL_COMPAT -I/usr/local/ssl/include
-DMOD_SSL_VERSION=\"2.8.10\" ssl_scache_shmcb.c
gcc -c  -I../../os/unix -I../../include   -DSOLARIS2=290 -DMOD_SSL=208110
-DEAPI -DUSE_EXPAT -I../../lib/expat-lite -DNO_DL_NEEDED `../../apaci`
-DSSL_COMPAT -I/usr/local/ssl/include -DMOD_SSL_VERSION=\"2.8.10\"
ssl_expr.c
flex -Pssl_expr_yy -s -B ssl_expr_scan.l
sh: flex: not found
*** Error code 1
make: Fatal error: Command failed for target `ssl_expr_scan.c'
Current working directory
/home/oracle/building/apache_1.3.26/src/modules/ssl
*** Error code 1
make: Fatal error: Command failed for target `all'
Current working directory /home/oracle/building/apache_1.3.26/src/modules
*** Error code 1
make: Fatal error: Command failed for target `subdirs'
Current working directory /home/oracle/building/apache_1.3.26/src
*** Error code 1
make: Fatal error: Command failed for target `build-std'
Current working directory /home/oracle/building/apache_1.3.26
*** Error code 1
make: Fatal error: Command failed for target `build'

---
Outgoing mail is certified Virus Free.
Checked by AVG anti-virus system (http://www.grisoft.com).
Version: 6.0.393 / Virus Database: 223 - Release Date: 30/09/2002

---

From: "Julian R Panchen" <[email-masked]>
Date: Wed, 2 Oct 2002 19:23:39 +0100

I managed to get it working here (as far as I can remember) is what I
did.

I used openssl-0.9.6g mod_ssl-2.8.10 apache_1.3.26 and mm-1.2.1

Referring to the mod_ssl INSTALL file I followed steps 1 through 4 with
all optional steps.

I then used 5b with the following commands

In mod_ssl
	./configure –with-apache=../apache_1.3.26

In apache_1.3.26
	EAPI_MM=../mm-1.2.1 \
       SSL_BASE=../openssl-0.9.6g \     
       ./configure \                      
       --with-layout=Apache \           
       --server-uid=apache \            
       --server-gid=daemon \            
       --with-perl=/usr/local/bin/perl \
       --prefix=/export/apache \        
       --enable-module=most \           
       --enable-shared=max \            
       --enable-module=ssl \            
       --disable-rule=SSL_COMPAT \      
       --enable-rule=SSL_SDBM
make
make certificate
make install

You will probably need to change the configure for apache, not least the
perl location if you are using mod_perl.

Hopefully this will be of some help to you.

-- 
Julian

-----Original Message-----
From: [email-masked]
[mailto:[email-masked]] On Behalf Of Zandi Patrick S TSgt
AFRL/IFOSS
Sent: 02 October 2002 18:51
To: [email-masked]'
Subject: RE: mod_ssl-2.8.10-1.3.26 on Solaris 9 getting errors 

Well it compiles anyhoo.. 
After make, 
make certificate, 
and make install   now if I type apachectl start   or apachectl
startssl  
Core Segmentation errors.
-----Original Message-----
From: Julian R Panchen [mailto:[email-masked]] 
Sent: Wednesday, October 02, 2002 1:17 PM
To: [email-masked]
Subject: RE: mod_ssl-2.8.10-1.3.26 on Solaris 9 getting errors 
You need a copy of flex you can obtain the source code from GNU see
http://www.gnu.org/software/flex/

-----Original Message-----
From: [email-masked]
[mailto:[email-masked]] On Behalf Of Zandi Patrick S TSgt
AFRL/IFOSS
Sent: 02 October 2002 17:57
To: [email-masked]'
Subject: mod_ssl-2.8.10-1.3.26 on Solaris 9 getting errors 
 
Hello folks, 
 
However When I compile the apache I am getting the following.. 
     EEDED `../../apaci` -DSSL_COMPAT -I/usr/local/ssl/include
-DMOD_SSL_VERSION=\"2.8.10\" ssl_scache_shmcb.c
gcc -c  -I../../os/unix -I../../include   -DSOLARIS2=290
-DMOD_SSL=208110 -DEAPI -DUSE_EXPAT -I../../lib/expat-lite
-DNO_DL_NEEDED `../../apaci` -DSSL_COMPAT -I/usr/local/ssl/include
-DMOD_SSL_VERSION=\"2.8.10\" ssl_expr.c
flex -Pssl_expr_yy -s -B ssl_expr_scan.l
sh: flex: not found
*** Error code 1
make: Fatal error: Command failed for target `ssl_expr_scan.c'
Current working directory
/home/oracle/building/apache_1.3.26/src/modules/ssl
*** Error code 1
make: Fatal error: Command failed for target `all'
Current working directory
/home/oracle/building/apache_1.3.26/src/modules
*** Error code 1
make: Fatal error: Command failed for target `subdirs'
Current working directory /home/oracle/building/apache_1.3.26/src
*** Error code 1
make: Fatal error: Command failed for target `build-std'
Current working directory /home/oracle/building/apache_1.3.26
*** Error code 1
make: Fatal error: Command failed for target `build'

---

---

______________________________________________________________________
Apache Interface to OpenSSL (mod_ssl)                   www.modssl.org
User Support Mailing List                      [email-masked]
Automated List Manager                            [email-masked]