Subject: Installing ModSSL Question

From: "Don" <[email-masked]>
Date: Tue, 4 Jun 2002 10:41:06 -0400

Hi,

I'm new to this so please bare with me.  I am running RedHat Linux 6.2 with Apache 1.3.22 and OpenSSL 0.9.6d.  I wish to install ModSSL so that I can secure my web site.

I have downloaded the mod_ssl-2.8.5-1.3.22 tarball from the web site.  Upon reading the documentation, I find that I need to recompile apache with additional configuration options in order to install ModSSL.

Here is my dilemma.  I never compiled Apache from source but rather installed from rpm packages.  Therefore, there doesn't seem to be any way I can install ModSSL.  I've looked at the FAQ but can see no hints on installing ModSSL once Apache is installed.  Neither have I found and ModSSL rpm package.

I DON'T want to download the Apache tarball and compile/install if I can help it because RedHat is a bit screwy as it uses it's own directories.  Installing Apache from the tarball will undoubtedly mess up my system as it will install in other directories and confuse the hell out of me.

Do I have other options?

Thanks,
Don

---

From: Nalin Dahyabhai <[email-masked]>
Date: Tue, 4 Jun 2002 10:57:55 -0400

> Here is my dilemma.  I never compiled Apache from source but rather installed from rpm packages.  Therefore, there doesn't seem to be any way I can install ModSSL.  I've looked at the FAQ but can s…

The packaged version for Red Hat Linux already has the necessary EAPI
patch applied.  You should be able to either compile mod_ssl using apxs
(which is included in the apache-devel package) or rebuild a mod_ssl RPM
package from a later release using 'rpm --rebuild' (though I haven't done
that lately, YMMV).

HTH,

Nalin
______________________________________________________________________
Apache Interface to OpenSSL (mod_ssl)                   www.modssl.org
User Support Mailing List                      [email-masked]
Automated List Manager                            [email-masked]

---

From: "Don" <[email-masked]>
Date: Thu, 6 Jun 2002 11:37:47 -0400

Hi,

I looked the documentation for compiling mod_ssl using apxs and noticed the configure options as such:

./configure \
    --with-apxs[=/path/to/apache/bin/apxs] \
    --with-ssl=/path/to/openssl

Is the first option the path to the httpd binary (httpd) or the config file (httpd.conf)?
Is the second option the path to the openssl binary (openssl)?

Thanks,
Don
  ----- Original Message ----- 
  From: Nalin Dahyabhai 
  To: [email-masked] 
  Sent: Tuesday, June 04, 2002 10:57 AM
  Subject: Re: Installing ModSSL Question

  HTH,

  Nalin

---

From: Cliff Woolley <[email-masked]>
Date: Thu, 6 Jun 2002 12:46:27 -0400 (EDT)

> Is the first option the path to the httpd binary (httpd) or the config

Neither.  It's the path to apxs.  :)  apxs is a script that usually sits
in the same directory as the httpd binary, but it's not the same thing.

--Cliff