Subject: [email-masked]

From: dian dian <[email-masked]>
Date: Mon, 9 Dec 2002 11:58:11 +0000 (GMT)

please ...(10x)

i need clear instructions about : installing mod_ssl
step by step.

i've follow the readme file but i'am stuck at..
(..ms\do_ms...(about...*.mak files))..

info :
OS :win98 se
perl : activeperl 5.6.1
apache : 1.3.27
tools :visual c++ 6 
ssl-core : openssl 0.9.6h

--thank you..

__________________________________________________
Do You Yahoo!?
Everything you'll ever need on one web page
from News and Sport to Email and Music Charts
http://uk.my.yahoo.com
______________________________________________________________________
Apache Interface to OpenSSL (mod_ssl)                   www.modssl.org
User Support Mailing List                      [email-masked]
Automated List Manager                            [email-masked]

---

From: hunter <[email-masked]>
Date: 09 Dec 2002 09:20:33 -0500

> ssl-core : openssl 0.9.6h

dian,

I assume from what you have written that you are building OpenSSL at
this point.

I also assume that before you ran 'ms\do_ms' 
...you ran 'perl configure VC-WIN32'

Your output should have been similar to this...

 Microsoft Windows XP [Version 5.1.2600]
(C) Copyright 1985-2001 Microsoft Corp.

2002.12.09  8.15.44.96
[D:\work\openssl]perl Configure VC-WIN32
Configuring for VC-WIN32
IsWindows=1
CC            =cl
CFLAG         =-DTHREADS  -DDSO_WIN32
EX_LIBS       =
BN_ASM        =bn_asm.o
DES_ENC       =des_enc.o fcrypt_b.o
BF_ENC        =bf_enc.o
CAST_ENC      =c_enc.o
RC4_ENC       =rc4_enc.o
RC5_ENC       =rc5_enc.o
MD5_OBJ_ASM   =
SHA1_OBJ_ASM  =
RMD160_OBJ_ASM=
PROCESSOR     =
RANLIB        =true
PERL          =perl
THIRTY_TWO_BIT mode
BN_LLONG mode
RC4_INDEX mode
RC4_CHUNK is undefined

Configured for VC-WIN32.

'ms\do_ms' is a batch file that calls perl to create the correct build -
if you are using the wrong perl it will fail...

Now when you run 'ms\do_ms' you should get the following output...

2002.12.09  8.17.24.65
[D:\work\openssl]

2002.12.09  8.17.24.65
[D:\work\openssl]ms\do_ms

2002.12.09  8.19.47.05
[D:\work\openssl]perl util\mkfiles.pl  1>MINFO

2002.12.09  8.19.47.22
[D:\work\openssl]rem perl util\mk1mf.pl VC-MSDOS no-sock >ms\msdos.ma

2002.12.09  8.19.47.22
[D:\work\openssl]rem perl util\mk1mf.pl VC-W31-32 >ms\w31.mak

2002.12.09  8.19.47.22
[D:\work\openssl]perl util\mk1mf.pl dll VC-W31-32  1>ms\w31dll.mak

2002.12.09  8.19.47.39
[D:\work\openssl]perl util\mk1mf.pl no-asm VC-WIN32  1>ms\nt.mak

2002.12.09  8.19.47.50
[D:\work\openssl]perl util\mk1mf.pl dll no-asm VC-WIN32  1>ms\ntdll.m

2002.12.09  8.19.47.74
[D:\work\openssl]perl util\mkdef.pl 16 libeay  1>ms\libeay16.def

2002.12.09  8.19.48.93
[D:\work\openssl]perl util\mkdef.pl 32 libeay  1>ms\libeay32.def

2002.12.09  8.19.50.18
[D:\work\openssl]perl util\mkdef.pl 16 ssleay  1>ms\ssleay16.def

2002.12.09  8.19.51.33
[D:\work\openssl]perl util\mkdef.pl 32 ssleay  1>ms\ssleay32.def

2002.12.09  8.19.52.47
[D:\work\openssl]

Following this you run 'nmake -f ms\ntdll.mak'...

The following errors are caused because I previously built the code
using MASM (I think) ... anyway I was using old source so I downloaded
new source... 

I have also experienced problems when my cygwin perl is in the path
before my other perl - I do not know for certain what my other perl is
(I think it is active perl 5 something) ... but it works and I have no
intention of breaking it by getting something else.  Having failed in
the environment you have to get a new copy of the source from the tar
ball. 

However, before I replay this with the new source ... since you want a
detailed answer ... how about if you provide I detailed question so that
I do not have to guess at what you are seeing ... when I ran through the
steps with the new source it works perfectly and the output is large...

Perhaps you could cut 'n paste the console output of your failure so
that I can see what you are doing? Or, redirect the output to a file and
send the file.

2002.12.09  8.19.52.47
[D:\work\openssl]nmake -f ms\ntdll.mak

Microsoft (R) Program Maintenance Utility   Version 6.00.8168.0
Copyright (C) Microsoft Corp 1988-1998. All rights reserved.

Building OpenSSL
        copy nul+ .\crypto\buildinf.h tmp32dll\buildinf.h
nul
.\crypto\buildinf.h
        1 file(s) copied.
        copy nul+ .\crypto\opensslconf.h inc32\openssl\opensslconf.h
nul
.\crypto\opensslconf.h
        1 file(s) copied.
        cl /Fotmp32dll\des_enc.obj  -Iinc32 -Itmp32dll /MD /W3 /WX /G5
/Ox /O2 /
Ob2 /Gs0 /GF /Gy
/nologo -DWIN32 -DWIN32_LEAN_AND_MEAN -DL_ENDIAN -DDSO_WIN32 /F
dout32dll /GD -D_WINDLL -D_DLL  -c .\crypto\des\des_enc.c
des_enc.c
        cl /Fotmp32dll\fcrypt_b.obj  -Iinc32 -Itmp32dll /MD /W3 /WX /G5
/Ox /O2
/Ob2 /Gs0 /GF /Gy
/nologo -DWIN32 -DWIN32_LEAN_AND_MEAN -DL_ENDIAN -DDSO_WIN32 /
Fdout32dll /GD -D_WINDLL -D_DLL  -c .\crypto\des\fcrypt_b.c
fcrypt_b.c
        cl /Fotmp32dll\rc4_enc.obj  -Iinc32 -Itmp32dll /MD /W3 /WX /G5
/Ox /O2 /
Ob2 /Gs0 /GF /Gy
/nologo -DWIN32 -DWIN32_LEAN_AND_MEAN -DL_ENDIAN -DDSO_WIN32 /F
dout32dll /GD -D_WINDLL -D_DLL  -c .\crypto\rc4\rc4_enc.c
rc4_enc.c
        cl /Fotmp32dll\rc5_enc.obj  -Iinc32 -Itmp32dll /MD /W3 /WX /G5
/Ox /O2 /
Ob2 /Gs0 /GF /Gy
/nologo -DWIN32 -DWIN32_LEAN_AND_MEAN -DL_ENDIAN -DDSO_WIN32 /F
dout32dll /GD -D_WINDLL -D_DLL  -c .\crypto\rc5\rc5_enc.c
rc5_enc.c
        cl /Fotmp32dll\bf_enc.obj  -Iinc32 -Itmp32dll /MD /W3 /WX /G5
/Ox /O2 /O
b2 /Gs0 /GF /Gy
/nologo -DWIN32 -DWIN32_LEAN_AND_MEAN -DL_ENDIAN -DDSO_WIN32 /Fd
out32dll /GD -D_WINDLL -D_DLL  -c .\crypto\bf\bf_enc.c
bf_enc.c
        cl /Fotmp32dll\c_enc.obj  -Iinc32 -Itmp32dll /MD /W3 /WX /G5 /Ox
/O2 /Ob
2 /Gs0 /GF /Gy
/nologo -DWIN32 -DWIN32_LEAN_AND_MEAN -DL_ENDIAN -DDSO_WIN32 /Fdo
ut32dll /GD -D_WINDLL -D_DLL  -c .\crypto\cast\c_enc.c
c_enc.c
        cl /Fotmp32dll\bn_asm.obj  -Iinc32 -Itmp32dll /MD /W3 /WX /G5
/Ox /O2 /O
b2 /Gs0 /GF /Gy
/nologo -DWIN32 -DWIN32_LEAN_AND_MEAN -DL_ENDIAN -DDSO_WIN32 /Fd
out32dll /GD -D_WINDLL -D_DLL  -c .\crypto\bn\bn_asm.c
bn_asm.c
        link /nologo /subsystem:console /machine:I386 /opt:ref /dll
/out:out32dl
l\libeay32.dll /def:ms/LIBEAY32.def @D:\Temp\nma01212.
   Creating library out32dll\libeay32.lib and object
out32dll\libeay32.exp
md5_dgst.obj : error LNK2001: unresolved external symbol
_md5_block_asm_host_ord
er
sha1dgst.obj : error LNK2001: unresolved external symbol
_sha1_block_asm_data_or
der
sha1dgst.obj : error LNK2001: unresolved external symbol
_sha1_block_asm_host_or
der
rmd_dgst.obj : error LNK2001: unresolved external symbol
_ripemd160_block_asm_ho
st_order
out32dll\libeay32.dll : fatal error LNK1120: 4 unresolved externals
NMAKE : fatal error U1077: 'link' : return code '0x460'
Stop.

2002.12.09  8.21.53.77
[D:\work\openssl]

I may have provided enough clues for you to continue on your own -- if
not then you will have to ask questions with more detail.

-hunter