Subject: trouble getting set up

From: "Bill Angus" <[email-masked]>
Date: Fri, 12 Jul 2002 14:24:52 -0700

I got the binaries distribution of Apache 2.0.39 for Windows 2000. Unfortunately I got it without MOD-SSL built, which I guess is the only way it comes. 

The 2.0.39 version of Apache wouldn't install like version 2.0.36 did. I still haven't figured out how to install it but I assume RTFM and following the manual installation instructions will work. PLEASE somone let me know if this version can't be installed at all. 

Next I downloaded the source files and went to build the apache and MOD_SSL source, because I figured that is something I would have to do to get MOD_SSL installed and working. Uckfay. I have Borland C++ Builder5 and Microsoft Visual Studio with MS-C++ 6 installed on my computer. Neither will allow me to build the project. 

It seems like the platform of choice is Microsoft VC++, cause the Borland compiler switcher look different, so MSVC++ is the compiler I tried hardest to get to work. I keep getting errors like those appended below...

I am not a VC++ programmer by trade, so it goes without saying that I could not have written Apache from scratch in C. I haven't a clue why the file-set won't compile, but assume that it is undocumented compiler configuration requirements -- or files missing from source distribution. 

Any help greatly appreciated. 

Bill Angus
http://www.psychtest.com

Trying to compile the base project fails as follows:

--------------------------------------------------------------------------------

Deleting intermediate files and output files for project 'libapr - Win32 Debug'.
Deleting intermediate files and output files for project 'gen_uri_delims - Win32 Debug'.
Deleting intermediate files and output files for project 'xml - Win32 Debug'.
Deleting intermediate files and output files for project 'libaprutil - Win32 Debug'.
Build : warning : failed to (or don't know how to) build 'C:\apachesource\httpd-2.0.39\srclib\apr-util\uri\gen_uri_delims.exe'
Deleting intermediate files and output files for project 'dftables - Win32 Debug'.
Deleting intermediate files and output files for project 'pcre - Win32 Debug'.
Deleting intermediate files and output files for project 'pcreposix - Win32 Debug'.
Deleting intermediate files and output files for project 'gen_test_char - Win32 Debug'.
Deleting intermediate files and output files for project 'libhttpd - Win32 Debug'.
Deleting intermediate files and output files for project 'Apache - Win32 Debug'.
--------------------Configuration: libapr - Win32 Debug--------------------
Creating apr.h from apr.hw
Creating Version Resource
'awk' is not recognized as an internal or external command,
operable program or batch file.
Error executing c:\winnt\system32\cmd.exe.

Apache.exe - 1 error(s), 0 warning(s)

--------------------------------------------------------------------------------

Trying to compile MOD-SSL fails as follows:

Deleting intermediate files and output files for project 'mod_ssl - Win32 Debug'.
--------------------Configuration: mod_ssl - Win32 Debug--------------------
Generating ssl_expr_parse.c/.h from ssl_expr_parse.y
'bison' is not recognized as an internal or external command,
operable program or batch file.
The system cannot find the file specified.
Could Not Find C:\apachesource\httpd-2.0.39\modules\ssl\y.tab.c
The system cannot find the file specified.
Could Not Find C:\apachesource\httpd-2.0.39\modules\ssl\y.tab.h
Error executing c:\winnt\system32\cmd.exe.

mod_ssl.so - 1 error(s), 0 warning(s)

--------------------------------------------------------------------------------

---

From: Jan Škola <[email-masked]>
Date: Sat, 13 Jul 2002 00:13:54 +0200

Yes problem is that you need Win32 utilities ,awk' and ,bison'...
Download them somewhere put in directory in PATH and try compile
again...

Jan Skola

-----Original Message-----
From: [email-masked]
[mailto:[email-masked]] On Behalf Of Bill Angus
Sent: Friday, July 12, 2002 11:25 PM
To: [email-masked]
Subject: trouble getting set up

I got the binaries distribution of Apache 2.0.39 for Windows 2000.
Unfortunately I got it without MOD-SSL built, which I guess is the only
way it comes. 

The 2.0.39 version of Apache wouldn't install like version 2.0.36 did. I
still haven't figured out how to install it but I assume RTFM and
following the manual installation instructions will work. PLEASE somone
let me know if this version can't be installed at all. 

Next I downloaded the source files and went to build the apache and
MOD_SSL source, because I figured that is something I would have to do
to get MOD_SSL installed and working. Uckfay. I have Borland C++
Builder5 and Microsoft Visual Studio with MS-C++ 6 installed on my
computer. Neither will allow me to build the project. 

It seems like the platform of choice is Microsoft VC++, cause the
Borland compiler switcher look different, so MSVC++ is the compiler I
tried hardest to get to work. I keep getting errors like those appended
below...

I am not a VC++ programmer by trade, so it goes without saying that I
could not have written Apache from scratch in C. I haven't a clue why
the file-set won't compile, but assume that it is undocumented compiler
configuration requirements -- or files missing from source distribution.

Bill Angus
http://www.psychtest.com

  _____  

Deleting intermediate files and output files for project 'libapr - Win32
Debug'.
Deleting intermediate files and output files for project 'gen_uri_delims
- Win32 Debug'.
Deleting intermediate files and output files for project 'xml - Win32
Debug'.
Deleting intermediate files and output files for project 'libaprutil -
Win32 Debug'.
Build : warning : failed to (or don't know how to) build
'C:\apachesource\httpd-2.0.39\srclib\apr-util\uri\gen_uri_delims.exe'
Deleting intermediate files and output files for project 'dftables -
Win32 Debug'.
Deleting intermediate files and output files for project 'pcre - Win32
Debug'.
Deleting intermediate files and output files for project 'pcreposix -
Win32 Debug'.
Deleting intermediate files and output files for project 'gen_test_char
- Win32 Debug'.
Deleting intermediate files and output files for project 'libhttpd -
Win32 Debug'.
Deleting intermediate files and output files for project 'Apache - Win32
Debug'.
--------------------Configuration: libapr - Win32
Debug--------------------
Creating apr.h from apr.hw
Creating Version Resource
'awk' is not recognized as an internal or external command,
operable program or batch file.
Error executing c:\winnt\system32\cmd.exe.

  _____  

Deleting intermediate files and output files for project 'mod_ssl -
Win32 Debug'.
--------------------Configuration: mod_ssl - Win32
Debug--------------------
Generating ssl_expr_parse.c/.h from ssl_expr_parse.y
'bison' is not recognized as an internal or external command,
operable program or batch file.
The system cannot find the file specified.
Could Not Find C:\apachesource\httpd-2.0.39\modules\ssl\y.tab.c
The system cannot find the file specified.
Could Not Find C:\apachesource\httpd-2.0.39\modules\ssl\y.tab.h
Error executing c:\winnt\system32\cmd.exe.

  _____

---

From: Cliff Woolley <[email-masked]>
Date: Fri, 12 Jul 2002 19:09:49 -0400 (EDT)

> Download them somewhere put in directory in PATH and try compile

Right.  See also http://apr.apache.org/compiling_win32.html .

--Cliff

______________________________________________________________________
Apache Interface to OpenSSL (mod_ssl)                   www.modssl.org
User Support Mailing List                      [email-masked]
Automated List Manager                            [email-masked]