Subject: Apache 1.3.26 and 1.3.27 with mod_ssl crashed on S390

From: "Bao, Xiliang" <[email-masked]>
Date: Fri, 11 Oct 2002 15:09:13 -0400

Hi:

I was compiling apache with mod_ssl on S390. I picked apache 1.3.27, mod_ssl 2.8.11-1.3.27, openssl-0.9.6g.
First, I compiled openssl and installed in its default location /usr/local/ssl.
Second, I cd to mod_ssl directory and do a config: 
./configure \
--with-apache=../apache_1.3.26_ssl \
--with-openssl=../openssl-0.9.6g \
--prefix=/usr/local/apache_ssl \
--with-layout=Apache \
--enable-module=most \
--enable-shared=max \
--enable-rule=WANTHSREGEX

Third, I do "export SSL_BASE=/usr/local/ssl", then do a config:
./configure --prefix=/usr/local/apache_ssl \
		 --enable-module=most \
		 --enable-shared=max \
		 --enable-rule=WANTHSREGEX \
		 --enable-module=ssl
Then do a "make" followed by "make certificate" 
Finally, do a "make install".

The same procedure works very well on Redhat Linux 7.3 on intel Pentium III.
But when I do it on IBM S390, the httpd crashed. Here are some debug information.
Any help will be great appreciated.

/usr/local/apache_ssl/bin # gdb httpd
GNU gdb 5.2.1
Copyright 2002 Free Software Foundation, Inc.
GDB is free software, covered by the GNU General Public License, and you are
welcome to change it and/or distribute copies of it under certain conditions.
Type "show copying" to see the conditions.
There is absolutely no warranty for GDB.  Type "show warranty" for details.
This GDB was configured as "s390-ibm-linux"...
(gdb) run -X -DSSL
Starting program: /usr/local/apache_ssl/bin/httpd -X -DSSL

Program received signal SIGSEGV, Segmentation fault.
0x004457de in ap_ctx_get (ctx=0x90bff02c, key=0x4034b284 "ssl_module") at ap_ctx.c:125
125         for (i = 0; ctx->cr_entry[i] != NULL; i++)
(gdb) p ctx
$1 = (struct {...} *) 0x90bff02c
(gdb) up
#1  0x40299d70 in ssl_config_global_create () at ssl_engine_config.c:119
119         mc = ap_ctx_get(ap_global_ctx, "ssl_module");
(gdb) p ap_global_ctx
$2 = (struct {...} *) 0x4984e8
(gdb) p *ap_global_ctx
$3 = {cr_pool = 0x0, cr_entry = 0x4984f8}
(gdb) down
#0  0x004457de in ap_ctx_get (ctx=0x90bff02c, key=0x4034b284 "ssl_module") at ap_ctx.c:125
125         for (i = 0; ctx->cr_entry[i] != NULL; i++)
(gdb) p *ctx
Cannot access memory at address 0x90bff02c
(gdb) where
#0  0x004457de in ap_ctx_get (ctx=0x90bff02c, key=0x4034b284 "ssl_module") at ap_ctx.c:125
#1  0x40299d70 in ssl_config_global_create () at ssl_engine_config.c:119
#2  0x40299fde in ssl_config_server_create (p=0x48f118, s=0x48f140) at ssl_engine_config.c:193
#3  0x00413a34 in ap_single_module_configure (p=0x48f118, s=0x48f140, m=0x403660b0)
    at http_config.c:1691
#4  0x0040931e in load_module (cmd=0x7ffff608, dummy=0x0, modname=0x49cde8 "ssl_module",
    filename=0x49cdf8 "libexec/libssl.so") at mod_so.c:307
#5  0x0041161e in invoke_cmd (cmd=0x4764c8, parms=0x7ffff608, mconfig=0x0, args=0x7fffd5b7 "")
    at http_config.c:869
#6  0x004122ca in ap_handle_command (parms=0x7ffff608, config=0x48f670,
    l=0x7fffd588 "LoadModule ssl_module         libexec/libssl.so") at http_config.c:1080
#7  0x00412380 in ap_srm_command_loop (parms=0x7ffff608, config=0x48f670) at http_config.c:1094
#8  0x00412d64 in ap_process_resource_config (s=0x48f140,
    fname=0x490820 "/usr/local/apache_ssl/conf/httpd.conf", p=0x48f118, ptemp=0x493148)
    at http_config.c:1382
#9  0x0041396e in ap_read_config (p=0x48f118, ptemp=0x493148, confname=0x487a88 "conf/httpd.conf")
    at http_config.c:1674
#10 0x00422ef8 in main (argc=3, argv=0x7ffff8b4) at http_main.c:5531

    _/_/_/_/  _/   Steve Bao
   _/       _/_/   Computer Associates
  _/      _/  _/   
 _/     _/_/_/_/   Tel: (858) 625-6964
_/_/_/_/      _/   Fax: (858) 453-2816

---

From: "Bao, Xiliang" <[email-masked]>
Date: Fri, 11 Oct 2002 15:31:27 -0400

I forgot to mention that on S390, I installed Linux SuSE SLES-7 Kernal 2.4.7.
Steve

-----Original Message-----
From: Bao, Xiliang 
Sent: Friday, October 11, 2002 12:09 PM
To: [email-masked]
Subject: Apache 1.3.26 and 1.3.27 with mod_ssl crashed on S390

Hi: 

    _/_/_/_/  _/   Steve Bao