Subject: RE: I am having a heck of a time - Please help.

From: David Loesche <[email-masked]>
Date: Mon, 15 Jul 2002 12:07:15 -0700

I did read the referred document concerning the build phase.  I am intrigued
by the LD_LIBRARY_PATH suggestion.  What would you recommend I set it to?

-----Original Message-----
From: Boyle Owen [mailto:[email-masked]]
Sent: Monday, July 15, 2002 12:51 AM
To: [email-masked]
Subject: RE: I am having a heck of a time - Please help.

Could be to do with your version of openssl lib (check it is reasonably up
to date) or with your LD_LIBRARY_PATH environment variable..

Check out http://www.delouw.ch/linux/Apache-Compile-HOWTO/html/apache.html

for a good user's summary.

Rgds,

Owen Boyle

>-----Original Message-----
>From: David Loesche [mailto:[email-masked]]
>Sent: Freitag, 12. Juli 2002 20:12
>To: [email-masked]'
>Subject: I am having a heck of a time - Please help.
>
>
>I have poured through all the documentation I can find on
>enabling mod_ssl
>with Apache 1.3.26 but keep coming up short.  If I static link
>the mod_ssl
>it works fine but when I try to enable DSO and use it as a
>shared library I
>keep getting ap_add_config_define : referenced symbol not
>found.  I have the
>following config setup for the apache build:
>
>#!/bin/ksh
>SSL_BASE=/usr/local/ssl \
>EAPI_MM=../mm-1.1.3 \
>EAPI_MM_CORE_PATH=logs/httpd.mm \
>LIBS=/usr/lib/libC.so.5 \
>CFLAGS=-fPIC \
>./configure    --prefix=/opt/apache \
>               --enable-rule=EAPI \
>               --enable-module=ssl \
>               --enable-shared=ssl \
>               --disable-rule=SSL_COMPAT \
>               --enable-rule=SSL_SDBM \
>               --enable-suexec \
>               --suexec-caller=http
>
>I have followed the instructions in the modssl install guide to patch
>Apache.  Please verify the following build for mod_ssl:
>
>./configure    --with-apache=../apache_1.3.26 \
>               --with-ssl=/usr/local/ssl \
>               --with-mm=../mm-1.1.3
>
>If you can help (point me to some documentation) I would be
>very grateful...
>
>
>David S. Loesche
>[email-masked]                        Yipes
>Communications, Inc.
>Main:  (415) 901-2000                  114 Sansome Street, Suite 1045
>Direct:        (415) 901-2210                  San Francisco, CA 94104
>Fax:   (415) 901-2201                  http://www.yipes.com
>
>Yipes is the defining provider of fully scalable bandwidth for
>businesses.
>We offer fully managed high-speed Internet and Nationwide LAN-to-LAN
>services at speeds ranging from 1 Mbps to 1 Gbps, in 1 Mbps
>increments.
>
>Yipes delivers this uniquely flexible service over the first nationwide
>system of optical IP networks.
>
>______________________________________________________________________
>Apache Interface to OpenSSL (mod_ssl)                   www.modssl.org
>User Support Mailing List                      [email-masked]
>Automated List Manager                            [email-masked]
>
______________________________________________________________________
Apache Interface to OpenSSL (mod_ssl)                   www.modssl.org
User Support Mailing List                      [email-masked]
Automated List Manager                            [email-masked]
______________________________________________________________________
Apache Interface to OpenSSL (mod_ssl)                   www.modssl.org
User Support Mailing List                      [email-masked]
Automated List Manager                            [email-masked]

---

From: Glen Mehn <[email-masked]>
Date: Mon, 15 Jul 2002 21:35:12 -0700

well, the LD_LIBRARY_PATH should point to all the shared libs that
you'll need. Probably

/usr/lib:/lib:/usr/local/lib:/usr/local/ssl/lib

is a good start

-g

-- 
Glen S Mehn
Contract Systems Administrator		SquareTrade, Inc
[email-masked]	Building Trust in Transactions (sm)
______________________________________________________________________
Apache Interface to OpenSSL (mod_ssl)                   www.modssl.org
User Support Mailing List                      [email-masked]
Automated List Manager                            [email-masked]