Subject: httpd.conf

From: Cuong Tran <[email-masked]>
Date: Tue, 10 Sep 2002 16:13:55 +1000 (EST)

Wondering if some kind soul could help me. I already
have 3 name based
virtual hosts set up correctly. Now I'm in the process
of creating a SSL
host which I have successfully done. The problem I am
having is that all the
normal virtual hosts as a result have been SSL
readable as well.
Where as they once were ok http://localhost, they are
now also viewable as
https://localhost also which I do not want.  My SSL
section is below along
with 1 virtual host :

<VirtualHost 192.168.0.3:80>
        # This is for mod_ssl. SSLEngine off
        ServerName localhost
        DocumentRoot /path
        ServerAdmin root@localhost
        ServerSignature email
</VirtualHost>

##
## SSL Virtual Host Context
##

#  Apache will only listen on port 80 by default. 
Defining the virtual
server
#  (below) won't make it automatically listen on the
virtual server's port.
Listen 443
#   SSL Session Cache:
#   The cache speeds up processing of multiple
parallel requests from
#   the same client.
SSLSessionCache shm:/var/cache/ssl_gcache_data(524288)

<VirtualHost 192.168.0.3:443>
        ServerName secure
        DocumentRoot /path/to/secure
        ServerAdmin root@localhost
        ServerSignature email
        SSLEngine on
        SSLCertificateFile
/etc/httpd/conf/ssl.crt/server.crt
        SSLCertificateKeyFile
/etc/httpd/conf/ssl.key/server.key
</VirtualHost>

http://www.sold.com.au - SOLD.com.au
- Find yourself a bargain!
______________________________________________________________________
Apache Interface to OpenSSL (mod_ssl)                   www.modssl.org
User Support Mailing List                      [email-masked]
Automated List Manager                            [email-masked]

---

From: John Ott <[email-masked]>
Date: Tue, 10 Sep 2002 12:20:33 -0400

Cuong Tran wrote:

>  The problem I am

> #  (below) won't make it automatically listen on the

Change the above to
Listen 192.168.0.3:443
that will get the result you desire.

later
John

---

From: Cuong Tran <[email-masked]>
Date: Wed, 11 Sep 2002 11:39:14 +1000 (EST)

Thanks for the tip John,

But that shuts down port 443 altogether. I still need
it open for my 1 SSL host

<VirtualHost 192.168.0.3:443>
        ServerName secure
        DocumentRoot /path
        ServerAdmin root@localhost
        ServerSignature email
        # Turning the 3 below on is VERY important
        SSLEngine on
        SSLCertificateFile
/etc/httpd/conf/ssl.crt/server.crt
        SSLCertificateKeyFile
/etc/httpd/conf/ssl.key/server.key
        # must manually create file first
        SSLLogFile
/var/www/html/WEBSITES/SITE2/logs/ssl.log
</VirtualHost>

 --- John Ott <[email-masked]> wrote: > Cuong Tran
wrote:
> > begin:vcard 
> n:Ott;John
> tel;pager:202 688 9735
> tel;cell:301 502 4356
> tel;work:202 687 8929
> x-mozilla-html:FALSE
> org:Georgetown University;UIS-SNS
> version:2.1
> email;internet:[email-masked]
> title:UNIX Systems Programmer
> adr;quoted-printable:;;304E St. Mary's
> Hall=0D=0A3800 Reservoir Road, NW;Washington
> ;DC;20007;USA
> x-mozilla-cpt:;-13752
> fn:John Ott
> end:vcard
>

---

From: "Peter Viertel" <[email-masked]>
Date: Wed, 11 Sep 2002 09:53:11 +0100

I notice that your virtual hosts are all using the ip address of your 
machine, but your testing example uses http://localhost/
It's probably worth pointing out that localhost usually resolves to 
127.0.0.1 which is not the same thing as your machine's ip address.
Try testing against https://192.168.0.3/

Cuong Tran wrote:

>>>#  (below) won't make it automatically listen on
>>>      
>>>
>>the
>>    
>>
>>>virtual server's port.
>>>Listen 443
>>>      
>>>
>>Change the above to
>>Listen 192.168.0.3:443

---

From: Cuong Tran <[email-masked]>
Date: Wed, 11 Sep 2002 21:57:15 +1000 (EST)

Hi Peter,

The IP adressess all work fine. Is there a command
that shuts out SSL for normal virtual hosts?
I tried putting "SSLEngine off" in the normal host
container but https://normalhost  still shows.

 --- Peter Viertel <[email-masked]>
wrote: > I notice that your virtual hosts are all
using the
> ip address of your