Subject: incorrect MAC

From: Kevin DeGraaf <[email-masked]>
Date: Wed, 4 Jun 2003 16:10:35 -0400 (EDT)

I set up a mod_ssl server using:

  Apache 1.3.27
  mm 1.3.0
  mod_ssl 2.8.14
  OpenSSL 0.9.7b
  Slackware Linux 8.1

When I (attempt to) connect, Mozilla gives me this error:
"secure2.solidusdesign.com received a message with an incorrect Message
Authentication Code".  How do I fix this?

Here is the procedure I used:

OpenSSL: ./config && make install

mm: ./configure --disable-shared && make install

mod_ssl: ./configure --with-apache=../apache_1.3.27

Apache:

SSL_BASE=../openssl-0.9.7b \
EAPI_MM=../mm-1.3.0 \
./configure \
  --prefix=/usr/local/apache \
  --enable-module=so \
  --enable-module=ssl \
  --enable-shared=ssl \
  --enable-shared=rewrite \
  --enable-shared=speling \
  --disable-module=userdir \
  --htdocsdir=/var/www/htdocs \
  --cgidir=/var/www/cgi-bin \
  --runtimedir=/var/www/runtime \
  --logfiledir=/var/www/logs \
  --server-uid=apache \
  --server-gid=apache

--
Kevin DeGraaf

______________________________________________________________________
Apache Interface to OpenSSL (mod_ssl)                   www.modssl.org
User Support Mailing List                      [email-masked]
Automated List Manager                            [email-masked]

---

From: Kevin DeGraaf <[email-masked]>
Date: Fri, 6 Jun 2003 16:36:00 -0400 (EDT)

> Authentication Code".  How do I fix this?

I fixed the problem by upgrading from a dummy SSL cert to a real one.

But really, guys, many thanks to everyone who posted useful suggestions.
The list's help was invaluable in getting to the bottom of this matter.
I can't imagine what I would have done without such a caring, useful group
of experts.  I'll be sure to return here in the future if I ever have a
problem with mod_ssl, since you've all bent over backwards to get me an
answer on this one.  Thanks again!

--
Kevin DeGraaf