Subject: OpenSSL with mod_ssl in Apache 2.0.35

From: MegaZone <[email-masked]>
Date: Mon, 6 May 2002 19:22:33 -0400

Hello,

The platform is Solaris 8.

I've installed OpenSSL 0.9.6c, and then Apache 2.0.35 using 
./configure --prefix=/local/webhome/apache-2.0.35 --enable-mods-shared="ssl"

I can start Apache without SSL, but when I try to use SSL I receive
this message:

[malarkey:/local/webhome/apache/conf]458 % /local/webhome/apache/bin/apachectl startssl
Syntax error on line 219 of /local/webhome/apache-2.0.35/conf/httpd.conf:
Cannot load /local/webhome/apache-2.0.35/modules/mod_ssl.so into server: ld.so.1: /local/webhome/apache-2.0.35/bin/httpd: fatal: relocation error: file /local/webhome/apache-2.0.35/modules/mod_ssl.so: symbol X509_INFO_free: referenced symbol not found
/local/webhome/apache/bin/apachectl startssl: httpd could not be started

There is nothing in the logs directory.

The line in httd.conf is simply the loadmodule for SSL:
<IfDefine SSL>
LoadModule ssl_module modules/mod_ssl.so
</IfDefine>

I've spent some time searching the list archives, google, etc, but I
haven't found a good pointer for this.  I'd appreciate a kick in the
right direction.

Thanks.

-MZ, CISSP #3762, RHCE #806199299900541
-- 
<URL:mailto:[email-masked], Discordian, Author, Engineer, me..
"A little nonsense now and then, is relished by the wisest men" 781-788-0130
<URL:http://www.megazone.org/ <URL:http://www.eyrie-productions.com/Eris
______________________________________________________________________
Apache Interface to OpenSSL (mod_ssl)                   www.modssl.org
User Support Mailing List                      [email-masked]
Automated List Manager                            [email-masked]

---

From: MegaZone <[email-masked]>
Date: Tue, 7 May 2002 13:55:25 -0400

Once upon a time MegaZone shaped the electrons to say...
> The platform is Solaris 8.

[snip]

Whoa, that got stuck in the Ether for a while - I sent this out earlier
last night than the message that came through then.

This was the issue with the non-shared OpenSSL.

-MZ, CISSP #3762, RHCE #806199299900541
-- 
<URL:mailto:[email-masked]> Gweep, Discordian, Author, Engineer, me..
"A little nonsense now and then, is relished by the wisest men" 781-788-0130
<URL:http://www.megazone.org/>  <URL:http://www.eyrie-productions.com/> Eris
______________________________________________________________________
Apache Interface to OpenSSL (mod_ssl)                   www.modssl.org
User Support Mailing List                      [email-masked]
Automated List Manager                            [email-masked]