Subject: Re: Creating client certificates ?

From: [email-masked]
Date: Thu, 4 Apr 2002 01:43:05 +0200 (MEST)

[email-masked] wrote:
> 
> Hello modssl users !
> 
> I managed to set up an ssl aware web server.
> Although I searched the web and also the list
> archive I haven't been able to create a client
> certificate which is signed by my own CA for
> client authentication.
> 
> Could someone describe the process of creating
> such a certificate in detail ?

Thank you Owen for your answer but you misunderstood
my question.
And you Maik misunderstood my question, too.
I, of course, read the FAQ and all the other available docs
but they say nothing about creating client (!) certificates !
The process of creating a server certificate is sufficiently
documented in the FAQ and it was no problem for me to
create it.

My question is: How can I create client (!) certificates for
                     client authentication to the server and not
                     server certificates ?!

Anyone ?

-- 
GMX - Die Kommunikationsplattform im Internet.
http://www.gmx.net
______________________________________________________________________
Apache Interface to OpenSSL (mod_ssl)                   www.modssl.org
User Support Mailing List                      [email-masked]
Automated List Manager                            [email-masked]

---

From: Mads Toftum <[email-masked]>
Date: Thu, 4 Apr 2002 10:11:07 +0200

>                      client authentication to the server and not

There is a nice example script called cca.sh in the mod_ssl tarball -
as pkg.contrib/cca.sh or availabe online via cvsweb:

http://www.modssl.org/source/cvs/exp/mod_ssl/pkg.mod_ssl/pkg.contrib/cca.sh?rev=1.6

vh

Mads Toftum
-- 
With a rubber duck, one's never alone.
              -- "The Hitchhiker's Guide to the Galaxy"
______________________________________________________________________
Apache Interface to OpenSSL (mod_ssl)                   www.modssl.org
User Support Mailing List                      [email-masked]
Automated List Manager                            [email-masked]