Subject: Re: Apache warning: Connection refused: connect to listener

From: "Alex Hart" <[email-masked]>
Date: Thu, 02 Oct 2003 23:58:35 -0400

> 
> > On Mon, Sep 29, 2003 at 11:06:31PM -0400, Alex Hart wrote:
> > > I just installed Apache/2.0.47 (Unix) mod_ssl/2.0.47 OpenSSL/0.9.7b 
> > > However, I keep getting the following line in my error log file (thousands 
> > of times):
> > > 
> > > [Wed Sep 24 12:51:15 2003] [warn] (61)Connection refused: connect to  listener
> > > 
> > > I have thousands of these warnings now in just a couple of days. 
> 
> ./httpd -V
> Server version: Apache/2.0.47
> Server built:   Sep 29 2003 18:29:13
> Server's Module Magic Number: 20020903:4
> Architecture:   32-bit
> Server compiled with....
>  -D APACHE_MPM_DIR="server/mpm/prefork"
>  -D APR_HAS_SENDFILE
>  -D APR_HAS_MMAP
>  -D APR_HAVE_IPV6 (IPv4-mapped addresses enabled)
>  -D APR_USE_FLOCK_SERIALIZE
>  -D SINGLE_LISTEN_UNSERIALIZED_ACCEPT
>  -D APR_HAS_OTHER_CHILD
>  -D AP_HAVE_RELIABLE_PIPED_LOGS
>  -D HTTPD_ROOT="/usr/local/apache2"
>  -D SUEXEC_BIN="/usr/local/apache2/bin/suexec"
>  -D DEFAULT_PIDLOG="logs/httpd.pid"
>  -D DEFAULT_SCOREBOARD="logs/apache_runtime_status"
>  -D DEFAULT_LOCKFILE="logs/accept.lock"
>  -D DEFAULT_ERRORLOG="logs/error_log"
>  -D AP_TYPES_CONFIG_FILE="conf/mime.types"
>  -D SERVER_CONFIG_FILE="conf/httpd.conf"
> 

More Info:

SSLSessionCache         dbm:logs/ssl_scache
SSLMutex  file:logs/ssl_mutex

I will try out different values for these, but I reinstalled without modssl, so I have to install modssl first. Seems like these are pretty standard settings. I'm surprised no one else has run across this warning.

Please let me know if there is anything else I can provide to help out.

- Alex Hart
http://atpmail.com
______________________________________________________________________
Apache Interface to OpenSSL (mod_ssl)                   www.modssl.org
User Support Mailing List                      [email-masked]
Automated List Manager                            [email-masked]

---

From: Mads Toftum <[email-masked]>
Date: Fri, 3 Oct 2003 10:49:13 +0200

> SSLSessionCache         dbm:logs/ssl_scache

Ususally I'd suggest using an shm based cache for performance reasons,
but that probably isn't the cause.

> SSLMutex  file:logs/ssl_mutex
I seem to recall some sort of trouble with mutexes on bsd that has been
fixed recently - although your error message doesn't seem directly 
related, it might be worth looking into. Or possibly even going for the
latest cvs version in APACHE_2_0_BRANCH (a new release should be right
around the corner anyway).

> I will try out different values for these, but I reinstalled without modssl, so I have to install modssl first. Seems like these are pretty standard settings. I'm surprised no one else has run acro…
I have heard one reporting similar problems on irc, but that's it.

vh

Mads Toftum
-- 
Speaking at ApacheCon 2003 - http://ApacheCon.com/
T03, "Apache 2 mod_ssl tutorial" (3h)
WE03, "Troubleshooting Apache configurations" 
WE11, "Apache mod_rewrite, the Swiss Army Knife of URL manipulation" 
______________________________________________________________________
Apache Interface to OpenSSL (mod_ssl)                   www.modssl.org
User Support Mailing List                      [email-masked]
Automated List Manager                            [email-masked]