Subject: mod_ssl/2.8.13 and php

From: Sophia Petridou <[email-masked]>
Date: Wed, 19 Mar 2003 16:39:25 +0200

Hello all,

SERVER: Apache 1.3.27 + mod_ssl/2.8.13 + PHP/4.3.1

I have just installed mod_ssl/2.8.13 and my server
has started without problems.
(config command: ./configure  --with-apxs=/usr/local/apache/bin/apxs
--with-ssl=/usr/local/ssl --with-mm=/usr/local/include)

The requests about html files or server-status and server-info pages
are ok. But, when I request a php file (/php3-info.php3) I get the
message
'The page cannot be displayed'. These are the entries in my error log
file:
[Wed Mar 19 16:10:31 2003] [notice] child pid 11411 exit signal
Segmentation Fault (11)
[Wed Mar 19 16:10:33 2003] [notice] child pid 11414 exit signal
Segmentation Fault (11)
[Wed Mar 19 16:20:54 2003] [notice] child pid 11413 exit signal
Segmentation Fault (11)
[Wed Mar 19 16:21:04 2003] [notice] child pid 11415 exit signal
Segmentation Fault (11)
[Wed Mar 19 16:21:17 2003] [notice] child pid 11412 exit signal
Segmentation Fault (11)

This problem does not exist with mod_ssl/2.8.12 and the same version of
php

thanks in advance

-sophia

---

From: Ed Kubaitis <[email-masked]>
Date: Thu, 20 Mar 2003 09:47:03 -0600

I see the problem with

   Apache/1.3.27
   mod_ssl/2.8.13
   (no other optional Apache modules except mod_rewrite)
   OpenSSL/0.9.7a
   Red Hat Linux 7.3 system

I tried OpenSSL 0.9.7a both with and without the RSA
blinding patch distributed by Ben Laurie and saw the
problem both times.

I see no problems with modssl 2.8.12 and OpenSSL 0.9.7a
-- either with or without the Ben Laurie patch.

I have made the error_log and ssl_engine_log for the
failure with 2.8.13 available at

  http://ejk.cso.uiuc.edu/modssl-2.8.13-logs/

--
Ed Kubaitis - [email-masked]
CITES/STS - University of Illinois at Urbana-Champaign

Burkhard Ulric wrote:

> I have this Problems with:
>
> Apache/1.3.27 mod_gzip/1.3.26.1a PHP/4.3.1 mod_ssl/2.8.13 OpenSSL/0.9.7a
>
> Requesting Pages without ssl encryption works fine but requesting this
> Pages with encryption causes segfault on every request.
>
> There are no Problems with  2.8.12
>
> Regards
>
> Burkhard
>
>
> On Wed, 19 Mar 2003, Frye, David wrote:
>
>> I had the same problem but without using PHP.  Ended up reverting back
>> to 2.8.12 \ until I (or someone else) can figure it out.  It will also
>> install the snakeoil \ certificates even if I specifiy the path to an
>> existing cert.  -----Original Message-----
>> From: Sophia Petridou [mailto:[email-masked]]
>> Sent: Wednesday, March 19, 2003 9:39 AM
>> To: [email-masked]
>> Subject: mod_ssl/2.8.13 and php
>>
>>
>> Hello all,
>>
>> ______________________________________________________________________
>> Apache Interface to OpenSSL (mod_ssl)                   www.modssl.org
>> User Support Mailing List                      [email-masked]
>> Automated List Manager                            [email-masked]
>>
>

______________________________________________________________________
Apache Interface to OpenSSL (mod_ssl)                   www.modssl.org
User Support Mailing List                      [email-masked]
Automated List Manager                            [email-masked]