Subject: Post ./configure issue with BSD and apache_1.3.22

From: "Joe Magee" <[email-masked]>
Date: Mon, 11 Mar 2002 13:54:58 -0500

Hello all, I'm new to the mod_ssl world... I'm trying to setup mod_ssl 2.8.5 with apache_1.3.22. Im running FreeBSD 4.5-RELEASE I seem to be having trouble when setting the "SSL_BASE=" part of the configuration. When I attempt to type in SSL_BASE= I get file not found... If I do an ls in the apache_1.3.22 directory I donot see any files that refer to SSL_BASE= I've scowered google and the archives looking for a resolution. If anyone could lend me a hand I would greatly appreciate it. 

IMPORTANT NOTE: I already had a copy of apache_1.3.22 installed before doing this these steps.  I'm not sure if that impacts this issue.

I've already installed openssl-0.9.6b by doing hte following:
# cd openssl-0.9.6b
# sh config 
# make 
# make test 
# make install

Then I installed mod_ssl by:
# cd ../mod_ssl-2.8.5-1.3.22
# ./configure --with-apache=../apache_1.3.22

snortsensor# cd ../mod_ssl-2.8.5-1.3.22
snortsensor# ./configure --with-apache=../apache_1.3.22
Configuring mod_ssl/2.8.5 for Apache/1.3.22
 + Apache location: ../apache_1.3.22 (Version 1.3.22)
 + Auxiliary patch tool: ./etc/patch/patch (local)
 + Applying packages to Apache source tree:
   o Extended API (EAPI)
   o Distribution Documents
   o SSL Module Source
   o SSL Support
   o SSL Configuration Additions
   o SSL Module Documentation
   o Addons
Done: source extension and patches successfully applied.

Now proceed with the following commands (Bourne-Shell syntax):
 $ cd ../apache_1.3.22
 $ SSL_BASE=/path/to/openssl ./configure ... --enable-module=ssl
 $ make
 $ make certificate
 $ make install
#------------------------------------------
#Here is where the problem seems to occur:
#------------------------------------------
snortsensor# cd ../apache_1.3.22
snortsensor# SSL_BASE=../openssl-0.9.6b/ \
? ./configure --enable-module=ssl \
? --enable-module=so \
? --prefix=/usr/local/www/
SSL_BASE=../openssl-0.9.6b/: Command not found.

I also tryed typing in:

SSL_BASE=../openssl-0.9.6b/ ./configure --enable-module=ssl --enable-module=so --prefix=/usr/local/www/
SSL_BASE=../openssl-0.9.6b/: Command not found.

Thanks all!

Joe Magee
______________________________________________________________________
Apache Interface to OpenSSL (mod_ssl)                   www.modssl.org
User Support Mailing List                      [email-masked]
Automated List Manager                            [email-masked]

---

From: Thomas Binder <[email-masked]>
Date: Mon, 11 Mar 2002 23:43:07 +0100

Hi!

> SSL_BASE=../openssl-0.9.6b/: Command not found.

You're using a csh'ish shell, but for the above construct to work
as expected you need to use an sh-compatible one, e.g. sh, ksh,
bash, etc.

Ciao

Thomas

-- 
If you can keep your head when all about you are losing theirs, then
you clearly don't understand the situation.
______________________________________________________________________
Apache Interface to OpenSSL (mod_ssl)                   www.modssl.org
User Support Mailing List                      [email-masked]
Automated List Manager                            [email-masked]

---

From: "Robin P. Blanchard" <[email-masked]>
Date: Mon, 11 Mar 2002 14:55:41 -0500

are you using a bourne shell? default root shell on fbsd isn't a
bourne-style shell...why not use ports to accomplish all of this? why
install another copy of openssl? anyways...all of your commands i
believe would work if you simply switched to sh instead of (t)csh.

-- 
------------------------------------
Robin P. Blanchard
IT Program Specialist
Georgia Center for Continuing Ed.
fon: 706.542.2404 fax: 706.542.6546
email: [email-masked]
------------------------------------
______________________________________________________________________
Apache Interface to OpenSSL (mod_ssl)                   www.modssl.org
User Support Mailing List                      [email-masked]
Automated List Manager                            [email-masked]