Subject: win2000 compile

From: "ross" <[email-masked]>
Date: Mon, 29 Apr 2002 15:18:42 +0100

hi,

I am trying to compile apache 2 with mod_ssl on win2000.(visual c++ 6)
(I'm not a c++ developer, java is much more my thing.)

I have compiled openssl successfully and installed cygwin.

but when trying to compile apache2 I get the following errors from mod_ssl.

--------------------Configuration: mod_ssl - Win32 Release--------------------
Generating ssl_expr_parse.c/.h from ssl_expr_parse.y
/usr/local/share/bison.simple: No such file or directory
bison: The system cannot find the file specified.
Could Not Find C:\ross\work\projects\apache_ssl_php\httpd-2.0.35\modules\ssl\y.tab.c
The system cannot find the file specified.
Could Not Find C:\ross\work\projects\apache_ssl_php\httpd-2.0.35\modules\ssl\y.tab.h
Error executing c:\winnt\system32\cmd.exe.
mod_ssl.so - 1 error(s), 0 warning(s)
--------------------Configuration: abs - Win32 Release--------------------
Compiling...
ab.c
C:\ross\work\projects\apache_ssl_php\httpd-2.0.35\support\ab.c(164) : fatal error C1083: Cannot open include file: 'open
ssl/rsa.h': No such file or directory
Error executing cl.exe.
abs.exe - 1 error(s), 0 warning(s)
NMAKE : fatal error U1077: 'msdev' : return code '0x2'
Stop.
Error executing NMAKE.

Apache.exe - 4 error(s), 4 warning(s)
NMAKE : fatal error U1077: 'msdev' : return code '0x4'
Stop.
NMAKE : fatal error U1077: '"C:\Program Files\Microsoft Visual Studio\VC98\bin\NMAKE.EXE"' : return code '0x2'
Stop.
<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<

Does anyone have a suggestion as to how i can get round this.
The 'y.tab.c' and 'y.tab.h' files seem to be generated by sed, but the cygwin version doesn't seem to be being used.(i think :-} )

thanks

Ross

---

From: "Dwayne Miller" <[email-masked]>
Date: Tue, 30 Apr 2002 08:23:43 -0400

Try extracting the zip again (or get ssl_expr_parse.x from CVS).  Your 
attempt to build probaby resulted in empty files for 
ssl_expr_parse.c/.h.  Then edit (or touch) the .c/.h version to make 
them modified after ssl_expr_parse.y.  They do not need to be rebuilt, 
but since their timestamps are wrong, make believes they are out of date.

The same problem might exist with the tab.c/.h files.

ross wrote:

> Could Not Find 
> C:\ross\work\projects\apache_ssl_php\httpd-2.0.35\modules\ssl\y.tab.c
> Could Not Find 
> C:\ross\work\projects\apache_ssl_php\httpd-2.0.35\modules\ssl\y.tab.h
> C:\ross\work\projects\apache_ssl_php\httpd-2.0.35\support\ab.c(164) : 
> fatal error C1083: Cannot open include file: 'open
> NMAKE : fatal error U1077: '"C:\Program Files\Microsoft Visual 
> Studio\VC98\bin\NMAKE.EXE"' : return code '0x2'
> Stop.
> The 'y.tab.c' and 'y.tab.h' files seem to be generated by sed, but the 
> cygwin version doesn't seem to be being used.(i think :-} )
>  
> thanks
>  
> Ross

______________________________________________________________________
Apache Interface to OpenSSL (mod_ssl)                   www.modssl.org
User Support Mailing List                      [email-masked]
Automated List Manager                            [email-masked]

---

From: Cliff Woolley <[email-masked]>
Date: Tue, 30 Apr 2002 09:43:14 -0400 (EDT)

> but since their timestamps are wrong, make believes they are out of date.

Right.  The timestamps were bad in the tarball.  This is fixed in 2.0.36,
which will be released soon.  For now, the files you need to touch are:

ssl_expr_parse.c
ssl_expr_parse.h
ssl_expr_scan.c

--Cliff

--------------------------------------------------------------
   Cliff Woolley
   [email-masked]
   Charlottesville, VA