Subject: apache with mod_ssl

From: Shouben Zhou <[email-masked]>
Date: Fri, 15 Mar 2002 12:36:34 -0500

I currently use apache-SSL and  am switching to the apache with modssl
module.
The building process is success. The version I am using to build
apache-modssl is
apache_1.3.23, modssl-2.8.7.-1.3.23 and openssl-0.9.6a.

I am having 2 problems when using this httpd:

 1) when access the HTTPS server, netscape is asked to select the user
certificate, then
passphease. After that netscape is asked again twice to select user
certificate! This never
happens on my apache-SSL version.

    SSLVerifyClient require
    SSLVerifyDepth 1

2) When I switch to HTTP server ( VirtualHost same node ), most times
netscape crashs!
This also never happens on my apache-SSL version.

I have tried both shared and static building methods and no luck. What
am I missing
here?

*--------------------------------------------------------------*
*  Shouben Zhou                  |                             *
*  ICASE                         |                             *
*  Mail Stop 132C, Bldg. 1152    | Phone: (757) 864-6558       *
*  NASA Langley Research Center  |   Fax: (757) 864-6134       *
*  Hampton, VA 23681-2199        | Email: [email-masked]      *
*--------------------------------------------------------------*

______________________________________________________________________
Apache Interface to OpenSSL (mod_ssl)                   www.modssl.org
User Support Mailing List                      [email-masked]
Automated List Manager                            [email-masked]

---

From: Shiva Murugesan <[email-masked]>
Date: Sat, 16 Mar 2002 23:39:43 -0800 (PST)

Hi Shouban,

I am also exactly facing the same problem and
struggling to find the solution.  I have some clues on
this problem.

It happens only in the following scenario.

If the server has 128bit encrypted server certificate,
then it asks the NE client to present the certificate
multiple times.  

It does not happen if we have the following.

(1)If the server certificate has 40bit encryption.

(2)If both the server and client certificates are
issued by same CA. ( even for 128 bit encryption, it
asks only once in NE to present the certificate ).

It will be extremenly helpful if someone helps how to
get the NE not asking to present the client
certificate more than once.

Shiva

> *  Shouben Zhou                  |                  
>           *
> *  ICASE                         |                  
>           *
> User Support Mailing List                     

__________________________________________________
Do You Yahoo!?
Yahoo! Sports - live college hoops coverage
http://sports.yahoo.com/
______________________________________________________________________
Apache Interface to OpenSSL (mod_ssl)                   www.modssl.org
User Support Mailing List                      [email-masked]
Automated List Manager                            [email-masked]