Subject: Re: Apache 2.0.35 with SSL - wont start

From: "R. DuFresne" <[email-masked]>
Date: Mon, 15 Apr 2002 09:26:37 -0400 (EDT)

> > (13)Permission denied: make_sock: could not bind to address
0.0.0.0:443
> > no listening sockets available, shutting down
> > ./apachectl startssl: httpd could not be started
> >

It's *not* trying to start on 8443 though...

thanks,

Ron DuFresne

On Mon, 15 Apr 2002, paul priestman wrote:

> i'm actually trying to run this server on port 8443 - the other httpd runs 
> on port 443 but i have stopped this server running (as its just another test 
> server).  I am starting the server as my self - not as root but the port is 
>  > 1024 anyway
> 
> I have tried chaning the port to other numbers aswell but to no luck....
> 
> Paul
> 
> >From: "R. DuFresne" <[email-masked]>
> >To: paul priestman <[email-masked]>
> >CC: [email-masked]
> >Subject: Re: Apache 2.0.35 with SSL - wont start
> >Date: Mon, 15 Apr 2002 09:12:42 -0400 (EDT)
> >
> >
> >You're not trying to run two httpd's on the same set of ports are you, the
> >old one running while trying to fire up the new?
> >
> >that's what the error suggests I think...
> >
> >thanks,
> >
> >Ron DuFresne
> >
> >On Mon, 15 Apr 2002, paul priestman wrote:
> >
> > > Hello all,
> > >
> > > I have downloaded and installed Apache 2.0.35 with SSL.  I have 
> >configured
> > > the httpd.conf as they suggest in ssl.conf.  However, when i try to 
> >start
> > > apachectl i get the following message:
> > >
> > > (13)Permission denied: make_sock: could not bind to address 0.0.0.0:443
> > > no listening sockets available, shutting down
> > > ./apachectl startssl: httpd could not be started
> > >
> > > Has anyone any ideas what i'm doing wrong - i have succesfully got ssl
> > > working with apache 1.3.22.
> > >
> > > Thanks for your time
> > >
> > > Paul
> > >
> > > _________________________________________________________________
> > > Chat with friends online, try MSN Messenger: http://messenger.msn.com
> > >
> > > ______________________________________________________________________
> > > Apache Interface to OpenSSL (mod_ssl)                   www.modssl.org
> > > User Support Mailing List                      [email-masked]
> > > Automated List Manager                            [email-masked]
> > >
> >
> >--
> >~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
> >         admin & senior security consultant:  sysinfo.com
> >                         http://sysinfo.com
> >
> >"Cutting the space budget really restores my faith in humanity.  It
> >eliminates dreams, goals, and ideals and lets us get straight to the
> >business of hate, debauchery, and self-annihilation."
> >                 -- Johnny Hart
> >
> >testing, only testing, and damn good at it too!
> >
> 
> 
> 
> 
> _________________________________________________________________
> Get your FREE download of MSN Explorer at http://explorer.msn.com/intl.asp.
> 

-- 
~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
        admin & senior security consultant:  sysinfo.com
                        http://sysinfo.com

"Cutting the space budget really restores my faith in humanity.  It
eliminates dreams, goals, and ideals and lets us get straight to the
business of hate, debauchery, and self-annihilation."
                -- Johnny Hart

testing, only testing, and damn good at it too!

______________________________________________________________________
Apache Interface to OpenSSL (mod_ssl)                   www.modssl.org
User Support Mailing List                      [email-masked]
Automated List Manager                            [email-masked]

---

From: "Jeremy Walton" <[email-masked]>
Date: Mon, 15 Apr 2002 09:27:48 -0400

There is 2 reason for not being able to bind to a port.  One, another
process already has it open and is currently listen (netstat -a   or
under linux  netstat -vatp).  Two, you have to be root to bind to ports
under 1024.

Jeremy Walton
DICE Corporation

-----Original Message-----
From: [email-masked]
[mailto:[email-masked]] On Behalf Of R. DuFresne
Sent: Monday, April 15, 2002 9:27 AM
To: paul priestman
Cc: [email-masked]
Subject: Re: Apache 2.0.35 with SSL - wont start

0.0.0.0:443

thanks,

Ron DuFresne

On Mon, 15 Apr 2002, paul priestman wrote:

> >You're not trying to run two httpd's on the same set of ports are 
> >you, the old one running while trying to fire up the new?
> >
> > > 0.0.0.0:443 no listening sockets available, shutting down 
> > > Has anyone any ideas what i'm doing wrong - i have succesfully got

> > > ssl working with apache 1.3.22.
> > >
> > > Thanks for your time
> > >
> > > Paul
> > >

---

From: "paul priestman" <[email-masked]>
Date: Mon, 15 Apr 2002 13:18:01 +0000

Paul

---

From: "Andrew Lietzow" <[email-masked]>
Date: Mon, 15 Apr 2002 09:26:51 -0500

Dear Paul,
RE:>>(13)Permission denied: make_sock: could not bind to address 0.0.0.0:443
no listening sockets available, shutting down AND I have tried changing the
port
to other numbers as well but to no luck....
-------------------
Just a thought... can you ping to that IP address of 0.0.0.0?  And is this a
port
that you can bind to?  Seems like it ought to be either a private C Class
address, or some other address than the default of 0.0.0.0.

In other words, are you certain that you can direct TCP/IP framed packets
through this IP address?

Andrew Lietzow
The ACL Group, Inc.

----- Original Message -----
From: "paul priestman" <[email-masked]>
To: <[email-masked]>
Cc: <[email-masked]>
Sent: Monday, April 15, 2002 8:18 AM
Subject: Re: Apache 2.0.35 with SSL - wont start

0.0.0.0:443

---

From: "Jeremy Walton" <[email-masked]>
Date: Mon, 15 Apr 2002 10:41:48 -0400

0.0.0.0 tells the OS to bind to all network adapters.  Its not really a
usable IP address.

Jeremy Walton
DICE Corporation

-----Original Message-----
From: [email-masked]
[mailto:[email-masked]] On Behalf Of Andrew Lietzow
Sent: Monday, April 15, 2002 10:27 AM
To: [email-masked]
Subject: Re: Apache 2.0.35 with SSL - wont start

Dear Paul,
RE:>>(13)Permission denied: make_sock: could not bind to address
0.0.0.0:443 no listening sockets available, shutting down AND I have
tried changing the port to other numbers as well but to no luck....
-------------------
Just a thought... can you ping to that IP address of 0.0.0.0?  And is
this a port that you can bind to?  Seems like it ought to be either a
private C Class address, or some other address than the default of
0.0.0.0.

In other words, are you certain that you can direct TCP/IP framed
packets through this IP address?

Andrew Lietzow
The ACL Group, Inc.

----- Original Message -----
From: "paul priestman" <[email-masked]>
To: <[email-masked]>
Cc: <[email-masked]>
Sent: Monday, April 15, 2002 8:18 AM
Subject: Re: Apache 2.0.35 with SSL - wont start

> i'm actually trying to run this server on port 8443 - the other httpd 
> runs on port 443 but i have stopped this server running (as its just 
> another
test
> server).  I am starting the server as my self - not as root but the 
> port
is
> >you,
the
0.0.0.0:443

---

From: "Andrew Lietzow" <[email-masked]>
Date: Mon, 15 Apr 2002 10:22:58 -0500

Hello Jeremy,
RE>::> 0.0.0.0 tells the OS to bind to all network adapters.  Its not really
a
> usable IP address.
--------
Maybe this is a bit off subject, but doesn't the Apache web server have to
bind to a specific network interface?  If you are trying to have it listen
for packets on 443 or 8443, or whatever, you couldn't have it listen to four
(or some other multiple of one) IP addresses and associated ports
simultaneously... or could you?  I mean it might be "able" to do it, but how
would it know how to control traffic without specifically binding addresses
to an interface, whether they be static, or at least IP-masqueraded (as in
NAT).

Just for testing purposes, if one could say, either in the main server or in
a virtual host directive:
Listen _default_:*

with one network interface, what would happen if you had multiple network
interfaces?  The httpd daemon would start for the first one, possibly, but
could it route traffic for all of the interfaces and not know specific IP
address for those cards?  Obviously, I'm confused.

This will eventually lead to my burning question of how to setup multiple
secure servers with the VirtualHost directive.  I think I can do this by
assigning each server to a different port address but I'm not quite there
yet.

Andrew Lietzow
The ACL Group, Inc.