Subject: RE: openssl upgrade

From: Robert Lagana <[email-masked]>
Date: Thu, 20 Mar 2003 11:50:19 -0500

Linux 7.2 RedHat
Pentium

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]
Sent: Thursday, March 20, 2003 11:45 AM
To: [email-masked]'
Subject: Re: openssl upgrade

On 20 Mar 2003 at 11:34, Robert Lagana wrote:

> 
> On a linux 7.2 system, would it be easy to upgrade the current version of
> OpenSSL to the most recent?
> Are there any directions for this?
> 
> Thanks

linux 7.2 what? (RedHat, SuSE, etc.)

Aloha => Beau;

______________________________________________________________________
Apache Interface to OpenSSL (mod_ssl)                   www.modssl.org
User Support Mailing List                      [email-masked]
Automated List Manager                            [email-masked]
______________________________________________________________________
Apache Interface to OpenSSL (mod_ssl)                   www.modssl.org
User Support Mailing List                      [email-masked]
Automated List Manager                            [email-masked]

---

From: "Drew J. Como" <[email-masked]>
Date: Thu, 20 Mar 2003 12:50:09 -0500

Beau,

The easiest way to upgrade is to simply install the latest
RPM for your distibution.  These are free downloads and
can be easily obtained by going to www.redhat.com.

Here is something easier for you.  Click on the link below
and simply download the patch for the appropriate OS:

https://rhn.redhat.com/errata/RHSA-2003-062.html

Download the package and then install it using the following
command:

	rpm -Uvh [nameofpackage.rpm]

Enjoy :-)

============================================
Drew J. Como             Phone: 631-434-6600
Systems Administrator      Fax: 631-434-7800
[email-masked]         Web: www.bascom.com
    Bascom Global Internet Services, Inc.
--------------------------------------------
          "When quality is the goal, 
           winning is guaranteed."  

-----Original Message-----
From: [email-masked]
[mailto:[email-masked]]On Behalf Of Robert Lagana
Sent: Thursday, March 20, 2003 11:50 AM
To: [email-masked]'
Subject: RE: openssl upgrade

Linux 7.2 RedHat
Pentium

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]
Sent: Thursday, March 20, 2003 11:45 AM
To: [email-masked]'
Subject: Re: openssl upgrade

Aloha => Beau;

---

From: [email-masked]
Date: Thu, 20 Mar 2003 08:02:05 -1000

> linux 7.2 what? (RedHat, SuSE, etc.)

Hi -

It should not be too hard (but I am not
using RedHat):

1) read http://www.openssl.org/support/faq.html
   Note the RedHat sections.

2) download the latest (0.9.7a) to some dir
   (I use something like /usr/local/src/openssl).

3) untar it and check its signature (see faq).

4) read the following in the expanded dir:
   FAQ and INSTALL and/or INSTALL.whatever

5) make you choices and do a
    ./config --whatever=whatever \
      ...
    make
    make test

6) if OK, you have proved you can get
   openssl compiled and tested from source.

7) now is the tricky part; examine your current
   installed openssl, determine it's location,
   and, if you are sure you know what's what,
   remove it with rpm (man rpm if ?s). I assume
   you can always revert to the RedHat version
   by re-installing the 'official' RedHat
   openssl rpm. (I hope you are doing this on
   a test machine.)

8) make location changes (prefix=....) (if
   necessary) and repeat from step 4.

9) make install and ldconfig.

10)test and, etc.

Aloha => Beau;

PS: please remember that every distro has it's
own quirks; you eventually will have to fight
through them on your own - and, yes, it gets
easier and easier as you install more and more
packages. Good luck!

---

From: "R. DuFresne" <[email-masked]>
Date: Thu, 20 Mar 2003 13:16:25 -0500 (EST)

On Thu, 20 Mar 2003 [email-masked] wrote:

	[SNIP]

>    openssl rpm. (I hope you are doing this on

and get the sources and recompile all red-hat apps that rely upon openssl.
There are others on the list that might beable to document what those
applications are, but, I believe there are a few.

> 9) make install and ldconfig.

Thanks,

Ron DuFresne
-- 
~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
        admin & senior security consultant:  sysinfo.com
                        http://sysinfo.com

"Cutting the space budget really restores my faith in humanity.  It
eliminates dreams, goals, and ideals and lets us get straight to the
business of hate, debauchery, and self-annihilation."
                -- Johnny Hart

testing, only testing, and damn good at it too!

---

From: Nalin Dahyabhai <[email-masked]>
Date: Thu, 20 Mar 2003 14:28:22 -0500

> applications are, but, I believe there are a few.

You can make that list by finding which version of libcrypto the default
openssl package installs:

  nalin@blade:~> rpm -q --provides openssl | grep libcrypto
  libcrypto.so.2

and then by checking which packages require that shared library:

  nalin@blade:~> rpm -q --whatrequires libcrypto.so.2

Cheers,

Nalin