Subject: Mod.so errors.

From: Zandi Patrick S TSgt AFRL/IFOSS <[email-masked]>
Date: Mon, 7 Oct 2002 13:47:19 -0000

Hello ,
I cannot get mod.so to work.. And I have no Idea where it should be here..
 
I build apache with the following options.. 
EAPI_MM="/usr/local/bin" \
SSL_BASE="/usr/local/ssl" \
./configure \
"--with-layout=Apache" \
"--server-uid=zandip" \
"--server-gid=other" \
"--with-perl=/usr/local/bin/perl" \
"--prefix=/apache" \
"--enable-module=most" \
"--enable-shared=max" \
"--enable-module=ssl" \
"--disable-rule=SSL_COMPAT" \
"--enable-rule=SSL_SDBM" \
"--enable-module=so" \
"--enable-module=rewrite" \
"--enable-module=log_referer" \
"--enable-module=log_agent" \
"--enable-module=expires" \
"--enable-module=info" \
"--enable-module=usertrack" \

Now When I execute I am getting the following..

Syntax error on line 204 of /apache/conf/httpd.conf:
Cannot load /apache/libexec/mod.so into server: ld.so.1: /apache/bin/httpd:
fatal: /apache/libexec/mod.so: open failed: No such file or directory
./apachectl start: httpd could not be started

Looking at line 204 says
LoadModule       mod_so  libexec/mod.so

Ls -la of LIBEXEC Shows..
httpd.exp           mod_asis.so         mod_cgi.so          mod_headers.so
mod_log_referer.so  mod_speling.so
libproxy.so         mod_auth.so         mod_define.so       mod_imap.so
mod_mime.so         mod_status.so
libssl.so           mod_auth_anon.so    mod_digest.so       mod_include.so
mod_mime_magic.so   mod_unique_id.so
mod_access.so       mod_auth_dbm.so     mod_dir.so          mod_info.so
mod_negotiation.so  mod_userdir.so
mod_actions.so      mod_autoindex.so    mod_env.so          mod_log_agent.so
mod_rewrite.so      mod_usertrack.so
mod_alias.so        mod_cern_meta.so    mod_expires.so
mod_log_config.so   mod_setenvif.so     mod_vhost_alias.so
______________________________________________________________________
Apache Interface to OpenSSL (mod_ssl)                   www.modssl.org
User Support Mailing List                      [email-masked]
Automated List Manager                            [email-masked]

---

From: "Jose Correia (J)" <[email-masked]>
Date: Mon, 7 Oct 2002 15:53:56 +0200

You have to obtain the mod.so file and place it in the ../libexec
directory.. its not there.

-----Original Message-----
From: Zandi Patrick S TSgt AFRL/IFOSS [mailto:[email-masked]]
Sent: 07 October 2002 15:47
To: [email-masked]'
Subject: Mod.so errors.

Hello ,
I cannot get mod.so to work.. And I have no Idea where it should be
here..

Syntax error on line 204 of /apache/conf/httpd.conf:
Cannot load /apache/libexec/mod.so into server: ld.so.1:
/apache/bin/httpd:
fatal: /apache/libexec/mod.so: open failed: No such file or directory
./apachectl start: httpd could not be started

Looking at line 204 says

Ls -la of LIBEXEC Shows..
httpd.exp           mod_asis.so         mod_cgi.so
mod_headers.so
mod_log_referer.so  mod_speling.so
libproxy.so         mod_auth.so         mod_define.so
mod_imap.so
mod_mime.so         mod_status.so
libssl.so           mod_auth_anon.so    mod_digest.so
mod_include.so
mod_mime_magic.so   mod_unique_id.so
mod_access.so       mod_auth_dbm.so     mod_dir.so
mod_info.so
mod_negotiation.so  mod_userdir.so
mod_actions.so      mod_autoindex.so    mod_env.so
mod_log_agent.so
mod_rewrite.so      mod_usertrack.so
mod_alias.so        mod_cern_meta.so    mod_expires.so
mod_log_config.so   mod_setenvif.so     mod_vhost_alias.so
______________________________________________________________________
Apache Interface to OpenSSL (mod_ssl)                   www.modssl.org
User Support Mailing List                      [email-masked]
Automated List Manager                            [email-masked]
______________________________________________________________________
Apache Interface to OpenSSL (mod_ssl)                   www.modssl.org
User Support Mailing List                      [email-masked]
Automated List Manager                            [email-masked]