Subject: Issue with IE6 and a self-signed cert.

From: James Kilton <[email-masked]>
Date: Wed, 5 Feb 2003 07:29:17 -0800 (PST)

Hello.

I'm trying out modssl for the first time on Apache
1.3.27.  I followed the instructions in the modssl
INSTALL file to install both modssl and Apache.  I
went with option 2 because I also needed to integrate
PHP with Apache.

When I ran 'make certificate', I used TYPE=custom
because I wanted to self-sign it.  This all seemed to
go well -- the CA cert was created, then the server's
cert was created and signed.
 
When I go to the site in IE, however, I always get the
pop-up that warns about the cert being signed by an
untrusted CA.  If I try to install the cert into my
trusted root store, IE says the import has succeeded
but the cert doesn't appear in the store, and I
continue to get the popup warning.  I've tried this
several times to no avail.

I've never run into anything like this so I'm somewhat
at a loss.  I created and imported a cert in Tomcat 
he other day and it went fine, but for some reason IE 
doesn't seem to like this one.  Has anyone ever
experienced anything like this?  Any advice would be
appreciated.
 
Thanks.

__________________________________________________
Do you Yahoo!?
Yahoo! Mail Plus - Powerful. Affordable. Sign up now.
http://mailplus.yahoo.com
______________________________________________________________________
Apache Interface to OpenSSL (mod_ssl)                   www.modssl.org
User Support Mailing List                      [email-masked]
Automated List Manager                            [email-masked]

---

From: "Drew J. Como" <[email-masked]>
Date: Wed, 5 Feb 2003 10:30:37 -0500

I have run into this problem as well and have
not found a resolution to it either.  If you do
find the answer, please let me know!!

============================================
Drew J. Como             Phone: 631-434-6600
Systems Administrator      Fax: 631-434-7800
[email-masked]         Web: www.bascom.com
    Bascom Global Internet Services, Inc.
--------------------------------------------
          "When quality is the goal, 
           winning is guaranteed."  

-----Original Message-----
From: [email-masked]
[mailto:[email-masked]]On Behalf Of James Kilton
Sent: Wednesday, February 05, 2003 10:29 AM
To: [email-masked]
Subject: Issue with IE6 and a self-signed cert.

Hello.

 

Thanks.