Subject: Some help

From: "Frederic DONNAT" <[email-masked]>
Date: Thu, 2 May 2002 20:16:19 +0200

Hi All,

I quite new to mod-ssl and apache 2.0.x, so i have a few question.

With Apache 1.3.x, i was use to call openssl engine througth mod-ssl, with some compilation condition (--enable-rule=SSL_ExPERIMENTAL), and http.conf modification (SSLCryptoDevice ...). 

My problem comes with new Apache 2.0.x!
Am i right if i try to compile mod-ssl with the same rule adding "--enable-rule=SSL_ExPERIMENTAL" when doing ./configure for apache?
If i do not misundersand, we can have compilation directive for module (as mod-ssl) from apache configuration script?
Should i be able to use an openssl engine using the same "SSLCryptoDevice ..."?

Thanks in advance.
Regards
Fred

---

From: Estrade Matthieu <[email-masked]>
Date: 03 May 2002 13:37:11 +0200

Hi,

To compile your apache with this flags, --enable-rule is not working for
me, so i did it like:
bash# CFLAGS="-DSSL_EXPERIMENTAL -DSSL_ENGINE" ./configure....

regards
Estrade Matthieu

> Should i be able to use an openssl engine using the same "SSLCryptoDevice ..."?

______________________________________________________________________________
ifrance.com, l'email gratuit le plus complet de l'Internet !
vos emails depuis un navigateur, en POP3, sur Minitel, sur le WAP...
http://www.ifrance.com/_reloc/email.emailif

______________________________________________________________________
Apache Interface to OpenSSL (mod_ssl)                   www.modssl.org
User Support Mailing List                      [email-masked]
Automated List Manager                            [email-masked]