Subject: Re: Apache_1.3.27 and ssl

From: [email-masked]
Date: Tue, 22 Oct 2002 16:39:39 -0500

Here's what we did:

####################################################################
# notes to install and configure apache with modules, mod_perl, so
####################################################################

    #   extract the packages
 
    $ gzip -d -c openssl-0.9.6a.tar.gz | tar xvf -
!!!
    ##########################
    INSTALL openssl first !!!
    ##########################
!!!

    $ gzip -d -c apache_1.3.x.tar.gz | tar xvf -
    $ gzip -d -c mod_ssl-2.8.x-1.3.x.tar.gz | tar xvf -
    $ gzip -d -c mod_perl-1.xx.tar.gz | tar xvf -

    ########################################################
    #   apply mod_ssl to Apache source tree

      cd mod_ssl*
      ./configure --with-apache=../apache_1.3.27
    ########################################################
    #   apply mod_perl to Apache source tree
    #   and build/install the Perl-side of mod_perl
 
    cd mod_perl-1.27
    perl Makefile.PL EVERYTHING=1 APACHE_SRC=../apache_1.3.27/src 
USE_APACI=1 PREP_HTTPD=1 DO_HTTPD=1
    make
    make install
    cd ../
    ########################################################

    #   build/install Apache with mod_ssl and mod_perl

    cd apache_1.3.27
    SSL_BASE=../openssl-0.9.6a ./configure --prefix=/usr/local/apache 
--enable-module=ssl --activate-module=src/modules/perl/libperl.a 
--enable-module=perl --enable-module=so
    make
    make certificate
    make install
    cd ../
    ########################################################

Troy Garner
Information Technology Manager
Gulf Winds International, Inc.
713.747.4909 x5753
www.gwii.com

leanne lai <[email-masked]>
Sent by: [email-masked]
10/22/2002 04:26 PM
Please respond to modssl-users

        To:     [email-masked]
        cc: 
        Subject:        Apache_1.3.27 and ssl

Dear All,

I don't know whether this is the right place for asking this question 
but I am desperate :(

I am trying to compile apache_1.3.27 and mod_ssl-2.8.11-1.3.27, 
however, apachec_1.3.27 does not seem to have "enable_module=ssl" 
option anymore in its congfigure script!!!

Help!

Thanks,
Leanne

______________________________________________________________________
Apache Interface to OpenSSL (mod_ssl)                   www.modssl.org
User Support Mailing List                      [email-masked]
Automated List Manager                            [email-masked]

---

From: leanne lai <[email-masked]>
Date: Tue, 22 Oct 2002 15:01:05 -0700 (PDT)

Thanks Troy and Drew!!! It is working now!! Thanks for answering!!!

---

From: "Kong, Yi - HPL" <[email-masked]>
Date: Wed, 23 Oct 2002 09:49:07 -0500

Any suggestion on upgrade? We can run the same procedure or need to remove
the old one first?
 
Thanks
 
Yi

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]
Sent: Tuesday, October 22, 2002 4:40 PM
To: [email-masked]
Subject: Re: Apache_1.3.27 and ssl

Here's what we did: 

    #   extract the packages 

      cd mod_ssl* 
    
    cd mod_perl-1.27 

    cd apache_1.3.27 

Troy Garner

10/22/2002 04:26 PM 

Dear All,

Help!

Thanks,
Leanne

---

From: [email-masked]
Date: Wed, 23 Oct 2002 10:10:05 -0500

We upgraded; we did not remove any prior versions.

Troy Garner

"Kong, Yi - HPL" <[email-masked]>
Sent by: [email-masked]
10/23/2002 09:49 AM
Please respond to modssl-users

        To:     "[email-masked]'" <[email-masked]>
        cc: 
        Subject:        RE: Apache_1.3.27 and ssl

Thanks
 
Yi
-----Original Message-----
From: [email-masked] [mailto:[email-masked]]
Sent: Tuesday, October 22, 2002 4:40 PM
To: [email-masked]
Subject: Re: Apache_1.3.27 and ssl

Here's what we did: 

    #   extract the packages 

      cd mod_ssl* 
 
    cd mod_perl-1.27 

    cd apache_1.3.27 

Troy Garner

Dear All,

Help!

Thanks,
Leanne