Subject: Re: [BugDB] Performance issue (PR#723)

From: [email-masked]
Date: Fri, 28 Jun 2002 23:25:09 +0200 (MET DST)

Hi,

I tried with the prngd and exactly the same problem appeared.
=(

Regards

On Mon, 2002-06-24 at 05:52, Thomas Binder wrote:
> Hi!
> 
> On Sat, Jun 22, 2002 at 01:49:12AM +0200, [email-masked] wrote:
> > This caused a different behavior. I mean, it took a little while
> > (~3 minutes), to the loadav get high, and after a few minutes,
> > it got worse... the loadav reached ~60... Without the
> > "no-threads no-idea -fPIC" options at the openSSL compilation,
> > the high loadav is instantaneous.
> > 
> > I can bring any information you need to debug this problem. Just
> > let me know what do you need.
> 
> What kind of random seed do you use? As far as I know, IRIX has no
> /dev/random (nor /dev/urandom), so I might be a good idea to
> install prngd and let SSLRandomSeed point to its socket (using
> egd:/path/to/socket)
> 
> This might already solve your problem.
> 
> 
> Ciao
> 
> Thomas
> ______________________________________________________________________
> Apache Interface to OpenSSL (mod_ssl)                   www.modssl.org
> User Support Mailing List                      [email-masked]
> Automated List Manager                            [email-masked]
> 
-- 
Denis A.V.Jr. - [email-masked]
Systems Engineer - ICQ 2524962
Universo Online

perl -e 'print "computers are like air-conditioners: they stop working
when you open windows ", pack("c*",hex
"3A",sqrt(2025),(unpack(c,"=")-20),10);'

______________________________________________________________________
Apache Interface to OpenSSL (mod_ssl)                   www.modssl.org
User Support Mailing List                      [email-masked]
Automated List Manager                            [email-masked]

---

From: Lutz Jaenicke <[email-masked]>
Date: Sat, 29 Jun 2002 11:51:37 +0200

> I tried with the prngd and exactly the same problem appeared.

I don't think, that your problem has to do with random seeding.
Even the built-in seeding should not cause significant load increases.

What other modules or add-ons do you use? I know that there is at least
one interaction between php4 and mod_ssl: child processes do not correctly
shut down, when both modules are used.

Best regards,
	Lutz
-- 
Lutz Jaenicke                             [email-masked]
http://www.aet.TU-Cottbus.DE/personen/jaenicke/
BTU Cottbus, Allgemeine Elektrotechnik
Universitaetsplatz 3-4, D-03044 Cottbus
______________________________________________________________________
Apache Interface to OpenSSL (mod_ssl)                   www.modssl.org
User Support Mailing List                      [email-masked]
Automated List Manager                            [email-masked]

---

From: "Denis A.V.Jr." <[email-masked]>
Date: 01 Jul 2002 13:38:52 -0300

Hi Lutz...

I compile apache using...: (from mod_ssl dir)

export CFLAGS='-DHARD_SERVER_LIMIT=8192'; ./configure
--disable-rule=DEV_RANDOM --disable-rule=EXPAT --disable-rule=IRIXN32
--disable-rule=IRIXNIS --disable-rule=SHARED_CHAIN
--disable-rule=WANTHSREGEX --enable-module=most
--enable-module=mmap_static --enable-shared=max
--with-apache=../apache_1.3.26 --with-ssl=../openssl-0.9.6d
--prefix=/opt/apache-1.3.26

cd ../apache_1.3.26
make

and I have...:

denao@isherwood /opt/apache-1.3.26# bin/httpd -l
Compiled-in modules:
  http_core.c
  mod_so.c
suexec: disabled; invalid wrapper /opt/apache-1.3.26/bin/suexec

and at the conf, I call...:

LoadModule mmap_static_module libexec/mod_mmap_static.so
<IfDefine access_log>
        LoadModule config_log_module  libexec/mod_log_config.so
</IfDefine>
#LoadModule mime_magic_module  libexec/mod_mime_magic.so
LoadModule mime_module        libexec/mod_mime.so
<IfDefine status>
        LoadModule status_module      libexec/mod_status.so
        LoadModule info_module        libexec/mod_info.so
</IfDefine>
LoadModule imap_module        libexec/mod_imap.so
LoadModule access_module      libexec/mod_access.so
LoadModule expires_module     libexec/mod_expires.so
LoadModule setenvif_module    libexec/mod_setenvif.so
LoadModule negotiation_module libexec/mod_negotiation.so
#LoadModule vhost_alias_module libexec/mod_vhost_alias.so
LoadModule ssl_module         libexec/libssl.so

The real strange thing here, is that those high loads never happens
using apache1.3.22 and mod_ssl 2.8.5... but any combination newer than
this, brings me a high load.

Best regards, and thank you so much for helping me out on this.

Denis.