Subject: Non SSL requires a certificate acceptance

From: "Takeshi Kuriyama" <[email-masked]>
Date: Tue, 28 Oct 2003 13:54:05 +0900

Hi,

I'm running some name-based vhosts and one of them is a self-signed ssl
vhost under:
	apache-1.3.27-13
	openssl-0.9.6k-2
	mod_ssl-2.8.14-13.
My apache configure is like this:
	Port 80
	<IfDefine SSL>
		Listen 80
		Listen 443
	</IfDefine>
	ServerName domainA
	DocumentRoot "/dummy/doc/root"
	NameVirtualHost *
	<VirtualHost *>
		ServerName domainA
		DocumentRoot /domainA/doc/root
	</VirtualHost>
	<VirtualHost *>
		ServerName domainB
		DocumentRoot /domainB/doc/root
	</VirtualHost>
	<VirtualHost *>
		ServerName domainC
		DocumentRoot /domainC/doc/root
	</VirtualHost>
	<VirtualHost _default_:443>
		ServerName domainA
		DocumentRoot /ssl-domainA/doc/root
		SSLEngine on
	</VirtualHost>

The trouble is:
When I connect a non-SSL domainC(http://domainC/) , I get a pop-up warning
which says certificate is self generated, and I can't see any secret
icon on the brouser when I accept or not. And more confusing, any
another non-SSL domains(A and B) don't! A both-domain(domainA) goes good
non-ssl and ssl.

I walked around some archives and googles but could not find any answers.
Anybody met this problem? 
I would really appreciate any help or suggestion.

Thanks,
Takeshi

[email-masked]

______________________________________________________________________
Apache Interface to OpenSSL (mod_ssl)                   www.modssl.org
User Support Mailing List                      [email-masked]
Automated List Manager                            [email-masked]

---

From: "Takeshi Kuriyama" <[email-masked]>
Date: Tue, 28 Oct 2003 19:35:36 +0900

Everything is settled.
A reason is that a tiny Javascript in domainC index.html goes to a SSl
host every time accessed.

Thanks,
Takeshi

[email-masked]

---

From: Peter Brown <[email-masked]>
Date: Wed, 29 Oct 2003 16:57:51 +1100

Takeshi,

Can you share with us how you stopped the warning message - presumably in IE?

Peter'

---

From: "Takeshi Kuriyama" <[email-masked]>
Date: Wed, 29 Oct 2003 19:00:19 +0900

Hi,

That's all my mistake.
I've gorgotten that an index.html in non-ssl contains a javascript that
accesses to an ssl-url for counting access log. I gave up ssl communication.
All I do is changing a logging tool into non-ssl  'cause luckily a
logging tool is running also on server.
So, IE or Opera isn't the matter. Neither mod_ssl nor apache
configuration. Sorry I easily posted into ML.

Thanks,
Takeshi

[email-masked]