Subject: Can I get SSL_CLIENT_S_DN_CN within Rewrite Module?

From: "Harry Yu" <[email-masked]>
Date: Wed, 13 Nov 2002 20:36:11 -0500

Dear expert:

We are trying to get the SSL_CLIENT_S_DN_CN from client certificate
and put it into request as a quary string by using RewriteRule, but we could
not
rewrite it and always get empty quary string. The config is as following:

SSLOptions +StdEnvVars

RewriteEngine On
RewriteOptions inherit
RewriteLog logs/rewrite.log
RewriteLogLevel 9
#RewriteRule ^/esdi/pat$ /esdi/pat?SSL_CLIENT_S_DN_CN=%{SSL_CLIENT_S_DN_CN}
#RewriteCond %{HTTP_USER_AGENT} ^Mozilla.*
#RewriteCond %{ENV:SSL_CLIENT_S_DN_CN} ^(.*)$
RewriteCond %{ENV:SSL_CLIENT_S_DN_CN} (.*)
RewriteRule ^/esdi/pat$ - [E=ID:%1,C]
RewriteRule ^/esdi/pat$ /esdi/pat?pat-id=%{ENV:ID} [L]

Can I get environment varable like SSL_CLIENT_XXX within Rewrite Module, I
have no problem
to get %{SERVER_NAME} and rewrite it into quary string.

Is it correct? Hope to get your help soon. Thanks in advance!

Harry Yu

______________________________________________________________________
Apache Interface to OpenSSL (mod_ssl)                   www.modssl.org
User Support Mailing List                      [email-masked]
Automated List Manager                            [email-masked]

---

From: "Harry Yu" <[email-masked]>
Date: Mon, 18 Nov 2002 14:11:10 -0500

I never got any response since I sent this to you last week. Could you pls
send response at [email-masked]

Thanks a lot and best regards.

Harry Yu
----- Original Message -----
From: "Harry Yu" <[email-masked]>
To: <[email-masked]>
Sent: Wednesday, November 13, 2002 8:36 PM
Subject: Can I get SSL_CLIENT_S_DN_CN within Rewrite Module?

> #RewriteRule ^/esdi/pat$
/esdi/pat?SSL_CLIENT_S_DN_CN=%{SSL_CLIENT_S_DN_CN}