Subject: Apache 1.3.9 make fails with mod_ssl 2.4.10 and openssl 0.9.5a

From: hiren mehta <[email-masked]>
Date: Tue, 17 Sep 2002 02:24:35 -0700 (PDT)

Hi,

                      I am getting the error as below
when making apache .I am using Apache 1.3.9+mod_ssl
2.4.10 with openssl 0.9.5 .I also tried with openssl
0.9.5a without success .

                               Error below appears
when making apache

---------------------------------------------------------------
                               ssl_util_ssl.c:145:
conflicting types for
                      `d2i_PrivateKey_bio'

/usrhome/ryoussef/openssl-0.9.5a/include/openssl/x509.h:696:
                      previous declaration of
`d2i_PrivateKey_bio'
                               *** Error code 1
                               make: Fatal error:
Command failed for target
                      `ssl_util_ssl.lo'
                               Current working
directory
                     
/usrhome/ryoussef/apache_1.3.9/src/modules/ssl
                               *** Error code 1
                               make: Fatal error:
Command failed for target
                      `all'
                               Current working
directory
                     
/usrhome/ryoussef/apache_1.3.9/src/modules
                               *** Error code 1
                               make: Fatal error:
Command failed for target
                      `subdirs'
                               Current working
directory
                     
/usrhome/ryoussef/apache_1.3.9/src
                               *** Error code 1
                               make: Fatal error:
Command failed for target
                      `build-std'
                               Current working
directory
                      /usrhome/ryoussef/apache_1.3.9
                               *** Error code 1
                               make: Fatal error:
Command failed for target
                      `build'

Any help how to resolve this is appreciated.

                      Thanks in advance.

                      Regards,
                      Hiren

__________________________________________________
Do you Yahoo!?
Yahoo! News - Today's headlines
http://news.yahoo.com
______________________________________________________________________
Apache Interface to OpenSSL (mod_ssl)                   www.modssl.org
User Support Mailing List                      [email-masked]
Automated List Manager                            [email-masked]

---

From: Mads Toftum <[email-masked]>
Date: Tue, 17 Sep 2002 12:23:37 +0200

> 2.4.10 with openssl 0.9.5 .I also tried with openssl
IIRC you would need an even older version of openssl for this to work -
something in the early 0.9.4 series. But you should not do that, as there
are well known exploits for all of these. You really should be using
openssl-0.9.6g, apache-1.3.26 and mod_ssl-2.8.10.

vh

Mads Toftum
-- 
`Darn it, who spiked my coffee with water?!' - lwall