Subject: Re: private key not found

From: "camun2020" <[email-masked]>
Date: Mon, 10 Mar 2003 05:42:38 -0500 (EST)

>1 out of 1 certificate requests certified, commit? [y/n]y
>Write out database with 1 new entries
>ata Base Updated
>CA verifying: server.crt <-> CA cert
>server.crt: /C=US/ST=Kansas/L=Lawrence/O=Pelathe 
>Center/CN=www.pelathe.org/Email=[email-masked]
>error 18 at 0 depth lookup:self signed certificate
>/C=US/ST=Kansas/L=Lawrence/O=Pelathe 
>Center/CN=www.pelathe.org/Email=[email-masked]
>error 7 at 0 depth lookup:certificate signature failure
>
>What is an 'error 18 at depth 0' and an 'error 7 at depth 0'? Would >this be a 
>reason why my server cannot find the Private Key?

I've no idea what this error means but I've seen it several times but never seen an explanation on the list. I would strongly recommend that you use the alternative certificate scripts available as ssl.ca-0.1.tar.gz at:

http://www.openssl.org/contrib/

These have fixed this problem for me numerous times.

_______________________________________________
No banners. No pop-ups. No kidding.
Introducing My Way - http://www.myway.com
______________________________________________________________________
Apache Interface to OpenSSL (mod_ssl)                   www.modssl.org
User Support Mailing List                      [email-masked]
Automated List Manager                            [email-masked]

---

From: "A. Putnam" <[email-masked]>
Date: Thu, 13 Mar 2003 14:09:52 -0600

Still no luck. I get the same error with this script too. Thank you for 
pointing out the script though. It was a LOT easier to use than the other one 
I had been using. 

On Monday 10 March 2003 04:42, camun2020 wrote:
> >What is an 'error 18 at depth 0' and an 'error 7 at depth 0'? Would >this
> > be a reason why my server cannot find the Private Key?
>
> I've no idea what this error means but I've seen it several times but never
> seen an explanation on the list. I would strongly recommend that you use
> the alternative certificate scripts available as ssl.ca-0.1.tar.gz at:
>

-- 
A. Putnam
Assistant IT Administrator
Pelathe Community Resource Center