Subject: how to nest SSLRequire

From: Hendrik Robbel <[email-masked]>
Date: Wed, 20 Aug 2003 10:56:11 +0200

Hi,

I tried to nest two <directory> with SSLRequire entries:

<Directory /htdocs-ssl/user/>
SSLRequire (    %{SSL_CIPHER} !~ m/^(EXP|NULL)-/ \
             and %{SSL_CLIENT_S_DN_O} eq "user" )
</Directory>

<Directory /htdocs-ssl/>
SSLRequire (    %{SSL_CIPHER} !~ m/^(EXP|NULL)-/ \
             and %{SSL_CLIENT_S_DN_O} eq "Global" )
</Directory>

But I got a 403 when I tried to access the /htdocs-ssl/user/ with a certificate, which
have the organisation entry "user".

It's the same with <Location>, <LocationMatch> ...

any ideas ?

Thanks in advance
Hendrik

______________________________________________________________________
Apache Interface to OpenSSL (mod_ssl)                   www.modssl.org
User Support Mailing List                      [email-masked]
Automated List Manager                            [email-masked]

---

From: Mads Toftum <[email-masked]>
Date: Wed, 20 Aug 2003 11:02:11 +0200

> have the organisation entry "user".
Why not just use REQUEST_URI as part of your SSLRequire statement
instead of wrapping it in <Directory? 

vh

Mads Toftum
-- 
`Darn it, who spiked my coffee with water?!' - lwall

---

From: Hendrik Robbel <[email-masked]>
Date: Thu, 21 Aug 2003 12:36:03 +0200

> instead of wrapping it in <Directory? 

It works, thank you!

+Hendrik