Subject: authentication

From: "Lionel Gauliardon" <[email-masked]>
Date: Thu, 14 Mar 2002 10:10:08 +0100

Hello,

I currently work with apache 1.3.12, i want authenticate user (login/password) from server ldap, today (in my config) login and password are cleartext so i want to "crypt" there.
Should I use mod_ssl to do this or mod_auth_ldap (which also support ssh) ? 

Thanks for your advice.

Regards, Lionel.

---

From: "Joe Pearson" <[email-masked]>
Date: Thu, 14 Mar 2002 05:08:31 -0700

If you want to encrypt the login and password, you would use SSL.  I've never tried mod_auth_ldap, but I assume it would do nothing about encrypting the login and password between the browser and the server.   If mod_auth_ldap supports ssh, it is to encrypt the transmission between Apache and the ldap server.  You would only need mod_auth_ldap + SSH if the LDAP server was connected across an insecure link.

Joe Pearson

----- Original Message ----- 
  From: Lionel Gauliardon 
  To: [email-masked] 
  Sent: Thursday, March 14, 2002 2:10 AM
  Subject: authentication

  Hello,

  Thanks for your advice.

  Regards, Lionel.