Subject: Apache not spawning MinSpareServers 16

From: "Theodore Jencks" <[email-masked]>
Date: Sat, 20 Mar 2004 17:02:14 -0800

I'm having an interesting problem with Apache after compiling and installing
the latest mod_ssl DSO: libssl.so in my apache server.

I am using the following enviorment:
OS:		RedHat Linux 8
Platform:	x86 (athlon processor)
Openssl:	0.9.7d (compiled and installed w/ clean sources)
Apache:	1.3.29 (compiled and installed w/ clean sources)
Mod_ssl:	2.8.16-1.3.29 (compiled and installed w/ clean sources)

The problem occurs when I start Apache with SSL enabled it seems to ignore
the "MinSpareServers 16" directive and only starts up one process.  Once I
access one of the sites that my Apache server handles it spawns another
child process but still does not spawn 16 child processes like I'd like.
I'm not quite sure what's going on and I haven't found a mention of this
issue on the mailing lists thus far; though perhaps I wasn't using the right
key words to search with:-)  Thanks in advance to any help u'all might
provide.

Another interesting point is that this only happens when I start apache with
httpd -DSSL. Otherwise even if I start the apache server normally and
explicitly LoadModule libssl.so apache starts up the correct amount of
servers.

Best regards,
Theo

I start Apache by calling "/etc/init.d/httpd start":

#Options passed to httpd at start
#All this does is pass httpd -DSSL to start Apache with SSL
if [ -f /etc/sysconfig/httpd ]; then
        . /etc/sysconfig/httpd
fi

start() {
        echo -n $"Starting $prog: "
        daemon $httpd $OPTIONS
        RETVAL=$?
        echo
        [ $RETVAL = 0 ] && touch /var/lock/subsys/httpd
        return $RETVAL
}

Top part of httpd.conf looks like this:

ServerType standalone
ServerRoot "/inet/www/apache"
PidFile /var/run/httpd/httpd.pid
ScoreBoardFile /var/log/apache/httpd.scoreboard
ResourceConfig /dev/null
AccessConfig /dev/null
Timeout 300
KeepAlive On
MaxKeepAliveRequests 100
KeepAliveTimeout 15
MinSpareServers 16
MaxSpareServers 32
StartServers 64
MaxClients 256
MaxRequestsPerChild 0
Listen *:80
<IfDefine SSL>
Listen *:443
</IfDefine>

SSL Global Context in httpd.conf looks like this:

<IfModule mod_ssl.c>
AddType application/x-x509-ca-cert .crt
AddType application/x-pkcs7-crl    .crl

SSLPassPhraseDialog  builtin
SSLSessionCache none
SSLSessionCacheTimeout  300
SSLMutex sem
SSLRandomSeed startup file:/dev/urandom 1024
SSLRandomSeed connect file:/dev/urandom 1024
SSLLog /var/log/httpd/ssl_engine.log
SSLLogLevel info

______________________________________________________________________
Apache Interface to OpenSSL (mod_ssl)                   www.modssl.org
User Support Mailing List                      [email-masked]
Automated List Manager                            [email-masked]

---

From: "Theodore Jencks" <[email-masked]>
Date: Sat, 20 Mar 2004 18:49:17 -0800

Best regards,
Theo

start() {

ServerType standalone

<IfModule mod_ssl.c>