Subject: RE: RE: apache 1.3.24 + mod_ssl 2.8.8 for Windows (2000)

From: Jay Burgess <[email-masked]>
Date: Wed, 03 Apr 2002 09:31:46 -0600

At least on Windows NT, the .so file can not be read-only, or you get a 
similar error.

Is it possible that your file is read-only?

Jay

 > -----Original Message-----
 > From: Danalien [mailto:[email-masked]]
 > Sent: Wednesday, April 03, 2002 9:18 AM
 > To: [email-masked]
 > Subject: RE: RE: apache 1.3.24 + mod_ssl 2.8.8 for Windows (2000)
 >
 >
 > -----BEGIN PGP SIGNED MESSAGE-----
 > Hash: SHA1
 >
 >
 > Japp, allready put it here.
 >
 >
 >
 >
 > >Can you go to c:/program files/apache_ssl/modules and see
 > the mod_ssl.so
 > >file?
 > >
 > >Your second test seems logical since the module wasn't loaded in the
 > >LoadModule section.
 > >
 > >Eric
 > >
 > >-----Original Message-----
 > >From: Danalien [mailto:[email-masked]]
 > >Sent: Wednesday, April 03, 2002 8:52 AM
 > >To: [email-masked]
 > >Subject: apache 1.3.24 + mod_ssl 2.8.8 for Windows (2000)
 > >
 > >
 > >Hi,
 > >
 > >I need some help, i patch, complie, and everything according to:
 > >
 > http://www.modssl.org/source/exp/mod_ssl/pkg.mod_ssl/INSTALL.Win32
 > >
 > >all goes fine fine, only get a few warnings (during the
 > apache complie)
 > >
 > >I then go to the httpd.conf  (%my_apache_ssl_root%/conf)
 > >
 > >and put this in:
 > >
 > >LoadModule ssl_module modules/mod_ssl.so
 > >
 > >
 > >and I get (this) when i do apache -t :
 > >
 > >C:\Program Files\Apache_SSL>apache -t
 > >Syntax error on line 62 of c:/program
 > files/apache_ssl/conf/httpd.conf:
 > >Cannot load c:/program files/apache_ssl/modules/mod_ssl.so
 > into server:
 > >(182)
 > >Note the errors or messages above, and press the <ESC> key
 > to exit.  26...
 > >C:\Program Files\Apache_SSL>
 > >
 > >*thinking* *thinking*...
 > >
 > >... then I just do a little test.
 > >
 > >remove the previos loadModule by puting a # infront (lite this):
 > >
 > >#LoadModule ssl_module modules/mod_ssl.so
 > >
 > >
 > >and add:
 > >
 > >AddModule mod_ssl.c
 > >
 > >
 > >and get :
 > >
 > >C:\Program Files\Apache_SSL>apache -t
 > >Syntax error on line 110 of c:/program
 > files/apache_ssl/conf/httpd.conf:
 > >Cannot add module via name 'mod_ssl.c': not in list of loaded modules
 > >Note the errors or messages above, and press the <ESC> key
 > to exit.  23...
 > >C:\Program Files\Apache_SSL>
 > >
 > >
 > >and do a apache -l
 > >where I get this:
 > >
 > >Compiled-in modules:
 > >  http_core.c
 > >  mod_so.c
 > >  mod_mime.c
 > >  mod_access.c
 > >  mod_auth.c
 > >  mod_negotiation.c
 > >  mod_include.c
 > >  mod_autoindex.c
 > >  mod_dir.c
 > >  mod_cgi.c
 > >  mod_userdir.c
 > >  mod_alias.c
 > >  mod_env.c
 > >  mod_log_config.c
 > >  mod_asis.c
 > >  mod_imap.c
 > >  mod_actions.c
 > >  mod_setenvif.c
 > >  mod_isapi.c
 > >
 > >
 > >and my suspicions were correct, "where are/is the SSL -
 > module(s)?" cause it
 > >ain't in
 > >the compiled apache :)
 > >
 > >If some could explain/help me how to meld this SSL module
 > into apache, it
 > >would be great :)
 > >thanks.
 > >
 > >
 > >
 > >
 > >
 > >
 > >//   with regards
 > >//   ID ::  danalien  ::  <[email-masked]>
 > >
 > >PGP Public Key Fingerprint: C891 D3A1 427A A5E7  449F B19E 1E85 A109
 > >
 > >
 > >_____________________________________________________________
 > _________
 > >Apache Interface to OpenSSL (mod_ssl)
www.modssl.org
 >User Support Mailing List                      [email-masked]
 >Automated List Manager                            [email-masked]
 >
 >______________________________________________________________________
 >Apache Interface to OpenSSL (mod_ssl)                   www.modssl.org
 >User Support Mailing List                      [email-masked]
 >Automated List Manager                            [email-masked]

//   with regards
//   ID ::  danalien  ::  <[email-masked]>

PGP Public Key Fingerprint: C891 D3A1 427A A5E7  449F B19E 1E85 A109

-----BEGIN PGP SIGNATURE-----
Version: PGPsdk version 1.7.1 (C) 1997-1999 Network Associates, Inc. and 
its affiliated companies.

iQA/AwUBPKsO/x6FoQlEaqKIEQIOiACdFE57iQebkBg6r1wIbjJf4TOWDYIAoKwY
o1SRuk++dFNMuY/7MNbsgYT5
=Z7o4
-----END PGP SIGNATURE-----

______________________________________________________________________
Apache Interface to OpenSSL (mod_ssl)                   www.modssl.org
User Support Mailing List                      [email-masked]
Automated List Manager                            [email-masked]

---

From: "Danalien" <[email-masked]>
Date: Wed, 03 Apr 2002 22:36:26 +0200

nope, I have no attributes on it/them.

//   with regards