Subject: Apache + mod_ssl bug?

From: pr0ject <[email-masked]>
Date: Thu, 17 Jan 2002 17:31:36 -0600

I recently installed Apache 1.3.22 + mod_ssl to give my users
SSL capabilities...

Unfortunately by doing so, it broke the /~user web space.

I went back, reconfigured like it should be (uncommented the basic Directory
container for the public_html options..)

Restarted apachessl with no errors. Yet, when viewing the userspace, I get
a forbidden error.

The logs tell me the following:

[Thu Jan 17 17:37:23 2002] [error] [client] Symbolic link not allowed: /home/

The ONLY fix I have found for this so far (have been testing variations of the
conf file all day!!) has been to allow the top level directory <Directory />
to have the Options FollowSymLinks.

My platform is FreeBSD 4.4-Release with Apache+mod_ssl+php... since FreeBSD
symlinks /usr/home to /home, I assume this is where the problems begin.

FYI: I have explicitly assigned the user directory container to /usr/home/*/
public_html with the same error occuring.

Is this an Apache issue? Or maybe an SSL/Apache issue?

Anyone ever have this problem? I'm at a loss at this point....
______________________________________________________________________
Apache Interface to OpenSSL (mod_ssl)                   www.modssl.org
User Support Mailing List                      [email-masked]
Automated List Manager                            [email-masked]

---

From: Glen Mehn <[email-masked]>
Date: Fri, 18 Jan 2002 10:46:14 -0800

when you recompiled apache, did you get mod_userdir installed?

to httpd -l, and you should see something like:

# ./httpd -l
Compiled-in modules:
  http_core.c
  mod_env.c
  mod_log_config.c
  mod_mime.c
  mod_negotiation.c
  mod_status.c
  mod_include.c
  mod_autoindex.c
  mod_dir.c
  mod_cgi.c
  mod_asis.c
  mod_imap.c
  mod_actions.c
  mod_userdir.c
  mod_alias.c
  mod_access.c
  mod_auth.c
  mod_setenvif.c

if it's compiled as DSO, you should know what to do.

Also, check your config-- http://httpd.apache.org/docs/mod/mod_userdir.html

-g

-- 
Glen S Mehn
Lead Systems Administrator		SquareTrade, Inc
[email-masked]	Building Trust in Transactions (sm)
______________________________________________________________________
Apache Interface to OpenSSL (mod_ssl)                   www.modssl.org
User Support Mailing List                      [email-masked]
Automated List Manager                            [email-masked]

---

From: pr0ject <[email-masked]>
Date: Fri, 18 Jan 2002 14:39:53 -0600

yeah... the mod_userdir.so is compiled in.

LoadModule userdir_module     libexec/apache/mod_userdir.so

AddModule mod_userdir.c

Anything else?

Today [email-masked] spoke in tongue:
** when you recompiled apache, did you get mod_userdir installed?
** 
** to httpd -l, and you should see something like:
** 
** # ./httpd -l
** Compiled-in modules:
**   http_core.c
**   mod_env.c
**   mod_log_config.c
**   mod_mime.c
**   mod_negotiation.c
**   mod_status.c
**   mod_include.c
**   mod_autoindex.c
**   mod_dir.c
**   mod_cgi.c
**   mod_asis.c
**   mod_imap.c
**   mod_actions.c
**   mod_userdir.c
**   mod_alias.c
**   mod_access.c
**   mod_auth.c
**   mod_setenvif.c
** 
** 
** 
** if it's compiled as DSO, you should know what to do.
** 
** Also, check your config-- http://httpd.apache.org/docs/mod/mod_userdir.html
** 
** -g
** 
** On Thu, Jan 17, 2002 at 05:31:36PM -0600, pr0ject wrote:
** > I recently installed Apache 1.3.22 + mod_ssl to give my users
** > SSL capabilities...
** > 
** > Unfortunately by doing so, it broke the /~user web space.
** > 
** > I went back, reconfigured like it should be (uncommented the basic Directory
** > container for the public_html options..)
** > 
** > Restarted apachessl with no errors. Yet, when viewing the userspace, I get
** > a forbidden error.
** > 
** > The logs tell me the following:
** > 
** > [Thu Jan 17 17:37:23 2002] [error] [client] Symbolic link not allowed: /home/
** > 
** > The ONLY fix I have found for this so far (have been testing variations of the
** > conf file all day!!) has been to allow the top level directory <Directory />
** > to have the Options FollowSymLinks.
** > 
** > My platform is FreeBSD 4.4-Release with Apache+mod_ssl+php... since FreeBSD
** > symlinks /usr/home to /home, I assume this is where the problems begin.
** > 
** > FYI: I have explicitly assigned the user directory container to /usr/home/*/
** > public_html with the same error occuring.
** > 
** > Is this an Apache issue? Or maybe an SSL/Apache issue?
** > 
** > Anyone ever have this problem? I'm at a loss at this point....
** > ______________________________________________________________________
** > Apache Interface to OpenSSL (mod_ssl)                   www.modssl.org
** > User Support Mailing List                      [email-masked]
** > Automated List Manager                            [email-masked]
** 
** -- 
** Glen S Mehn
** Lead Systems Administrator		SquareTrade, Inc
** [email-masked]	Building Trust in Transactions (sm)
** ______________________________________________________________________
** Apache Interface to OpenSSL (mod_ssl)                   www.modssl.org
** User Support Mailing List                      [email-masked]
** Automated List Manager                            [email-masked]
______________________________________________________________________
Apache Interface to OpenSSL (mod_ssl)                   www.modssl.org
User Support Mailing List                      [email-masked]
Automated List Manager                            [email-masked]