Subject: I need help please!

From: "MARTIN Pierre" <[email-masked]>
Date: Fri, 1 Mar 2002 08:48:31 +0100

Hi, im using an apache server with mod_ssl.  (the last one, newest one version...)
I get the error

724:error:140770FC:SSL routines:SSL23_GET_SERVER_HELLO:unknown protocol:D:\MyPro
jects\Applications\opensa\openssl\ssl\s23_clnt.c:460:

When i'm trying to connect. I can only read this with the openssl s_client mode, because the broser just search forever when i type the secured domain name.

Notice that the number of the error is sometimes 724, sometimes 982, sometimes 972,...

I red about my config was pointing to a wrong port and i may had "Listen 80" instead of "Port 80". That is all i found about this error, and it was already done in my config.

Thanks a lot,
Regards, MARTIN Pierre

PS: Sorry for my bad english...

http://hickscorp.dyndns.org
http://3dMeeting.dyndns.org
http://Iloa.dyndns.org
http://StatsAGogo.dyndns.org
http://www.Lv4-26.com

MSN: [email-masked]
ICQ: 73133239

---

From: Owen Boyle <[email-masked]>
Date: Fri, 01 Mar 2002 12:14:54 +0100

> MARTIN Pierre wrote:
> When i'm trying to connect. I can only read this with the openssl
> s_client mode, because the broser just search forever when i type the
> secured domain name.
> 
> I red about my config was pointing to a wrong port and i may had
> "Listen 80" instead of "Port 80". That is all i found about this
> error, and it was already done in my config.

You're trying to connect to an SSL-aware server with plain HTTP.

Do you want an SSL server? If so, you must set up a VH on port 443 then
access it using "https://servername/"  <-- NB "https", *not* "http".

rgds,

Owen Boyle.
______________________________________________________________________
Apache Interface to OpenSSL (mod_ssl)                   www.modssl.org
User Support Mailing List                      [email-masked]
Automated List Manager                            [email-masked]