Subject: ssl no response

From: Aodhan H <[email-masked]>
Date: Tue, 29 Jan 2002 12:36:38 -0800 (PST)

Hello, I am trying to get an ssl virtual site running. The http site
works fine, but bringing up the https site gives me 'Could not reach
remote server' error.
 I can find no log of the event, and no error code comes up.
 I used apachectl to check the syntax, and I get no errors. Looking around
the web I have seen a variety of different configuration options, but none
of them get me very far.
 Here is the virtual host directive I have, if people could point out what
is wrong with it, I would appreciate it.

 <VirtualHost x.x.x.x:443 >
     ServerAdmin [email-masked]
     DocumentRoot /www/domain.net/ssl
     ServerName server.domain.net
     ErrorLog logs/443error_log
     CustomLog logs/443access_log common
     ScriptAlias /cgi-bin/ "/usr/local/apache/cgi-bin/"
     Group users
 <Directory /www/domain.net/ssl>
    AuthName "ssl"
    AuthType Basic
    AuthUserFile auth/.htpasswd
    Require user aodhan
    SSLVerifyClient require
    SSLVerifyDepth 1
    SSLRequireSSLA
 </Directory>

 </VirtualHost>

-- 

   =-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=

        Aodhan H.

        -   -   -   -   -   -   -   -   -   -   -   -   -   -   -   -
                   Ad Astra per Aspera
                          A Rough Road Leads To The Stars
        -   -   -   -   -   -   -   -   -   -   -   -   -   -   -   -

         Freedom is something you have, not something you're given.

   =-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=

______________________________________________________________________
Apache Interface to OpenSSL (mod_ssl)                   www.modssl.org
User Support Mailing List                      [email-masked]
Automated List Manager                            [email-masked]

---

From: "Julian C. Dunn" <[email-masked]>
Date: Tue, 29 Jan 2002 19:14:25 -0500 (EST)

> works fine, but bringing up the https site gives me 'Could not reach

Do you have

Listen 443

or even

Listen x.x.x.x:443

somewhere in your server config? That is a common cause of "port 80
responding but port 443 not" problems.

- Julian

--
Julian C. Dunn, B.A.Sc <[email-masked]>
Senior Software Developer, VerticalScope Inc.
Tel.: (416) 341-8950 x236  Fax: (416) 341-8959
WWW: www.verticalscope.com

"Windows NT encountered the following error:
The operation was completed successfully."

---

From: Glen Mehn <[email-masked]>
Date: Tue, 29 Jan 2002 16:00:43 -0800

I don't see 

SSLEngine On

in your VirtualHost section. 

-- 
Glen S Mehn
Lead Systems Administrator		SquareTrade, Inc
[email-masked]	Building Trust in Transactions (sm)
______________________________________________________________________
Apache Interface to OpenSSL (mod_ssl)                   www.modssl.org
User Support Mailing List                      [email-masked]
Automated List Manager                            [email-masked]