Subject: RE: Apache 2.0.44 with Openssl -0.9.7

From: "Yu, Ming" <[email-masked]>
Date: Fri, 7 Mar 2003 10:57:07 -0500

I use the following switches to compile APACHE 2.0.44 with OpenSSL 0.9.7
./configure --enable-layout=TEST \
		--enable-ssl \
		--with-ssl=/usr/local/ssl \
		--enable-mods-shared=max \
		--enable-modules=most \
		--with-mpm=worker

It went through the installation process. 

Thanks 

- Ming Yu

-----Original Message-----
From: Ted Rolle [mailto:[email-masked]] 
Sent: Friday, March 07, 2003 10:36 AM
To: [email-masked]
Subject: Re: Apache 2.0.44 with Openssl -0.9.7

YOU GOT Apache-2.0.44 and OpenSSL-0.9.7 WORKING???
What are your ./configure files like?  I keep getting the dreaded "can't
find X509_free" message.

On Fri, 7 Mar 2003, Ian Miller wrote:

>
> Did you uncomment out the entropy lines in the ssl.conf file? I am 
> running it with 0.9.7a and it works fine -Ian
> Quoting "Yu, Ming" <[email-masked]>:
>
> > Does anyone have problem with apache 2.0.44 and Openssl 0.9.7. I 
> > installed the server, no problem.  Then I wanted to start the httpd 
> > server, even without mod_ssl.
> >
> > ./apachectl -k start
> >
> > There is no message on the screen, but an error message in the log 
> > file. The apache engine did not start.
> >
> > [warn] Init: PRNG still contains insufficient entropy! [error] Init: 
> > Failed to generate temporary 512 bit RSA private key Configuration 
> > Failed
> >
> > Any suggestions.
> >
> > - Ming Yu 
> > ______________________________________________________________________
> > Apache Interface to OpenSSL (mod_ssl)                   www.modssl.org
> > User Support Mailing List                      [email-masked]
> > Automated List Manager                            [email-masked]
> >
>
>
> --
> Ian Miller
> Sr. Systems Engineer
> University of Chicago
> [email-masked] 
> ______________________________________________________________________
> Apache Interface to OpenSSL (mod_ssl)                   www.modssl.org
> User Support Mailing List                      [email-masked]
> Automated List Manager                            [email-masked]
>
______________________________________________________________________
Apache Interface to OpenSSL (mod_ssl)                   www.modssl.org
User Support Mailing List                      [email-masked]
Automated List Manager                            [email-masked]
______________________________________________________________________
Apache Interface to OpenSSL (mod_ssl)                   www.modssl.org
User Support Mailing List                      [email-masked]
Automated List Manager                            [email-masked]

---

From: "apachep2" <[email-masked]>
Date: Fri, 7 Mar 2003 11:19:09 -0500

Of course. When you build mod_ssl into apache (that is STATIC), you
won't encounter X509_free issue.

-----Original Message-----
From: [email-masked]
[mailto:[email-masked]] On Behalf Of Yu, Ming
Sent: March 7, 2003 10:57 AM
To: [email-masked]'
Subject: RE: Apache 2.0.44 with Openssl -0.9.7

Thanks 

- Ming Yu

---

From: Ian Miller <[email-masked]>
Date: Fri, 7 Mar 2003 10:24:46 -0600

I just run config with ./configure
                       --enable-ssl 
                       --with-ssl=/usr/local/ssl 
                       --enable-so 
                       --enable-rewrite
                       --enable-speling
solairs 9 & 8 systems 
gcc 3.2.2 
gnu binutils 2.13.2.1

I think I had a problem once ... 
I just recompiled ssl and ran the make check or make test 
everything worked then

---

From: Ted Rolle <[email-masked]>
Date: Fri, 7 Mar 2003 19:46:35 -0600 (CST)

Good.  Now what is the configuration file for OpenSSL?

On Fri, 7 Mar 2003, Yu, Ming wrote:

> ../configure --enable-layout=TEST \
> 		--enable-ssl \

---

From: Ted Rolle <[email-masked]>
Date: Fri, 7 Mar 2003 19:47:57 -0600 (CST)

Yes, this is true. But DSO should work too.