Subject: RE: csr password

From: "Price, Gary" <[email-masked]>
Date: Wed, 27 Feb 2002 13:55:05 -0600

Use the SSLPassPhraseDialog option. For example in httpd.conf put the
following.
 
SSLPassPhraseDialog exec:/path to script/script_name
 
The script should look like this, all it needs to do is echo the password
back.
_________________________________________
#!/bin/ksh
# A few comments
echo Your_Password
_________________________________________

-----Original Message-----
From: Henning Sittler [mailto:[email-masked]]
Sent: Wednesday, February 27, 2002 1:35 PM
To: [email-masked]'
Subject: csr password

I setup a secure server with a password on the csr that must be entered when
apache starts up.  How can I remove this password so that apache can start
without asking for it?

Do I need to generate a new key pair?  If I do, will that invalidate my
current issued certificate? 

Thanks, 

Henning Sittler 
www.inscriber.com

---

From: Henning Sittler <[email-masked]>
Date: Wed, 27 Feb 2002 15:14:28 -0500

Ok, I found the HOWTO (from a link in the mail list archives):
http://www.modssl.org/docs/2.3/ssl_faq.html#ToC25

But when I try this, I get:
read RSA key
Enter PEM pass phrase:
unable to load key
29484:error:06065064:digital envelope routines:EVP_DecryptFinal:bad
decrypt:evp_enc.c:277:
29484:error:0906A065:PEM routines:PEM_do_header:bad decrypt:pem_lib.c:451:

curious.

Henning Sittler
www.inscriber.com

-----Original Message-----
From: Henning Sittler 
Sent: Wednesday, February 27, 2002 2:35 PM
To: [email-masked]'
Subject: csr password

Thanks,

Henning Sittler
www.inscriber.com