Subject: Re: 2.0.36 + mod-ssl + Win2k = Easy Money

From: "Phil Smiley" <[email-masked]>
Date: Tue, 11 Jun 2002 00:05:52 -0500

I've successfully compiled Apacche 2.0.36 and openssl as this thread describes.  I'm encountering problems building modssl though.  When I try to use NMAKE /f "mod_ssl.mak" CFG="mod_ssl - Win32 Release", i get the following:
        link.exe @C:\DOCUME~1\ADMINI~1.000\LOCALS~1\Temp\nma02752.   Creating library .\Release\libapr.lib and object .\Release\libapr.exp        cd "..\..\modules\ssl"        tempfile.batThe system cannot find the file specified.Could Not Find C:\httpd-2.0.36\modules\ssl\y.tab.cThe system cannot find the file specified.Could Not Find C:\httpd-2.0.36\modules\ssl\y.tab.hNMAKE : fatal error U1077: 'tempfile.bat' : return code '0x1'Stop.
I didn't find these files anywhere in the apache or openssl directories.

When I used VC++, I get:
Linking...   Creating library Debug/mod_ssl.lib and object Debug/mod_ssl.expssl_expr_scan.obj : error LNK2001: unresolved external symbol _ap_pstrdupDebug/mod_ssl.so : fatal error LNK1120: 1 unresolved externalsError executing link.exe.
mod_ssl.so - 2 error(s), 0 warning(s)
I'm sure its something obvious that I've overlooked.  Does anyone have any suggestions?

Thanks; Phil

Thanks everyone, we now have everything working fine.

A quick howto for beginners (who perhaps experience what we have
experienced):

If you want win2k + mod-ssl, don't trust the apache HOWTO at
http://httpd.apache.org/docs-2.0/platform/win_compiling.html, they may
be fine for those who don't need ssl (and those people can simply use
the supplied binaries) but they are wrong if you need ssl.

Firstly, don't use the perl examples given on apache.org to prepare and
compile openssl, use the instructions in INSTALL.W32 that comes with the
openSSL source.

We eventually found that with visual C++ 6 we could compile apache
without ssl fine. Later we compiled mod-ssl alone (also in VC++) and
moved the mod-ssl.so binary to the modules folder in the apache
installation.

And that's it, except you need to know how to start Apache in "ssl
mode".

from the console in the apache\bin use

>apache -D SSL

to install apache to run as a service with SSL

>apache -i -D SSL

Hope this helps someone out there, and thanks to everyone who helped us!

John.

----- Original Message -----
From: "Mark Chew" <[email-masked]>
To: <[email-masked]>
Sent: Monday, June 10, 2002 7:11 PM
Subject: Re: 2.0.36 + mod-ssl + Win2k = Easy Money

: Assuming the win2k service for Apache is created
: (else create one using sc command),
: try configure the Apache service properties like this :
:
: Path to executable:
: "C:\Program Files\Apache Group\Apache\Apache.exe" --ntservice
:
: Startup type:
: Automatic
:
:
:
: Regards,
: Mark
:
:
: >From: "John" <[email-masked]>
: >Reply-To: [email-masked]
: >To: <[email-masked]>
: >Subject: Re: 2.0.36 + mod-ssl + Win2k = Easy Money
: >Date: Mon, 10 Jun 2002 17:20:20 +1200
: >
: >We have discovered that if we start Apache from the console with
: > >apache -D SSL on our windows server, then we have ssl support...
: >Please, someone, how do we get ssl support running as a service?
: >
: >It seems we have wasted a couple of days, simply to find this out!
: >
: >John.
: >
: >
: >
: >
:
>______________________________________________________________________
: >Apache Interface to OpenSSL (mod_ssl)
www.modssl.org
: >User Support Mailing List
[email-masked]
: >Automated List Manager
[email-masked]
:
:
:
:
: _________________________________________________________________
: Chat with friends online, try MSN Messenger: http://messenger.msn.com
:
: ______________________________________________________________________
: Apache Interface to OpenSSL (mod_ssl)                   www.modssl.org
: User Support Mailing List                      [email-masked]
: Automated List Manager                            [email-masked]
:

______________________________________________________________________
Apache Interface to OpenSSL (mod_ssl)                   www.modssl.org
User Support Mailing List                      [email-masked]
Automated List Manager                            [email-masked]

---

From: Victor Medina <[email-masked]>
Date: Tue, 11 Jun 2002 12:52:09 -0400

Most probably you haven´t add path to the ssl dll´s or lib inside VS, go to 
tools\configure\directories and add the path to the include and bin folders 
of your OpenSSL installation this should work just fine

Best Regards

Victor Medina
Universidad Tecnologica del Centro
Valencia-Venezuela
(http://www.unitec.edu.ve)

At 12:05 AM 6/11/2002 -0500, you wrote:

>I've successfully compiled Apacche 2.0.36 and openssl as this thread 
>describes.  I'm encountering problems building modssl though.  When I try 
>to use NMAKE /f "mod_ssl.mak" CFG="mod_ssl - Win32 Release", i get the 
>following:
>         link.exe @C:\DOCUME~1\ADMINI~1.000\LOCALS~1\Temp\nma02752.
>    Creating library .\Release\libapr.lib and object .\Release\libapr.exp
>         cd "..\..\modules\ssl"
>         tempfile.bat
>The system cannot find the file specified.
>Could Not Find C:\httpd-2.0.36\modules\ssl\y.tab.c
>The system cannot find the file specified.
>Could Not Find C:\httpd-2.0.36\modules\ssl\y.tab.h
>NMAKE : fatal error U1077: 'tempfile.bat' : return code '0x1'
>Stop.
>Linking...
>    Creating library Debug/mod_ssl.lib and object Debug/mod_ssl.exp
>ssl_expr_scan.obj : error LNK2001: unresolved external symbol _ap_pstrdup
>Debug/mod_ssl.so : fatal error LNK1120: 1 unresolved externals
>Error executing link.exe.
>Automated List 
>Manager 
><mailto:[email-masked]>[email-masked]

---

From: "Phil Smiley" <[email-masked]>
Date: Tue, 11 Jun 2002 19:54:35 -0500

I've included the following libs with the results I soecified below.

kernel32.lib user32.lib wsock32.lib ws2_32.lib advapi32.lib gdi32.lib
ssleay32.lib libeay32.lib libapr.lib libaprutil.lib libhttpd.lib

I also included the directories with the openssl libraries.  Same result.

Thanks; Phil

----- Original Message -----
From: "Victor Medina" <[email-masked]>
To: <[email-masked]>
Sent: Tuesday, June 11, 2002 11:52 AM
Subject: Re: 2.0.36 + mod-ssl + Win2k = Easy Money

> >I'm sure its something obvious that I've overlooked.  Does anyone have
any
> >suggestions?

---

From: "Dwayne Miller" <[email-masked]>
Date: Wed, 12 Jun 2002 08:13:35 -0400

I just recently built the 2.0.36 + ssl tree and had similar results. 
 Although the error messages were slightly different, the root cause 
might be the same.

Turns out that several .c and .h files are delivered with dates earlier 
than the .y and .l files they are built from.  However, the .c and .h 
files are actually up-to-date.  So, by simply 'touching' (I used an 
editor to add a blank line) to the .c and .h files to make their dates 
more recent than their source files, and the system will not try to 
build them again.  (I thought that I read that this problem had been 
corrected in the 2.0.36 tree, but apparently not).

Anyway,  I also had to uninstall the bison utility (I did not have the 
other required tools, lex, sed and yacc anyway) before this would 
actually work.  Having bison on my system, even with the modified file 
dates, would still cause an error for some reason.  Removing bison and 
altering the file dates allowed the build to work as expected.

The files that you need to 'touch' are
ssl_expr_parse.c
ssl_expr_parse.h
ssl_expr_scan.c

Since you have run the make with errors, you will probably have to 
reinstall these files from the distribution before running make again. 
 They might have been emptied as a result of your failed make.

Hope this helps

Phil Smiley wrote:

>>Most probably you haven´t add path to the ssl dll´s or lib inside VS, go
>>    
>>
>to
>  
>
>>tools\configure\directories and add the path to the include and bin
>>    
>>
>folders
>  
>

---

From: "Phil Smiley" <[email-masked]>
Date: Sun, 16 Jun 2002 02:26:53 -0500

----- Original Message -----
From: "Dwayne Miller" <[email-masked]>
To: <[email-masked]>
Sent: Wednesday, June 12, 2002 7:13 AM
Subject: Re: 2.0.36 + mod-ssl + Win2k = Easy Money

> The files that you need to 'touch' are

In the version of Apache that I have (2.0.36), the .c and .h files above
have later dates than the .y and .l files.  Still, nmake tries to rebuild
them.  I got around this by taking out the generation steps in mod_ssl.mak.
This works.  I now have Apache 2.0..36 running on Win2K with ssl support.
Thanks to everyone on this thread for their suggestions and shared
experiences.

Phil