Subject: apache 1.3.24 + mod_ssl 2.8.8 for Windows (2000)

From: "Danalien" <[email-masked]>
Date: Wed, 03 Apr 2002 16:51:50 +0200

Hi,

I need some help, i patch, complie, and everything according to:
     http://www.modssl.org/source/exp/mod_ssl/pkg.mod_ssl/INSTALL.Win32

all goes fine fine, only get a few warnings (during the apache complie)

I then go to the httpd.conf  (%my_apache_ssl_root%/conf)

and put this in:

LoadModule ssl_module modules/mod_ssl.so

and I get (this) when i do apache -t :

C:\Program Files\Apache_SSL>apache -t
Syntax error on line 62 of c:/program files/apache_ssl/conf/httpd.conf:
Cannot load c:/program files/apache_ssl/modules/mod_ssl.so into server: (182)
Note the errors or messages above, and press the <ESC> key to exit.  26...
C:\Program Files\Apache_SSL>

*thinking* *thinking*...

... then I just do a little test.

remove the previos loadModule by puting a # infront (lite this):

#LoadModule ssl_module modules/mod_ssl.so

and add:

AddModule mod_ssl.c

and get :

C:\Program Files\Apache_SSL>apache -t
Syntax error on line 110 of c:/program files/apache_ssl/conf/httpd.conf:
Cannot add module via name 'mod_ssl.c': not in list of loaded modules
Note the errors or messages above, and press the <ESC> key to exit.  23...
C:\Program Files\Apache_SSL>

and do a apache -l
where I get this:

Compiled-in modules:
  http_core.c
  mod_so.c
  mod_mime.c
  mod_access.c
  mod_auth.c
  mod_negotiation.c
  mod_include.c
  mod_autoindex.c
  mod_dir.c
  mod_cgi.c
  mod_userdir.c
  mod_alias.c
  mod_env.c
  mod_log_config.c
  mod_asis.c
  mod_imap.c
  mod_actions.c
  mod_setenvif.c
  mod_isapi.c

and my suspicions were correct, "where are/is the SSL - module(s)?" cause it ain't in
the compiled apache :)

If some could explain/help me how to meld this SSL module into apache, it would be great :)
thanks.

//   with regards
//   ID ::  danalien  ::  <[email-masked]>

PGP Public Key Fingerprint: C891 D3A1 427A A5E7  449F B19E 1E85 A109

______________________________________________________________________
Apache Interface to OpenSSL (mod_ssl)                   www.modssl.org
User Support Mailing List                      [email-masked]
Automated List Manager                            [email-masked]

---

From: "Kristijan Cafuta RIP" <[email-masked]>
Date: Wed, 3 Apr 2002 20:34:48 +0200

in Apache conf file you shoul add both, first
LoadModule ssl_module modules/mod_ssl.so
and an somewhere after that
AddModule mod_ssl.c

but I think this error also reports when someone forget to copy the files
ssleay32.dll and libeay32.dll to WINNT\System32

did you do it?

----- Original Message -----
From: "Danalien" <[email-masked]>
To: <[email-masked]>
Sent: Wednesday, April 03, 2002 4:51 PM
Subject: apache 1.3.24 + mod_ssl 2.8.8 for Windows (2000)

> -----BEGIN PGP SIGNED MESSAGE-----
> Hash: SHA1
>
> Hi,
>
> -----BEGIN PGP SIGNATURE-----
> Version: PGPsdk version 1.7.1 (C) 1997-1999 Network Associates, Inc. and
its affiliated companies.
>
> iQA/AwUBPKsI9x6FoQlEaqKIEQKKOQCfQTAK3SV7vSoe8aE8YQqv7cjVqrQAoOe7
> DmQQDW2F53itoAyTwCj7zlEj
> =hTM+
> -----END PGP SIGNATURE-----
>
>

---

From: "Danalien" <[email-masked]>
Date: Wed, 03 Apr 2002 23:40:22 +0200

BINGO! :), that was it! There you have the solution : )

Some, put this in INSTALL.Win32 or in an error FAQ:

"Check and delete any other/older ssleay32.dll & libleay32.dll 
that exist in:
1] winnt\system32
2] or any other path that exist in your %path%-varable.
    Simply remove the path from %path%-variable, or remove it from there.
    
Because other/older complied dll's in tandem with newer may cause an 182 (minor) error,
while starting up apache."

maybe it is cygwin that puts it there ( in winnt\system32) or I did? a llonng looong time ago
and forgot about it : ) *hehe*

thanks, kristjan!

//   with regards