Subject: ap_hook_pool and ssl_var_lookup on solaris

From: Himanshu Soni <[email-masked]>
Date: Wed, 27 Mar 2002 15:07:03 -0800

Hi

I have written a module that calls ap_hook_call(char *hook).
The hook called is ap::mod_ssl::var_lookup which is registered when mod_ssl
loads up in the     void  (*add_module) (struct module_struct *) call.
However, when I make call, at run time, my module dumps core because
ap_hook_pool is not initialized for that instance.
Does it have something to do with child processes on solaris not being able
to get handle to the hook pool?

Any ideas? Help is greatly appreciated.

Thanx

Himanshu Soni
ValiCert Inc.
http://www.valicert.com
Software Engineer
phone: 650-567-5491

______________________________________________________________________
Apache Interface to OpenSSL (mod_ssl)                   www.modssl.org
User Support Mailing List                      [email-masked]
Automated List Manager                            [email-masked]

---

From: Himanshu Soni <[email-masked]>
Date: Thu, 28 Mar 2002 10:05:14 -0800

Ok

This one was my bad.
I was explicitly linking my module with apache libs and it was only seeing a
local copy of the ap_hook_pool.

Thanx

-----Original Message-----
From: Himanshu Soni [mailto:[email-masked]]
Sent: Wednesday, March 27, 2002 3:07 PM
To: [email-masked]
Subject: ap_hook_pool and ssl_var_lookup on solaris

Hi

Thanx

Himanshu Soni
ValiCert Inc.
http://www.valicert.com
Software Engineer
phone: 650-567-5491