Subject: Apache modssl last release ...

From: [ Falk Großwig ] <[email-masked]>
Date: Tue, 15 Jan 2002 00:39:16 +0100

Hello,

i just installed the mod_ssl for Apache. First it workes fine, but i cant tell how, the Apache shuts down the mod_ssl ...

i cant reach the mod_ssl url if i open a new browser window.

my config file loos so :

....
..
...

LoadModule ....
AddModule.....

.....
...
....

BindAddress design-4-you.ath.cx

<VirtualHost www.design-4-you.ath.cx>
    ServerAdmin [email-masked]
    DocumentRoot E:/Server/www/
    ServerName www.design-4-you.ath.cx
    ErrorLog E:/Server/logs/www.design-4-you.ath.cx-error_log
    CustomLog E:/Server/logs/www.design-4-you.ath.cx-access_log common
    ScriptAlias /cgi-bin/ E:/Server/www/cgi-bin/
<Directory E:/Server/www/>
    AllowOverride All
</Directory>
</VirtualHost>

<VirtualHost server.design-4-you.ath.cx>
    ServerAdmin [email-masked]
    DocumentRoot E:/Server/logs/
    ServerName www.design-4-you.ath.cx
    ErrorLog E:/Server/logs/server.design-4-you.ath.cx-error_log
    CustomLog E:/Server/logs/server.design-4-you.ath.cx-access_log common
<Directory E:/Server/logs/>
    AllowOverride All
</Directory>
</VirtualHost>

<VirtualHost mysql.design-4-you.ath.cx>
    ServerAdmin [email-masked]
    DocumentRoot E:/Server/phpmyadmin/
    ServerName mysql.design-4-you.ath.cx
    ErrorLog E:/Server/logs/mysql.design-4-you.ath.cx-error_log
    CustomLog E:/Server/logs/mysql.design-4-you.ath.cx-access_log common
<Directory E:/Server/phpmyadmin/>
    AllowOverride All
</Directory>
</VirtualHost>

#SSLMutex sem
SSLRandomSeed startup builtin
SSLSessionCache dbm:C:/Apache/logs/ssl_gcache_data
SSLSessionCacheTimeout 600
SSLProtocol all
#SSLVerifyClient require
SSLVerifyDepth 10

#SSLOptions +FakeBasicAuth -StrictRequire

SSLLog logs/SSL.log
SSLLogLevel warn

<VirtualHost ssl.design-4-you.ath.cx>
ServerAdmin [email-masked]
ServerName design-4-you
DocumentRoot E:/Server/secure/
ErrorLog E:/Server/logs/secure.design-4-you.ath.cx-error_log
CustomLog E:/Server/logs/secure.design-4-you.ath.cx-access_log common
SSLEngine On
SSLCertificateFile conf/ssl/www.design-4-you.ath.cx.cert
SSLCertificateKeyFile conf/ssl/www.design-4-you.ath.cx.key
</VirtualHost>

----------------------------------------------------------------------------------------------------------------------------------

by the way, im using windows 2000 professional 

Apache/1.3.22 (Win32) mod_ssl/2.8.5 OpenSSL/0.9.6b PHP/4.1.1

I hope u can help me ...

mybe tell me how the order should be in the httpd.conf that mod_ssl works correct ...

---

From: Owen Boyle <[email-masked]>
Date: Wed, 16 Jan 2002 12:54:05 +0100

> [ Falk Großwig ] wrote:
> 
> Hello,
> 
> i just installed the mod_ssl for Apache. First it workes fine, but i
> cant tell how, the Apache shuts down the mod_ssl ...
> 

> SSLCertificateKeyFile conf/ssl/www.design-4-you.ath.cx.key

So this is your SSL VH?

First, you need:

Listen 443

before the VH so apache listens to port 443, which is where SSL works.

Second, you need to define port 443 in the VH, i.e.

<VirtualHost ssl.design-4-you.ath.cx:443>

Third, you need to start apache with SSL. In unix, the command is:

# apachectl startssl

or (more primitively)

# ./httpd -DSSL

check the docs for the appropriate command under windows.

Rgds,

Owen boyle.
______________________________________________________________________
Apache Interface to OpenSSL (mod_ssl)                   www.modssl.org
User Support Mailing List                      [email-masked]
Automated List Manager                            [email-masked]