Subject: RE: modssl for Apache 2.0

From: Cliff Woolley <[email-masked]>
Date: Thu, 11 Apr 2002 10:35:12 -0400 (EDT)

On Thu, 11 Apr 2002, R. DuFresne wrote:

> I've found this, do I point at the openssl dir I have the all the sub dirs
> and bins installed in, or to the source tree they were compiled from?

The install dir's prefix.  So, for example, if your OpenSSL is in /usr/lib
and /usr/include/openssl, then you'd use --with-ssl=/usr

PS: warning, danger Will Robinson:  I heard a rumor that if you link to a
static OpenSSL (ie, libssl.a and libcrypto.a) instead of a shared one
(libssl.so and libcrypto.so) and you use mod_ssl as a DSO, then it breaks.
If you get errors along the lines of unresolved symbols such as
X509_INFO_free, this is probably what's going on.  Watch out for that!

--Cliff

______________________________________________________________________
Apache Interface to OpenSSL (mod_ssl)                   www.modssl.org
User Support Mailing List                      [email-masked]
Automated List Manager                            [email-masked]

---

From: [email-masked] (George Walsh)
Date: Thu, 11 Apr 2002 17:19:40 -0400

I stand upbraided for my open software bigotry.

Actually, Chuck, apologies are in order because I was going through a heavy mailing for SuSE users where there has been discussion about Apache 2. with mod_ssl. I (rather carelessly) did not notice the source of your mailing.

My sincere apologies, and the very best of luck with your project.

George

"Chuck Goehring" <[email-masked]> wrote:

>George,
>
>It wasn't really my decision to go with Windows.  There are many
>Unix-phobics out there.  Have peculiar combination of requirements that
>causes the need for ssl - Not doing ecomerce.
>
>Chuck
>
>----- Original Message -----
>From: "George Walsh" <[email-masked]>
>To: <[email-masked]>
>Sent: Wednesday, April 10, 2002 10:07 PM
>Subject: RE: modssl for Apache 2.0
>
>
>> Chuck:
>>
>> With Apache 2.0, mod_ssl is a part of the 'whole'. The build is a far
>simpler process, and the server, at least in my experience, is much crisper
>in terms of response.
>>
>> As for windows, that is NOT my cup of tea. We are a Micro-soft Free zone
>here, so I cannot comment on the peculiarities you might experience in your
>environment. I really do not know hy you would want to run a secure server
>on top of a windows box, but then I admit to a happy ignorance about it, at
>least :-)
>>
>> George
>>
>> >I see all the activity on the list about Apache 2.0 and modssl.  Where
>can I get the necessary "stuff" for Apache 2.0.  I don't see it on the
>modssl, openssl or Apache web sites.  I need to get ssl up on Apache on
>Windows 2000.
>> >
>> >
>> >Chuck
>> >
>>
>>
>> --
>> George Walsh,
>> Managing Director,
>> CruiseRoutes Division,
>> DSC Directional Services Corp
>> Courtenay, British Columbia, Canada
>>
>>
>>
>>
>> __________________________________________________________________
>> Your favorite stores, helpful shopping tools and great gift ideas.
>Experience the convenience of buying online with Shop@Netscape!
>http://shopnow.netscape.com/
>>
>> Get your own FREE, personal Netscape Mail account today at
>http://webmail.netscape.com/
>>

-- 
George Walsh,
Managing Director,
CruiseRoutes Division,
DSC Directional Services Corp
Courtenay, British Columbia, Canada

__________________________________________________________________
Your favorite stores, helpful shopping tools and great gift ideas. Experience the convenience of buying online with Shop@Netscape! http://shopnow.netscape.com/

Get your own FREE, personal Netscape Mail account today at http://webmail.netscape.com/