Subject: RE: Apache 2.039

From: "Gregg Andrew" <[email-masked]>
Date: Thu, 8 Aug 2002 14:17:24 -0400

Did you use just the base directory, default is /usr/local/ssl, this worked for me.
Gregg Andrew
 
-----Original Message-----
From: Xiao, Wei [mailto:[email-masked]] 
Sent: Thursday, August 08, 2002 2:03 PM
To: [email-masked]'
Subject: RE: Apache 2.039
 
When I run configure --with-ssl=$directory_of_open_ssl, it complained that it can't find ssl toolkit library. Did I do anything wrong?
Thanks. 
Wei 
-----Original Message----- 
From: Cliff Woolley [

---

From: "Xiao, Wei" <[email-masked]>
Date: Thu, 8 Aug 2002 14:25:45 -0400

Thanks.

-----Original Message-----
From: Daniel Lopez [mailto:[email-masked]]
Sent: Thursday, August 08, 2002 2:09 PM
To: [email-masked]
Subject: Re: Apache 2.039

Have a look at http://www.apacheworld.org/ty24/site.chapter17.html
That is a chapter I have online that explains step by step how to build
Apache 2 with SSL support. 

> When I run configure --with-ssl=$directory_of_open_ssl, it complained that
> it can't find ssl toolkit library. Did I do anything wrong?
> 
> Thanks.
> 
> Wei
> 
> From: Cliff Woolley [mailto:[email-masked]]
> Sent: Thursday, August 08, 2002 1:50 PM
> To: [email-masked]
> Subject: Re: Apache 2.039
> 
> 
> On Thu, 8 Aug 2002, Tony Jarriault wrote:
> 
> > I'm search openssl for Apache 2.039, where can i find it, please ?
> 
> I assume you mean mod_ssl, not openssl.  mod_ssl is bundled with Apache
> 2.0.x -- check your copy of Apache 2.0 and you'll find that it's already
> there (caveat: we do not distribute binaries of mod_ssl, only source
> code).
> 
> OpenSSL is the same regardless of what mod_ssl you use and is available at
> www.openssl.org.
> 
> --Cliff
> 
> PS: Can we PLEASE add this to the FAQ or even the main modssl.org site?
> 
> ______________________________________________________________________
> Apache Interface to OpenSSL (mod_ssl)                   www.modssl.org
> User Support Mailing List                      [email-masked]
> Automated List Manager                            [email-masked]
______________________________________________________________________
Apache Interface to OpenSSL (mod_ssl)                   www.modssl.org
User Support Mailing List                      [email-masked]
Automated List Manager                            [email-masked]

---

From: "Xiao, Wei" <[email-masked]>
Date: Fri, 9 Aug 2002 12:00:40 -0400

Followed your instruction, finally got every configuration done. But server
won't start with following message in error_log,

[Fri Aug 09 11:49:29 2002] [warn] Init: PRNG still contains not sufficient
entropy!
[Fri Aug 09 11:49:32 2002] [error] Init: Failed to generate temporary 512
bit RSA private key Configuration Failed

Thanks.