Subject: RE: autosigning certificate

From: Zampognaro Sergio <[email-masked]>
Date: Fri, 31 Jan 2003 18:16:09 +0100

Hi,
I'm using openssl-0.9.7!
any other suggestions?

thanks
Sergio.

-----Original Message-----
From: Aihong Yin [mailto:[email-masked]]
Sent: venerdì 31 gennaio 2003 18.01
To: [email-masked]
Subject: Re: autosigning certificate

Hello Zampognaro,

>Hi all,
>I tried to use my own CA in order to sign the CSR previously produced.
>Following what I got:
>
>[naunx04:aspprod] /home/aspprod/aspapp/mySSL/openSSL/bin> ./sign.sh
>server.csr
>CA signing: server.csr -> server.crt:
>Using configuration from ca.config
>Enter pass phrase for ./ca.key:
>Check that the request matches the signature
>Signature ok
>The Subject's Distinguished Name is as follows
>countryName           :PRINTABLE:'IT'
>stateOrProvinceName   :PRINTABLE:'Napoli'
>localityName          :PRINTABLE:'Pozzuoli'
>organizationName      :PRINTABLE:'SchlumbergerSema'
>organizationalUnitName:PRINTABLE:'EAI'
>commonName            :PRINTABLE:'naunx04:8443'
>emailAddress          :IA5STRING:[email-masked]'
>Certificate is to be certified until Jan 29 17:29:55 2004 GMT (365 days)
>Sign the certificate? [y/n]:y
>
>
>1 out of 1 certificate requests certified, commit? [y/n]y
>Write out database with 1 new entries
>Data Base Updated
>CA verifying: server.crt <-> CA cert
>server.crt:
>/C=IT/ST=Napoli/L=Pozzuoli/O=SchlumbergerSema/OU=EAI/CN=naunx04:8443/emailA
d
>dress=[email-masked]
>error 18 at 0 depth lookup:self signed certificate
>/C=IT/ST=Napoli/L=Pozzuoli/O=SchlumbergerSema/OU=EAI/CN=naunx04:8443/emailA
d
>dress=[email-masked]
>error 7 at 0 depth lookup:certificate signature failure
>[naunx04:aspprod] /home/aspprod/aspapp/mySSL/openSSL/bin>
>
>I see 2 ERRORS:
>error 18 at 0 depth lookup:self signed certificate
>error 7 at 0 depth lookup:certificate signature failure
>
>What they means? The certificate signing process is ok or not?
>
The certificate signing process is not ok!
Are you using openssl-2.9.6g? Please try it again with openssl-2.9.7.

I hope this mail is not too late for you!

Cheers,
Aihong Yin.

______________________________________________________________________
Apache Interface to OpenSSL (mod_ssl)                   www.modssl.org
User Support Mailing List                      [email-masked]
Automated List Manager                            [email-masked]
______________________________________________________________________
Apache Interface to OpenSSL (mod_ssl)                   www.modssl.org
User Support Mailing List                      [email-masked]
Automated List Manager                            [email-masked]

---

From: Aihong Yin <[email-masked]>
Date: Fri, 31 Jan 2003 20:07:15 +0100

Hello Zampognaro,

>any other suggestions?
I'm not sure whether I can help you.

Are the "Common Name" in your self-signed CA certificate and server 
certificate the same?
Please try to give the difference names for them!

Cheers,
Aihong Yin.

--

---

From: Aihong Yin <[email-masked]>
Date: Fri, 31 Jan 2003 20:19:50 +0100

> Please try to give the difference names for them! 

Not the "Common Name". The "Organizational Unit Name" should be 
different. I'm sorry for that!

Cheers,
Aihong Yin.

--