Subject: RE: Apache.exe generates errors and is closed by Windows.

From: Ramakrishna Kuppa <[email-masked]>
Date: Mon, 30 Sep 2002 18:29:07 -0700

Chris,

I am getting the following message in my SSL log:

[30/Sep/2002 17:57:49 02000] [info]  Server: Apache/1.3.26, Interface:
mod_ssl/2.8.10, Library: OpenSSL/0.9.6g
[30/Sep/2002 17:57:49 02000] [warn]  You are using mod_ssl under Win32. This
combination is *NOT* officially supported. Use it at your own risk!

Anything to be noted/concerned of?

> -----Original Message-----
> From: hunter [mailto:[email-masked]] 
> Sent: Monday, September 30, 2002 5:22 PM
> To: [email-masked]
> Subject: Re: Apache.exe generates errors and is closed by Windows.
> 
> 
> Ramakrishna Kuppa wrote:
> > Chris,
> > 
> > I upgraded our system to use OpenSSL 0.9.6g from your latest build.
> > However, the error I was referring to occurred in the 
> previous build 
> > that had version 0.9.6d of OpenSSL.
> > 
> > The error is a Dr.Watson error. The usual popup box comes with the 
> > above
> > message and until the user acknowledges, the system doesn't 
> service any 
> > requests. There aren't any useful messages that get logged either.
> > 
> > The complete message is as follows:
> > "Apache.exe generates errors and will be closed by Windows. You will
> > need to restart the program. An error log is being created."
> > 
> > 
> > 
> >  > -----Original Message-----
> >  > From: hunter [mailto:[email-masked]]
> >  > Sent: Monday, September 30, 2002 4:59 PM
> >  > To: [email-masked]
> >  > Subject: Re: Apache.exe generates errors and is closed 
> by Windows.  
> > >  >
> >  > Ramakrishna Kuppa wrote:
> >  > > I am getting the above error on my Windows platform. The
> >  > environment
> >  > > details are as follows:
> >  > >
> >  > > OS: Windows 2000
> >  > > Server: Apache 1.3.26 with OpenSSL 0.9.6d and mod_ssl 2.8.10
> >  > >
> >  > > The OS pops up a box with the above message and until the user
> >  > > acknowledges, the system doesn't respond to any user
> >  > requests. In a way,
> >  > > the system "hangs".
> >  > >
> >  > > Any ideas on how this can be resolved? Alternatively, can
> >  > the server
> >  > > be
> >  > > made to service user requests?
> >  > >
> >  > > Thanks
> >  > > Ramakrishna
> >  > >
> >  >
> >  > Ramakrishna,
> >  >
> >  > Could you please explain what is 'the above error'.
> >  >
> >  > Guess: Are you referring to an abnormal end.. a dialog 
> that says a
> >  > program is exiting unexpectedly?
> >  >
> >  > Warning: You should not be using OpenSSL 0.9.6d - I 
> thought you were
> >  > using one of the new builds I made?
> >  >
> >  > Advice: This error might happen if you did not have all of
> >  > the parts or
> >  > it is misconfigured.  You may find a clue in the 
> error.log.  Have you
> >  > ever had this working or are you failing on an initial install.
> >  >
> >  > Chris.
> >  >
> >  > 
> ______________________________________________________________________
> >  > Apache Interface to OpenSSL (mod_ssl)                   
> www.modssl.org
> >  > User Support Mailing List                 
>      [email-masked]
> >  > Automated List Manager                            
> [email-masked]
> >  >
> > 
> 
> Ramakrishna,
> 
> It would be helpful to see the apache error log ... usually called 
> 'error.log' in the ..\Apache\logs directory.
> 
> Also, the Dr Watson log can also be useful but less so when I do not 
> have the same build - with the same build I can walk it into 
> the failure 
> with the debugger.  The Dr Watson log can be found in the 
> %SystemRoot% 
> .. mine is I:\WINDOWS (XP PRO) yours could be C:\WINNT - the file is 
> called 'drwtsn32.log'
> 
> This could have been caused by a buffer overrun ... like in a failed 
> exploit ... previous versions of OpenSSL were vulnerable.
> 
> I will look at the log if you send it.  Maybe there will be clues.
> 
> 
> The new code is ok?
> 
> Chris.
> 
> 
> 
> 
> 
> 
> ______________________________________________________________________
> Apache Interface to OpenSSL (mod_ssl)                   www.modssl.org
> User Support Mailing List                      [email-masked]
> Automated List Manager                            [email-masked]
>

---

From: hunter <[email-masked]>
Date: Mon, 30 Sep 2002 23:53:29 -0400

Ramakrishna Kuppa wrote:
> [30/Sep/2002 17:57:49 02000] [warn]  You are using mod_ssl under Win32. 
> This combination is *NOT* officially supported. Use it at your own risk!
> 
> 

Ramakrishna,

I don't know.  While I have been building Apache for several years, I 
have only recently started playing with SSL.  I never used it at all 
with Apache 1.3.26.  It is now integrated into Apache 2.0.xx and that is 
what I am using.  I have never seen a message like this with Apache2.

This message reminds me of the disclaimer that says that Apache for 
Windows should not be considered production quality.  I have never 
personally had any problems with the Windows Apache until version 2.0.xx 
and Windows XP - auto-index was broken with a large number of files the 
last time I checked.

Anyway, I don't think the message is cause for worry.  Maybe someone 
more closely involved with mod_ssl will comment.

I will have a look at the mod_ssl code and see if I can find the source 
of the message - I am curious.

Chris.

---

From: hunter <[email-masked]>
Date: Tue, 01 Oct 2002 00:07:00 -0400

Ramakrishna,

     /*
      * Identification
      */
     if (mc->nInitCount == 1) {
         ssl_log(s, SSL_LOG_INFO, "Server: %s, Interface: %s, Library: %s",
                 SERVER_BASEVERSION,
                 ssl_var_lookup(p, NULL, NULL, NULL, 
"SSL_VERSION_INTERFACE"),
                 ssl_var_lookup(p, NULL, NULL, NULL, 
"SSL_VERSION_LIBRARY"));
#ifdef WIN32
         ssl_log(s, SSL_LOG_WARN, "You are using mod_ssl under Win32. "
                 "This combination is *NOT* officially supported. "
                 "Use it at your own risk!");
#endif
     }

...it is simply a comment - disclaimer - whatever - it is there in any 
case if you are running Windows version.

Chris.