Subject: mod_ssl/openssl error with test certificate?

From: "Otto L. Miller" <[email-masked]>
Date: Wed, 5 Mar 2003 09:05:32 -0500

modssl-users,

OK, I just built an apache + mod_ssl + mod_perl configuration.  I
built the test certificate and installed it (make certificate && make
install).  But when I 'apachectl startssl' I get the following
message:

[error] Init: Unable to read server certificate from file /opt/sisapache/conf/ssl.crt/server.crt (OpenSSL library error follows)
[error] OpenSSL: error:0D09F007:asn1 encoding routines:d2i_X509:expecting an asn1 sequence

I checked permissions and thought that might be the problem, however,
the problem persists even if I 'chmod 444
/opt/sisapache/conf/ssl.crt/server.crt'.  Any thoughts?

Thanks,
Otto
---
Otto L. Miller
Network Architect
[email-masked]
Titan Systems
3877 Fairfax Ridge Road
Fairfax, VA  22030-7448
Phone:  703-383-8022
Fax:    703-383-4055

______________________________________________________________________
Apache Interface to OpenSSL (mod_ssl)                   www.modssl.org
User Support Mailing List                      [email-masked]
Automated List Manager                            [email-masked]

---

From: Geoff Thorpe <[email-masked]>
Date: Wed, 05 Mar 2003 13:21:59 -0500

* Otto L. Miller ([email-masked]) wrote:

[snip]

> /opt/sisapache/conf/ssl.crt/server.crt'.  Any thoughts?

Could you post a copy of the server.crt file?

Cheers,
Geoff

-- 
Geoff Thorpe
[email-masked]
http://www.geoffthorpe.net/

---

From: "Otto L. Miller" <[email-masked]>
Date: Wed, 5 Mar 2003 15:19:33 -0500

Geoff,

Opps!  Checked out the file and it is a dummy ascii file :-(.  I
replaced it with a 'real' file from the source tree and then it whined
about the private key.  It too was a dummy ascii file.  I replaced it
with a 'real' key file and voila... it all works!  It never occurred
to me that 'make install' *does not* install the certificate files
files. Thanks to all who spent time on this!

Thanks,
Otto
---
Otto L. Miller
Network Architect
[email-masked]
Titan Systems
3877 Fairfax Ridge Road
Fairfax, VA  22030-7448
Phone:  703-383-8022
Fax:    703-383-4055