Subject: RE: Solaris 8 - ModSSL 2.8.7-1.3.23 and libssl.so problems

From: Lily Tian <[email-masked]>
Date: Wed, 27 Mar 2002 10:22:59 -0800

I had this problem before. I think this is because the libssl.so is not
built correctly.
Try to do the following:
 1)  cd /openssl-0.9.6c
     sh config no-thread  -fPIC
     make
     make test
     cd ..

 2) cd mod_ssl-2.8.6-1.3.23
     ./confgiure --with-apache=/u02/app/apache_1.3.23  
                     --with-ssl=../openssl-0.9.6c 
                     --prefix=/u02/app/apache
                     --enable-shared=ssl
                     --enable-module=ssl
                     --enable-module=so
                     --enable-rule=SHARED_CORE
 3)  cd /u02/app/apache_1.3.23
      make 
      make certificate
      make install

Here I was using mod_ssl-2.8.6-1.3.23, I also try it on
mod_ssl-2.8.7-1.3.23. It should works.
Good luck!

Lily

-----Original Message-----
From: Vince Church [mailto:[email-masked]]
Sent: Wednesday, March 27, 2002 9:55 AM
To: ModSSL UserGroup
Subject: Solaris 8 - ModSSL 2.8.7-1.3.23 and libssl.so problems

Hi Everyone,

I've researched the archives and found several users with this same problem,
but none of the solutions seems to work for me. Does anyone know the
workaround
or solution?

Basically I have:
 mod_ssl-2.8.7-1.3.23
 openssl-0.9.6c
 mm-1.1.3
 apache_1.3.23
 Solaris 8 (x86)

When I try to run apache, the following message occurs.

# ./apachectl startssl
Syntax error on line 206 of /usr/local/apache/conf/httpd.conf:
Cannot load /usr/local/apache/libexec/libssl.so into server: ld.so.1:
/usr/local/apache/bin/httpd: fatal: relocation error: file
/usr/local/apache/libexec/libssl.so: symbol ap_user_id: referenced symbol
not found
./apachectl startssl: httpd could not be started

Hope I have not missed the answer somewhere else...

Thank You in advance,

Vince

______________________________________________________________________
Apache Interface to OpenSSL (mod_ssl)                   www.modssl.org
User Support Mailing List                      [email-masked]
Automated List Manager                            [email-masked]
______________________________________________________________________
Apache Interface to OpenSSL (mod_ssl)                   www.modssl.org
User Support Mailing List                      [email-masked]
Automated List Manager                            [email-masked]

---

From: Bill -Sx- Jones <[email-masked]>
Date: Wed, 27 Mar 2002 15:22:02 -0500

Using this procedure:

cd /
openssl md5 * > /private/var/root/rand.dat

cd /private/var/root/
openssl genrsa -des3 -out server.key -rand rand.dat 1024
openssl req -new -key server.key -out server.csr
openssl genrsa -des3 -out ca.key -rand rand.dat 1024
openssl req -new -x509 -days 365 -key ca.key -out ca.crt
/private/var/root/sign.sh server.csr

On Platform:
Apache 1.3.22, MacOS X 10.1.3 - self signing error ?

I get -

Check that the request matches the signature
Signature ok
The Subjects Distinguished Name is as follows
countryName           :PRINTABLE:'US'
stateOrProvinceName   :PRINTABLE:'Florida'
localityName          :PRINTABLE:'Jacksonville'
organizationName      :PRINTABLE:'FCCJ'
organizationalUnitName:PRINTABLE:'courseware support'
commonName            :PRINTABLE:'sneex.fccj.edu'
emailAddress          :IA5STRING:[email-masked]'
Certificate is to be certified until Mar 27 20:13:54 2003 GMT (365 days)
Sign the certificate? [y/n]:y

1 out of 1 certificate requests certified, commit? [y/n]y
Write out database with 1 new entries
Data Base Updated
CA verifying: server.crt <-> CA cert
server.crt: /C=US/ST=Florida/L=Jacksonville/O=FCCJ/OU=courseware
support/CN=sneex.fccj.edu/Email=[email-masked]
error 18 at 0 depth lookup:self signed certificate
/C=US/ST=Florida/L=Jacksonville/O=FCCJ/OU=courseware
support/CN=sneex.fccj.edu/Email=[email-masked]
error 7 at 0 depth lookup:certificate signature failure

Is this an error I can ignore?  If not, how can I fix it?

BTW - The clients I have tried all fail to connect to 443 ...

Help?
-Sx-  :]