Subject: help needed for virtualhosting + SSL configuration.

From: Nisarg Rav <[email-masked]>
Date: Fri, 3 May 2002 21:16:06 -0700 (PDT)

hello gurus ,

      I've installed and configured apache-1.3.23 + openssl-0.9.6b + mod_ssl and mod_perl successfully.
      It is working fine for my main site and self signed ssl certificate.

      I want to do IP based virtual hosting for more one site and want to serve that site through self signed ssl certificate. 
      so may i get help to configure httpd.conf to full fill my requirement .

Regards 

Nisarg Rav 

_____________________________________________________________
Want a new web-based email account ? ---> http://www.firstlinux.net

_____________________________________________________________
Promote your group and strengthen ties to your members with [email-masked] by Everyone.net  http://www.everyone.net/?btn=tag
______________________________________________________________________
Apache Interface to OpenSSL (mod_ssl)                   www.modssl.org
User Support Mailing List                      [email-masked]
Automated List Manager                            [email-masked]

---

From: Owen Boyle <[email-masked]>
Date: Mon, 06 May 2002 09:47:41 +0200

>       so may i get help to configure httpd.conf to full fill my requirement .

No problem. You just need to create IP-based VirtualHosts:

- Remove all "Port" and "BindAddress" directives (they will be replaced
by "Listen").
- set up as follows:

# Original HTTP site
Listen 192.168.1.1:80
<VirtualHost 192.168.1.1:80>
DocumentRoot /path/to/original/http
..
</VirtualHost>

# Original SSL site
Listen 192.168.1.1:443
<VirtualHost 192.168.1.1:443>
DocumentRoot /path/to/original/ssl
SSLCertificateFile    /path/to/original/cert
SSLCertificateKeyFile /path/to/original/key
..
</VirtualHost>

# Second SSL site
Listen 192.168.1.2:443
<VirtualHost 192.168.1.2:443>
DocumentRoot /path/to/second/ssl
SSLCertificateFile    /path/to/second/cert
SSLCertificateKeyFile /path/to/second/key
..
</VirtualHost>

and so on...

Rgds,

Owen Boyle.

---

From: "Subscribed" <[email-masked]>
Date: Mon, 6 May 2002 09:50:42 -0500

I Just walked down this road.
Make your default site a virtual host, and NameVirtualHosts, make that your
IP address.
Remove documentroot and servername from your "Main" configuration and keep
it only in <Virtualhost>
Thats a start, let me know if you have issues from there.
Remember that the first virtual host becomes default when you remove your
current "default" settings.

====================================
"My advice is worth exactly what you paid for it,
and not a penny more."
====================================
----- Original Message -----
From: "Nisarg Rav" <[email-masked]>
To: <[email-masked]>
Cc: <[email-masked]>
Sent: Friday, May 03, 2002 11:16 PM
Subject: help needed for virtualhosting + SSL configuration.

>       I want to do IP based virtual hosting for more one site and want to
serve that site through self signed ssl certificate.
> Promote your group and strengthen ties to your members with
[email-masked] by Everyone.net  http://www.everyone.net/?btn=tag