Subject: can´t configure mod_ssl

From: "Gilberto Garcia Jr." <[email-masked]>
Date: Fri, 22 Nov 2002 10:12:21 -0200

Hey guys,

Can someone explain me how configure mod_ssl on apchache web server? I have installed apache with mod_ssl on a red hat 7.3

thanks

---

From: Julio César Mejia Vergara <[email-masked]>
Date: Fri, 22 Nov 2002 09:51:12 -0800

Que tal Gilberto,

Hay te va.

Saludos
Julio Mejia
TELNOR
Tijuana-Baja California-México.

DESCRIPCION: Pasos para instalar Apache 1.3.19 con ModSSL 2.8.1 para 
Apache 1.3.19.

Paso 1: Tener previamente instalado el compilador de C (GNUgcc 2.95.2) 
<http://intranet.telnor.com/netshare/Sistemas/Tecnologia/TecnologiaT/Knowledge/jume/Inst_GNUgcc2_95_2_Sol.html>, 
y la utileria make (GNUmake 2.78.1) 
<http://intranet.telnor.com/netshare/Sistemas/Tecnologia/TecnologiaT/Knowledge/jume/Inst_GNUmake3_78_1_Sol.html> 
de GNU, además Perl 5.6.0 
<http://intranet.telnor.com/netshare/Sistemas/Tecnologia/TecnologiaT/Knowledge/jume/Inst_Perl5_6_Sol.html>, 
el JDK 1.3 
<http://intranet.telnor.com/netshare/Sistemas/Tecnologia/TecnologiaT/Knowledge/jume/Inst_JDK1.3_Sol.html>,  
OpenSSL 0.9.6 
<http://intranet.telnor.com/netshare/Sistemas/Tecnologia/TecnologiaT/Knowledge/jume/Inst_OpenSSL0_9_6_Sol.html> 
(puedes buscar la versión más nueva de ModSSL enwww.modssl.org 
<http://www.modssl.org>) y las bibliotecas de memoria virtual MM 1.1.3. 
<http://intranet.telnor.com/netshare/Sistemas/Tecnologia/TecnologiaT/Knowledge/jume/Inst_MM_1_1_3_Sol.html>

Paso 2: Crear el directorio temporal en donde se va a colocar el 
software a instalar de modssl y apache.

#mkdir /trayectoria/temp

Paso 3: Copiar el software a instalar a los directorios temporales creados.

#cp mod_ssl-2.8.1-1.3.19.tar /trayectoria/temp
#cp apache_1.3.19.tar /trayectoria/temp

Paso 4: Desempaquetar el software de instalación de ModSSL y Apache.

#cd /trayectoria/temp
#tar -xvf mod_ssl-2.8.1-1.3.19.tar
#cd /trayectoria/temp
#tar -xvf apache_1.3.19.tar

Paso 5: Crear el directorio en donde se va a instalar el Apache.

#cd /usr/local
#mkdir apache

Paso 6: Introducir las siguientes variables de ambiente en el archivo 
.profile bajo root "/", si el archivo no existe crearlo

# vi .profile
#
# @(#)local.profile 1.6 98/02/06 SMI
#
stty istrip
PATH=.:/usr/local/bin:/usr/java/bin:/bin:/usr/ccs/bin:/usr/local/ssl/bin:/usr/local/apache/bin:$PATH
LD_LIBRARY_PATH=/usr/local/lib:/lib:/usr/lib:/usr/local/ssl/lib:$LD_LIBRARY_PATH
MANPATH=/usr/local/man:/usr/man:$MANPATH
CLASSPATH=/opt/JSDK2.0/lib/jsdk.jar
JAVA_HOME=/usr/java
export PATH  LD_LIBRARY_PATH MANPATH CLASSPATH JAVA_HOME

#
# If possible, start the windows system
#
if [ "`tty`" = "/dev/console" ] ; then
        if [ "$TERM" = "sun" -o "$TERM" = "AT386" ] ; then

                if [ ${OPENWINHOME:-""} = "" ] ; then
                        OPENWINHOME=/usr/openwin
                        export OPENWINHOME
                fi

                echo ""
                echo "Starting OpenWindows in 5 seconds (type Control-C 
to interrupt)"
                sleep 5
                echo ""
                $OPENWINHOME/bin/openwin

                clear # get rid of annoying cursor rectangle
                exit # logout after leaving windows system

        fi
fi

Paso 7: El archivo de configuración de modssl va a instalar el modulo de 
SSL en Apache y lo va a instalar, por lo consecuente ejecutar el 
siguiente comando de instalación desde modssl.

#cd /trayectoria/temp/mod_ssl-2.8.1-1.3.19
#./configure --with-apache=../apache_1.3.19 --with-ssl=../opensll-0.9.6 
--with-mm=../mm-1.1.3 --prefix=/usr/local/apache --enable-module=ssl 
--enable-module=so --enable-shared=max --enable-rule=SHARED_CORE 
--enable-rule=EAPI
#cd /trayectoria/temp/apache_1.3.19
#make
#make certificate TYPE=test
Signature Algorithm ((R)SA or (D)SA) [R]: R
Country Name (2 letter code): MX
State or Province Name (full name): Baja California
Locality Name (eg, City): Tijuana
Organization Name (eg, company): Telefonos del Noroeste S.A. de C.V.
Organizational Unit Name (eg, section): Sistemas
Common Name (eg, FQDN): nombre_maquina.telnor.com
Email Address (eg, name@FQDN <mailto:name@FQDN>): [email-masked] 
<mailto:[email-masked]>
Certificate Validity (days): 365
Certificate Version (1 or 3): 3
Encrrypt the private key now? [Y/n]: Y
Enter PEM pass phrase: xxxxxxxx
Verifying password - Enter PEM pass phrase: xxxxxxxx
#make install
#

Paso 8: Editar el archivo de configuración del apache y levanta el 
servidor con ssl.

#cd  /usr/local/apache/conf
#vi httpd.conf
configura archivo!!
#cd ../bin
#apachectl startssl
pass phrase: xxxxxxxx
apache started.
#

Para parar el apache utiliza:

#apachectl stop
#

Gilberto Garcia Jr. wrote:

> Hey guys,
>  
> Can someone explain me how configure mod_ssl on apchache web server? I 
> have installed apache with mod_ssl on a red hat 7.3
>  
> thanks
>  

______________________________________________________________________
Apache Interface to OpenSSL (mod_ssl)                   www.modssl.org
User Support Mailing List                      [email-masked]
Automated List Manager                            [email-masked]