Subject: [Q] VirtualHost problems..

From: "Han, Donghoon" <[email-masked]>
Date: Wed, 22 May 2002 16:07:58 +0900

Hi everyone,

I recently configured several named virtual hosts on my Apache 1.3.24
server.

NameVirtualHost A.B.C.D:80
NameVirtualHost E.F.G.H:80
NameVirtualHost A.B.C.D:443
NameVirtualHost E.F.G.H:443

-- Several :80 virtual hosts --

<VirtualHost A.B.C.D:443 E.F.G.H:443>
ServerName blah.blah.com
SSLCertificateFile A.crt
SSLCertificateKeyFile A.key
-- other configurations --
</VirtualHost>
<VirtualHost A.B.C.D:443 E.F.G.H:443>
ServerName blah2.blah2.com
SSLCertificateFile A2.crt
SSLCertificateKeyFile A2.key
-- other configurations --
</VirtualHost>

I configured like this, but when I connect to blah2.blah2.com
Explorer gets the certificate of the first virtual host.
The other configurations are ok, I get authentication dialogs and
I get the right file as I configured the virtual host.
The only one problem is that I get the different certificate from the
one I configured. Did I miss something?

Thanks in advance.

______________________________________________________________________
Apache Interface to OpenSSL (mod_ssl)                   www.modssl.org
User Support Mailing List                      [email-masked]
Automated List Manager                            [email-masked]

---

From: "Peter Viertel" <[email-masked]>
Date: Wed, 22 May 2002 09:11:18 +0100

Try reading the FAQ.....

http://www.modssl.org/docs/2.8/ssl_faq.html#ToC47

---

From: "Han, Donghoon" <[email-masked]>
Date: Wed, 22 May 2002 17:18:29 +0900

Oh, my... Thanks Peter.
Then theoretically, name based virtual host can't use
Their own certificates on any web server, with any SSL module.

Hmm... Then I need more IP Address........

--------
[email-masked] ( [email-masked] is not avail. )

http://www.nazgul33.com

-----Original Message-----
From: [email-masked]
[mailto:[email-masked]] On Behalf Of Peter Viertel
Sent: Wednesday, May 22, 2002 5:11 PM
To: [email-masked]
Subject: Re: [Q] VirtualHost problems..

Try reading the FAQ.....