Subject: Mod_SSL_2.8.10 and OpenSSL_0.9.6g

From: David Diehl <[email-masked]>
Date: Thu, 19 Sep 2002 14:14:38 -0400

Has anybody got this to function on a NT 4.0 server?

I've downloaded and compiled apache 1.3.26 with modssl 2.8.10 and
openssl 9.6g and can't seem to get it to work on a NT 4.0 server. It
works fine on a windows 2000 server, but when I try and start it on a NT
4.0 server the second apache process never starts and there are no error
indications in the log files.

I've also download 2 seperate precompiled builds and niether of them
came with the openssl dll files libeay32.dll and ssleay32.dll, which
normally reside in the system32 directory. If I use the ones I compiled,
the same symptoms occur. Of course, if I remove all SSL directives from
the httpd.conf file, I don't need the dll's and it functions properly.

It seems that any version prior to 9.6 i.e. 9.5a  functions without any
problems.

Any ideas or insight would be greatly appreciated.

Thanks

David

______________________________________________________________________
Apache Interface to OpenSSL (mod_ssl)                   www.modssl.org
User Support Mailing List                      [email-masked]
Automated List Manager                            [email-masked]

---

From: Geoffrey Talvola <[email-masked]>
Date: Fri, 20 Sep 2002 10:40:34 -0400

Apache 1.3.26, which comes with the OpenSA release I referred to.

- Geoff

> -----Original Message-----
> From: Paul Bleimeyer [mailto:[email-masked]]
> Sent: Thursday, September 19, 2002 6:42 PM
> To: [email-masked]
> Subject: RE: Mod_SSL_2.8.10 and OpenSSL_0.9.6g
> 
> 
> Geoff,
> 
> Are you running 1.x or 2.40 apache?
> 
> Regards,
> 
> Paul
> 
> 
> > -----Original Message-----
> > From: [email-masked]
> > [mailto:[email-masked]]On Behalf Of Geoffrey Talvola
> > Sent: Thursday, September 19, 2002 1:28 PM
> > To: [email-masked]'
> > Subject: RE: Mod_SSL_2.8.10 and OpenSSL_0.9.6g
> > 
> > 
> > I'm using the binaries from the OpenSA package and they are 
> > working fine for
> > me, both on NT and on 2000.
> > 
> > details at http://www.opensa.org/development/news/101.html
> > 
> > - Geoff
> > 
> > > -----Original Message-----
> > > From: David Diehl [mailto:[email-masked]]
> > > Sent: Thursday, September 19, 2002 2:15 PM
> > > To: [email-masked]
> > > Subject: Mod_SSL_2.8.10 and OpenSSL_0.9.6g
> > > 
> > >