Subject: RE: Problems compiling mod_ssl with apache 2.0.44

From: "Boulytchev, Vasiliy" <[email-masked]>
Date: Fri, 7 Feb 2003 09:31:52 -0700

This is off the modssl track, but has anyone gotten frontpage extensions working for httpd-2.0.44?   2.0.40 is the supported version, and the install quits if that is not it.  Just checking....   

-----Original Message-----
From: Sasa STUPAR [mailto:[email-masked]]
Sent: Friday, February 07, 2003 2:39 AM
To: [email-masked]
Subject: Re: Problems compiling mod_ssl with apache 2.0.44

I have just succesfully compiled apache 2.0.44 with mod_ssl and openssl
0.9.7 on RH8. First I have compiled openssl then apache and everything
works fine. On trick after make install in openssl it doesn't copy
headers so you have to manually copy them to your install directory.

On 2/7/2003 10:25 AM, Erik Melkersson a écrit:
> Hi!
> 
> Thanks for the reply.
> 
> Geoff Thorpe wrote:
>> ... The kind of linker
>> error you report usually suggests the code was compiled against one
>> openssl version's headers, but is trying to link against a different
>> openssl version's libraries....
> 
> Yes, I tried to compile it against different openssl-version and didn't 
> make clean in betweend (dumb fault by me)
> 
> After cleaning and compiling again we get some other errors.
> undefined reference to OPENSSL_free, RAND_egd and RAND_status (se below 
> for complete data)
> 
> In order to make apache compile we
> - changed OPENSSL_free to CRYPTO_free in a #define in the modules/ssl/ 
> headers file. (As that is done in openssl anyway)
> - commented out the 3+3 lines where RAND_egd and RAND_status are used in 
> modules/ssl/ssl_engine_rand.c
> 
> Now we can compile and use it over ssl even though commenting out non 
> working code is propably a bad thing to do.
> 
> 
> ./configure --prefix=/service/apache2 
> --exec-prefix=/service/apache2/arch/linux-intel --enable-ssl 
> --with-openssl=/service/apache2/openssl/
> ...lots of rows...
> make
> ...lots of rows...
> /bin/sh /usr/local/service/apache2/src/httpd-2.0.44/srclib/apr/libtool 
> --mode=link gcc  -g -O2 -pthread    -DLINUX=2 -D_REENTRANT 
> -D_XOPEN_SOURCE=500 -D_BSD_SOURCE -D_SVID_SOURCE 
> -DAP_HAVE_DESIGNATED_INITIALIZER 
> -I/usr/local/service/apache2/src/httpd-2.0.44/srclib/apr/include 
> -I/usr/local/service/apache2/src/httpd-2.0.44/srclib/apr-util/include 
> -I/service/apache2/openssl/include 
> -I/usr/local/service/apache2/src/httpd-2.0.44/srclib/apr-util/xml/expat/lib 
> -I. -I/usr/local/service/apache2/src/httpd-2.0.44/os/unix 
> -I/usr/local/service/apache2/src/httpd-2.0.44/server/mpm/prefork 
> -I/usr/local/service/apache2/src/httpd-2.0.44/modules/http 
> -I/usr/local/service/apache2/src/httpd-2.0.44/modules/filters 
> -I/usr/local/service/apache2/src/httpd-2.0.44/modules/proxy 
> -I/usr/local/service/apache2/src/httpd-2.0.44/include 
> -I/usr/local/ssl/include/openssl -I/usr/local/ssl/include 
> -I/usr/local/service/apache2/src/httpd-2.0.44/modules/dav/main 
> -export-dynamic 
> -L/usr/local/service/apache2/src/httpd-2.0.44/srclib/apr-util/xml/expat/lib 
> -L/usr/local/ssl/lib   -o httpd  modules.lo  modules/aaa/mod_access.la 
> modules/aaa/mod_auth.la modules/filters/mod_include.la 
> modules/loggers/mod_log_config.la modules/metadata/mod_env.la 
> modules/metadata/mod_setenvif.la modules/ssl/mod_ssl.la 
> modules/http/mod_http.la modules/http/mod_mime.la 
> modules/generators/mod_status.la modules/generators/mod_autoindex.la 
> modules/generators/mod_asis.la modules/generators/mod_cgi.la 
> modules/mappers/mod_negotiation.la modules/mappers/mod_dir.la 
> modules/mappers/mod_imap.la modules/mappers/mod_actions.la 
> modules/mappers/mod_userdir.la modules/mappers/mod_alias.la 
> modules/mappers/mod_so.la server/mpm/prefork/libprefork.la 
> server/libmain.la os/unix/libos.la -lssl -lcrypto 
> /usr/local/service/apache2/src/httpd-2.0.44/srclib/pcre/libpcre.la 
> /usr/local/service/apache2/src/httpd-2.0.44/srclib/apr-util/libaprutil-0.la 
> -lgdbm -ldb 
> /usr/local/service/apache2/src/httpd-2.0.44/srclib/apr-util/xml/expat/lib/libexpat.la 
> /usr/local/service/apache2/src/httpd-2.0.44/srclib/apr/libapr-0.la -lm 
> -lcrypt -lnsl -lresolv -ldl
> modules/ssl/.libs/mod_ssl.al(ssl_engine_kernel.lo): In function 
> `ssl_hook_UserCheck':
> /usr/local/service/apache2/src/httpd-2.0.44/modules/ssl/ssl_engine_kernel.c:875: 
> undefined reference to `OPENSSL_free'
> modules/ssl/.libs/mod_ssl.al(ssl_engine_kernel.lo): In function 
> `ssl_callback_SSLVerify':
> /usr/local/service/apache2/src/httpd-2.0.44/modules/ssl/ssl_engine_kernel.c:1206: 
> undefined reference to `OPENSSL_free'
> /usr/local/service/apache2/src/httpd-2.0.44/modules/ssl/ssl_engine_kernel.c:1210: 
> undefined reference to `OPENSSL_free'
> modules/ssl/.libs/mod_ssl.al(ssl_engine_kernel.lo): In function 
> `ssl_callback_SSLVerify_CRL':
> /usr/local/service/apache2/src/httpd-2.0.44/modules/ssl/ssl_engine_kernel.c:1469: 
> undefined reference to `OPENSSL_free'
> modules/ssl/.libs/mod_ssl.al(ssl_engine_kernel.lo): In function 
> `modssl_proxy_info_log':
> /usr/local/service/apache2/src/httpd-2.0.44/modules/ssl/ssl_engine_kernel.c:1507: 
> undefined reference to `OPENSSL_free'
> modules/ssl/.libs/mod_ssl.al(ssl_engine_rand.lo): In function 
> `ssl_rand_seed':
> /usr/local/service/apache2/src/httpd-2.0.44/modules/ssl/ssl_engine_rand.c:125: 
> undefined reference to `RAND_egd'
> /usr/local/service/apache2/src/httpd-2.0.44/modules/ssl/ssl_engine_rand.c:163: 
> undefined reference to `RAND_status'
> modules/ssl/.libs/mod_ssl.al(ssl_engine_vars.lo): In function 
> `ssl_var_lookup_ssl_cert':
> /usr/local/service/apache2/src/httpd-2.0.44/modules/ssl/ssl_engine_vars.c:351: 
> undefined reference to `OPENSSL_free'
> 
> Machine running Linux 2.2.17-14smp (RedHat 6.2)
> openssl 0.9.7
> apache 2.0.44
> 

______________________________________________________________________
Apache Interface to OpenSSL (mod_ssl)                   www.modssl.org
User Support Mailing List                      [email-masked]
Automated List Manager                            [email-masked]
______________________________________________________________________
Apache Interface to OpenSSL (mod_ssl)                   www.modssl.org
User Support Mailing List                      [email-masked]
Automated List Manager                            [email-masked]

---

From: "R. DuFresne" <[email-masked]>
Date: Fri, 7 Feb 2003 11:46:02 -0500 (EST)

are you sure you wish to degrade the security of your apache  server with
front[age extensions?  Frontpage and coldfusion have a nasty security
history.

Thanks,

Ron DuFresne

-- 
~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
        admin & senior security consultant:  sysinfo.com
                        http://sysinfo.com

"Cutting the space budget really restores my faith in humanity.  It
eliminates dreams, goals, and ideals and lets us get straight to the
business of hate, debauchery, and self-annihilation."
                -- Johnny Hart

testing, only testing, and damn good at it too!