Subject: apache and mod_ssl

From: bhawna sinha <[email-masked]>
Date: Thu, 7 Feb 2002 16:02:02 -0800 (PST)

I have installed apache web server software and the
Apache interface to OpenSSL(mod_ssl) in order to have
a secure server. I have changed the configuration file
httpd.conf and ssl is enabled on port 443. But the
problem is whenever I try the url
https://localhost:443, it says cannot connect to
server. It seems that it is not able to connect to
port 443. Also in the error log it says "invalid
method in request".
I am attaching the conf file:

-------***************************************---------<IFDefine
SSL>
LoadModule ssl_module modules/mod_ssl.so
</IFDefine>

<VirtualHost 127.0.0.1:80>
ServerAdmin [email-masked]
ServerName 127.0.0.1
</VirtualHost>

<IfDefine SSL>
SSLMutex sem
SSLRandomSeed startup builtin
SSLSessionCache none
SSLLog logs/ssl.log
SSLLogLevel info
<VirtualHost 127.0.0.1:443>
SSLEngine on
SSLCertificateFile conf/ssl/my-server.cert
SSLCertificateKeyFile conf/ssl/my-server.key
</VirtualHost>
#SSLVerifyClient require
#SSLVerifyDepth 1
#SSLCACertificatePath conf/ssl
#SSLCACertificateFile conf/ssl/my-server.cert
</IfDefine>

I would appreciate if anyone could give me a solution

Thanks
Bhawna

__________________________________________________
Do You Yahoo!?
Send FREE Valentine eCards with Yahoo! Greetings!
http://greetings.yahoo.com
______________________________________________________________________
Apache Interface to OpenSSL (mod_ssl)                   www.modssl.org
User Support Mailing List                      [email-masked]
Automated List Manager                            [email-masked]

---

From: "Toomas Aas" <[email-masked]>
Date: Fri, 8 Feb 2002 11:26:44 +0200

Hi bhawna!

On  7 Feb 02 at 16:02 you wrote:

> server.

Have you tried just https://localhost ? It should work without 
specifying the port, but it also should work when you do specify 
the port.

Do you have 'Listen 443' somewhere in your config file? You should.
--
Toomas Aas | [email-masked] | http://www.raad.tartu.ee/~toomas/
* Make yourself at home! Clean my kitchen.

---

From: "Kent Freeman" <[email-masked]>
Date: Fri, 8 Feb 2002 08:23:22 -0800

You neet to point your browser to https://www.yourdomain.foo or
http://www.yourdomain.foo:443.

Unless you are testing from the local http server, you will need to update
your DNS with the new domain name(s).

You also need to tell Apache to listen on port 443 in the httpd.conf file.

If you are using virtual hosts, you will need to add other things in the
httpd.conf file like
(this config is for name-based v-hosts):

NameVirtualHost *:80
NameVirtualHost *:443

<IfDefine SSL>
Listen 80
Listen 443
</IfDefine>

<VirtualHost *:443>
SSLEngine	on
SSLCACertificatePath /usr/local/apache/conf/certs/
SSLCACertificateFile /usr/local/apache/conf/certs/ca.crt
SSLCertificateChainFile /usr/local/apache/conf/certs/ca.crt
SSLCertificateFile /usr/local/apache/conf/certs/server.crt
SSLCertificateKeyFile /usr/local/apache/conf/certs/server.key
DocumentRoot /usr/local/apache/htdocs
ServerName www.yourdomain.foo [or www.sub.yourdomain.foo]
</VirtualHost>

-----Original Message-----
From: [email-masked]
[mailto:[email-masked]]On Behalf Of bhawna sinha
Sent: Thursday, February 07, 2002 4:02 PM
To: [email-masked]
Subject: apache and mod_ssl

<IfDefine SSL>
SSLMutex sem

Thanks
Bhawna

---

From: jon schatz <[email-masked]>
Date: 08 Feb 2002 10:06:05 -0800

On Thu, 2002-02-07 at 16:02, bhawna sinha wrote:
> Also in the error log it says "invalid
> method in request".

that means you're talking SSL to a normal http server. in other words,
port 443 is not listening for ssl connections.

-- 
[email-masked] || www.divisionbyzero.com
gpg key: www.divisionbyzero.com/pubkey.asc
think i have a virus?: www.divisionbyzero.com/pgp.html
"You are in a twisty little maze of Sendmail rules, all confusing."