Subject: Linux Red Hat 7.2 + openSSL 0.9.7 + Apache 1.3.27 + mod_ssl 2.8.1 2 = PROBLEMS!!!

From: Zampognaro Sergio <[email-masked]>
Date: Tue, 25 Feb 2003 15:05:13 +0100

Hi,
everything is in the subject!
I installed everything following this procedure:

$ ./config --prefix=/home/aspco1/openSSL
$ make
$ make test
$ make install

#   extract the packages
$ gzip -d -c apache_1.3.27.tar.gz | tar xvf -
$ gzip -d -c mod_ssl-2.8.12-1.3.27.tar.gz | tar xvf -

#   apply mod_ssl to Apache source tree
$ cd /mod_ssl-2.8.12-1.3.27
$ ./configure --with-apache=../apache_1.3.27
$ cd ..

#   build/install Apache with mod_ssl
$ cd apache_1.3.27
$ SSL_BASE=/home/aspco1/openSSL 
$ ./configure --prefix=/home/aspco1/apache_1.3.27 --enable-module=proxy
--enable-module=ssl 
$ make
$ make certificate TYPE=test
$ make install
$ cd ..
    
#   cleanup after work
$ rm -rf mod_ssl-2.8.12-1.3.27
$ rm -rf apache_1.3.27

Everything seems to be ok, but when I try to start the web server:

$ apachectl start
Ouch! ap_mm_create(1048576, "/var/run/httpd.mm.22620") failed
Error: MM: mm:core: failed to open semaphore file (Permission denied): OS:
No such file or directory
/usr/sbin/apachectl start: httpd could not be started

> Even bad with SSL:
$ apachectl startssl
usage: /usr/sbin/apachectl
(start|stop|restart|fullstatus|status|graceful|configtest|help)

start      - start httpd
stop       - stop httpd
restart    - restart httpd if running by sending a SIGHUP or start if
             not running
fullstatus - dump a full status screen; requires lynx and mod_status enabled
status     - dump a short status screen; requires lynx and mod_status
enabled
graceful   - do a graceful restart by sending a SIGUSR1 or start if not
running
configtest - do a configuration syntax test
help       - this screen

(startssl is not recognized!!!), and finally:

$ httpd -l
Compiled-in modules:
  http_core.c
  mod_so.c
suexec: enabled; valid wrapper /usr/sbin/suexec

> Even if I compiled with --enable-module=proxy --enable-module=ssl options
> I can't see proxy and ssl modules in the list of compiled-in modules!!!
> 
What's happening???

thanks
Sergio

---

From: "Boyle Owen" <[email-masked]>
Date: Tue, 25 Feb 2003 16:15:15 +0100

PLain text please..

Now you have to plough through the mail below to find my comments

Rgds,
Owen Boyle
Disclaimer: Any disclaimer attached to this message may be ignored. 

-----Original Message-----
From: Zampognaro Sergio [mailto:[email-masked]]
Sent: Dienstag, 25. Februar 2003 15:05
To: [email-masked]
Subject: Linux Red Hat 7.2 + openSSL 0.9.7 + Apache 1.3.27 + mod_ssl
2.8.1 2 = PROBLEMS!!!
Importance: High
Sensitivity: Confidential

Hi, 
    
#   cleanup after work 
$ rm -rf mod_ssl-2.8.12-1.3.27 
$ rm -rf apache_1.3.27 
Everything seems to be ok, but when I try to start the web server: 
$ apachectl start 
Ouch! ap_mm_create(1048576, "/var/run/httpd.mm.22620") failed 
Error: MM: mm:core: failed to open semaphore file (Permission denied):
OS: No such file or directory 
/usr/sbin/apachectl start: httpd could not be started 

*********************************************************************

Why is apachectl in /usr/sbin/apachectl? This sounds like the default
installation that came with RH. Your apachectl and httpd should be in
/home/aspco1/apache_1.3.27/bin. What happens if you do
/home/aspco1/apache_1.3.27/bin/apachectl startssl? I think this is your
MAIN problem... 

Be certain you are executing the right apache before proceeding!

Also, did you install the MM shared memory library
(http://www.ossp.org/pkg/lib/mm/)? I don't think it is entirely
necessary although I've never installed without it.

*********************************************************************

Even bad with SSL: 
$ apachectl startssl 
usage: /usr/sbin/apachectl
(start|stop|restart|fullstatus|status|graceful|configtest|help) 
start      - start httpd 
stop       - stop httpd 
restart    - restart httpd if running by sending a SIGHUP or start if 
             not running 
fullstatus - dump a full status screen; requires lynx and mod_status
enabled 
status     - dump a short status screen; requires lynx and mod_status
enabled 
graceful   - do a graceful restart by sending a SIGUSR1 or start if not
running 
configtest - do a configuration syntax test 
help       - this screen 
(startssl is not recognized!!!), and finally: 
$ httpd -l 
Compiled-in modules: 
  http_core.c 
  mod_so.c 
suexec: enabled; valid wrapper /usr/sbin/suexec 
Even if I compiled with --enable-module=proxy --enable-module=ssl
options I can't see proxy and ssl modules in the list of compiled-in
modules!!!
What's happening??? 
thanks 
Sergio

This message is for the named person's use only. It may contain
confidential, proprietary or legally privileged information. No
confidentiality or privilege is waived or lost by any mistransmission.
If you receive this message in error, please notify the sender urgently
and then immediately delete the message and any copies of it from your
system. Please also immediately destroy any hardcopies of the message.
You must not, directly or indirectly, use, disclose, distribute, print,
or copy any part of this message if you are not the intended recipient.
The sender's company reserves the right to monitor all e-mail
communications through their networks. Any views expressed in this
message are those of the individual sender, except where the message
states otherwise and the sender is authorised to state them to be the
views of the sender's company. 

______________________________________________________________________
Apache Interface to OpenSSL (mod_ssl)                   www.modssl.org
User Support Mailing List                      [email-masked]
Automated List Manager                            [email-masked]