Subject: Re: Dynamic IP Addressing

From: [email-masked]
Date: Wed, 8 May 2002 08:30:03 +0100

Jack,
The point of the certificate is that you can't change the domain name presented to the browser (as it's in the cert) so that world knows you are who
you say you are as somebody
else (the certificate authority) who issued the cert is trusted by the general public.
A fixed IP is the best solution, another option (although not secure when your IP changes) is to use a dynamic DNS service such as
http://www.dyndns.org/
I would not recommend using a dynamic DNS system with https for any kind of serious or business purpose.
Mikey

>The problem is that I'd like to offer SSL as a feature of my home download server.  I've got a broadband connection with a company that doesn't offer
 static IP
>addressing for it's users, so my home IP address changes now and then.  I then simply have to go to the main site and update my link to the server to
 reflect
>t.he new IP address and I'm back in business, but I'm wondering if this will prohibit me from using SSL.  I'm not sure how to overcome the name
matching that
>the SSL certificate requires.  I can't apply for a certificate using an IP address for an identity, because it'll change, but I also can't use the
domain name of my
>computer because my client's browser's see only the IP address used for access.
>
>What I'd like to know is if there's any way to configure Apache+mod-ssl to return my computer's domain name, even if it's accessed by way of it's IP
address?
>That would give me a consistent name that would satisfy the SSL certificate name matching.  When my IP address changes, all I'd need to do is update
my
>httpd.conf file to reflect the new IP address to respond to and the SSL certificate should never know the difference.
>
>I know that this is a reverse DNS function of sorts and I'm pretty sure that there's a way of doing it, but so far I've read all the documentation
that I could find on
>httpd.conf configuration, but still haven't had any luck.  I'd sure appreciate any help that you could provide.
>
>Thanks --
>Jack Jacobsen
>[email-masked]
>Voice (407) 636-9458
>FAX   (407) 632-8189

All telephone calls are recorded and may be monitored.

E-mail communication is not secure and may be intercepted
by a third party. This message is confidential to the intended addressee.
If you are not the intended addressee, please inform us immediately and then
delete this message. Virgin One account does not accept responsibility for
changes made to this message after it was sent. Although Virgin One account
believes this e-mail is free of any virus or other defect which may affect a
computer, it is the responsibility of the recipient to ensure that it is
virus free and Virgin One account does not accept any responsibility for any
loss or damage arising from its use.

The Virgin One account is a secured personal bank account with The Royal Bank
of Scotland plc administered by Virgin Direct Personal Finance Ltd. It is an
Introducer representative only of Virgin Money Personal Financial Service Ltd,
which is authorised by the Financial Services Authority for life insurance,
pension and unit trust business and represents only the Virgin Money marketing
group.

Registered office: Waterhouse Square, 138-142 Holborn, London EC1N 2TH, UK.
Registered in England no 3414708.
______________________________________________________________________
Apache Interface to OpenSSL (mod_ssl)                   www.modssl.org
User Support Mailing List                      [email-masked]
Automated List Manager                            [email-masked]

---

From: Jack Jacobsen <[email-masked]>
Date: Thu, 09 May 2002 01:29:19 -0400

Thanks Mikey,

I can see why presenting a different name or URL alias wouldn't be such a good thing after all.  I think that I may need to look into establishing a
static IP address.  That seems to be the only reliable way around the problem.

Thanks for your help.

--
Jack Jacobsen
[email-masked]
Voice (407) 636-9458
FAX   (407) 632-8189