Subject: Re: Apache 2.0.35 with SSL - wont start

From: "paul priestman" <[email-masked]>
Date: Mon, 15 Apr 2002 14:54:41 +0000

So its trying to bind to 443 - i have stated in my ssl.conf to listen on 
port 8443 and have set up a virtual host for port 8443 with ssl enabled - 
how come it tries to bind to port 443?

I have therefore tried to start the server as root - it started okay but I 
cannot make a ssl connection - i goto https://servername.com:443 but get a 
server error telling me i could not connect to server - in the error logs i 
get:
mod_ssl: Unable to set session id context to 'servername.com:443' (OpenSSL 
library error follows)

OpenSSL: error:140DA111::lib(20) :func(218) :reason(273)

> > (13)Permission denied: make_sock: could not bind to address
0.0.0.0:443
> > no listening sockets available, shutting down
> > ./apachectl startssl: httpd could not be started
> >

It's *not* trying to start on 8443 though...

thanks,

Ron DuFresne

On Mon, 15 Apr 2002, paul priestman wrote:

>i'm actually trying to run this server on port 8443 - the other httpd runs 
>on port 443 but i have stopped this server running (as its just another 
>test server).  I am starting the server as my self - not as root but the 
>port is  > 1024 anyway
>
>I have tried chaning the port to other numbers aswell but to no luck....
>
>Paul
>
> >From: "R. DuFresne" <[email-masked]>
> >To: paul priestman <[email-masked]>
> >CC: [email-masked]
> >Subject: Re: Apache 2.0.35 with SSL - wont start
> >Date: Mon, 15 Apr 2002 09:12:42 -0400 (EDT)
> >
> >
> >You're not trying to run two httpd's on the same set of ports are you, 
>the
> >old one running while trying to fire up the new?
> >
> >that's what the error suggests I think...
> >
> >thanks,
> >
> >Ron DuFresne
> >
> >On Mon, 15 Apr 2002, paul priestman wrote:
> >
> > > Hello all,
> > >
> > > I have downloaded and installed Apache 2.0.35 with SSL.  I have 
> >configured
> > > the httpd.conf as they suggest in ssl.conf.  However, when i try to 
> >start
> > > apachectl i get the following message:
> > >

>From: "R. DuFresne" <[email-masked]>
>To: paul priestman <[email-masked]>
>CC: [email-masked]
>Subject: Re: Apache 2.0.35 with SSL - wont start
>Date: Mon, 15 Apr 2002 09:12:42 -0400 (EDT)
>
>
>You're not trying to run two httpd's on the same set of ports are you, the
>old one running while trying to fire up the new?
>
>that's what the error suggests I think...
>
>thanks,
>
>Ron DuFresne
>
>On Mon, 15 Apr 2002, paul priestman wrote:
>
> > Hello all,
> >
> > I have downloaded and installed Apache 2.0.35 with SSL.  I have 
>configured
> > the httpd.conf as they suggest in ssl.conf.  However, when i try to 
>start
> > apachectl i get the following message:
> >
> > (13)Permission denied: make_sock: could not bind to address 0.0.0.0:443
> > no listening sockets available, shutting down
> > ./apachectl startssl: httpd could not be started
> >
> > Has anyone any ideas what i'm doing wrong - i have succesfully got ssl
> > working with apache 1.3.22.
> >
> > Thanks for your time
> >
> > Paul
> >
> > _________________________________________________________________
> > Chat with friends online, try MSN Messenger: http://messenger.msn.com
> >
> > ______________________________________________________________________
> > Apache Interface to OpenSSL (mod_ssl)                   www.modssl.org
> > User Support Mailing List                      [email-masked]
> > Automated List Manager                            [email-masked]
> >
>
>--
>~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
>         admin & senior security consultant:  sysinfo.com
>                         http://sysinfo.com
>
>"Cutting the space budget really restores my faith in humanity.  It
>eliminates dreams, goals, and ideals and lets us get straight to the
>business of hate, debauchery, and self-annihilation."
>                 -- Johnny Hart
>
>testing, only testing, and damn good at it too!
>

_________________________________________________________________
Send and receive Hotmail on your mobile device: http://mobile.msn.com

______________________________________________________________________
Apache Interface to OpenSSL (mod_ssl)                   www.modssl.org
User Support Mailing List                      [email-masked]
Automated List Manager                            [email-masked]

---

From: Owen Boyle <[email-masked]>
Date: Mon, 15 Apr 2002 17:18:05 +0200

> mod_ssl: Unable to set session id context to 'servername.com:443' (OpenSSL

What's this about ssl.conf? Are you "including" this file into
httpd.conf at runtime?
If so, I have a nasty suspicion that you have two SSL VHs defined -
perhaps an old one in httpd.conf which is trying to Listen to port 433
(therefore causing a no permission error when you try to start as a
normal user) but when you do start as root still fails because its
docroot or certificates or something is missing (since it is an old VH -
anything is possible).

Can you thoroughly check (or even post!) all your config information...

Rgds,

Owen Boyle.

---

From: Mads Toftum <[email-masked]>
Date: Mon, 15 Apr 2002 17:33:07 +0200

> What's this about ssl.conf? Are you "including" this file into

This is the default for Apache2 - the ssl configuration has been
moved out of httpd.conf to ssl.conf

vh

Mads Toftum
-- 
With a rubber duck, one's never alone.
              -- "The Hitchhiker's Guide to the Galaxy"
______________________________________________________________________
Apache Interface to OpenSSL (mod_ssl)                   www.modssl.org
User Support Mailing List                      [email-masked]
Automated List Manager                            [email-masked]

---

From: "R. DuFresne" <[email-masked]>
Date: Mon, 15 Apr 2002 10:50:34 -0400 (EDT)

As owen I think mentioned, you might have to cleanup the old httpd.conf
file, it might well be trying to setup two connections on thesame port. 

another suggested here it might be your config, you might not be binding
to a specific IP/NIC.

Thanks,

Ron DuFresne

---

From: "Andrew Lietzow" <[email-masked]>
Date: Mon, 15 Apr 2002 11:16:38 -0500

Dear Mads Toftum, 
> moved out of httpd.conf to ssl.conf
-------
And what a marvelous business/IT decision  that was!  I applaude 
this whole-heartedly.   

I am but a mere mortal, simply needing to know enough to 
configure, launch, and maintain Apache mod_ssl enabled 
servers.  

IMO, this makes for a more straightforward configuration, 
allowing more users to adopt and utilize the technology.  Hopefully,
this is perceived to be a good thing by those who enable this project
to persist.   

Andrew Lietzow
The ACL Group, Inc.

---

From: "R. DuFresne" <[email-masked]>
Date: Mon, 15 Apr 2002 12:51:55 -0400 (EDT)

Actually, the capability to seperate parts of the configuration has always
been in place, it just was not the standard nor the adopted practise in
earlier apache releases.  In fact, I think seperation of configuration was
dropped fairly early on in apache/modssl development as some early web
admins found it confusing.

Thanks,

Ron DuFresne