Subject: Réf. : RE: Problem with ssl

From: [email-masked]
Date: Wed, 24 Jul 2002 09:17:18 +0200

Hi Fred,
That's exactly what I meant by patched (as we may consider that mod_ssl is
not more than a patch applied to Apache source to modify it.

I just keep getting that error.
Please, help if you can.

Thanx

                    "Frederic DONNAT"                                                                                  
                    <frederic.donnat@z       Pour :  <[email-masked]>                                            
                    encod.com>               cc :                                                                      
                                             Objet : RE: Problem with ssl                                              
                    23/07/2002 18:45                                                                                   

Hi Abdel

What do you mean by "patched"?

The classic way is :
[root]# cd mod_ssl-2.8.10-1.3.26
[root]# ./configure --prefix=/path_where_to_install_apache \
--with-apache=/path_to_apache_src --with-ssl=/path_to_openssl_src
[root]# cd /path_to_apache_src
[root]# make
[root]# make install

That's for a dynamic build.

Type the following command line before for a static one:
export LDFLAGS="-ldl"

Be sure to have the rigth openssl installed.

Hope it will help
Fred

-----Original Message-----
From:   [email-masked] [mailto:[email-masked]]
Sent:   Tue 07/23/2002 5:06 PM
To:     [email-masked]
Cc:     [email-masked]
Subject:        Problem with ssl

*Hi all

I'm trying to get mod_ssl work with Apache on RedHat 7.2, with Apache
1.3.26 & mod_ssl-2.8.10-1.3.26

I just keep getting an error on line 76 of the mod_ssl.c while compiling
apache (patched with mod_ssl)

which is :

--------------------------------------------------------------------------------------------------
 *  identify the module to SCCS `what' and RCS `ident' commands
 */
static char const sccsid[] = "@(#) mod_ssl/" MOD_SSL_VERSION " >";
static char const rcsid[]  = "$Id: mod_ssl/" MOD_SSL_VERSION " $";
--------------------------------------------------------------------------------------------------

Just followed many procedures and the error remain the same.

______________________________________________________________________
Apache Interface to OpenSSL (mod_ssl)                   www.modssl.org
User Support Mailing List                      [email-masked]
Automated List Manager                            [email-masked]

______________________________________________________________________
Apache Interface to OpenSSL (mod_ssl)                   www.modssl.org
User Support Mailing List                      [email-masked]
Automated List Manager                            [email-masked]

---

From: "Carter, Coates" <[email-masked]>
Date: Wed, 24 Jul 2002 15:47:06 -0400

Abdel,

What is the error message?  You wrote that the error was on line 76 of
mod_ssl.c, but I don't believe you mentioned the error message itself.  I've
just installed mod_ssl on apache on RedHat 7.2, all the same versions as
you.  I didn't have any errors or problems.  I chose to use the latest
openssl, which added a few more lines of work form me.  I've included for
you my notes from my installation.  Good luck.

Coates Carter
University of Richmond

#OPENSSL- REMOVE OLD RPM AND INSTALL LATEST TARBALL
rpm -e --repackage --nodeps openssl
cd /usr/local/src
gzip -dc openssl-0.9.6d.tar.gz |tar xvf -
cd /usr/local/src/openssl-0.9.6d
more INSTALL
./config shared
make
make test
make install
mv /usr/lib/libssl.so /usr/lib/libssl.so.old
mv /usr/lib/libcrypto.so /usr/lib/libcrypto.so.old
ln -s /usr/local/ssl/lib/libssl.so.0.9.6 /usr/lib/libssl.so
ln -s /usr/local/ssl/lib/libssl.so.0.9.6 /usr/lib/libssl.so.2
ln -s /usr/local/ssl/lib/libssl.so.0.9.6 libssl.so.0.9.6
ln -s /usr/local/ssl/lib/libcrypto.so.0.9.6 /usr/lib/libcrypto.so
ln -s /usr/local/ssl/lib/libcrypto.so.0.9.6 /usr/lib/libcrypto.so.2
ln -s /usr/local/ssl/lib/libcrypto.so.0.9.6 libcrypto.so.0.9.6
ln -s /usr/local/ssl/bin/openssl /usr/bin/openssl

#MM- BUILD THE SOURCE (www.engelschall.com/sw/mm)
cd /usr/local/src
gzip -dc mm-1.1.3.tar.gz|tar xvf -
cd /mm-1.1.3
./configure
make

#MOD_SSL- INSTALL NEW PATCH TO APACHE SOURCE
cd /usr/local/src
gzip -dc apache_1.3.26.tar.gz|tar xvf -
gzip -dc mod_ssl-2.8.10-1.3.26.tar.gz |tar xvf -
cd mod_ssl-2.8.10-1.3.26
./configure --with-apache=/usr/local/src/apache_1.3.26

#APACHE- INSTALL NEW TARBALL
cd /usr/local/src/apache_1.3.26
SSL_BASE=SYSTEM; EAPI_MM=../mm-1.1.3
./configure --prefix=/usr/local/apache --enable-module=ssl
--enable-shared=ssl
make
tar cvf /usr/local/apache.020724.tar /usr/local/apache
/usr/local/apache/bin/apachectl stop
#NOTE: INSTALL SSL CERTIFICATE AND KEY NOW, IF NOT ALREADY THERE
make install
/usr/local/apache/bin/apachectl startssl
#......THAT'S ALL IT TAKES......

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]
Sent: Wednesday, July 24, 2002 3:17 AM
To: Frederic DONNAT
Subject: Réf. : RE: Problem with ssl

Hi Fred,

Thanx

                    "Frederic DONNAT"

                    encod.com>               cc :

                    23/07/2002 18:45

Hi Abdel

The classic way is :

Hope it will help
Fred

-----Original Message-----

*Hi all

which is :

----------------------------------------------------------------------------
----------------------
 *  identify the module to SCCS `what' and RCS `ident' commands
 */
static char const sccsid[] = "@(#) mod_ssl/" MOD_SSL_VERSION " >";
static char const rcsid[]  = "$Id: mod_ssl/" MOD_SSL_VERSION " $";
----------------------------------------------------------------------------
----------------------