Subject: IE browser does not disply proper error message if the certificate is expired

From: Shiva Murugesan <[email-masked]>
Date: Sun, 3 Mar 2002 00:52:36 -0800 (PST)

Hello there,

I have a apache webserver with the following build
details.

apache 1.3.17
modssl 2.8.0
openssl 0.9.6

I have set 
SSLVerifyClient require  in order to make the browser
to present a certificate.

If I present a expired certificate in the NE it comes
back and says "The server rejected the certificate as
expired".

Whereas if I do the same in IE 5.5, it comes up with
the stupid error
"The page cannot be displayed".  It also displays when
I present the revoked certificate as well.

Could anyone help me to show proper error message in
IE, that is of great help.

Cheers
Shiva

__________________________________________________
Do You Yahoo!?
Yahoo! Sports - sign up for Fantasy Baseball
http://sports.yahoo.com
______________________________________________________________________
Apache Interface to OpenSSL (mod_ssl)                   www.modssl.org
User Support Mailing List                      [email-masked]
Automated List Manager                            [email-masked]

---

From: Shiva Murugesan <[email-masked]>
Date: Mon, 4 Mar 2002 09:20:05 -0800 (PST)

Dear folks,

In other words, when IE 5.0 is communicating with SSL
enabled apache, it does not display whenever there is
any valid errrors( alerts ) occurs, such as client
certificate expired or revoked.  It just displays the
misleading error "Page cannot be displayed" DNS
errors.

Sincerly ,
Shiva

---

From: jon schatz <[email-masked]>
Date: 04 Mar 2002 15:50:08 -0800

On Mon, 2002-03-04 at 09:20, Shiva Murugesan wrote:
> It just displays the

if you uncheck "Tools -> Internet Options -> Advanced -> Show Friendly
HTTP error messages", you can get more useful info. Unfortunately, the
default is to show the same error message for everything. You'll have to
change this by hand on your end users' machines (or write an ActiveX
control to do it for you).

-jon

-- 
[email-masked] || www.divisionbyzero.com
gpg key: www.divisionbyzero.com/pubkey.asc
think i have a virus?: www.divisionbyzero.com/pgp.html
"You are in a twisty little maze of Sendmail rules, all confusing."

---

From: jon schatz <[email-masked]>
Date: 04 Mar 2002 15:54:18 -0800

> control to do it for you).

oops. this is on ie 5.5/6.0. i can't speak for ie 5.0 personally. so
ymmv.

-jon

---

From: Shiva Murugesan <[email-masked]>
Date: Mon, 4 Mar 2002 21:04:56 -0800 (PST)

Many thanks jon.  The problem occurs in 5.5 and 6.0 as
well.  
I have tried unchecking the "Show friendly error
message", still it is not displaying the correct SSL
message.  After unchecking, it started asking twice to
present the client certificate. After presenting the
client certificate for the second time, it displays
the standard error message.

Ta 
Shiva

> ATTACHMENT part 2 application/pgp-signature
name=signature.asc

Try FREE Yahoo! Mail - the world's greatest free email!
http://mail.yahoo.com/

---

From: Shiva Murugesan <[email-masked]>
Date: Thu, 7 Mar 2002 05:47:57 -0800 (PST)

Any help from anyone?
I need this desperately.
Sincerely
Shiva

--- Shiva Murugesan <[email-masked]> wrote:
> > "You are in a twisty little maze of Sendmail
> rules,
> > all confusing." 
> > 
>