Subject: 128 bit key

From: Robert Durdle <[email-masked]>
Date: Thu, 18 Apr 2002 17:05:54 -0300

Hi,

I need to create a 128 bit key, but when I try to, it throws this at
me.

11663:error:04075070:rsa routines:RSA_sign:digest too big for rsa key:rsa_sign.c:114:
11663:error:0D072006:asn1 encoding routines:ASN1_sign:bad get asn1 object call:a_sign.c:129:

I need it to create a 128 bit key due to an employers special
needs, a 1024 bit one would be useless to me :/

- Robert                            
______________________________________________________________________
Apache Interface to OpenSSL (mod_ssl)                   www.modssl.org
User Support Mailing List                      [email-masked]
Automated List Manager                            [email-masked]

---

From: Anbuchezhian Chelliah <[email-masked]>
Date: Fri, 19 Apr 2002 06:18:34 -0700 (PDT)

Hello All,
  I am trying to make a proxy server(apache 1.3.22
compiled after enabling SSL_EXPERIMENTAL) authenticate
itself to a backend server(apache 1.3.19) which is in
the same machine (although in a real scenario the
backend server will run on a different machine).
 
   Proxyserver listens at port 6666 on a machine and
the backend server listnes at 127.0.0.2:8443. All the
communications are SSL-enabled.
 browser ->---SSL + client auth--> Proxy server
--SSL-->backend server.
  Browser authenticates itself to the proxy server
whereas proxy server does not authenticate itself to
the backend server.
   
 Now, the need is to make the proxy server also
authenticate itself to the backend server. 
 The proxy server has  the directive
"SSLProxyMachineCertficateFile" in it's httpd.conf.
This directive has the value set to the its'(proxy's)
client certificate. 
 Should I need to set the value for  
SSLProxyCACertficateFile also?
 
The error I see in the browser is:
        ------------------
     The proxy server received an invalid response
from an upstream server.

The proxy server could not handle the request GET /.

Reason: SSL proxy connect failed (test:6666): peer
127.0.0.1:8443: key values mismatch
        -------------------

Can anyone please throw light on this ?

Thanks a lot in advance.

Thanks and Regards,
Anbu

__________________________________________________
Do You Yahoo!?
Yahoo! Tax Center - online filing with TurboTax
http://taxes.yahoo.com/
______________________________________________________________________
Apache Interface to OpenSSL (mod_ssl)                   www.modssl.org
User Support Mailing List                      [email-masked]
Automated List Manager                            [email-masked]

---

From: Jon <[email-masked]>
Date: Fri, 19 Apr 2002 06:23:44 -0700 (MST)

>From what I'm reading, a 128 bit key is too small so it's complaining. I
think it wants a minimum of 1028.

Do a 'google' on this string 'routines:RSA_sign:digest too big for rsa'.
some of the links are dead so click on the 'cached' version to read the
page.

Jon