Subject: Apache/mod_ssl not compiling, Solaris 8

From: "Nathan Coraor" <[email-masked]>
Date: Mon, 17 Mar 2003 09:52:09 -0500 (EST)

Hi all,

I'm attempting to compile Apache 1.3.27 + mod_perl 1.27 + mod_ssl
2.8.12-1.3.27 under Solaris 8, and it's failing when linking.  I've got
OpenSSL 0.9.7a compiled for 'solaris64-sparcv9-cc'.

The output's here:

cc  -DSOLARIS2=280 -DMOD_SSL=208112 -DMOD_PERL -DUSE_PERL_SSI -I/usr/local/include -D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64 -DEAPI -I/usr/local/include -D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64 `./apaci` -L/usr/local/ssl/lib   \
      -o httpd buildmark.o modules.o modules/ssl/libssl.a modules/perl/libperl.a modules/standard/libstandard.a main/libmain.a ./os/unix/libos.a ap/libap.a    -lsocket -lnsl -lpthread  -lssl -lcrypto    -L/usr/local/lib -L/opt/SUNWspro/WS6U1/lib  /usr/local/lib/perl5/5.6.1/sun4-solaris/auto/DynaLoader/DynaLoader.a -L/usr/local/lib/perl5/5.6.1/sun4-solaris/CORE -lperl -lsocket -lnsl -ldl -lm -lc  -ldl
ld: warning: file /usr/local/ssl/lib/libssl.a(s2_srvr.o): wrong ELF class: ELFCLASS64
ld: warning: file /usr/local/ssl/lib/libcrypto.a(bn_lib.o): wrong ELF class: ELFCLASS64
Undefined                       first referenced
 symbol                             in file
d2i_SSL_SESSION                     modules/ssl/libssl.a(ssl_scache_dbm.o)
SSL_get_verify_mode                 modules/ssl/libssl.a(ssl_engine_kernel.o)
SSL_library_init                    modules/ssl/libssl.a(ssl_engine_init.o)

... snip ... (a -lot- of undefined symbols here)

SSL_accept                          modules/ssl/libssl.a(ssl_engine_kernel.o)
X509_NAME_oneline                   modules/ssl/libssl.a(ssl_engine_init.o)
ERR_get_error                       modules/ssl/libssl.a(ssl_engine_log.o)
ld: fatal: Symbol referencing errors. No output written to httpd
make[3]: *** [target_static] Error 1
make[3]: Leaving directory `/usr/local/src/apache/apache_1.3.27/src'
make[2]: *** [build-std] Error 2
make[2]: Leaving directory `/usr/local/src/apache/apache_1.3.27'
make[1]: *** [build] Error 2
make[1]: Leaving directory `/usr/local/src/apache/apache_1.3.27'
make: *** [apaci_httpd] Error 2

Thanks in advance,
--nate

--------
nathan coraor
cse lab support
[email-masked]
______________________________________________________________________
Apache Interface to OpenSSL (mod_ssl)                   www.modssl.org
User Support Mailing List                      [email-masked]
Automated List Manager                            [email-masked]

---

From: Götz Babin-Ebell <[email-masked]>
Date: Mon, 17 Mar 2003 17:41:11 +0100

Hello Nathan,

> ld: warning: file /usr/local/ssl/lib/libssl.a(s2_srvr.o): wrong ELF class: ELFCLASS64
^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
> ld: warning: file /usr/local/ssl/lib/libcrypto.a(bn_lib.o): wrong ELF class: ELFCLASS64
^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
> SSL_library_init                    modules/ssl/libssl.a(ssl_engine_init.o)
[...]

You have build the OpenSSL libraries for Sparc 64 bit.
But the linker doesn't like them.
you build mod_ssl / apache for sparc 32 bit ?

Bye

Goetz

-- 
Goetz Babin-Ebell, TC TrustCenter AG, http://www.trustcenter.de
Sonninstr. 24-28, 20097 Hamburg, Germany
Tel.: +49-(0)40 80 80 26 -0,  Fax: +49-(0)40 80 80 26 -126

---

From: "Nathan Coraor" <[email-masked]>
Date: Mon, 17 Mar 2003 11:47:33 -0500 (EST)

> > ld: warning: file /usr/local/ssl/lib/libssl.a(s2_srvr.o): wrong ELF class: ELFCLASS64

  Goetz,

  That's what it looked like to me, however, I'm not sure how to build
  apache/mod_ssl 64 bit.  Is there a configuration option that needs to
  be passed for this?  Can it not be compiled 64 bit?

Thanks,
--nate

---

From: Götz Babin-Ebell <[email-masked]>
Date: Mon, 17 Mar 2003 19:00:10 +0100

Hello Nathan,

>   be passed for this?  Can it not be compiled 64 bit?

I don't know.

If there is no way to build apache/modssl 64 bit,
you have to build OpenSSL 32 bit...

Bye

Goetz