Subject: Starting apache with ssl module

From: Larry Cotton <[email-masked]>
Date: Thu, 20 Feb 2003 18:37:56 +0000

Hi

I'm trying to run apache including the ssl module, but am having some 
problems starting
it up.

I'm using red hat linux ver 7.1. uname -r gives the following output :
Linux localhost.localdomain 2.2.16-22 #1 Tue Aug 22 16:49:06 EDT 2000 i686 
unknown.

I've been through the following steps :

1) Downloaded OpenSSL version 0.9.7a (the latest as far as I could make 
out), extracted it, built and installed
it without error. For this I simply used the defaults :
./configure
make
make test
[su root]
make install

2) Downloaded apache 2.0.44, extract and configure using the command :
CPPFLAGS="-I/usr/local/ssl/include/openssl -I/usr/local/ssl/include" \
./configure --prefix=/home/Larry/WebServer/Apache \
--enable-so \
--enable-cgi \
--enable-info \
--enable-usertrack \
--enable-ssl \
--enable-mime-magic

This was successful.

3) make - seemed to compile OK

4) su root
make install - seemed to install OK

5) cd /home/Larry/WebServer/Apache
su root
./apachectl start

Results in the following error appearing in the error log :
Could not set permissions on ssl_mutex: check User and Group directives 
Cnfiguration Failed

I've not changed the configuration file, so the settings are currently the 
default ones. The User and Group directives are currently set as:
User nobody
Group #-1

Note that I compiled as user Larry, installed as root and am trying to 
start apache as root.

Does anyone have any idea what might be going on here?

Cheers
Larry

---

From: [email-masked]
Date: Thu, 20 Feb 2003 12:48:16 -0600

Here's what we did:

####################################################################
# notes to install and configure apache with modules, mod_perl, so
####################################################################

    #   extract the packages
 
    $ gzip -d -c openssl-0.9.6g.tar.gz | tar xvf -
!!!
    ##########################
    Then INSTALL openssl first !!!
    ##########################
!!!

    $ gzip -d -c apache_1.3.27.tar.gz | tar xvf -
    $ gzip -d -c mod_ssl-2.8.11-1.3.27.tar.gz | tar xvf -
    $ gzip -d -c mod_perl-1.26.tar.gz | tar xvf -

    ########################################################
    #   apply mod_ssl to Apache source tree

      cd mod_ssl*
      ./configure --with-apache=../apache_1.3.27
    ########################################################
    #   apply mod_perl to Apache source tree
    #   and build/install the Perl-side of mod_perl
 
    cd mod_perl-1.26
    perl Makefile.PL EVERYTHING=1 APACHE_SRC=../apache_1.3.27/src 
USE_APACI=1 PREP_HTTPD=1 DO_HTTPD=1
    make
    make install
    cd ../
    ########################################################

    #   build/install Apache with mod_ssl and mod_perl

    cd apache_1.3.27
    SSL_BASE=../openssl-0.9.6g ./configure --prefix=/usr/local/apache 
--enable-module=ssl --activate-module=src/modules/perl/libperl.a 
--enable-module=perl --enable-module=so
    make
    make certificate
    make install
    cd ../
    ########################################################

    /usr/local/apache/bin/apachectl startssl

Troy Garner
Information Technology Manager
Gulf Winds International, Inc.
713.747.4909 x5753
www.gwii.com

Larry Cotton <[email-masked]>
Sent by: [email-masked]
02/20/2003 12:37 PM
Please respond to modssl-users

        To:     [email-masked]
        cc: 
        Subject:        Starting apache with ssl module

Hi

This was successful.

4) su root

Cheers
Larry