Subject: Urgent help needed Regarding installation of openssl-0.9.6b on Redhat linux 7.1

From: Nisarg Rav <[email-masked]>
Date: Thu, 18 Apr 2002 06:06:07 -0700 (PDT)

Hello gurus ,

I'm facing one typical problem while configuring openssl-0.9.6b on RedHat linux 7.1 , kernel 2.4.2-2.

I have successfully configured and installed openssl-0.9.6b, mod_ssl-2.8.7-1.1.3.23 and  Apache_1.3.23  on Redhat linux 7.2 , kernel 2.4.7-10. It is also working properly. This installation i did with local access of servef.

Now i need to configure and install all these things remotely on one linux box with telnet access.  This linux box is RHL 7.1 and 2.4.2-2.

Now while doing ./config or ./Configure linux-elf on it it is giving problem. 
First of all for major of files it is saying that [File Exists] ..

[root@abcd openssl-0.9.6b]# ./config
Operating system: i686-whatever-linux2
Configuring for linux-elf
Configuring for linux-elf
IsWindows=0
CC            =gcc
CFLAG         =-fPIC -DTHREADS -D_REENTRANT -DDSO_DLFCN -DHAVE_DLFCN_H -DL_ENDIAN -DTERMIO -O3 -fomit-frame-pointer -m486 -Wall -DSHA1_ASM -DMD5_ASM -DRMD160_ASM
EX_LIBS       =-ldl
BN_ASM        =asm/bn86-elf.o asm/co86-elf.o
DES_ENC       =asm/dx86-elf.o asm/yx86-elf.o
BF_ENC        =asm/bx86-elf.o
CAST_ENC      =asm/cx86-elf.o
RC4_ENC       =asm/rx86-elf.o
RC5_ENC       =asm/r586-elf.o
MD5_OBJ_ASM   =asm/mx86-elf.o
SHA1_OBJ_ASM  =asm/sx86-elf.o
RMD160_OBJ_ASM=asm/rm86-elf.o
PROCESSOR     =
RANLIB        =/usr/bin/ranlib
PERL          =/usr/bin/perl
THIRTY_TWO_BIT mode
DES_PTR used
DES_RISC1 used
DES_UNROLL used
BN_LLONG mode
RC4_INDEX mode
RC4_CHUNK is undefined
Makefile => Makefile.ssl
e_os.h => include/openssl/e_os.h [File exists]
e_os2.h => include/openssl/e_os2.h [File exists]
making links in crypto...
make[1]: Entering directory `/usr/local/openssl-0.9.6b/crypto'
Makefile => Makefile.ssl
crypto.h => ../include/openssl/crypto.h [File exists]
tmdiff.h => ../include/openssl/tmdiff.h [File exists]
opensslv.h => ../include/openssl/opensslv.h [File exists]
opensslconf.h => ../include/openssl/opensslconf.h [File exists]
ebcdic.h => ../include/openssl/ebcdic.h [File exists]
symhacks.h => ../include/openssl/symhacks.h [File exists]
Makefile => Makefile.ssl
making links in crypto/md2...
make[2]: Entering directory `/usr/local/openssl-0.9.6b/crypto/md2'
Makefile => Makefile.ssl
md2.h => ../../include/openssl/md2.h [File exists]
md2test.c => ../../test/md2test.c [File exists]
make[2]: Leaving directory `/usr/local/openssl-0.9.6b/crypto/md2'
making links in crypto/md4...
make[2]: Entering directory `/usr/local/openssl-0.9.6b/crypto/md4'
Makefile => Makefile.ssl
md4.h => ../../include/openssl/md4.h [File exists]
md4test.c => ../../test/md4test.c [File exists]
md4.c => ../../apps/md4.c [File exists]
make[2]: Leaving directory `/usr/local/openssl-0.9.6b/crypto/md4'
making links in crypto/md5...
make[2]: Entering directory `/usr/local/openssl-0.9.6b/crypto/md5'
Makefile => Makefile.ssl
md5.h => ../../include/openssl/md5.h [File exists]
md5test.c => ../../test/md5test.c [File exists]
make[2]: Leaving directory `/usr/local/openssl-0.9.6b/crypto/md5'
making links in crypto/sha...
make[2]: Entering directory `/usr/local/openssl-0.9.6b/crypto/sha'
Makefile => Makefile.ssl
sha.h => ../../include/openssl/sha.h [File exists]
shatest.c => ../../test/shatest.c [File exists]
sha1test.c => ../../test/sha1test.c [File exists]
make[2]: Leaving directory `/usr/local/openssl-0.9.6b/crypto/sha'
making links in crypto/mdc2...
make[2]: Entering directory `/usr/local/openssl-0.9.6b/crypto/mdc2'
Makefile => Makefile.ssl
mdc2.h => ../../include/openssl/mdc2.h [File exists]
mdc2test.c => ../../test/mdc2test.c [File exists]
make[2]: Leaving directory `/usr/local/openssl-0.9.6b/crypto/mdc2'
making links in crypto/hmac...
make[2]: Entering directory `/usr/local/openssl-0.9.6b/crypto/hmac'
Makefile => Makefile.ssl
hmac.h => ../../include/openssl/hmac.h [File exists]
hmactest.c => ../../test/hmactest.c [File exists]
make[2]: Leaving directory `/usr/local/openssl-0.9.6b/crypto/hmac'
making links in crypto/ripemd...
make[2]: Entering directory `/usr/local/openssl-0.9.6b/crypto/ripemd'
Makefile => Makefile.ssl
ripemd.h => ../../include/openssl/ripemd.h [File exists]
rmdtest.c => ../../test/rmdtest.c [File exists]
make[2]: Leaving directory `/usr/local/openssl-0.9.6b/crypto/ripemd'
making links in crypto/des...
make[2]: Entering directory `/usr/local/openssl-0.9.6b/crypto/des'
Makefile => Makefile.ssl
asm/perlasm => ../../perlasm
des.h => ../../include/openssl/des.h [File exists]
destest.c => ../../test/destest.c [File exists]
make[2]: Leaving directory `/usr/local/openssl-0.9.6b/crypto/des'
making links in crypto/rc2...
make[2]: Entering directory `/usr/local/openssl-0.9.6b/crypto/rc2'
Makefile => Makefile.ssl
rc2.h => ../../include/openssl/rc2.h [File exists]
rc2test.c => ../../test/rc2test.c [File exists]
make[2]: Leaving directory `/usr/local/openssl-0.9.6b/crypto/rc2'
making links in crypto/rc4...
make[2]: Entering directory `/usr/local/openssl-0.9.6b/crypto/rc4'
Makefile => Makefile.ssl
rc4.h => ../../include/openssl/rc4.h [File exists]
rc4test.c => ../../test/rc4test.c [File exists]
make[2]: Leaving directory `/usr/local/openssl-0.9.6b/crypto/rc4'
making links in crypto/rc5...
make[2]: Entering directory `/usr/local/openssl-0.9.6b/crypto/rc5'
Makefile => Makefile.ssl
rc5.h => ../../include/openssl/rc5.h [File exists]
rc5test.c => ../../test/rc5test.c [File exists]
make[2]: Leaving directory `/usr/local/openssl-0.9.6b/crypto/rc5'
making links in crypto/idea...
make[2]: Entering directory `/usr/local/openssl-0.9.6b/crypto/idea'
Makefile => Makefile.ssl
idea.h => ../../include/openssl/idea.h [File exists]
ideatest.c => ../../test/ideatest.c [File exists]
make[2]: Leaving directory `/usr/local/openssl-0.9.6b/crypto/idea'
making links in crypto/bf...
make[2]: Entering directory `/usr/local/openssl-0.9.6b/crypto/bf'
Makefile => Makefile.ssl
blowfish.h => ../../include/openssl/blowfish.h [File exists]
bftest.c => ../../test/bftest.c [File exists]
make[2]: Leaving directory `/usr/local/openssl-0.9.6b/crypto/bf'
making links in crypto/cast...
make[2]: Entering directory `/usr/local/openssl-0.9.6b/crypto/cast'
Makefile => Makefile.ssl
cast.h => ../../include/openssl/cast.h [File exists]
casttest.c => ../../test/casttest.c [File exists]
make[2]: Leaving directory `/usr/local/openssl-0.9.6b/crypto/cast'
making links in crypto/bn...
make[2]: Entering directory `/usr/local/openssl-0.9.6b/crypto/bn'
Makefile => Makefile.ssl
bn.h => ../../include/openssl/bn.h [File exists]
bntest.c => ../../test/bntest.c [File exists]
exptest.c => ../../test/exptest.c [File exists]
make[2]: Leaving directory `/usr/local/openssl-0.9.6b/crypto/bn'
making links in crypto/rsa...
make[2]: Entering directory `/usr/local/openssl-0.9.6b/crypto/rsa'
Makefile => Makefile.ssl
rsa.h => ../../include/openssl/rsa.h [File exists]
rsa_test.c => ../../test/rsa_test.c [File exists]
make[2]: Leaving directory `/usr/local/openssl-0.9.6b/crypto/rsa'
making links in crypto/dsa...
make[2]: Entering directory `/usr/local/openssl-0.9.6b/crypto/dsa'
Makefile => Makefile.ssl
dsa.h => ../../include/openssl/dsa.h [File exists]
dsatest.c => ../../test/dsatest.c [File exists]
make[2]: Leaving directory `/usr/local/openssl-0.9.6b/crypto/dsa'
making links in crypto/dh...
make[2]: Entering directory `/usr/local/openssl-0.9.6b/crypto/dh'
Makefile => Makefile.ssl
dh.h => ../../include/openssl/dh.h [File exists]
dhtest.c => ../../test/dhtest.c [File exists]
make[2]: Leaving directory `/usr/local/openssl-0.9.6b/crypto/dh'
making links in crypto/dso...
make[2]: Entering directory `/usr/local/openssl-0.9.6b/crypto/dso'
Makefile => Makefile.ssl
dso.h => ../../include/openssl/dso.h [File exists]
make[2]: Leaving directory `/usr/local/openssl-0.9.6b/crypto/dso'
making links in crypto/buffer...
make[2]: Entering directory `/usr/local/openssl-0.9.6b/crypto/buffer'
Makefile => Makefile.ssl
buffer.h => ../../include/openssl/buffer.h [File exists]
make[2]: Leaving directory `/usr/local/openssl-0.9.6b/crypto/buffer'
making links in crypto/bio...
make[2]: Entering directory `/usr/local/openssl-0.9.6b/crypto/bio'
Makefile => Makefile.ssl
bio.h => ../../include/openssl/bio.h [File exists]
make[2]: Leaving directory `/usr/local/openssl-0.9.6b/crypto/bio'
making links in crypto/stack...
make[2]: Entering directory `/usr/local/openssl-0.9.6b/crypto/stack'
Makefile => Makefile.ssl
stack.h => ../../include/openssl/stack.h [File exists]
safestack.h => ../../include/openssl/safestack.h [File exists]
make[2]: Leaving directory `/usr/local/openssl-0.9.6b/crypto/stack'
making links in crypto/lhash...
make[2]: Entering directory `/usr/local/openssl-0.9.6b/crypto/lhash'
Makefile => Makefile.ssl
lhash.h => ../../include/openssl/lhash.h [File exists]
make[2]: Leaving directory `/usr/local/openssl-0.9.6b/crypto/lhash'
making links in crypto/rand...
make[2]: Entering directory `/usr/local/openssl-0.9.6b/crypto/rand'
Makefile => Makefile.ssl
rand.h => ../../include/openssl/rand.h [File exists]
randtest.c => ../../test/randtest.c [File exists]
make[2]: Leaving directory `/usr/local/openssl-0.9.6b/crypto/rand'
making links in crypto/err...
make[2]: Entering directory `/usr/local/openssl-0.9.6b/crypto/err'
Makefile => Makefile.ssl
err.h => ../../include/openssl/err.h [File exists]
make[2]: Leaving directory `/usr/local/openssl-0.9.6b/crypto/err'
making links in crypto/objects...
make[2]: Entering directory `/usr/local/openssl-0.9.6b/crypto/objects'
Makefile => Makefile.ssl
objects.h => ../../include/openssl/objects.h [File exists]
obj_mac.h => ../../include/openssl/obj_mac.h [File exists]
make[2]: Leaving directory `/usr/local/openssl-0.9.6b/crypto/objects'
making links in crypto/evp...
make[2]: Entering directory `/usr/local/openssl-0.9.6b/crypto/evp'
Makefile => Makefile.ssl
evp.h => ../../include/openssl/evp.h [File exists]
make[2]: Leaving directory `/usr/local/openssl-0.9.6b/crypto/evp'
making links in crypto/asn1...
make[2]: Entering directory `/usr/local/openssl-0.9.6b/crypto/asn1'
Makefile => Makefile.ssl
asn1.h => ../../include/openssl/asn1.h [File exists]
asn1_mac.h => ../../include/openssl/asn1_mac.h [File exists]
make[2]: Leaving directory `/usr/local/openssl-0.9.6b/crypto/asn1'
making links in crypto/pem...
make[2]: Entering directory `/usr/local/openssl-0.9.6b/crypto/pem'
Makefile => Makefile.ssl
pem.h => ../../include/openssl/pem.h [File exists]
pem2.h => ../../include/openssl/pem2.h [File exists]
make[2]: Leaving directory `/usr/local/openssl-0.9.6b/crypto/pem'
making links in crypto/x509...
make[2]: Entering directory `/usr/local/openssl-0.9.6b/crypto/x509'
Makefile => Makefile.ssl
x509.h => ../../include/openssl/x509.h [File exists]
x509_vfy.h => ../../include/openssl/x509_vfy.h [File exists]
make[2]: Leaving directory `/usr/local/openssl-0.9.6b/crypto/x509'
making links in crypto/x509v3...
make[2]: Entering directory `/usr/local/openssl-0.9.6b/crypto/x509v3'
Makefile => Makefile.ssl
x509v3.h => ../../include/openssl/x509v3.h [File exists]
make[2]: Leaving directory `/usr/local/openssl-0.9.6b/crypto/x509v3'
making links in crypto/conf...
make[2]: Entering directory `/usr/local/openssl-0.9.6b/crypto/conf'
Makefile => Makefile.ssl
conf.h => ../../include/openssl/conf.h [File exists]
conf_api.h => ../../include/openssl/conf_api.h [File exists]
make[2]: Leaving directory `/usr/local/openssl-0.9.6b/crypto/conf'
making links in crypto/txt_db...
make[2]: Entering directory `/usr/local/openssl-0.9.6b/crypto/txt_db'
Makefile => Makefile.ssl
txt_db.h => ../../include/openssl/txt_db.h [File exists]
make[2]: Leaving directory `/usr/local/openssl-0.9.6b/crypto/txt_db'
making links in crypto/pkcs7...
make[2]: Entering directory `/usr/local/openssl-0.9.6b/crypto/pkcs7'
Makefile => Makefile.ssl
pkcs7.h => ../../include/openssl/pkcs7.h [File exists]
make[2]: Leaving directory `/usr/local/openssl-0.9.6b/crypto/pkcs7'
making links in crypto/pkcs12...
make[2]: Entering directory `/usr/local/openssl-0.9.6b/crypto/pkcs12'
Makefile => Makefile.ssl
pkcs12.h => ../../include/openssl/pkcs12.h [File exists]
make[2]: Leaving directory `/usr/local/openssl-0.9.6b/crypto/pkcs12'
making links in crypto/comp...
make[2]: Entering directory `/usr/local/openssl-0.9.6b/crypto/comp'
Makefile => Makefile.ssl
comp.h => ../../include/openssl/comp.h [File exists]
make[2]: Leaving directory `/usr/local/openssl-0.9.6b/crypto/comp'
make[1]: Leaving directory `/usr/local/openssl-0.9.6b/crypto'
making links in ssl...
make[1]: Entering directory `/usr/local/openssl-0.9.6b/ssl'
Makefile => Makefile.ssl
ssl.h => ../include/openssl/ssl.h [File exists]
ssl2.h => ../include/openssl/ssl2.h [File exists]
ssl3.h => ../include/openssl/ssl3.h [File exists]
ssl23.h => ../include/openssl/ssl23.h [File exists]
tls1.h => ../include/openssl/tls1.h [File exists]
ssltest.c => ../test/ssltest.c [File exists]
make[1]: Leaving directory `/usr/local/openssl-0.9.6b/ssl'
making links in rsaref...
make[1]: Entering directory `/usr/local/openssl-0.9.6b/rsaref'
Makefile => Makefile.ssl
rsaref.h => ../include/openssl/rsaref.h [File exists]
make[1]: Leaving directory `/usr/local/openssl-0.9.6b/rsaref'
making links in apps...
make[1]: Entering directory `/usr/local/openssl-0.9.6b/apps'
Makefile => Makefile.ssl
make[1]: Leaving directory `/usr/local/openssl-0.9.6b/apps'
making links in test...
make[1]: Entering directory `/usr/local/openssl-0.9.6b/test'
Makefile => Makefile.ssl
make[1]: Leaving directory `/usr/local/openssl-0.9.6b/test'
making links in tools...
make[1]: Entering directory `/usr/local/openssl-0.9.6b/tools'
Makefile => Makefile.ssl
make[1]: Leaving directory `/usr/local/openssl-0.9.6b/tools'

Configured for linux-elf.
______________________________________________________________----
and then while doing make it is getting aborted and giving following error,

../cryptlib.h:65: Internal error: Segmentation fault.
Please submit a full bug report.
See <URL:http://bugzilla.redhat.com/bugzilla/> for instructions.
make[2]: *** [a_octet.o] Error 1
make[2]: Leaving directory `/usr/local/openssl-0.9.6b/crypto/asn1'
make[1]: *** [subdirs] Error 1
make[1]: Leaving directory `/usr/local/openssl-0.9.6b/crypto'
make: *** [sub_all] Error 1
_________________________________________________________________

Please help me to resolve this problem ... 

Thanks and Regards ..
Nisarg 

_____________________________________________________________
Want a new web-based email account ? ---> http://www.firstlinux.net

_____________________________________________________________
Run a small business? Then you need professional email like [email-masked] from Everyone.net  http://www.everyone.net?tag
______________________________________________________________________
Apache Interface to OpenSSL (mod_ssl)                   www.modssl.org
User Support Mailing List                      [email-masked]
Automated List Manager                            [email-masked]

---

From: Joe Orton <[email-masked]>
Date: Thu, 18 Apr 2002 14:20:39 +0100

> RedHat linux 7.1 , kernel 2.4.2-2.

Try upgrading your compiler:

http://www.redhat.com/support/errata/RHBA-2001-082.html

joe