Subject: RE: This combination is *NOT* officially supported

From: Ramakrishna Kuppa <[email-masked]>
Date: Tue, 1 Oct 2002 11:01:26 -0700

Chris,

Which code is this - is it the Apache OR mod_ssl OR OpenSSL?

And, if I understood you right, irrespective of the versions of the above
software, on Win32 systems, the message is written to the log file. Do you
see this log entry in any of the many installations you have?

> -----Original Message-----
> From: hunter [mailto:[email-masked]] 
> Sent: Monday, September 30, 2002 9:07 PM
> To: [email-masked]
> Subject: This combination is *NOT* officially supported
> 
> 
> Ramakrishna Kuppa wrote:
> > Chris,
> > 
> > I am getting the following message in my SSL log:
> > 
> > [30/Sep/2002 17:57:49 02000] [info]  Server: Apache/1.3.26, 
> Interface:
> > mod_ssl/2.8.10, Library: OpenSSL/0.9.6g
> > [30/Sep/2002 17:57:49 02000] [warn]  You are using mod_ssl 
> under Win32. 
> > This combination is *NOT* officially supported. Use it at 
> your own risk!
> > 
> > 
> > Anything to be noted/concerned of?
> > 
> 
> Ramakrishna,
> 
>      /*
>       * Identification
>       */
>      if (mc->nInitCount == 1) {
>          ssl_log(s, SSL_LOG_INFO, "Server: %s, Interface: %s, 
> Library: %s",
>                  SERVER_BASEVERSION,
>                  ssl_var_lookup(p, NULL, NULL, NULL, 
> "SSL_VERSION_INTERFACE"),
>                  ssl_var_lookup(p, NULL, NULL, NULL, 
> "SSL_VERSION_LIBRARY"));
> #ifdef WIN32
>          ssl_log(s, SSL_LOG_WARN, "You are using mod_ssl 
> under Win32. "
>                  "This combination is *NOT* officially supported. "
>                  "Use it at your own risk!");
> #endif
>      }
> 
> ...it is simply a comment - disclaimer - whatever - it is 
> there in any 
> case if you are running Windows version.
> 
> Chris.
> 
> 
> ______________________________________________________________________
> Apache Interface to OpenSSL (mod_ssl)                   www.modssl.org
> User Support Mailing List                      [email-masked]
> Automated List Manager                            [email-masked]
>

---

From: hunter <[email-masked]>
Date: Tue, 01 Oct 2002 21:31:36 -0400

Ramakrishna Kuppa wrote:
> And, if I understood you right, irrespective of the versions of the 
> above software, on Win32 systems, the message is written to the log 
> file. Do you see this log entry in any of the many installations you have?
> 
> 
Ramakrishna,

This code segment is from mod_ssl...

f:\mod_ssl-2.8.10-1.3.26\pkg.sslmod\ssl_engine_init.c
...begins at line 175

Your statement is correct... this message will appear in your log if you 
are using mod_ssl on Windows with Apache 1.3.xx and mod_ssl 2.8.10

I have enabled SSL on only one of my Windows boxes.  It has never logged 
this message but the version is Apache 2.0.40 - OpenSSL 0.9.6g.

...mod_ssl is integrated into Apache 2.

All of my other Windows boxes have the SSL code included but SSL has not 
turned on - may never need to be.

IMHO - It means nothing, unless you are paying for support ... this is 
open source afterall.  Take it as a cheap shot at Windows.  There are 
some days when I share the thought, but I curse my Linux equally.

Chris.

---

From: Cliff Woolley <[email-masked]>
Date: Tue, 1 Oct 2002 21:33:42 -0400 (EDT)

> This code segment is from mod_ssl...

Correct.

> ...mod_ssl is integrated into Apache 2.

mod_ssl is not officially supported on Apache 1.3 on win32.
mod_ssl *is* officially supported on Apache 2.0 on win32.

And under 1.3, it's not that it won't work, it's just that the author
(Ralf) makes no guarantees that it will.  :)

It's that simple.

--Cliff