Subject: Re: Shared mod_ssl problems

From: "Jirka Vejrazka" <[email-masked]>
Date: Tue, 25 Feb 2003 17:46:52 -0500

Hi,

  I've faced exactly the same problem "undefined symbol: X509_free"
> Ideally I would like to link ssl dynamically and I guess the solution is to use shared openssl libraries (libcrypto.so and libssl.so). Does anyone know :
> a) How (or even if) I can build a shared OpenSSL (or where I can find out)

  "config shared" worked fine for me (instead of simple "config") -  don't forget "configure -s" for zlib if you compile zlib that will be used by this OpenSSL

> b) How I link these shared libraries into apache (can I use the standard LoadModule directive for the OpenSSL libs, or do I need some special SSL configuration ?) - or where I can find this out.

  LoadModule works well - of course you have to have Apache with mod_so module.

  Jirka Vejrazka
-- 
__________________________________________________________
Sign-up for your own FREE Personalized E-mail at Mail.com
http://www.mail.com/?sr=signup

______________________________________________________________________
Apache Interface to OpenSSL (mod_ssl)                   www.modssl.org
User Support Mailing List                      [email-masked]
Automated List Manager                            [email-masked]

---

From: Larry Cotton <[email-masked]>
Date: Wed, 26 Feb 2003 13:22:50 +0000

Hi thanks for this.

I'm still having a few problems and was wondering if you new anyhting about 
the following:

1) Do I have to re-compile zlib ?

At 17:46 25/02/2003 -0500, you wrote:
> > Ideally I would like to link ssl dynamically and I guess the solution 
> is to use shared openssl libraries (libcrypto.so and libssl.so). Does 
> anyone know :
>   "config shared" worked fine for me (instead of simple "config") 
> -  don't forget "configure -s" for zlib if you compile zlib that will be 
> used by this OpenSSL
>
> > b) How I link these shared libraries into apache (can I use the 
> standard LoadModule directive for the OpenSSL libs, or do I need some 
> special SSL configuration ?) - or where I can find this out.
>

---

From: Larry Cotton <[email-masked]>
Date: Wed, 26 Feb 2003 14:01:08 +0000

Hi

Thanks for these tips Jirka

When I build openssl, having configured it

---

From: Larry Cotton <[email-masked]>
Date: Wed, 26 Feb 2003 14:09:52 +0000

Hi

Thanks for this Jirka.

When I build the openssl shared libs :
 > ./configure
 > make
 > make install

and try and run openssl
 > openssl

I get an error message saying it can't find the shared libraries :
openssl: error while loading shared libraries: libssl.so.0.9.7: cannot open 
shared object file: No such file or directory

If I run ldd on the openssl exe I get the following message :
 > ldd -v openssl
         libssl.so.0.9.7 => not found
         libcrypto.so.0.9.7 => not found
         libdl.so.2 => /lib/libdl.so.2 (0x4001f000)
         libc.so.6 => /lib/libc.so.6 (0x40022000)
         /lib/ld-linux.so.2 => /lib/ld-linux.so.2 (0x40000000)

         Version information:
         ./openssl:
                 libc.so.6 (GLIBC_2.1.3) => /lib/libc.so.6
                 libc.so.6 (GLIBC_2.1) => /lib/libc.so.6
                 libc.so.6 (GLIBC_2.0) => /lib/libc.so.6
         /lib/libdl.so.2:
                 libc.so.6 (GLIBC_2.1.3) => /lib/libc.so.6
                 libc.so.6 (GLIBC_2.1) => /lib/libc.so.6
                 libc.so.6 (GLIBC_2.2) => /lib/libc.so.6
                 libc.so.6 (GLIBC_2.0) => /lib/libc.so.6
         /lib/libc.so.6:
                 ld-linux.so.2 (GLIBC_2.1.1) => /lib/ld-linux.so.2
                 ld-linux.so.2 (GLIBC_2.2) => /lib/ld-linux.so.2
                 ld-linux.so.2 (GLIBC_2.1) => /lib/ld-linux.so.2
                 ld-linux.so.2 (GLIBC_2.0) => /lib/ld-linux.so.2

[ also attemting to configure apache also comes up with an error saying 
that  it can't find the shared libraries].

Does anyone know what might be going on here ?

Cheers
Larry