Subject: 2 ssl virtualhosts whith 1 IP

From: fred <[email-masked]>
Date: Thu, 7 Nov 2002 09:57:40 +0100

Hello,
I use modssl with apache.
I have 10 virtualhosts on port 80
And 1 on port 443 whith ssl.
At this time, every thing is good.
I have only one IP adresse and I have to create another ssl virtualhost whith 
another ssl.crt file. 
when I go on : https://domaine1.com/ 
and https://domaine2.com/ 
I am on the good website but this is the same ssl.crt.

Is it possible to have 2 ssl.crt with 2 virtualhosts with only one IP ?

Thanks for your support.
______________________________________________________________________
Apache Interface to OpenSSL (mod_ssl)                   www.modssl.org
User Support Mailing List                      [email-masked]
Automated List Manager                            [email-masked]

---

From: Josef Kandlhofer <[email-masked]>
Date: Thu, 7 Nov 2002 10:07:55 +0100 (MET)

> Is it possible to have 2 ssl.crt with 2 virtualhosts with only one IP ?

Only if u use different ports......

greetings,
josef

-- 
+++ GMX - Mail, Messaging & more  http://www.gmx.net +++
NEU: Mit GMX ins Internet. Rund um die Uhr für 1 ct/ Min. surfen!

---

From: fred <[email-masked]>
Date: Thu, 7 Nov 2002 10:25:17 +0100

Thank you.
Is it possible to use Rewrite to redirect request from:
https://domaine1.com/something/page.ext?var1=val1&var2=val2
to
https://domaine1.com:444/something/page.ext?var1=val1&var2=val2

I have try :
RewriteEngine On
RewriteCond %{SERVER_PORT}      ^443$
RewriteCond %{SERVER_NAME}      ^https://domaine1.com$
RewriteRule ^/$                 https://domaine1.com:444 [L,R]

But it doesn't work.
Thank you very mutch for your support.