Subject: Question regarding MM

From: "Gilles Gros" <[email-masked]>
Date: Wed, 18 Sep 2002 16:37:31 -0700

Hi,

I have a simple question, but I am still unable to find the answer in the
docs.

What are the use and benefit of using MM with mod_ssl?

Thank you for your insight.

Gilles

______________________________________________________________________
Apache Interface to OpenSSL (mod_ssl)                   www.modssl.org
User Support Mailing List                      [email-masked]
Automated List Manager                            [email-masked]

---

From: Lynn Gazis <[email-masked]>
Date: Thu, 19 Sep 2002 12:18:01 -0700

Once you have installed Apache 1.3.x, you have in your conf directory an
httpd.conf file which contains the lines:

#   Inter-Process Session Cache:
#   Configure the SSL Session Cache: First the mechanism 
#   to use and second the expiring timeout (in seconds).
#SSLSessionCache        none
#SSLSessionCache        shmht:/usr/local/apache/logs/ssl_scache(512000)
#SSLSessionCache        shmcb:/usr/local/apache/logs/ssl_scache(512000)
SSLSessionCache         dbm:/usr/local/apache/logs/ssl_scache
SSLSessionCacheTimeout  300

(In the case of Apache 2.0.x, these lines would be in ssl.conf, and you
wouldn't be using modssl, since that is built into the Apache 2.0
distribution already.)

The best performance session caching comes if you change these lines to:

#   Inter-Process Session Cache:
#   Configure the SSL Session Cache: First the mechanism 
#   to use and second the expiring timeout (in seconds).
#SSLSessionCache        none
#SSLSessionCache        shmht:/usr/local/apache/logs/ssl_scache(512000)
SSLSessionCache        shmcb:/usr/local/apache/logs/ssl_scache(512000)
#SSLSessionCache         dbm:/usr/local/apache/logs/ssl_scache
SSLSessionCacheTimeout  300

to turn on the shmcb session cache instead of the dbm one.  However, in
order for this to work, you will likely need to use the MM package (which
can be downloaded from http://www.ossp.org/pkg/lib/mm/ - see that site for
further information about this package).

Lynn Gazis

-----Original Message-----
From: Gilles Gros [mailto:[email-masked]]
Sent: Thursday, September 19, 2002 12:01 PM
To: [email-masked]
Subject: RE: Question regarding MM

Can you give me pointer on description of these configuration directives.

Thanks
Gilles

> -----Original Message-----
> From: [email-masked]
> [mailto:[email-masked]]On Behalf Of Lynn Gazis
> Sent: Wednesday, September 18, 2002 4:40 PM
> To: [email-masked]'
> Subject: RE: Question regarding MM
> 
> 
> It lets you use shared memory session caching; the session cache 
> which gets
> the best performance is a shared memory cache, the shmcb cache.
> 
> Lynn Gazis
> 
> -----Original Message-----
> From: Gilles Gros [mailto:[email-masked]]
> Sent: Wednesday, September 18, 2002 4:38 PM
> To: [email-masked]
> Subject: Question regarding MM
> 
> 
> Hi,
>