Subject: Problems with Apache / mod_ssl and Internet Explorer 5/6

From: [email-masked] (Marcel Selhorst)
Date: Fri, 11 Jan 2002 20:00:38 +0100

Hi everyone,

I´ve got a big problem:
I installed on SuSE Linux 7.3 the Apache Web Server including
the mod_ssl in order to run a secured webinterface for my
IMAP-Server...
Unsecured everything works just fine in every Browser.
After installing the SSL-Plugin I generated a custom certificate and everything
works fine with Netscape / Konquerer / w3m.
But when I try to connect via https with any version of Microsofts
Internet Explorer I get the message, that the page cannot be
displayed.
I found out that there are many problems with MSIE, and I did all
the fixes. Here are parts of my httpd.conf. Does anyone has an idea?

Apache-Version 1.3.20
mod_ssl Version 2.8.4
openssl Version 0.96b
PHP Version Pear 4.1.0
MySQL Version 3.21

[...]
SSLPassPhraseDialog  builtin
SSLSessionCache         dbm:/var/run/ssl_scache
SSLSessionCacheTimeout  300
SSLRandomSeed startup builtin
SSLRandomSeed connect builtin

<VirtualHost _default_:443>
SSLEngine on

#*** here I tried both versions .... no change
#SSLProtocol ALL -SSLv3 
SSLCipherSuite ALL:!ADH:!EXPORT56:RC4+RSA:+HIGH:+MEDIUM:+LOW:+SSLv2:+EXP:+eNULL

SSLVerifyClient none

<Files ~ "\.(cgi|shtml|phtml|php3|php?)$">
    SSLOptions +StdEnvVars
</Files>
<Directory "/usr/local/httpd/cgi-bin">
    SSLOptions +StdEnvVars
</Directory>

#*** here I tried both versions .... no change
#SetEnvIf User-Agent ".*MSIE.*" nokeepalive ssl-unclean-shutdown downgrade-1.0 force-response-1.0
BrowserMatch "MSIE [1-4]" nokeepalive ssl-unclean-shutdown downgrade-1.0 force-response-1.0
BrowserMatch "MSIE [5-9]" ssl-unclean-shutdown

---

From: [email-masked]
Date: Mon, 14 Jan 2002 10:21:06 -0000

I'd suggest you try this for SSLSessionCache instead:
 
SSLSessionCache         shm:logs/ssl_scache(512000)

It seems to fix it for most users.
 
-
John Airey
Internet systems support officer, ITCSD, Royal National Institute for the
Blind,
Bakewell Road, Peterborough PE2 6XU,
Tel.: +44 (0) 1733 375299 Fax: +44 (0) 1733 370848 [email-masked]

Agnostic (Greek) = Ignoramus (Latin)

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]
Sent: 11 January 2002 19:01
To: [email-masked]
Subject: Problems with Apache / mod_ssl and Internet Explorer 5/6

Hi everyone,
 
I´ve got a big problem:
After installing the SSL-Plugin I generated a custom certificate and
everything

Apache-Version 1.3.20
mod_ssl Version 2.8.4
openssl Version 0.96b
PHP Version Pear 4.1.0
MySQL Version 3.21
 
[...]

#*** here I tried both versions .... no change
#SSLProtocol ALL -SSLv3 
SSLCipherSuite
ALL:!ADH:!EXPORT56:RC4+RSA:+HIGH:+MEDIUM:+LOW:+SSLv2:+EXP:+eNULL
 
SSLVerifyClient none

#*** here I tried both versions .... no change
#SetEnvIf User-Agent ".*MSIE.*" nokeepalive ssl-unclean-shutdown
downgrade-1.0 force-response-1.0
BrowserMatch "MSIE [1-4]" nokeepalive ssl-unclean-shutdown downgrade-1.0
force-response-1.0
BrowserMatch "MSIE [5-9]" ssl-unclean-shutdown

- 

NOTICE: The information contained in this email and any attachments is 
confidential and may be legally privileged. If you are not the 
intended recipient you are hereby notified that you must not use, 
disclose, distribute, copy, print or rely on this email's content. If 
you are not the intended recipient, please notify the sender 
immediately and then delete the email and any attachments from your 
system.

RNIB has made strenuous efforts to ensure that emails and any 
attachments generated by its staff are free from viruses. However, it 
cannot accept any responsibility for any viruses which are 
transmitted. We therefore recommend you scan all attachments.

Please note that the statements and views expressed in this email 
and any attachments are those of the author and do not necessarily 
represent those of RNIB.

RNIB Registered Charity Number: 226227

Website: http://www.rnib.org.uk