Subject: FW: newbie request for assistance

From: "Kurt A. Buckardt" <[email-masked]>
Date: Mon, 3 Feb 2003 11:52:09 -0600

Omar,

Thanks for your response, but isn't this accommodated by the fact that
ssl.conf is "called" from httpd.conf?  Note the "Listen 443" below.  

Here's the extract from the httpd.conf that I believe calls the
ssl.conf.

<IfModule mod_ssl.c>
    Include conf/ssl.conf
</IfModule>

for the record, here's the only error_log output I'm receiving.
[Mon Feb 03 12:45:51 2003] [warn] Init: Session Cache is not configured
[hint: SSLSessionCache]
[Mon Feb 03 12:45:51 2003] [notice] Apache/2.0.44 (Unix) mod_ssl/2.0.44
OpenSSL/0.9.6g configured -- resuming normal operations

Like I said I'm new at this, so what do I know.

Thanks again for responding.

Kurt
-----Original Message-----
From: Omar TANTAOUI [mailto:[email-masked]] 
Sent: Monday, February 03, 2003 10:58 AM
To: [email-masked]
Subject: RE: newbie request for assistance

Have you added the line
"Listen 443"
in your httpd.conf file ? If no, make a search on "Listen 80" and copy
"Listen 443" under.

Omar.

> -----Message d'origine-----
> De : [email-masked]
> [mailto:[email-masked]]De la part de Kurt A. Buckardt
> Envoye : lundi 3 fevrier 2003 15:49
> A : [email-masked]
> Objet : newbie request for assistance
>
>
> I am trying to bring up Apache 2.0.44 with mod_ssl module on Solaris
8,
> and can't get an https connection to the box.  Http works just fine.
> Any suggestions on how to proceed would be greatly appreciated.
>
> I've downloaded & installed OpenSSL 0.9.6g (sunfreeware.comn
> I've created a certificate and key:
> /usr/local/apache2/conf/ssl.crt/server.crt
> /usr/local/apache2/conf/ssl.key/server.key
> I've downloaded, compiled, & made Apache with --enable-ssl
>
> Here's Apache's ssl.conf file, which is called from Apache's
httpd.conf
> file:
> <IfDefine SSL>
> Listen 443
>
> AddType application/x-x509-ca-cert .crt
> AddType application/x-pkcs7-crl    .crl
>
> SSLPassPhraseDialog  builtin
>
> SSLSessionCache         dbm:logs/ssl_scache
> SSLSessionCacheTimeout  300
>
> SSLMutex  file:logs/ssl_mutex
>
> SSLRandomSeed startup builtin
> SSLRandomSeed connect builtin
> SSLRandomSeed startup file:/dev/urandom 512
>
> <VirtualHost _default_:443>
>
> DocumentRoot "/usr/local/apache2/htdocs"
> ServerName new.host.name:443
> ServerAdmin [email-masked]
> ErrorLog logs/error_log
> TransferLog logs/access_log
>
> SSLEngine on
>
> SSLCipherSuite
> ALL:!ADH:!EXPORT56:RC4+RSA:+HIGH:+MEDIUM:+LOW:+SSLv2:+EXP:+eNULL
>
> SSLCertificateFile /usr/local/apache2/conf/ssl.crt/server.crt
>
> SSLCertificateKeyFile /usr/local/apache2/conf/ssl.key/server.key
>
> <Files ~ "\.(cgi|shtml|phtml|php3?)$">
>     SSLOptions +StdEnvVars
> </Files>
> <Directory "/usr/local/apache2/cgi-bin">
>     SSLOptions +StdEnvVars
> </Directory>
>
> SetEnvIf User-Agent ".*MSIE.*" \
>          nokeepalive ssl-unclean-shutdown \
>          downgrade-1.0 force-response-1.0
>
> CustomLog logs/ssl_request_log \
>           "%t %h %{SSL_PROTOCOL}x %{SSL_CIPHER}x \"%r\" %b"
>
> </VirtualHost>
>
> </IfDefine>
> ______________________________________________________________________
> Apache Interface to OpenSSL (mod_ssl)                   www.modssl.org
> User Support Mailing List                      [email-masked]
> Automated List Manager                            [email-masked]
>
>

______________________________________________________________________
Apache Interface to OpenSSL (mod_ssl)                   www.modssl.org
User Support Mailing List                      [email-masked]
Automated List Manager                            [email-masked]
______________________________________________________________________
Apache Interface to OpenSSL (mod_ssl)                   www.modssl.org
User Support Mailing List                      [email-masked]
Automated List Manager                            [email-masked]

---

From: Mads Toftum <[email-masked]>
Date: Mon, 3 Feb 2003 18:59:55 +0100

> OpenSSL/0.9.6g configured -- resuming normal operations
Right, so you're missing a configuration directive - see
http://httpd.apache.org/docs-2.0/mod/mod_ssl.html#sslsessioncache

vh

Mads Toftum
-- 
`Darn it, who spiked my coffee with water?!' - lwall