Subject: RE: Mod_SSL_2.8.10 and OpenSSL_0.9.6g

From: Geoffrey Talvola <[email-masked]>
Date: Thu, 19 Sep 2002 14:27:41 -0400

I'm using the binaries from the OpenSA package and they are working fine for
me, both on NT and on 2000.

details at http://www.opensa.org/development/news/101.html

- Geoff

> -----Original Message-----
> From: David Diehl [mailto:[email-masked]]
> Sent: Thursday, September 19, 2002 2:15 PM
> To: [email-masked]
> Subject: Mod_SSL_2.8.10 and OpenSSL_0.9.6g
> 
> 
> Has anybody got this to function on a NT 4.0 server?
> 
> I've downloaded and compiled apache 1.3.26 with modssl 2.8.10 and
> openssl 9.6g and can't seem to get it to work on a NT 4.0 server. It
> works fine on a windows 2000 server, but when I try and start 
> it on a NT
> 4.0 server the second apache process never starts and there 
> are no error
> indications in the log files.
> 
> I've also download 2 seperate precompiled builds and niether of them
> came with the openssl dll files libeay32.dll and ssleay32.dll, which
> normally reside in the system32 directory. If I use the ones 
> I compiled,
> the same symptoms occur. Of course, if I remove all SSL 
> directives from
> the httpd.conf file, I don't need the dll's and it functions properly.
> 
> It seems that any version prior to 9.6 i.e. 9.5a  functions 
> without any
> problems.
> 
> Any ideas or insight would be greatly appreciated.
> 
> Thanks
> 
> David
> 
> ______________________________________________________________________
> Apache Interface to OpenSSL (mod_ssl)                   www.modssl.org
> User Support Mailing List                      [email-masked]
> Automated List Manager                            [email-masked]
> 
______________________________________________________________________
Apache Interface to OpenSSL (mod_ssl)                   www.modssl.org
User Support Mailing List                      [email-masked]
Automated List Manager                            [email-masked]

---

From: "Paul Bleimeyer" <[email-masked]>
Date: Thu, 19 Sep 2002 17:42:03 -0500

Geoff,

Are you running 1.x or 2.40 apache?

Regards,

Paul

> From: [email-masked]
> [mailto:[email-masked]]On Behalf Of Geoffrey Talvola
> Sent: Thursday, September 19, 2002 1:28 PM
> To: [email-masked]'
> Subject: RE: Mod_SSL_2.8.10 and OpenSSL_0.9.6g
> 
>

---

From: David Diehl <[email-masked]>
Date: Fri, 20 Sep 2002 10:51:03 -0400

I'm running 1.3.26; I re-tried the opensa precompiled apache and used their
httpd.conf vice mine  and I think I may have narrowed it down to an
incompatibility with the mod_ntlm.so module that I'm loading in my
httpd.conf. If I don't load that module I can get it to run on NT 4.0. Why
it's causing the symptoms I'm observing is unknown.

David