Subject: Re: 2.0.36 + mod-ssl + Win2k = Easy Money

From: "Mark Chew" <[email-masked]>
Date: Mon, 10 Jun 2002 07:11:47 +0000

Assuming the win2k service for Apache is created
(else create one using sc command),
try configure the Apache service properties like this :

Path to executable:
"C:\Program Files\Apache Group\Apache\Apache.exe" --ntservice

Startup type:
Automatic

Regards,
Mark

>From: "John" <[email-masked]>
>Reply-To: [email-masked]
>To: <[email-masked]>
>Subject: Re: 2.0.36 + mod-ssl + Win2k = Easy Money
>Date: Mon, 10 Jun 2002 17:20:20 +1200
>
>We have discovered that if we start Apache from the console with
> >apache -D SSL on our windows server, then we have ssl support...
>Please, someone, how do we get ssl support running as a service?
>
>It seems we have wasted a couple of days, simply to find this out!
>
>John.
>
>
>
>
>______________________________________________________________________
>Apache Interface to OpenSSL (mod_ssl)                   www.modssl.org
>User Support Mailing List                      [email-masked]
>Automated List Manager                            [email-masked]

_________________________________________________________________
Chat with friends online, try MSN Messenger: http://messenger.msn.com

______________________________________________________________________
Apache Interface to OpenSSL (mod_ssl)                   www.modssl.org
User Support Mailing List                      [email-masked]
Automated List Manager                            [email-masked]

---

From: "John" <[email-masked]>
Date: Mon, 10 Jun 2002 23:01:29 +1200

Thanks everyone, we now have everything working fine.

A quick howto for beginners (who perhaps experience what we have
experienced):

If you want win2k + mod-ssl, don't trust the apache HOWTO at
http://httpd.apache.org/docs-2.0/platform/win_compiling.html, they may
be fine for those who don't need ssl (and those people can simply use
the supplied binaries) but they are wrong if you need ssl.

Firstly, don't use the perl examples given on apache.org to prepare and
compile openssl, use the instructions in INSTALL.W32 that comes with the
openSSL source.

We eventually found that with visual C++ 6 we could compile apache
without ssl fine. Later we compiled mod-ssl alone (also in VC++) and
moved the mod-ssl.so binary to the modules folder in the apache
installation.

And that's it, except you need to know how to start Apache in "ssl
mode".

from the console in the apache\bin use

>apache -D SSL

to install apache to run as a service with SSL

>apache -i -D SSL

Hope this helps someone out there, and thanks to everyone who helped us!

John.

----- Original Message -----
From: "Mark Chew" <[email-masked]>
To: <[email-masked]>
Sent: Monday, June 10, 2002 7:11 PM
Subject: Re: 2.0.36 + mod-ssl + Win2k = Easy Money

: Assuming the win2k service for Apache is created
: (else create one using sc command),
: try configure the Apache service properties like this :
:
: Path to executable:
: "C:\Program Files\Apache Group\Apache\Apache.exe" --ntservice
:
: Startup type:
: Automatic
:
:
:
: Regards,
: Mark
:
:
: >From: "John" <[email-masked]>
: >Reply-To: [email-masked]
: >To: <[email-masked]>
: >Subject: Re: 2.0.36 + mod-ssl + Win2k = Easy Money
: >Date: Mon, 10 Jun 2002 17:20:20 +1200
: >
: >We have discovered that if we start Apache from the console with
: > >apache -D SSL on our windows server, then we have ssl support...
: >Please, someone, how do we get ssl support running as a service?
: >
: >It seems we have wasted a couple of days, simply to find this out!
: >
: >John.
: >
: >
: >
: >
: >Apache Interface to OpenSSL (mod_ssl)
www.modssl.org
: >User Support Mailing List
[email-masked]
: >Automated List Manager
[email-masked]
:
:
:
:
: _________________________________________________________________
: Chat with friends online, try MSN Messenger: http://messenger.msn.com
:
: ______________________________________________________________________
: Apache Interface to OpenSSL (mod_ssl)                   www.modssl.org
: User Support Mailing List                      [email-masked]
: Automated List Manager                            [email-masked]
: