Subject: Problem with Apache 2 and OpenSSL

From: "nico" <[email-masked]>
Date: Sun, 17 Aug 2003 18:15:51 +0200

Hello

So I start with Linux/Apache and openssl and I can't get running Apache 2 and Openssl.

That's an extract of my httpd.conf

Listen 80

<IfDefine SSL>
<VirtualHost www.test.com:443>
 
DocumentRoot "/usr/local/apache/htdocs"
ServerName www.test.com
ServerAdmin test
ErrorLog /usr/local/apache/logs/error_log
TransferLog /usr/local/apache/logs/access_log
 
SSLEngine on
SSLCertificateFile /usr/local/apache/conf/ssl.crt/www.test.com.cert
SSLCertificateKeyFile /usr/local/apache/conf/ssl.key/www.test.com.key
</VirtualHost>
</IfDefine>

When I try to connect with my brownser on http://www.test.com => it's OK
but with https://www.test.com => My brownser return me :"Unkown socket type"

If I try to connect me with shell to openssl it works.

I  start apache with

/usr/local/apache/bin/apachectl startssl

=> openssl prompt me for the pass

I give him the pass all is OK apache start http work but https doens't work
at all

Thanks for your help

---

From: Randy Katz <[email-masked]>
Date: Sun, 17 Aug 2003 17:40:24 -0700

Add
Listen 443

-- 
---
Take care,
Randy Katz
______________________________________________________________________
Apache Interface to OpenSSL (mod_ssl)                   www.modssl.org
User Support Mailing List                      [email-masked]
Automated List Manager                            [email-masked]