Subject: Modssl wait background script to finish

From: Vincent KERAVEC <[email-masked]>
Date: Mon, 01 Sep 2003 17:32:11 +0200

Hello,
I've got a problem with modssl. When I run a script in background, the
server doesn't respond to the browser who start the script on port 143
until the script finish. The server continue to reply to all other browser.

I'm running Apache/2.0.40 (Red Hat Linux) with mod_ssl/2.0.40 and
OpenSSL/0.9.7a. I'm also using client side authentication.

Is there something to change in the ssl configuration to allow
background process ?

Thanks,
Vincent KERAVEC

ps : When i put modssl in loglevel debug the server seems to wait after
this message :
    [Wed Aug 27 15:10:30 2003] [debug]
/usr/src/build/250859-i386/BUILD/httpd-2.0.40/modules/ssl/ssl_engine_io.c(1005):

+-------------------------------------------------------------------------+
[Wed Aug 27 15:10:30 2003] [info] Initial (No.1) HTTPS request received
for child 0 (server ***.****.***:443)

---

From: "Dave Paris" <[email-masked]>
Date: Mon, 1 Sep 2003 11:40:25 -0400

A couple questions.  Is this something like a SSL-protected web interface to
an IMAP server (ref: your mention of port 143)?  If so, are you accepting
certain directives which are being passed on to the IMAP server (ref: "start
the script on port 143")?  If this is the case, it sounds like what you're
intending to do is start a "fire and forget" script .. not being concerned
about the return value from the script.  If that's the case, you may want to
look at creating a IPC process of some sort that can be left to fend for
itself after being started, allowing a response to get back to the user.

Is this an accurate assessment of what you're trying to do?

-dsp

-----Original Message-----
From: [email-masked]
[mailto:[email-masked]]On Behalf Of Vincent KERAVEC
Sent: Monday, September 01, 2003 11:32 AM
To: [email-masked]
Subject: Modssl wait background script to finish

Hello,

Thanks,
Vincent KERAVEC

ps : When i put modssl in loglevel debug the server seems to wait after
this message :
    [Wed Aug 27 15:10:30 2003] [debug]
/usr/src/build/250859-i386/BUILD/httpd-2.0.40/modules/ssl/ssl_engine_io.c(10
05):

______________________________________________________________________
Apache Interface to OpenSSL (mod_ssl)                   www.modssl.org
User Support Mailing List                      [email-masked]
Automated List Manager                            [email-masked]

---

From: Vincent KERAVEC <[email-masked]>
Date: Mon, 01 Sep 2003 17:58:43 +0200

Thanks for your response,
Sorry I mean 443 and not 143  :(

I just want to run a bash script on the server.
I launch the script whith :
<?php
    exec ("nohup ./script.sh > /dev/null &");
?>

The page load successfully but when I follow a link the server didn't 
respond.
If I use an other navigator the server respond normally.

Vincent KERAVEC

---

From: "Dave Paris" <[email-masked]>
Date: Mon, 1 Sep 2003 12:10:33 -0400

Someone with more PHP experience than I will need to address the use of
exec() in the context of PHP, but were this Perl then exec() would stop the
running Perl process after launching the external process - which would have
the effect of stopping your running Perl script.

Whether PHP operates similarly, I'm not sure (I don't do anything with
PHP).. however this might be something to look into since (as I understand
it) many of PHP's internals were borrowed from Perl originally.  If this was
Perl, you'd want either system(), open2(), open3(), or backticks.

Good luck!
-dsp

-----Original Message-----
From: [email-masked]
[mailto:[email-masked]]On Behalf Of Vincent KERAVEC
Sent: Monday, September 01, 2003 11:59 AM
To: [email-masked]
Subject: Re: Modssl wait background script to finish

Vincent KERAVEC

---

From: Vincent KERAVEC <[email-masked]>
Date: Thu, 04 Sep 2003 10:55:06 +0200

I solve the problem by upgrading apache version to 2.0.47.

Vincent KERAVEC

Dave Paris wrote:

>>A couple questions.  Is this something like a SSL-protected web interface
>>    
>>
>to
>  
>
>>certain directives which are being passed on to the IMAP server (ref:
>>    
>>
>"start
>  
>
>>about the return value from the script.  If that's the case, you may want
>>    
>>
>to
>  
>
>>/usr/src/build/250859-i386/BUILD/httpd-2.0.40/modules/ssl/ssl_engine_io.c(1
>>    
>>
>0
>  
>
>>05):
>>
>>