Subject: How to Benchmark SSL on Apache based servers?

From: [email-masked]
Date: Thu, 26 Sep 2002 20:34:32 +0000

Due to unaviodable circumstances, I am away from the office until the Monday 30th September 2002 

I will get back to you as soon as i can on my return.

If it's an urgent Online Learning Support Unit / Web/ MUBSWEB/ MUBS Online matter
that requires urgent attention then  please contact either  Kirsteen1, Sanjay1 or Jeff1
who should be able to help.

If the problem relates to mubsweb please contact sanjay1
If the probelm relates to OASIS or WebCT please contact Kirsteen1
If your query  relates to mbs1111 or it support please contact Jeff1

All the best 
Alex
______________________________________________________________________
Apache Interface to OpenSSL (mod_ssl)                   www.modssl.org
User Support Mailing List                      [email-masked]
Automated List Manager                            [email-masked]

---

From: Robert Lagana <[email-masked]>
Date: Fri, 27 Sep 2002 14:53:44 -0400

Thanks !

-----Original Message-----
From: Josh Chamas [mailto:[email-masked]]
Sent: Friday, September 27, 2002 1:28 PM
To: [email-masked]
Subject: Re: How to Benchmark SSL on Apache based servers?

Robert Lagana wrote:
> 
> Hi,
> 
> Is it possible to benchmark the server load with mod_ssl enabled on
Apache?
> 
> Is there particular software that can do this?
> 

In perl, you could do this by scripting a quick benchmark
with LWP & Crypt::SSLeay libraries. ( LWP loads Crypt::SSLeay
on the backend for https URLs )

Here's a crude command that will set 2 web clients hitting
your SSL server at the same time:

]$ perl -MLWP::Simple -MBenchmark -e 'fork; timethis(25, sub {
get(qq(https://localhost/)); }); wait;'
timethis 25: 11 wallclock secs ( 2.78 usr +  0.07 sys =  2.85 CPU) @  8.77/s
(n=25)
timethis 25: 11 wallclock secs ( 3.03 usr +  0.07 sys =  3.10 CPU) @  8.06/s
(n=25)

The timethis() stats aren't really relevant in this case, but
it gave 50 requests done in 11 seconds.  Obviously, since the
client was running on the same machine as the server, the servers
real performance would be quite different by itself.

Regards,

Josh
________________________________________________________________
Josh Chamas, Founder                   phone:925-552-0128
Chamas Enterprises Inc.                http://www.chamas.com
NodeWorks Link Checking                http://www.nodeworks.com
______________________________________________________________________
Apache Interface to OpenSSL (mod_ssl)                   www.modssl.org
User Support Mailing List                      [email-masked]
Automated List Manager                            [email-masked]