Subject: Re: FreeBSD 4.x and Apache+mod_ssl

From: "Ronnie Clark" <[email-masked]>
Date: Wed, 20 Nov 2002 08:15:14 -0600 (CST)

Marcel, 

Thanks for the help, but I am either too sleepy or too slow to make 
this work right. I did these steps from the /usr/ports/www/apache13-
modssl/ directory:
make
make certificate TYPE=custom
make install

When I do the make install, it automatically writes in the snake oil CA 
and server cert, which are old and expired. How do I get it to 
recognize and use my new custom CA and server cert?

Thanks again for the help. I am also sending this to freebsd-questions.
Ron Clark

> from /usr/ports/www/apache13-modssl/ run:
> make certificate TYPE=custom
> 
> and follow the prompts..  remember to copy them to wherever you're 
storing the 
> certs apache uses and run make from that dir to update the links... 
> 
> That should do it :)
> Hope this helps!
> Marcel
> 
> 
> 
> On Tuesday 19 November 2002 21:54, Ronnie Clark wrote:
> > Hello all,
> >
> > I am running FreeBSD 4.7 STABLE and just loaded mysql,
> > Apache13+mod_ssl, and mod_php4 from the ports collection. I got php 
and
> > SSL playing nice together, but I now have a website that is showing 
an
> > invalid cert. How do I generate my own CA and new server cert 
signed by
> > that CA in this format?
> > Thanks in advance,
> > Ron Clark
______________________________________________________________________
> > Apache Interface to OpenSSL (mod_ssl)                   
www.modssl.org
> > User Support Mailing List                      modssl-
[email-masked]
> > Automated List Manager                            
[email-masked]
> 
> -- 
> "They that give up essential liberty to obtain a little temporary 
safety... 
> deserve neither safety nor liberty." - Benjamin Franklin(1759)
> ______________________________________________________________________
> Apache Interface to OpenSSL (mod_ssl)                   www.modssl.org
> User Support Mailing List                      [email-masked]
> Automated List Manager                            [email-masked]
> 
> 

______________________________________________________________________
Apache Interface to OpenSSL (mod_ssl)                   www.modssl.org
User Support Mailing List                      [email-masked]
Automated List Manager                            [email-masked]

---

From: [email-masked]
Date: Wed, 20 Nov 2002 11:37:45 -0500

>recognize and use my new custom CA and server cert?

I'd highly recommend the CA scripts available at ModSSL thusly:

http://www.openssl.org/contrib/ssl.ca-0.1.tar.gz

-----------------------------------------
[email-masked]

__________________________________________________________________
The NEW Netscape 7.0 browser is now available. Upgrade now! http://channels.netscape.com/ns/browsers/download.jsp 

Get your own FREE, personal Netscape Mail account today at http://webmail.netscape.com/