Subject: shmcb vs shmht

From: "Sarah Haff" <[email-masked]>
Date: Sat, 11 Oct 2003 08:50:29 -0700

Hi,

What are the differences between
#SSLSessionCache        shmht:logs/ssl_scache(512000)
and
#SSLSessionCache        shmcb:logs/ssl_scache(512000)
(in ssl.conf file)

????

Sarah.

_________________________________________________________________
Share your photos without swamping your Inbox.  Get Hotmail Extra Storage 
today! http://join.msn.com/?PAGE=features/es

______________________________________________________________________
Apache Interface to OpenSSL (mod_ssl)                   www.modssl.org
User Support Mailing List                      [email-masked]
Automated List Manager                            [email-masked]

---

From: Mads Toftum <[email-masked]>
Date: Sat, 11 Oct 2003 19:08:43 +0200

> #SSLSessionCache        shmcb:logs/ssl_scache(512000)
Two different ways of storing sessions in shared memory -
ht is a hashtable while cb is a cyclic buffer. Look back
in the archive for mails from Geoff Thorpe for all the
gory details.

One thing that came to mind about your problem from the
other day - iirc you had a long session timeout, but a
small sized cache. Try increasing the size and/or lowering
the Timeout - just to make sure you're not exhausting your
session store capacity before the browser times out.

vh

Mads Toftum
-- 
Speaking at ApacheCon 2003 - http://ApacheCon.com/
T03, "Apache 2 mod_ssl tutorial" (3h)
WE03, "Troubleshooting Apache configurations" 
WE11, "Apache mod_rewrite, the Swiss Army Knife of URL manipulation" 
______________________________________________________________________
Apache Interface to OpenSSL (mod_ssl)                   www.modssl.org
User Support Mailing List                      [email-masked]
Automated List Manager                            [email-masked]