Subject: Apache & Mod_SSL Cannot load /modules/mod_ssl.so

From: "Oliver Enders" <[email-masked]>
Date: Thu, 25 Jul 2002 11:40:14 +0200

Hello ervebody,

I´ve got the following problem:

I´ve installed a apache_1.3.23 with OpenSSL, mod_ssl and mod_jk with WIN 2000 everything works fine when the LoadModule for mod_ssl is commented out. After including the LoadModule line, i get the following Syntax Error:

Syntax error on line 195 of c:/ptc/apache/conf/httpd.conf:
Cannot load /modules/mod_ssl.so into server: (126) Das angegebene Modul wurde nicht gefunden:

(Module couldnt be found) 

But it is the definately there !!

I´ve allready set the PATH  in the system variables to /apache/conf/ because i thought that might be the problem, but the path in the Error-message is absoloute, so it cant be...... 

Has anybody had/solved the same problems ??

Thanx a lot 

Oliver

---

From: David W <[email-masked]>
Date: Sun, 28 Jul 2002 11:19:53 -0700 (PDT)

Hopefully I'm not duplicating someone else's response,
but I think your answer can be found by searching the
archives.  It looks like you didn't copy the openssl
dlls into your c:\winnt\system32 directory.  You need:
libeay32.dll
ssleay32.dll

-david

--- Oliver Enders <[email-masked]> wrote:
> I´ve installed a apache_1.3.23 with OpenSSL, mod_ssl
> and mod_jk with WIN 2000 everything works fine when
> the LoadModule for mod_ssl is commented out. After
> including the LoadModule line, i get the following
> Syntax Error:
> 
> Cannot load /modules/mod_ssl.so into server: (126)
> Das angegebene Modul wurde nicht gefunden:
> 
> I´ve allready set the PATH  in the system variables
> to /apache/conf/ because i thought that might be the
> problem, but the path in the Error-message is
> absoloute, so it cant be...... 
> 

__________________________________________________
Do You Yahoo!?
Yahoo! Health - Feel better, live better
http://health.yahoo.com
______________________________________________________________________
Apache Interface to OpenSSL (mod_ssl)                   www.modssl.org
User Support Mailing List                      [email-masked]
Automated List Manager                            [email-masked]