Subject: Re: private key not found

From: "camun2020" <[email-masked]>
Date: Thu, 13 Mar 2003 06:01:36 -0500 (EST)

--- On Thu 03/13, A. Putnam < [email-masked] > wrote:

Still no luck. I get the same error with this script too. Thank you for 
pointing out the script though. It was a LOT easier to use than the other one 
I had been using. 

OK, now I'm getting vague but could this be to do with the fact that you have some 'incomplete' keys and data in your ca.db.certs directory from the previous failed attempts? 

Make sure you start in a whole new clean directory... 

Having said that, I haven't actually tried those scripts with the most recent openssl so perhaps there are new problems.

cam

_______________________________________________
No banners. No pop-ups. No kidding.
Introducing My Way - http://www.myway.com
______________________________________________________________________
Apache Interface to OpenSSL (mod_ssl)                   www.modssl.org
User Support Mailing List                      [email-masked]
Automated List Manager                            [email-masked]

---

From: "A. Putnam" <[email-masked]>
Date: Fri, 14 Mar 2003 13:37:00 -0600

Okay, I cleaned out all of the older versions of the keys and ran the scripts 
again. I ended up with this:

1 out of 1 certificate requests certified, commit? [y/n]y
Write out database with 1 new entries
Data Base Updated
CA verifying: www.pelathe.org.crt <-> CA cert
www.pelathe.org.crt: OK

That does mean it worked, right? Everything is good? If so, should I move the 
new files I have to their respective directories or should I change my 
httpd.conf file to point to the new directory? I don't know if moving or 
copying/patsing damages the integrity of the encryptions or not.

On Thursday 13 March 2003 05:01, camun2020 wrote:
> pointing out the script though. It was a LOT easier to use than the other
> one I had been using.
>
> OK, now I'm getting vague but could this be to do with the fact that you
> have some 'incomplete' keys and data in your ca.db.certs directory from the
> previous failed attempts?
>
> Having said that, I haven't actually tried those scripts with the most
> recent openssl so perhaps there are new problems.
>
> cam
>

-- 
A. Putnam
Assistant IT Administrator
Pelathe Community Resource Center

---

From: "Aaron Stromas" <[email-masked]>
Date: Thu, 13 Mar 2003 12:33:19 -0500 (EST)

You can copy your cert and key files to apache's conf directory.

A. Putnam said:
> Okay, I cleaned out all of the older versions of the keys and ran the
> scripts  again. I ended up with this:
>
> That does mean it worked, right? Everything is good? If so, should I
> move the  new files I have to their respective directories or should I
> change my  httpd.conf file to point to the new directory? I don't know
> if moving or  copying/patsing damages the integrity of the encryptions
> or not.
>
>
>> Still no luck. I get the same error with this script too. Thank you
>> for pointing out the script though. It was a LOT easier to use than
>> the other one I had been using.
>>
>> OK, now I'm getting vague but could this be to do with the fact that
>> you have some 'incomplete' keys and data in your ca.db.certs directory
>> from the previous failed attempts?
>>

-- 
Aaron Stromas         | "Tik-tik-tik!!!... ja, Pantani is weg..."
[email-masked]        | BRTN commentator
+1 (301) 493 4933     | L'Alpe d'Huez
http://www.izoard.com | 1995 Tour de France

---

From: "R. DuFresne" <[email-masked]>
Date: Thu, 13 Mar 2003 12:32:01 -0500 (EST)

you should beable to safely move then into place.  make sure perms are
restricted as possible to prevent their info from being leaked.

-- 
~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
        admin & senior security consultant:  sysinfo.com
                        http://sysinfo.com

"Cutting the space budget really restores my faith in humanity.  It
eliminates dreams, goals, and ideals and lets us get straight to the
business of hate, debauchery, and self-annihilation."
                -- Johnny Hart

testing, only testing, and damn good at it too!

---

From: "A. Putnam" <[email-masked]>
Date: Fri, 14 Mar 2003 14:00:48 -0600

I went ahead and changed my httpd.conf file to reflect the new directory. And 
when I went to restart Apache, it worked! (THANK YOU!!) However, when I go to 
my shopping cart and click 'checkout' (thus sending me to the secure server) 
I get this error moeesage:

"www.pelathe.org has received an incorrect or unexpected message. Error Code: 
-12227"

I've never seen an error code like that before. Does anyone know what it 
means?

On Friday 14 March 2003 13:37, A. Putnam wrote:
> That does mean it worked, right? Everything is good? If so, should I move
> the new files I have to their respective directories or should I change my
> > have some 'incomplete' keys and data in your ca.db.certs directory from
> > the previous failed attempts?
> >

---

From: "Aaron Stromas" <[email-masked]>
Date: Thu, 13 Mar 2003 12:50:18 -0500 (EST)

Just a guess: have you also added the CA certificate to the CA certificate
bundle? Also, set your logging to "trace", it should give you a clue.

-a

A. Putnam said:
> I went ahead and changed my httpd.conf file to reflect the new
> directory. And  when I went to restart Apache, it worked! (THANK YOU!!)
> However, when I go to  my shopping cart and click 'checkout' (thus
> sending me to the secure server)  I get this error moeesage:
>
> "www.pelathe.org has received an incorrect or unexpected message. Error
> Code:  -12227"
>
> I've never seen an error code like that before. Does anyone know what
> it  means?
>
>> > you have some 'incomplete' keys and data in your ca.db.certs
>> > directory from the previous failed attempts?
>> >
>> > Having said that, I haven't actually tried those scripts with the
>> > most recent openssl so perhaps there are new problems.
>> >
>> > cam
>> >
>> > Apache Interface to OpenSSL (mod_ssl)
>> > www.modssl.org User Support Mailing List
>> > [email-masked] Automated List Manager
>> >      [email-masked]
>
> --
> A. Putnam