Subject: SSLRandomSeed set to PRNGD socket = apache fails to start on IRIX

From: [email-masked]
Date: Tue, 5 Feb 2002 15:40:08 +0800

Ok, first, the environment: 
SGI Octane running IRIX 6.5.13f
Apache 1.3.22
ModSSL 2.8.5
OpenSSL 0.9.6b
PRNGD 0.9.17 and 0.9.23

If I have the following in my config:
SSLRandomSeed startup file:/dev/urandom2 512
SSLRandomSeed connect file:/dev/urandom2 512

The logs show:
[Tue Feb  5 15:30:43 2002] [error] mod_ssl: Init: Failed to generate temporary 512 bit RSA private key (OpenSSL library error follows)
[Tue Feb  5 15:30:43 2002] [error] OpenSSL: error:24064064:random number generator:SSLEAY_RAND_BYTES:PRNG not seeded
[Tue Feb  5 15:30:43 2002] [error] OpenSSL: error:04069003:rsa routines:RSA_generate_key:BN lib

If I switch to builtin, it works.

Here's the weird part - I have OpenSSH 3.0.2p2 using /dev/urandom without a problem, and using PRNGD's suggested ways of testing things (via egc.pl) shows no errors.

Anything anyone can suggest?
______________________________________________________________________
Apache Interface to OpenSSL (mod_ssl)                   www.modssl.org
User Support Mailing List                      [email-masked]
Automated List Manager                            [email-masked]

---

From: Lutz Jaenicke <[email-masked]>
Date: Wed, 6 Feb 2002 11:09:14 +0100

> Here's the weird part - I have OpenSSH 3.0.2p2 using /dev/urandom without a problem, and using PRNGD's suggested ways of testing things (via egc.pl) shows no errors.

You must specify the correct protocol to be used:
SSLRandomSeed startup egd:/path/to/egd-socket ...
                      ^^^

Best regards,
	Lutz
-- 
Lutz Jaenicke                             [email-masked]
http://www.aet.TU-Cottbus.DE/personen/jaenicke/
BTU Cottbus, Allgemeine Elektrotechnik
Universitaetsplatz 3-4, D-03044 Cottbus
______________________________________________________________________
Apache Interface to OpenSSL (mod_ssl)                   www.modssl.org
User Support Mailing List                      [email-masked]
Automated List Manager                            [email-masked]