Subject: Re: Help on Apache 2.0.43 + SSL installation

From: Cliff Woolley <[email-masked]>
Date: Wed, 12 Mar 2003 11:22:34 -0500 (EST)

I'm cc:ing the users list so that the response is in the archives in case
anyone else has a similar problem.

On Sat, 8 Mar 2003, Kitty Ko wrote:

> How are you? I read accross one of your email replay on the "binding
> shared libraries with OpenSSL" on the interent, and that's how I got
> your email address.
>
> I have encounter problems while installing SSL + APACHE.  I am wondering
> if you can give me some hits.
>
> I have successfully completed installing Tomcat 4.0.6 + Apache 2.0.43 on
> the Unix box.  Buy I can't have SSL installed.  FYI.  I build apache and
> open ssl form source.
>
> After I extracted the openssl-0.9.7, I did the following:
>
> # cd openssl-0.9.7
>
> # ./config --prefix=/depot/ssl/install
> --openssldir=/depot/ssl/install/openssl
>
> # make
>
> However, once I get into make build-shared, i got the following errors:
>
> ld:fetal: relocations remain against allocatable but non-writable
> sections colletc2:  ld returned 1 exit status
>
> make: ***[do-solars-shared] Error 1
>
> My questions are:
>
> 1.  how to fix this compile error

Hmmm... well honestly I'm not all that familiar with linker problems on
Solaris.  I have heard a number of people report problems getting the
shared library build of openssl to work on Solaris, though that's about as
much insight as I can offer.  The option to use both a static openssl and
a static mod_ssl remains, of course, and at this point sounds like your
best option.

> 2.  how do i know if I compiled mod_ssl statically or dynamicelly?

"httpd -l" will list all the statically-compiled modules.

> I build the apache by the following command:
>
> # ./configure --with-layout=Apache --prefix=/depot/apache2
> --enable-mods-shared=most --enable-ssl=shared
                            ^^^^^^^^^^^^^^^^^^^

...though this right here tells me you've built it as shared, since that's
what that means.  :)

--Cliff
______________________________________________________________________
Apache Interface to OpenSSL (mod_ssl)                   www.modssl.org
User Support Mailing List                      [email-masked]
Automated List Manager                            [email-masked]

---

From: "John P. Dodge" <[email-masked]>
Date: Wed, 12 Mar 2003 08:57:16 -0800 (PST)

> > --enable-mods-shared=most --enable-ssl=shared
For the openssl compile (with gcc) use:

./config --prefix=<path> shared threads no-idea '-fPIC'

Then build Apache 2.x:

./configure --with-layout=Apache --prefix=/depot/apache2 \
--enable-mods-shared=most \
--with-ssl=<path> \
--enable-ssl=shared

make ; make install

Note when using gcc on Solaris you may run across a dependency on libgcc.a
(__floatdisf, --floatdidf,...).

Set SH_LDFLAGS=`gcc -print-libgcc-file-name` ; ./configure...

This shlould be all you need.

Note: Use the linker (ld) in /usr/ccs/bin

----------------------------------------
"Mon aéroglisseur est plein d'anguilles"
John P. Dodge
Boeing Shared Services
______________________________________________________________________
Apache Interface to OpenSSL (mod_ssl)                   www.modssl.org
User Support Mailing List                      [email-masked]
Automated List Manager                            [email-masked]