Subject: Verifying OpenSSL Version in mod_ssl

From: Ken Schweigert <[email-masked]>
Date: 01 Apr 2003 00:02:21 -0500

I've been getting this error ever since I upgraded to
mod_ssl-2.8.14-1.3.27:

[Fri Mar 28 16:44:47 2003] [error] mod_ssl: Cannot store SSL session to
DBM file `/usr/local/apache/logs/ssl_scache' (System error follows)
[Fri Mar 28 16:44:47 2003] [error] System: Invalid argument (errno: 22)

When trying to debug the problem, I wanted to verify that mod_ssl was
compiled with the recently upgraded OpenSSL-0.9.7a.  Usually I just
use 'strings' and grep for 'openssl'.  However, when I do it against
libssl.so, it returns a string that looks like the version is 0.9.6c :

[root@www ssl]# strings libssl.so | grep -i "openssl"
OpenSSL
Spurious SSL handshake interrupt[Hint: Usually just one of those OpenSSL
confusions!?]
OpenSSL
OpenSSL
 (System and OpenSSL library errors follow)
 (OpenSSL library error follows)
OpenSSL
OpenSSL 0.9.6c 21 dec 2001
[root@www ssl]#

Version 0.9.6c hasn't been on the box in years, so I'm not sure if what
I'm seeing is the actually the real version of just something linked in.

This is what I see from configure:

[root@www mod_ssl-2.8.14-1.3.27]# ./configure
--with-apache=../apache_1.3.27 --with-ssl=../openssl-0.9.7a
--with-mm=../mm-1.3.0
Configuring mod_ssl/2.8.14 for Apache/1.3.27
 + Apache location: ../apache_1.3.27 (Version 1.3.27)
 + OpenSSL location: ../openssl-0.9.7a
 + MM location: ../mm-1.3.0
 + Auxiliary patch tool: ./etc/patch/patch (local)
 + Applying packages to Apache source tree:
<SNIP>
 + adding selected modules
    o ssl_module uses ConfigStart/End
      + SSL interface: mod_ssl/2.8.14
      + SSL interface build type: OBJ
      + SSL interface compatibility: enabled
      + SSL interface experimental code: disabled
      + SSL interface conservative code: disabled
      + SSL interface vendor extensions: disabled
      + SSL interface plugin: Built-in SDBM
      + SSL library path: /usr/src/APACHE-1.3.27/openssl-0.9.7a
      + SSL library version: OpenSSL 0.9.7a Feb 19 2003

And this is what I see from Apache's configure:
[root@www apache_1.3.27]# ./go-apache2.sh 
Configuring for Apache, Version 1.3.27
 + using installation path layout: Apache (config.layout)
Creating Makefile
Creating Configuration.apaci in src
Creating Makefile in src
 + configured for Linux platform
 + setting C compiler to gcc
 + setting C pre-processor to gcc -E
 + checking for system header files
 + adding selected modules
    o rewrite_module uses ConfigStart/End
 + using -lndbm for DBM support
      enabling DBM support for mod_rewrite
    o ssl_module uses ConfigStart/End
      + SSL interface: mod_ssl/2.8.14
      + SSL interface build type: DSO
      + SSL interface compatibility: enabled
      + SSL interface experimental code: disabled
      + SSL interface conservative code: disabled
      + SSL interface vendor extensions: disabled
      + SSL interface plugin: Built-in SDBM
      + SSL library path: /usr/src/APACHE-1.3.27/openssl-0.9.7a
      + SSL library version: OpenSSL 0.9.7a Feb 19 2003
<SNIP>

Can anyone help with determining the actual version?  Or if this is
irrelevant to determining the original error, I would appreciate a
pointer to what might help.

Thanks!
-- 
Ken Schweigert, Network Administrator
Byte Productions, LLC
http://www.byte-productions.com

______________________________________________________________________
Apache Interface to OpenSSL (mod_ssl)                   www.modssl.org
User Support Mailing List                      [email-masked]
Automated List Manager                            [email-masked]

---

From: "Jeff Bert" <[email-masked]>
Date: Mon, 31 Mar 2003 21:39:06 -0800

If you kill and restart your apache server you should see in its error log
the openssl version being used by apache when it starts and since apache is
controlling the compilation of mod_ssl then that should be your verification
of the version.

Jeff