Subject: Re: Apache warning: Connection refused: connect to listener

From: "Alex Hart" <[email-masked]>
Date: Tue, 30 Sep 2003 12:13:42 -0400

I sent this yesterday but never saw it, so sorry if this is double. Output of httpd -V at bottom.

- Alex

The following message was sent by Mads Toftum <[email-masked]> on Tue, 30 Sep 2003 10:32:42 +0200.

> On Mon, Sep 29, 2003 at 11:06:31PM -0400, Alex Hart wrote:
> > I just installed Apache/2.0.47 (Unix) mod_ssl/2.0.47 OpenSSL/0.9.7b in
> > my server (freebsd 4.8) and everything seems to be working fine. I have 
> apache
> > configured to serve both secure and insecure pages.
> > 
> > However, I keep getting the following line in my error log file (thousands 
> of times):
> > 
> > [Wed Sep 24 12:51:15 2003] [warn] (61)Connection refused: connect to 
> listener
> > 
> > I have thousands of these warnings now in just a couple of days. I can't 
> figure out any pattern to them.
> > I get this warning even when I don't have any activity going on with 
> the web server. 
> > It also happens if I don't have any SSL virtual hosts set up.
> > I notice no problems with any web pages, secure or not.
> > 
> We need a few more details to guess what might be happening - something 
> like
> the output of httpd -V, the configure options used when building apache 
> and
> wether you have any other non standard modules installed (ie. php and such).
> Also your SSL specific part of the configuration.
> 
> vh
> 
> Mads Toftum
> -- 
> Speaking at http://ApacheCon.com/
> T03, "Apache 2 mod_ssl tutorial" (3h)
> WE03, "Troubleshooting Apache configurations" 
> WE11, "Apache mod_rewrite, the Swiss Army Knife of URL manipulation" 
> ______________________________________________________________________
> Apache Interface to OpenSSL (mod_ssl)                   www.modssl.org
> User Support Mailing List                      [email-masked]
> Automated List Manager                            [email-masked]
> 
> 

./httpd -V
Server version: Apache/2.0.47
Server built:   Sep 29 2003 18:29:13
Server's Module Magic Number: 20020903:4
Architecture:   32-bit
Server compiled with....
 -D APACHE_MPM_DIR="server/mpm/prefork"
 -D APR_HAS_SENDFILE
 -D APR_HAS_MMAP
 -D APR_HAVE_IPV6 (IPv4-mapped addresses enabled)
 -D APR_USE_FLOCK_SERIALIZE
 -D SINGLE_LISTEN_UNSERIALIZED_ACCEPT
 -D APR_HAS_OTHER_CHILD
 -D AP_HAVE_RELIABLE_PIPED_LOGS
 -D HTTPD_ROOT="/usr/local/apache2"
 -D SUEXEC_BIN="/usr/local/apache2/bin/suexec"
 -D DEFAULT_PIDLOG="logs/httpd.pid"
 -D DEFAULT_SCOREBOARD="logs/apache_runtime_status"
 -D DEFAULT_LOCKFILE="logs/accept.lock"
 -D DEFAULT_ERRORLOG="logs/error_log"
 -D AP_TYPES_CONFIG_FILE="conf/mime.types"
 -D SERVER_CONFIG_FILE="conf/httpd.conf"

- Alex Hart
______________________________________________________________________
Apache Interface to OpenSSL (mod_ssl)                   www.modssl.org
User Support Mailing List                      [email-masked]
Automated List Manager                            [email-masked]

---

From: Mads Toftum <[email-masked]>
Date: Thu, 2 Oct 2003 16:50:12 +0200

>  -D SINGLE_LISTEN_UNSERIALIZED_ACCEPT

Right, this was part of what we needed - then there is the configuration.
Specifically there are two settings that might be worth taking a closer
look at - SSLMutex and SSLSessionCache. What are they currently set to?
and if you feel adventurous, try switching between different types.

http://httpd.apache.org/docs-2.0/mod/mod_ssl.html#sslmutex
http://httpd.apache.org/docs-2.0/mod/mod_ssl.html#sslsessioncache

vh

Mads Toftum
-- 
Speaking at ApacheCon 2003 - http://ApacheCon.com/