Subject: seg fault in apache in AIX

From: [email-masked]
Date: Mon, 29 Mar 2004 15:39:06 -0500

Hi! 
I'm getting the following output from a test of https on my apache server 
using modssl.  I can't easily rebuild it.  I'm hoping someone has an idea 
how to get more info without recompiling the server... 

CONNECTED(00000003)
SSL_connect:before/connect initialization
write to 2006ACC8 [2006AD18] (130 bytes => 130 (0x82))
0000 - 80 80 01 03 01 00 57 00-00 00 20 00 00 16 00 00   ......W... .....
0010 - 13 00 00 0a 07 00 c0 00-00 66 00 00 07 00 00 05   .........f......
0020 - 00 00 04 05 00 80 03 00-80 01 00 80 08 00 80 00   ................
0030 - 00 65 00 00 64 00 00 63-00 00 62 00 00 61 00 00   .e..d..c..b..a..
0040 - 60 00 00 15 00 00 12 00-00 09 06 00 40 00 00 14   `...........@...
0050 - 00 00 11 00 00 08 00 00-06 00 00 03 04 00 80 02   ................
0060 - 00 80 d3 cf b9 88 18 5b-8c 9c 19 3d a9 37 89 2e   .......[...=.7..
0070 - 54 11 87 da a6 34 7b f9-09 00 2e 38 eb 72 6b aa   T....4{....8.rk.
0080 - f2 f7                                             ..
SSL_connect:SSLv2/v3 write client hello A
read from 2006ACC8 [20070278] (7 bytes => 0 (0x0))
207398:error:140790E5:SSL routines:SSL23_WRITE:ssl handshake 
failure:s23_lib.c:216:

Compiled-in modules:
  http_core.c
  mod_env.c
  mod_log_config.c
  mod_mime.c
  mod_negotiation.c
  mod_status.c
  mod_include.c
  mod_autoindex.c
  mod_dir.c
  mod_cgi.c
  mod_asis.c
  mod_imap.c
  mod_actions.c
  mod_userdir.c
  mod_alias.c
  mod_access.c
  mod_auth.c
  mod_setenvif.c
  mod_ssl.c
  mod_auth_kerb.c
suexec: disabled; invalid wrapper /home/httpd/bin/

8-)
TIA
Chuck Lyon
UTS Enterprise Systems
University Park PC 417A
Florida International University
Miami, FL  33199 PH (305) 348-2912
______________________________________________________________________
Apache Interface to OpenSSL (mod_ssl)                   www.modssl.org
User Support Mailing List                      [email-masked]
Automated List Manager                            [email-masked]

---

From: Cliff Woolley <[email-masked]>
Date: Mon, 29 Mar 2004 15:44:01 -0500 (EST)

> how to get more info without recompiling the server...

You're gonna have to give us more than that.  :)

For starters:

 - Apache version, mod_ssl version, OpenSSL version?
 - session cache settings?
 - using client certificates or revocation lists?

--Cliff